| 10073 | Composite Module-Lattice-Based Digital Signature Algorithm (ML-DSA) for Use in X.509 Public Key InfrastructureM. Ounsworth, J. Gray, M. Pala, J. Klaußner, S. Fluhrer | Proposed Standard | November 2026 |
| 10031 | Media Access Control (MAC) Addresses in X.509 CertificatesR. Housley, C. Bonnell, J. Mandel, T. Okubo, M. StJohns | Proposed Standard | August 2026 |
| 10002 | Certificate Management over CMS (CMC)J. Mandel, Ed., S. Turner, Ed. | Proposed Standard | July 2026 |
| 9999 | Remote ATtestation procedureS (RATS) Conceptual Message Wrapper (CMW)H. Birkholz, N. Smith, T. Fossati, H. Tschofenig | Proposed Standard | July 2026 |
| 9935 | Internet X.509 Public Key Infrastructure - Algorithm Identifiers for the Module-Lattice-Based Key-Encapsulation Mechanism (ML-KEM)S. Turner, P. Kampanakis, J. Massimo, B. E. Westerbaan | Proposed Standard | March 2026 |
| 9925 | Unsigned X.509 CertificatesD. Benjamin | Proposed Standard | February 2026 |
| 9909 | Internet X.509 Public Key Infrastructure -- Algorithm Identifiers for the Stateless Hash-Based Digital Signature Algorithm (SLH-DSA)K. Bashiri, S. Fluhrer, S. Gazdag, D. Van Geest, S. Kousidis | Proposed Standard | December 2025 |
| 9908 | Clarification and Enhancement of the CSR Attributes Definition in RFC 7030M. Richardson, Ed., O. Friel, D. von Oheimb, D. Harkins | Proposed Standard | January 2026 |
| 9883 | An Attribute for Statement of Possession of a Private KeyR. Housley | Proposed Standard | October 2025 |
| 9881 | Internet X.509 Public Key Infrastructure -- Algorithm Identifiers for the Module-Lattice-Based Digital Signature Algorithm (ML-DSA)J. Massimo, P. Kampanakis, S. Turner, B. E. Westerbaan | Proposed Standard | October 2025 |
| 9810 | Internet X.509 Public Key Infrastructure -- Certificate Management Protocol (CMP)H. Brockhaus, D. von Oheimb, M. Ounsworth, J. Gray | Proposed Standard | July 2025 |
| 9802 | Use of the HSS and XMSS Hash-Based Signature Algorithms in Internet X.509 Public Key InfrastructureD. Van Geest, K. Bashiri, S. Fluhrer, S. Gazdag, S. Kousidis | Proposed Standard | June 2025 |
| 9763 | Related Certificates for Use in Multiple Authentications within a ProtocolA. Becker, R. Guthrie, M. Jenkins | Proposed Standard | June 2025 |
| 9708 | Use of the HSS/LMS Hash-Based Signature Algorithm in the Cryptographic Message Syntax (CMS)R. Housley | Proposed Standard | January 2025 |
| 9691 | A Profile for Resource Public Key Infrastructure (RPKI) Trust Anchor Keys (TAKs)C. Martinez, G. Michaelson, T. Harrison, T. Bruijnzeels, R. Austein | Proposed Standard | December 2024 |
| 9690 | Use of the RSA-KEM Algorithm in the Cryptographic Message Syntax (CMS)R. Housley, S. Turner | Proposed Standard | February 2025 |
| 9688 | Use of the SHA3 One-Way Hash Functions in the Cryptographic Message Syntax (CMS)R. Housley | Proposed Standard | November 2024 |
| 9654 | Online Certificate Status Protocol (OCSP) Nonce ExtensionH. Sharma, Ed. | Proposed Standard | August 2024 |
| 9629 | Using Key Encapsulation Mechanism (KEM) Algorithms in the Cryptographic Message Syntax (CMS)R. Housley, J. Gray, T. Okubo | Proposed Standard | August 2024 |
| 9608 | No Revocation Available for X.509 Public Key CertificatesR. Housley, T. Okubo, J. Mandel | Proposed Standard | June 2024 |
| 9598 | Internationalized Email Addresses in X.509 CertificatesA. Melnikov, W. Chuang, C. Bonnell | Proposed Standard | May 2024 |
| 9480 | Certificate Management Protocol (CMP) UpdatesH. Brockhaus, D. von Oheimb, J. Gray · obsoleted by RFC 9810, RFC 9811 | Proposed Standard | November 2023 |
| 9399 | Internet X.509 Public Key Infrastructure: Logotypes in X.509 CertificatesS. Santesson, R. Housley, T. Freeman, L. Rosenthol | Proposed Standard | May 2023 |
| 9345 | Delegated Credentials for TLS and DTLSR. Barnes, S. Iyengar, N. Sullivan, E. Rescorla | Proposed Standard | July 2023 |
| 9310 | X.509 Certificate Extension for 5G Network Function TypesR. Housley, S. Turner, J. Preuß Mattsson, D. Migault | Proposed Standard | January 2023 |
| 9174 | Delay-Tolerant Networking TCP Convergence-Layer Protocol Version 4B. Sipos, M. Demmer, J. Ott, S. Perreault | Proposed Standard | January 2022 |
| 9169 | New ASN.1 Modules for the Evidence Record Syntax (ERS)R. Housley, C. Wallace | Informational | December 2021 |
| 9162 | Certificate Transparency Version 2.0B. Laurie, E. Messeri, R. Stradling | Experimental | December 2021 |
| 9152 | Secure Object Delivery Protocol (SODP) Server Interfaces: NSA's Profile for Delivery of Certificates, Certificate Revocation Lists (CRLs), and Symmetric Keys to ClientsM. Jenkins, S. Turner | Informational | April 2022 |
| 9118 | Enhanced JSON Web Token (JWT) Claim Constraints for Secure Telephone Identity Revisited (STIR) CertificatesR. Housley | Proposed Standard | August 2021 |
| 9044 | Using the AES-GMAC Algorithm with the Cryptographic Message Syntax (CMS)R. Housley | Proposed Standard | June 2021 |
| 8994 | An Autonomic Control Plane (ACP)T. Eckert, Ed., M. Behringer, Ed., S. Bjarnason | Proposed Standard | May 2021 |
| 8951 | Clarification of Enrollment over Secure Transport (EST): Transfer Encodings and ASN.1M. Richardson, T. Werner, W. Pan | Proposed Standard | November 2020 |
| 8708 | Use of the HSS/LMS Hash-Based Signature Algorithm in the Cryptographic Message Syntax (CMS)R. Housley · obsoleted by RFC 9708 | Proposed Standard | February 2020 |
| 8702 | Use of the SHAKE One-Way Hash Functions in the Cryptographic Message Syntax (CMS)P. Kampanakis, Q. Dang | Proposed Standard | January 2020 |
| 8696 | Using Pre-Shared Key (PSK) in the Cryptographic Message Syntax (CMS)R. Housley | Proposed Standard | December 2019 |
| 8692 | Internet X.509 Public Key Infrastructure: Additional Algorithm Identifiers for RSASSA-PSS and ECDSA Using SHAKEsP. Kampanakis, Q. Dang | Proposed Standard | December 2019 |
| 8649 | Hash Of Root Key Certificate ExtensionR. Housley | Informational | August 2019 |
| 8619 | Algorithm Identifiers for the HMAC-based Extract-and-Expand Key Derivation Function (HKDF)R. Housley | Proposed Standard | June 2019 |
| 8520 | Manufacturer Usage Description SpecificationE. Lear, R. Droms, D. Romascanu | Proposed Standard | March 2019 |
| 8479 | Storing Validation Parameters in PKCS#8N. Mavrogiannopoulos | Informational | September 2018 |
| 8398 | Internationalized Email Addresses in X.509 CertificatesA. Melnikov, Ed., W. Chuang, Ed. · obsoleted by RFC 9598 | Proposed Standard | May 2018 |
| 8226 | Secure Telephone Identity Credentials: CertificatesJ. Peterson, S. Turner | Proposed Standard | February 2018 |
| 7906 | NSA's Cryptographic Message Syntax (CMS) Key Management AttributesP. Timmel, R. Housley, S. Turner | Informational | June 2016 |
| 7894 | Alternative Challenge Password Attributes for Enrollment over Secure TransportM. Pritikin, C. Wallace | Proposed Standard | June 2016 |
| 7773 | Authentication Context Certificate ExtensionS. Santesson | Proposed Standard | March 2016 |
| 7633 | X.509v3 Transport Layer Security (TLS) Feature ExtensionP. Hallam-Baker | Proposed Standard | October 2015 |
| 7427 | Signature Authentication in the Internet Key Exchange Version 2 (IKEv2)T. Kivinen, J. Snyder | Proposed Standard | January 2015 |
| 7299 | Object Identifier Registry for the PKIX Working GroupR. Housley | Informational | July 2014 |
| 7191 | Cryptographic Message Syntax (CMS) Key Package Receipt and Error Content TypesR. Housley | Proposed Standard | April 2014 |
| 6960 | X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSPS. Santesson, M. Myers, R. Ankney, A. Malpani, S. Galperin, C. Adams | Proposed Standard | June 2013 |
| 6955 | Diffie-Hellman Proof-of-Possession AlgorithmsJ. Schaad, H. Prafullchandra | Proposed Standard | May 2013 |
| 6664 | S/MIME Capabilities for Public Key DefinitionsJ. Schaad | Informational | July 2012 |
| 6402 | Certificate Management over CMS (CMC) UpdatesJ. Schaad · obsoleted by RFC 10002, RFC 10003, RFC 10004 | Proposed Standard | November 2011 |
| 6277 | Online Certificate Status Protocol Algorithm AgilityS. Santesson, P. Hallam-Baker · obsoleted by RFC 6960 | Proposed Standard | June 2011 |
| 6268 | Additional New ASN.1 Modules for the Cryptographic Message Syntax (CMS) and the Public Key Infrastructure Using X.509 (PKIX)J. Schaad, S. Turner | Informational | July 2011 |
| 6211 | Cryptographic Message Syntax (CMS) Algorithm Identifier Protection AttributeJ. Schaad | Proposed Standard | April 2011 |
| 6210 | Experiment: Hash Functions with Parameters in the Cryptographic Message Syntax (CMS) and S/MIMEJ. Schaad | Experimental | April 2011 |
| 6032 | Cryptographic Message Syntax (CMS) Encrypted Key Package Content TypeS. Turner, R. Housley | Proposed Standard | December 2010 |
| 6031 | Cryptographic Message Syntax (CMS) Symmetric Key Package Content TypeS. Turner, R. Housley | Proposed Standard | December 2010 |
| 6025 | ASN.1 TranslationC. Wallace, C. Gardiner | Informational | October 2010 |
| 6010 | Cryptographic Message Syntax (CMS) Content Constraints ExtensionR. Housley, S. Ashmore, C. Wallace | Proposed Standard | September 2010 |
| 5958 | Asymmetric Key PackagesS. Turner | Proposed Standard | August 2010 |
| 5940 | Additional Cryptographic Message Syntax (CMS) Revocation Information ChoicesS. Turner, R. Housley | Proposed Standard | August 2010 |
| 5934 | Trust Anchor Management Protocol (TAMP)R. Housley, S. Ashmore, C. Wallace | Proposed Standard | August 2010 |
| 5917 | Clearance Sponsor AttributeS. Turner | Informational | June 2010 |
| 5916 | Device Owner AttributeS. Turner | Informational | June 2010 |
| 5915 | Elliptic Curve Private Key StructureS. Turner, D. Brown | Informational | June 2010 |
| 5914 | Trust Anchor FormatR. Housley, S. Ashmore, C. Wallace | Proposed Standard | June 2010 |
| 5913 | Clearance Attribute and Authority Clearance Constraints Certificate ExtensionS. Turner, S. Chokhani | Proposed Standard | June 2010 |
| 5911 | New ASN.1 Modules for Cryptographic Message Syntax (CMS) and S/MIMEP. Hoffman, J. Schaad | Informational | June 2010 |