| 10023 | The "_for-sale" Underscored and Globally Scoped DNS Node NameM. Davids | Informational | July 2026 |
| 9990 | Domain-Based Message Authentication, Reporting, and Conformance (DMARC) Aggregate ReportingA. Brotman, Ed. | Proposed Standard | May 2026 |
| 9989 | Domain-Based Message Authentication, Reporting, and Conformance (DMARC)T. Herr, Ed., J. Levine, Ed. | Proposed Standard | May 2026 |
| 9911 | Common YANG Data TypesJ. Schönwälder, Ed. | Proposed Standard | December 2025 |
| 9873 | Additional Email Address Extension for the Extensible Provisioning Protocol (EPP)D. Belyavsky, J. Gould, S. Hollenbeck | Proposed Standard | October 2025 |
| 9849 | TLS Encrypted Client HelloE. Rescorla, K. Oku, N. Sullivan, C. A. Wood | Proposed Standard | March 2026 |
| 9788 | Header Protection for Cryptographically Protected EmailD. K. Gillmor, B. Hoeneisen, A. Melnikov | Proposed Standard | August 2025 |
| 9787 | Guidance on End-to-End Email SecurityD. K. Gillmor, Ed., A. Melnikov, Ed., B. Hoeneisen, Ed. | Informational | August 2025 |
| 9598 | Internationalized Email Addresses in X.509 CertificatesA. Melnikov, W. Chuang, C. Bonnell | Proposed Standard | May 2024 |
| 9552 | Distribution of Link-State and Traffic Engineering Information Using BGPK. Talaulikar, Ed. | Proposed Standard | December 2023 |
| 9549 | Internationalization Updates to RFC 5280R. Housley | Proposed Standard | March 2024 |
| 9525 | Service Identity in TLSP. Saint-Andre, R. Salz | Proposed Standard | November 2023 |
| 9499 | DNS TerminologyP. Hoffman, K. Fujiwara | Best Current Practice | March 2024 |
| 9498 | The GNU Name SystemM. Schanzenbach, C. Grothoff, B. Fix | Informational | November 2023 |
| 9495 | Certification Authority Authorization (CAA) Processing for Email AddressesC. Bonnell | Proposed Standard | October 2023 |
| 9464 | Internet Key Exchange Protocol Version 2 (IKEv2) Configuration for Encrypted DNSM. Boucadair, T. Reddy.K, D. Wing, V. Smyslov | Proposed Standard | November 2023 |
| 9456 | Updates to the TLS Transport Model for SNMPK. Vaughn, Ed. | Proposed Standard | November 2023 |
| 9393 | Concise Software Identification TagsH. Birkholz, J. Fitzgerald-McKay, C. Schmidt, D. Waltermire | Proposed Standard | June 2023 |
| 9361 | ICANN Trademark Clearinghouse (TMCH) Functional SpecificationsG. Lozano | Informational | March 2023 |
| 9233 | Internationalized Domain Names for Applications 2008 (IDNA2008) and Unicode 12.0.0P. Fältström | Proposed Standard | March 2022 |
| 9224 | Finding the Authoritative Registration Data Access Protocol (RDAP) ServiceM. Blanchet | Internet Standard | March 2022 |
| 9095 | Extensible Provisioning Protocol (EPP) Domain Name Mapping Extension for Strict Bundling RegistrationJ. Yao, L. Zhou, H. Li, N. Kong, J. Xie | Informational | July 2021 |
| 9083 | JSON Responses for the Registration Data Access Protocol (RDAP)S. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 9082 | Registration Data Access Protocol (RDAP) Query FormatS. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 8982 | Registration Data Access Protocol (RDAP) Partial ResponseM. Loffredo, M. Martinelli | Proposed Standard | February 2021 |
| 8977 | Registration Data Access Protocol (RDAP) Query Parameters for Result Sorting and PagingM. Loffredo, M. Martinelli, S. Hollenbeck | Proposed Standard | January 2021 |
| 8915 | Network Time Security for the Network Time ProtocolD. Franke, D. Sibold, K. Teichel, M. Dansarie, R. Sundblad | Proposed Standard | September 2020 |
| 8866 | SDP: Session Description ProtocolA. Begen, P. Kyzivat, C. Perkins, M. Handley | Proposed Standard | January 2021 |
| 8827 | WebRTC Security ArchitectureE. Rescorla | Proposed Standard | January 2021 |
| 8823 | Extensions to Automatic Certificate Management Environment for End-User S/MIME CertificatesA. Melnikov | Informational | April 2021 |
| 8753 | Internationalized Domain Names for Applications (IDNA) Review for New Unicode VersionsJ. Klensin, P. Fältström | Proposed Standard | April 2020 |
| 8616 | Email Authentication for Internationalized MailJ. Levine | Proposed Standard | June 2019 |
| 8598 | Split DNS Configuration for the Internet Key Exchange Protocol Version 2 (IKEv2)T. Pauly, P. Wouters | Proposed Standard | May 2019 |
| 8555 | Automatic Certificate Management Environment (ACME)R. Barnes, J. Hoffman-Andrews, D. McCarney, J. Kasten | Proposed Standard | March 2019 |
| 8499 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 9499 | Best Current Practice | January 2019 |
| 8489 | Session Traversal Utilities for NAT (STUN)M. Petit-Huguenin, G. Salgueiro, J. Rosenberg, D. Wing, R. Mahy, P. Matthews | Proposed Standard | February 2020 |
| 8483 | Yeti DNS TestbedL. Song, Ed., D. Liu, P. Vixie, A. Kato, S. Kerr | Informational | October 2018 |
| 8427 | Representing DNS Messages in JSONP. Hoffman | Informational | July 2018 |
| 8399 | Internationalization Updates to RFC 5280R. Housley · obsoleted by RFC 9549 | Proposed Standard | May 2018 |
| 8398 | Internationalized Email Addresses in X.509 CertificatesA. Melnikov, Ed., W. Chuang, Ed. · obsoleted by RFC 9598 | Proposed Standard | May 2018 |
| 8324 | DNS Privacy, Authorization, Special Uses, Encoding, Characters, Matching, and Root Structure: Time for Another Look?J. Klensin | Informational | February 2018 |
| 8265 | Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and PasswordsP. Saint-Andre, A. Melnikov | Proposed Standard | October 2017 |
| 8264 | PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application ProtocolsP. Saint-Andre, M. Blanchet | Proposed Standard | October 2017 |
| 8228 | Guidance on Designing Label Generation Rulesets (LGRs) Supporting Variant LabelsA. Freytag | Informational | August 2017 |
| 8222 | Selecting Labels for Use with Conventional DNS and Other Resolution Systems in DNS-Based Service DiscoveryA. Sullivan | Informational | September 2017 |
| 8141 | Uniform Resource Names (URNs)P. Saint-Andre, J. Klensin | Proposed Standard | April 2017 |
| 8120 | Mutual Authentication Protocol for HTTPY. Oiwa, H. Watanabe, H. Takagi, K. Maeda, T. Hayashi, Y. Ioku | Experimental | April 2017 |
| 8006 | Content Delivery Network Interconnection (CDNI) MetadataB. Niven-Jenkins, R. Murray, M. Caulfield, K. Ma | Proposed Standard | December 2016 |
| 7975 | Request Routing Redirection Interface for Content Delivery Network (CDN) InterconnectionB. Niven-Jenkins, Ed., R. van Brandenburg, Ed. | Proposed Standard | October 2016 |
| 7848 | Mark and Signed Mark Objects MappingG. Lozano | Proposed Standard | June 2016 |
| 7838 | HTTP Alternative ServicesM. Nottingham, P. McManus, J. Reschke | Proposed Standard | April 2016 |
| 7815 | Minimal Internet Key Exchange Version 2 (IKEv2) Initiator ImplementationT. Kivinen | Informational | March 2016 |
| 7752 | North-Bound Distribution of Link-State and Traffic Engineering (TE) Information Using BGPH. Gredler, Ed., J. Medved, S. Previdi, A. Farrel, S. Ray · obsoleted by RFC 9552 | Proposed Standard | March 2016 |
| 7719 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 8499 | Informational | December 2015 |
| 7673 | Using DNS-Based Authentication of Named Entities (DANE) TLSA Records with SRV RecordsT. Finch, M. Miller, P. Saint-Andre | Proposed Standard | October 2015 |
| 7622 | Extensible Messaging and Presence Protocol (XMPP): Address FormatP. Saint-Andre | Proposed Standard | September 2015 |
| 7613 | Preparation, Enforcement, and Comparison of Internationalized Strings Representing Usernames and PasswordsP. Saint-Andre, A. Melnikov · obsoleted by RFC 8265 | Proposed Standard | August 2015 |
| 7565 | The 'acct' URI SchemeP. Saint-Andre | Proposed Standard | May 2015 |
| 7564 | PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application ProtocolsP. Saint-Andre, M. Blanchet · obsoleted by RFC 8264 | Proposed Standard | May 2015 |
| 7542 | The Network Access IdentifierA. DeKok | Proposed Standard | May 2015 |
| 7530 | Network File System (NFS) Version 4 ProtocolT. Haynes, Ed., D. Noveck, Ed. | Proposed Standard | March 2015 |
| 7489 | Domain-based Message Authentication, Reporting, and Conformance (DMARC)M. Kucherawy, Ed., E. Zwicky, Ed. · obsoleted by RFC 9989, RFC 9990, RFC 9991 | Informational | March 2015 |
| 7485 | Inventory and Analysis of WHOIS Registration ObjectsL. Zhou, N. Kong, S. Shen, S. Sheng, A. Servin | Informational | March 2015 |
| 7484 | Finding the Authoritative Registration Data (RDAP) ServiceM. Blanchet · obsoleted by RFC 9224 | Proposed Standard | March 2015 |
| 7483 | JSON Responses for the Registration Data Access Protocol (RDAP)A. Newton, S. Hollenbeck · obsoleted by RFC 9083 | Proposed Standard | March 2015 |
| 7482 | Registration Data Access Protocol (RDAP) Query FormatA. Newton, S. Hollenbeck · obsoleted by RFC 9082 | Proposed Standard | March 2015 |
| 7480 | HTTP Usage in the Registration Data Access Protocol (RDAP)A. Newton, B. Ellacott, N. Kong | Internet Standard | March 2015 |
| 7462 | URNs for the Alert-Info Header Field of the Session Initiation Protocol (SIP)L. Liess, Ed., R. Jesske, A. Johnston, D. Worley, P. Kyzivat | Proposed Standard | March 2015 |
| 7451 | Extension Registry for the Extensible Provisioning ProtocolS. Hollenbeck | Informational | February 2015 |
| 7368 | IPv6 Home Networking Architecture PrinciplesT. Chown, Ed., J. Arkko, A. Brandt, O. Troan, J. Weil | Informational | October 2014 |
| 7296 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen, T. Kivinen | Internet Standard | October 2014 |
| 7208 | Sender Policy Framework (SPF) for Authorizing Use of Domains in Email, Version 1S. Kitterman | Proposed Standard | April 2014 |
| 7151 | File Transfer Protocol HOST Command for Virtual HostsP. Hethmon, R. McMurray | Proposed Standard | March 2014 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 6943 | Issues in Identifier Comparison for Security PurposesD. Thaler, Ed. | Informational | May 2013 |
| 6927 | Variants in Second-Level Names Registered in Top-Level DomainsJ. Levine, P. Hoffman | Informational | May 2013 |
| 6912 | Principles for Unicode Code Point Inclusion in Labels in the DNSA. Sullivan, D. Thaler, J. Klensin, O. Kolkman | Informational | April 2013 |
| 6885 | Stringprep Revision and Problem Statement for the Preparation and Comparison of Internationalized Strings (PRECIS)M. Blanchet, A. Sullivan | Informational | March 2013 |
| 6857 | Post-Delivery Message Downgrading for Internationalized Email MessagesK. Fujiwara | Proposed Standard | March 2013 |
| 6797 | HTTP Strict Transport Security (HSTS)J. Hodges, C. Jackson, A. Barth | Proposed Standard | November 2012 |
| 6783 | Mailing Lists and Non-ASCII AddressesJ. Levine, R. Gellens | Informational | November 2012 |
| 6763 | DNS-Based Service DiscoveryS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6762 | Multicast DNSS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6733 | Diameter Base ProtocolV. Fajardo, Ed., J. Arkko, J. Loughney, G. Zorn, Ed. | Proposed Standard | October 2012 |
| 6698 | The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSAP. Hoffman, J. Schlyter | Proposed Standard | August 2012 |
| 6630 | EAP Re-authentication Protocol Extensions for Authenticated Anticipatory Keying (ERP/AAK)Z. Cao, H. Deng, Q. Wu, G. Zorn, Ed. | Proposed Standard | June 2012 |
| 6595 | A Simple Authentication and Security Layer (SASL) and GSS-API Mechanism for the Security Assertion Markup Language (SAML)K. Wierenga, E. Lear, S. Josefsson | Proposed Standard | April 2012 |
| 6545 | Real-time Inter-network Defense (RID)K. Moriarty | Proposed Standard | April 2012 |
| 6541 | DomainKeys Identified Mail (DKIM) Authorized Third-Party SignaturesM. Kucherawy | Experimental | February 2012 |
| 6531 | SMTP Extension for Internationalized EmailJ. Yao, W. Mao | Proposed Standard | February 2012 |
| 6530 | Overview and Framework for Internationalized EmailJ. Klensin, Y. Ko | Proposed Standard | February 2012 |
| 6454 | The Web Origin ConceptA. Barth | Proposed Standard | December 2011 |
| 6440 | The EAP Re-authentication Protocol (ERP) Local Domain Name DHCPv6 OptionG. Zorn, Q. Wu, Y. Wang | Proposed Standard | December 2011 |
| 6376 | DomainKeys Identified Mail (DKIM) SignaturesD. Crocker, Ed., T. Hansen, Ed., M. Kucherawy, Ed. | Internet Standard | September 2011 |
| 6365 | Terminology Used in Internationalization in the IETFP. Hoffman, J. Klensin | Best Current Practice | September 2011 |
| 6353 | Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP)W. Hardaker | Internet Standard | July 2011 |
| 6265 | HTTP State Management MechanismA. Barth | Proposed Standard | April 2011 |
| 6155 | Use of Device Identity in HTTP-Enabled Location Delivery (HELD)J. Winterbottom, M. Thomson, H. Tschofenig, R. Barnes | Proposed Standard | March 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6122 | Extensible Messaging and Presence Protocol (XMPP): Address FormatP. Saint-Andre · obsoleted by RFC 7622 | Proposed Standard | March 2011 |
| 6068 | The 'mailto' URI SchemeM. Duerst, L. Masinter, J. Zawinski | Proposed Standard | October 2010 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6055 | IAB Thoughts on Encodings for Internationalized Domain NamesD. Thaler, J. Klensin, S. Cheshire | Informational | February 2011 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |
| 5992 | Internationalized Domain Names Registration and Administration Guidelines for European Languages Using CyrillicS. Sharikov, D. Miloshevic, J. Klensin | Informational | October 2010 |
| 5894 | Internationalized Domain Names for Applications (IDNA): Background, Explanation, and RationaleJ. Klensin | Informational | August 2010 |
| 5893 | Right-to-Left Scripts for Internationalized Domain Names for Applications (IDNA)H. Alvestrand, Ed., C. Karp | Proposed Standard | August 2010 |
| 5892 | The Unicode Code Points and Internationalized Domain Names for Applications (IDNA)P. Faltstrom, Ed. | Proposed Standard | August 2010 |
| 5891 | Internationalized Domain Names in Applications (IDNA): ProtocolJ. Klensin | Proposed Standard | August 2010 |