| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2154 | OSPF with Digital SignaturesS. Murphy, M. Badger, B. Wellington | Experimental | June 1997 |
| 2328 | OSPF Version 2J. Moy | Internet Standard | April 1998 |
| 3630 | Traffic Engineering (TE) Extensions to OSPF Version 2D. Katz, K. Kompella, D. Yeung | Proposed Standard | October 2003 |
| 3945 | Generalized Multi-Protocol Label Switching (GMPLS) ArchitectureE. Mannie, Ed. | Proposed Standard | November 2004 |
| 4202 | Routing Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2005 |
| 4203 | OSPF Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2005 |
| 4258 | Requirements for Generalized Multi-Protocol Label Switching (GMPLS) Routing for the Automatically Switched Optical Network (ASON)D. Brungard, Ed. | Informational | November 2005 |
| 4652 | Evaluation of Existing Routing Protocols against Automatic Switched Optical Network (ASON) Routing RequirementsD. Papadimitriou, Ed., L. Ong, J. Sadler, S. Shew, D. Ward | Informational | October 2006 |
| 4970 | Extensions to OSPF for Advertising Optional Router CapabilitiesA. Lindem, Ed., N. Shen, JP. Vasseur, R. Aggarwal, S. Shaffer · obsoleted by RFC 7770 | Proposed Standard | July 2007 |
| 5073 | IGP Routing Protocol Extensions for Discovery of Traffic Engineering Node CapabilitiesJ.P. Vasseur, Ed., J.L. Le Roux, Ed. | Proposed Standard | December 2007 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5250 | The OSPF Opaque LSA OptionL. Berger, I. Bryskin, A. Zinin, R. Coltun | Proposed Standard | July 2008 |
| 5340 | OSPF for IPv6R. Coltun, D. Ferguson, J. Moy, A. Lindem | Proposed Standard | July 2008 |
| 5709 | OSPFv2 HMAC-SHA Cryptographic AuthenticationM. Bhatia, V. Manral, M. Fanto, R. White, M. Barnes, T. Li, R. Atkinson | Proposed Standard | October 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5786 | Advertising a Router's Local Addresses in OSPF Traffic Engineering (TE) ExtensionsR. Aggarwal, K. Kompella | Proposed Standard | March 2010 |