| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2311 | S/MIME Version 2 Message SpecificationS. Dusse, P. Hoffman, B. Ramsdell, L. Lundblade, L. Repka | Historic | March 1998 |
| 2312 | S/MIME Version 2 Certificate HandlingS. Dusse, P. Hoffman, B. Ramsdell, J. Weinstein | Historic | March 1998 |
| 2313 | PKCS #1: RSA Encryption Version 1.5B. Kaliski · obsoleted by RFC 2437 | Informational | March 1998 |
| 2314 | PKCS #10: Certification Request Syntax Version 1.5B. Kaliski · obsoleted by RFC 2986 | Informational | March 1998 |
| 2315 | PKCS #7: Cryptographic Message Syntax Version 1.5B. Kaliski | Informational | March 1998 |
| 2630 | Cryptographic Message SyntaxR. Housley · obsoleted by RFC 3369, RFC 3370 | Proposed Standard | June 1999 |
| 2631 | Diffie-Hellman Key Agreement MethodE. Rescorla | Proposed Standard | June 1999 |
| 2632 | S/MIME Version 3 Certificate HandlingB. Ramsdell, Ed. · obsoleted by RFC 3850 | Proposed Standard | June 1999 |
| 2633 | S/MIME Version 3 Message SpecificationB. Ramsdell, Ed. · obsoleted by RFC 3851 | Proposed Standard | June 1999 |
| 2634 | Enhanced Security Services for S/MIMEP. Hoffman, Ed. | Proposed Standard | June 1999 |
| 2985 | PKCS #9: Selected Object Classes and Attribute Types Version 2.0M. Nystrom, B. Kaliski | Informational | November 2000 |
| 3114 | Implementing Company Classification Policy with the S/MIME Security LabelW. Nicolls | Informational | May 2002 |
| 3279 | Algorithms and Identifiers for the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileL. Bassham, W. Polk, R. Housley | Proposed Standard | May 2002 |
| 3447 | Public-Key Cryptography Standards (PKCS) #1: RSA Cryptography Specifications Version 2.1J. Jonsson, B. Kaliski · obsoleted by RFC 8017 | Informational | February 2003 |
| 3850 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.1 Certificate HandlingB. Ramsdell, Ed. · obsoleted by RFC 5750 | Proposed Standard | July 2004 |
| 3851 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.1 Message SpecificationB. Ramsdell, Ed. · obsoleted by RFC 5751 | Proposed Standard | July 2004 |
| 3852 | Cryptographic Message Syntax (CMS)R. Housley · obsoleted by RFC 5652 | Proposed Standard | July 2004 |
| 4055 | Additional Algorithms and Identifiers for RSA Cryptography for use in the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileJ. Schaad, B. Kaliski, R. Housley | Proposed Standard | June 2005 |
| 4056 | Use of the RSASSA-PSS Signature Algorithm in Cryptographic Message Syntax (CMS)J. Schaad | Proposed Standard | June 2005 |
| 5035 | Enhanced Security Services (ESS) Update: Adding CertID Algorithm AgilityJ. Schaad | Proposed Standard | August 2007 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5652 | Cryptographic Message Syntax (CMS)R. Housley | Internet Standard | September 2009 |
| 5741 | RFC Streams, Headers, and BoilerplatesL. Daigle, Ed., O. Kolkman, Ed., IAB · obsoleted by RFC 7841 | Informational | December 2009 |
| 5751 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Message SpecificationB. Ramsdell, S. Turner · obsoleted by RFC 8551 | Proposed Standard | January 2010 |
| 5758 | Internet X.509 Public Key Infrastructure: Additional Algorithms and Identifiers for DSA and ECDSAQ. Dang, S. Santesson, K. Moriarty, D. Brown, T. Polk | Proposed Standard | January 2010 |