| 10037 | Registration Data Access Protocol (RDAP) Extension for DNS Time-to-Live (TTL) ValuesG. Brown | Proposed Standard | August 2026 |
| 10026 | Operational Recommendations for DNSSEC Delegation Signer (DS) AutomationS. Sheng, P. Thomassen | Best Current Practice | July 2026 |
| 10023 | The "_for-sale" Underscored and Globally Scoped DNS Node NameM. Davids | Informational | July 2026 |
| 9975 | Clarifications on CDS/CDNSKEY and CSYNC ConsistencyP. Thomassen | Proposed Standard | May 2026 |
| 9886 | DRIP Entity Tags (DETs) in the Domain Name SystemA. Wiethuechter, Ed., J. Reid | Proposed Standard | December 2025 |
| 9874 | Best Practices for Deletion of Domain and Host Objects in the Extensible Provisioning Protocol (EPP)S. Hollenbeck, W. Carroll, G. Akiwate | Best Current Practice | September 2025 |
| 9873 | Additional Email Address Extension for the Extensible Provisioning Protocol (EPP)D. Belyavsky, J. Gould, S. Hollenbeck | Proposed Standard | October 2025 |
| 9536 | Registration Data Access Protocol (RDAP) Reverse SearchM. Loffredo, M. Martinelli | Proposed Standard | April 2024 |
| 9499 | DNS TerminologyP. Hoffman, K. Fujiwara | Best Current Practice | March 2024 |
| 9434 | Drone Remote Identification Protocol (DRIP) ArchitectureS. Card, A. Wiethuechter, R. Moskowitz, S. Zhao, Ed., A. Gurtov | Informational | July 2023 |
| 9167 | Registry Maintenance Notification for the Extensible Provisioning Protocol (EPP)T. Sattler, R. Carney, J. Kolker | Proposed Standard | December 2021 |
| 9154 | Extensible Provisioning Protocol (EPP) Secure Authorization Information for TransferJ. Gould, R. Wilhelm | Proposed Standard | December 2021 |
| 9095 | Extensible Provisioning Protocol (EPP) Domain Name Mapping Extension for Strict Bundling RegistrationJ. Yao, L. Zhou, H. Li, N. Kong, J. Xie | Informational | July 2021 |
| 9083 | JSON Responses for the Registration Data Access Protocol (RDAP)S. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 9082 | Registration Data Access Protocol (RDAP) Query FormatS. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 9038 | Extensible Provisioning Protocol (EPP) Unhandled NamespacesJ. Gould, M. Casanova | Proposed Standard | May 2021 |
| 9022 | Domain Name Registration Data (DNRD) Objects MappingG. Lozano, J. Gould, C. Thippeswamy | Proposed Standard | May 2021 |
| 8807 | Login Security Extension for the Extensible Provisioning Protocol (EPP)J. Gould, M. Pozun | Proposed Standard | August 2020 |
| 8748 | Registry Fee Extension for the Extensible Provisioning Protocol (EPP)R. Carney, G. Brown, J. Frakes | Proposed Standard | March 2020 |
| 8590 | Change Poll Extension for the Extensible Provisioning Protocol (EPP)J. Gould, K. Feher | Proposed Standard | May 2019 |
| 8544 | Organization Extension for the Extensible Provisioning Protocol (EPP)L. Zhou, N. Kong, J. Wei, J. Yao, J. Gould | Proposed Standard | April 2019 |
| 8543 | Extensible Provisioning Protocol (EPP) Organization MappingL. Zhou, N. Kong, J. Yao, J. Gould, G. Zhou | Proposed Standard | March 2019 |
| 8521 | Registration Data Access Protocol (RDAP) Object TaggingS. Hollenbeck, A. Newton | Best Current Practice | November 2018 |
| 8499 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 9499 | Best Current Practice | January 2019 |
| 8495 | Allocation Token Extension for the Extensible Provisioning Protocol (EPP)J. Gould, K. Feher | Proposed Standard | November 2018 |
| 8334 | Launch Phase Mapping for the Extensible Provisioning Protocol (EPP)J. Gould, W. Tan, G. Brown | Proposed Standard | March 2018 |
| 8063 | Key Relay Mapping for the Extensible Provisioning ProtocolH.W. Ribbers, M.W. Groeneweg, R. Gieben, A.L.J. Verschuren | Proposed Standard | February 2017 |
| 7992 | HTML Format for RFCsJ. Hildebrand, Ed., P. Hoffman | Informational | December 2016 |
| 7848 | Mark and Signed Mark Objects MappingG. Lozano | Proposed Standard | June 2016 |
| 7719 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 8499 | Informational | December 2015 |
| 7485 | Inventory and Analysis of WHOIS Registration ObjectsL. Zhou, N. Kong, S. Shen, S. Sheng, A. Servin | Informational | March 2015 |
| 7483 | JSON Responses for the Registration Data Access Protocol (RDAP)A. Newton, S. Hollenbeck · obsoleted by RFC 9083 | Proposed Standard | March 2015 |
| 7482 | Registration Data Access Protocol (RDAP) Query FormatA. Newton, S. Hollenbeck · obsoleted by RFC 9082 | Proposed Standard | March 2015 |
| 7451 | Extension Registry for the Extensible Provisioning ProtocolS. Hollenbeck | Informational | February 2015 |
| 7344 | Automating DNSSEC Delegation Trust MaintenanceW. Kumari, O. Gudmundsson, G. Barwood | Proposed Standard | September 2014 |
| 5910 | Domain Name System (DNS) Security Extensions Mapping for the Extensible Provisioning Protocol (EPP)J. Gould, S. Hollenbeck | Proposed Standard | May 2010 |
| 5734 | Extensible Provisioning Protocol (EPP) Transport over TCPS. Hollenbeck | Internet Standard | August 2009 |
| 5733 | Extensible Provisioning Protocol (EPP) Contact MappingS. Hollenbeck | Internet Standard | August 2009 |
| 5732 | Extensible Provisioning Protocol (EPP) Host MappingS. Hollenbeck | Internet Standard | August 2009 |
| 5731 | Extensible Provisioning Protocol (EPP) Domain Name MappingS. Hollenbeck | Internet Standard | August 2009 |