| 9959 | Careful Resume: Convergence of Congestion Control from Retained StateN. Kuhn, E. Stephan, G. Fairhurst, R. Secchi, C. Huitema | Proposed Standard | May 2026 |
| 9957 | The DOCSIS Queue Protection Algorithm to Preserve Low LatencyB. Briscoe, Ed., G. White | Informational | May 2026 |
| 9956 | A Non-Queue-Building Per-Hop Behavior (NQB PHB) for Differentiated ServicesG. White, T. Fossati, R. Geib | Proposed Standard | May 2026 |
| 9937 | Proportional Rate Reduction (PRR)M. Mathis, N. Cardwell, Y. Cheng, N. Dukkipati | Proposed Standard | December 2025 |
| 9840 | rLEDBAT: Receiver-Driven Low Extra Delay Background Transport for TCPM. Bagnulo, A. García-Martínez, G. Montenegro, P. Balasubramanian | Experimental | September 2025 |
| 9768 | More Accurate Explicit Congestion Notification (AccECN) Feedback in TCPB. Briscoe, M. Kühlewind, R. Scheffenegger | Proposed Standard | April 2026 |
| 9743 | Specifying New Congestion Control AlgorithmsM. Duke, Ed., G. Fairhurst, Ed. | Best Current Practice | March 2025 |
| 9681 | IS-IS Fast FloodingB. Decraene, L. Ginsberg, T. Li, G. Solignac, M. Karasek, G. Van de Velde, T. Przygienda | Experimental | November 2024 |
| 9438 | CUBIC for Fast and Long-Distance NetworksL. Xu, S. Ha, I. Rhee, V. Goel, L. Eggert, Ed. | Proposed Standard | August 2023 |
| 9406 | HyStart++: Modified Slow Start for TCPP. Balasubramanian, Y. Huang, M. Olson | Proposed Standard | May 2023 |
| 9332 | Dual-Queue Coupled Active Queue Management (AQM) for Low Latency, Low Loss, and Scalable Throughput (L4S)K. De Schepper, B. Briscoe, Ed., G. White | Experimental | January 2023 |
| 9331 | The Explicit Congestion Notification (ECN) Protocol for Low Latency, Low Loss, and Scalable Throughput (L4S)K. De Schepper, B. Briscoe, Ed. | Experimental | January 2023 |
| 9330 | Low Latency, Low Loss, and Scalable Throughput (L4S) Internet Service: ArchitectureB. Briscoe, Ed., K. De Schepper, M. Bagnulo, G. White | Informational | January 2023 |
| 9317 | Operational Considerations for Streaming MediaJ. Holland, A. Begen, S. Dawkins | Informational | October 2022 |
| 9293 | Transmission Control Protocol (TCP)W. Eddy, Ed. | Internet Standard | August 2022 |
| 9265 | Forward Erasure Correction (FEC) Coding and Congestion Control in TransportN. Kuhn, E. Lochin, F. Michel, M. Welzl | Informational | July 2022 |
| 9260 | Stream Control Transmission ProtocolR. Stewart, M. Tüxen, K. Nielsen | Proposed Standard | June 2022 |
| 9049 | Path Aware Networking: Obstacles to Deployment (A Bestiary of Roads Not Taken)S. Dawkins, Ed. | Informational | June 2021 |
| 9040 | TCP Control Block InterdependenceJ. Touch, M. Welzl, S. Islam | Informational | July 2021 |
| 9006 | TCP Usage Guidance in the Internet of Things (IoT)C. Gomez, J. Crowcroft, M. Scharf | Informational | March 2021 |
| 9002 | QUIC Loss Detection and Congestion ControlJ. Iyengar, Ed., I. Swett, Ed. | Proposed Standard | May 2021 |
| 9000 | QUIC: A UDP-Based Multiplexed and Secure TransportJ. Iyengar, Ed., M. Thomson, Ed. | Proposed Standard | May 2021 |
| 8985 | The RACK-TLP Loss Detection Algorithm for TCPY. Cheng, N. Cardwell, N. Dukkipati, P. Jha | Proposed Standard | February 2021 |
| 8961 | Requirements for Time-Based Loss DetectionM. Allman | Best Current Practice | November 2020 |
| 8931 | IPv6 over Low-Power Wireless Personal Area Network (6LoWPAN) Selective Fragment RecoveryP. Thubert, Ed. | Proposed Standard | November 2020 |
| 8869 | Evaluation Test Cases for Interactive Real-Time Media over Wireless NetworksZ. Sarker, X. Zhu, J. Fu | Informational | January 2021 |
| 8867 | Test Cases for Evaluating Congestion Control for Interactive Real-Time MediaZ. Sarker, V. Singh, X. Zhu, M. Ramalho | Informational | January 2021 |
| 8684 | TCP Extensions for Multipath Operation with Multiple AddressesA. Ford, C. Raiciu, M. Handley, O. Bonaventure, C. Paasch | Proposed Standard | March 2020 |
| 8540 | Stream Control Transmission Protocol: Errata and Issues in RFC 4960R. Stewart, M. Tuexen, M. Proshin · obsoleted by RFC 9260 | Informational | February 2019 |
| 8511 | TCP Alternative Backoff with ECN (ABE)N. Khademi, M. Welzl, G. Armitage, G. Fairhurst | Experimental | December 2018 |
| 8337 | Model-Based Metrics for Bulk Transport CapacityM. Mathis, A. Morton | Experimental | March 2018 |
| 8312 | CUBIC for Fast Long-Distance NetworksI. Rhee, L. Xu, S. Ha, A. Zimmermann, L. Eggert, R. Scheffenegger · obsoleted by RFC 9438 | Informational | February 2018 |
| 8303 | On the Usage of Transport Features Provided by IETF Transport ProtocolsM. Welzl, M. Tuexen, N. Khademi | Informational | February 2018 |
| 8289 | Controlled Delay Active Queue ManagementK. Nichols, V. Jacobson, A. McGregor, Ed., J. Iyengar, Ed. | Experimental | January 2018 |
| 8257 | Data Center TCP (DCTCP): TCP Congestion Control for Data CentersS. Bensley, D. Thaler, P. Balasubramanian, L. Eggert, G. Judd | Informational | October 2017 |
| 8095 | Services Provided by IETF Transport Protocols and Congestion Control MechanismsG. Fairhurst, Ed., B. Trammell, Ed., M. Kuehlewind, Ed. | Informational | March 2017 |
| 8087 | The Benefits of Using Explicit Congestion Notification (ECN)G. Fairhurst, M. Welzl | Informational | March 2017 |
| 8085 | UDP Usage GuidelinesL. Eggert, G. Fairhurst, G. Shepherd | Best Current Practice | March 2017 |
| 8084 | Network Transport Circuit BreakersG. Fairhurst | Best Current Practice | March 2017 |
| 8083 | Multimedia Congestion Control: Circuit Breakers for Unicast RTP SessionsC. Perkins, V. Singh | Proposed Standard | March 2017 |
| 7928 | Characterization Guidelines for Active Queue Management (AQM)N. Kuhn, Ed., P. Natarajan, Ed., N. Khademi, Ed., D. Ros | Informational | July 2016 |
| 7786 | TCP Modifications for Congestion Exposure (ConEx)M. Kuehlewind, Ed., R. Scheffenegger | Experimental | May 2016 |
| 7765 | TCP and Stream Control Transmission Protocol (SCTP) RTO RestartP. Hurtig, A. Brunstrom, A. Petlund, M. Welzl | Experimental | February 2016 |
| 7713 | Congestion Exposure (ConEx) Concepts, Abstract Mechanism, and RequirementsM. Mathis, B. Briscoe | Informational | December 2015 |
| 7701 | Multi-party Chat Using the Message Session Relay Protocol (MSRP)A. Niemi, M. Garcia-Martin, G. Sandbakken | Proposed Standard | December 2015 |
| 7661 | Updating TCP to Support Rate-Limited TrafficG. Fairhurst, A. Sathiaseelan, R. Secchi | Experimental | October 2015 |
| 7567 | IETF Recommendations Regarding Active Queue ManagementF. Baker, Ed., G. Fairhurst, Ed. | Best Current Practice | July 2015 |
| 7560 | Problem Statement and Requirements for Increased Accuracy in Explicit Congestion Notification (ECN) FeedbackM. Kuehlewind, Ed., R. Scheffenegger, B. Briscoe | Informational | August 2015 |
| 7424 | Mechanisms for Optimizing Link Aggregation Group (LAG) and Equal-Cost Multipath (ECMP) Component Link Utilization in NetworksR. Krishnan, L. Yong, A. Ghanwani, N. So, B. Khasnabish | Informational | January 2015 |
| 7414 | A Roadmap for Transmission Control Protocol (TCP) Specification DocumentsM. Duke, R. Braden, W. Eddy, E. Blanton, A. Zimmermann | Informational | February 2015 |
| 7413 | TCP Fast OpenY. Cheng, J. Chu, S. Radhakrishnan, A. Jain | Experimental | December 2014 |
| 7323 | TCP Extensions for High PerformanceD. Borman, B. Braden, V. Jacobson, R. Scheffenegger, Ed. | Proposed Standard | September 2014 |
| 7141 | Byte and Packet Congestion NotificationB. Briscoe, J. Manner | Best Current Practice | February 2014 |
| 7016 | Adobe's Secure Real-Time Media Flow ProtocolM. Thornburgh | Informational | November 2013 |
| 6937 | Proportional Rate Reduction for TCPM. Mathis, N. Dukkipati, Y. Cheng · obsoleted by RFC 9937 | Experimental | May 2013 |
| 6928 | Increasing TCP's Initial WindowJ. Chu, N. Dukkipati, Y. Cheng, M. Mathis | Experimental | April 2013 |
| 6846 | RObust Header Compression (ROHC): A Profile for TCP/IP (ROHC-TCP)G. Pelletier, K. Sandlund, L-E. Jonsson, M. West | Proposed Standard | January 2013 |
| 6824 | TCP Extensions for Multipath Operation with Multiple AddressesA. Ford, C. Raiciu, M. Handley, O. Bonaventure · obsoleted by RFC 8684 | Experimental | January 2013 |
| 6817 | Low Extra Delay Background Transport (LEDBAT)S. Shalunov, G. Hazel, J. Iyengar, M. Kuehlewind | Experimental | December 2012 |
| 6675 | A Conservative Loss Recovery Algorithm Based on Selective Acknowledgment (SACK) for TCPE. Blanton, M. Allman, L. Wang, I. Jarvinen, M. Kojo, Y. Nishida | Proposed Standard | August 2012 |
| 6633 | Deprecation of ICMP Source Quench MessagesF. Gont | Proposed Standard | May 2012 |
| 6582 | The NewReno Modification to TCP's Fast Recovery AlgorithmT. Henderson, S. Floyd, A. Gurtov, Y. Nishida | Proposed Standard | April 2012 |
| 6356 | Coupled Congestion Control for Multipath Transport ProtocolsC. Raiciu, M. Handley, D. Wischik | Experimental | October 2011 |
| 6298 | Computing TCP's Retransmission TimerV. Paxson, M. Allman, J. Chu, M. Sargent | Proposed Standard | June 2011 |
| 6297 | A Survey of Lower-than-Best-Effort Transport ProtocolsM. Welzl, D. Ros | Informational | June 2011 |
| 6272 | Internet Protocols for the Smart GridF. Baker, D. Meyer | Informational | June 2011 |
| 6077 | Open Research Issues in Internet Congestion ControlD. Papadimitriou, Ed., M. Welzl, M. Scharf, B. Briscoe | Informational | February 2011 |
| 6069 | Making TCP More Robust to Long Connectivity Disruptions (TCP-LCD)A. Zimmermann, A. Hannemann | Experimental | December 2010 |
| 6013 | TCP Cookie Transactions (TCPCT)W. Simpson · obsoleted by RFC 7805 | Historic | January 2011 |
| 5927 | ICMP Attacks against TCPF. Gont | Informational | July 2010 |
| 5827 | Early Retransmit for TCP and Stream Control Transmission Protocol (SCTP)M. Allman, K. Avrachenkov, U. Ayesta, J. Blanton, P. Hurtig | Experimental | April 2010 |
| 5690 | Adding Acknowledgement Congestion Control to TCPS. Floyd, A. Arcia, D. Ros, J. Iyengar | Informational | February 2010 |
| 5682 | Forward RTO-Recovery (F-RTO): An Algorithm for Detecting Spurious Retransmission Timeouts with TCPP. Sarolahti, M. Kojo, K. Yamamoto, M. Hata | Proposed Standard | September 2009 |
| 5677 | IEEE 802.21 Mobility Services Framework Design (MSFD)T. Melia, Ed., G. Bajko, S. Das, N. Golmie, JC. Zuniga | Proposed Standard | December 2009 |