| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2131 | Dynamic Host Configuration ProtocolR. Droms | Draft Standard | March 1997 |
| 2141 | URN SyntaxR. Moats · obsoleted by RFC 8141 | Proposed Standard | May 1997 |
| 2506 | Media Feature Tag Registration ProcedureK. Holtman, A. Mutz, T. Hardie | Best Current Practice | March 1999 |
| 2782 | A DNS RR for specifying the location of services (DNS SRV)A. Gulbrandsen, P. Vixie, L. Esibov | Proposed Standard | February 2000 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 3263 | Session Initiation Protocol (SIP): Locating SIP ServersJ. Rosenberg, H. Schulzrinne | Proposed Standard | July 2002 |
| 3320 | Signaling Compression (SigComp)R. Price, C. Bormann, J. Christoffersson, H. Hannu, Z. Liu, J. Rosenberg | Proposed Standard | January 2003 |
| 3327 | Session Initiation Protocol (SIP) Extension Header Field for Registering Non-Adjacent ContactsD. Willis, B. Hoeneisen | Proposed Standard | December 2002 |
| 3489 | STUN - Simple Traversal of User Datagram Protocol (UDP) Through Network Address Translators (NATs)J. Rosenberg, J. Weinberger, C. Huitema, R. Mahy · obsoleted by RFC 5389 | Proposed Standard | March 2003 |
| 3581 | An Extension to the Session Initiation Protocol (SIP) for Symmetric Response RoutingJ. Rosenberg, H. Schulzrinne | Proposed Standard | August 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 3840 | Indicating User Agent Capabilities in the Session Initiation Protocol (SIP)J. Rosenberg, H. Schulzrinne, P. Kyzivat | Proposed Standard | August 2004 |
| 3841 | Caller Preferences for the Session Initiation Protocol (SIP)J. Rosenberg, H. Schulzrinne, P. Kyzivat | Proposed Standard | August 2004 |
| 3968 | The Internet Assigned Number Authority (IANA) Header Field Parameter Registry for the Session Initiation Protocol (SIP)G. Camarillo | Best Current Practice | December 2004 |
| 3969 | The Internet Assigned Number Authority (IANA) Uniform Resource Identifier (URI) Parameter Registry for the Session Initiation Protocol (SIP)G. Camarillo | Best Current Practice | December 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4122 | A Universally Unique IDentifier (UUID) URN NamespaceP. Leach, M. Mealling, R. Salz · obsoleted by RFC 9562 | Proposed Standard | July 2005 |
| 4340 | Datagram Congestion Control Protocol (DCCP)E. Kohler, M. Handley, S. Floyd | Proposed Standard | March 2006 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 4960 | Stream Control Transmission ProtocolR. Stewart, Ed. · obsoleted by RFC 9260 | Proposed Standard | September 2007 |
| 5234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell | Internet Standard | January 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5389 | Session Traversal Utilities for NAT (STUN)J. Rosenberg, R. Mahy, P. Matthews, D. Wing · obsoleted by RFC 8489 | Proposed Standard | October 2008 |
| 5627 | Obtaining and Using Globally Routable User Agent URIs (GRUUs) in the Session Initiation Protocol (SIP)J. Rosenberg | Proposed Standard | October 2009 |