| 2004 | Minimal Encapsulation within IPC. Perkins | Proposed Standard | October 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2710 | Multicast Listener Discovery (MLD) for IPv6S. Deering, W. Fenner, B. Haberman | Proposed Standard | October 1999 |
| 2784 | Generic Routing Encapsulation (GRE)D. Farinacci, T. Li, S. Hanks, D. Meyer, P. Traina | Proposed Standard | March 2000 |
| 2983 | Differentiated Services and TunnelsD. Black | Informational | October 2000 |
| 3024 | Reverse Tunneling for Mobile IP, revisedG. Montenegro, Ed. | Proposed Standard | January 2001 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3344 | IP Mobility Support for IPv4C. Perkins, Ed. · obsoleted by RFC 5944 | Proposed Standard | August 2002 |
| 3519 | Mobile IP Traversal of Network Address Translation (NAT) DevicesH. Levkowetz, S. Vaarala | Proposed Standard | May 2003 |
| 3588 | Diameter Base ProtocolP. Calhoun, J. Loughney, E. Guttman, G. Zorn, J. Arkko · obsoleted by RFC 6733 | Proposed Standard | September 2003 |
| 3633 | IPv6 Prefix Options for Dynamic Host Configuration Protocol (DHCP) version 6O. Troan, R. Droms · obsoleted by RFC 8415 | Proposed Standard | December 2003 |
| 3775 | Mobility Support in IPv6D. Johnson, C. Perkins, J. Arkko · obsoleted by RFC 6275 | Proposed Standard | June 2004 |
| 3810 | Multicast Listener Discovery Version 2 (MLDv2) for IPv6R. Vida, Ed., L. Costa, Ed. · obsoleted by RFC 9777 | Proposed Standard | June 2004 |
| 3963 | Network Mobility (NEMO) Basic Support ProtocolV. Devarapalli, R. Wakikawa, A. Petrescu, P. Thubert | Proposed Standard | January 2005 |
| 4213 | Basic Transition Mechanisms for IPv6 Hosts and RoutersE. Nordmark, R. Gilligan | Proposed Standard | October 2005 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5265 | Mobile IPv4 Traversal across IPsec-Based VPN GatewaysS. Vaarala, E. Klovning | Proposed Standard | June 2008 |
| 5266 | Secure Connectivity and Mobility Using Mobile IPv4 and IKEv2 Mobility and Multihoming (MOBIKE)V. Devarapalli, P. Eronen | Best Current Practice | June 2008 |