| 9312 | Manageability of the QUIC Transport ProtocolM. Kühlewind, B. Trammell | Informational | September 2022 |
| 9308 | Applicability of the QUIC Transport ProtocolM. Kühlewind, B. Trammell | Informational | September 2022 |
| 9006 | TCP Usage Guidance in the Internet of Things (IoT)C. Gomez, J. Crowcroft, M. Scharf | Informational | March 2021 |
| 8764 | Apple's DNS Long-Lived Queries ProtocolS. Cheshire, M. Krochmal | Informational | June 2020 |
| 8547 | TCP-ENO: Encryption Negotiation OptionA. Bittau, D. Giffin, M. Handley, D. Mazieres, E. Smith | Experimental | May 2019 |
| 8512 | A YANG Module for Network Address Translation (NAT) and Network Prefix Translation (NPT)M. Boucadair, Ed., S. Sivakumar, C. Jacquenet, S. Vinapamula, Q. Wu | Proposed Standard | January 2019 |
| 8490 | DNS Stateful OperationsR. Bellis, S. Cheshire, J. Dickinson, S. Dickinson, T. Lemon, T. Pusateri | Proposed Standard | March 2019 |
| 8445 | Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) TraversalA. Keranen, C. Holmberg, J. Rosenberg | Proposed Standard | July 2018 |
| 8158 | IP Flow Information Export (IPFIX) Information Elements for Logging NAT EventsS. Sivakumar, R. Penno | Proposed Standard | December 2017 |
| 8030 | Generic Event Delivery Using HTTP PushM. Thomson, E. Damaggio, B. Raymor, Ed. | Proposed Standard | December 2016 |
| 7915 | IP/ICMP Translation AlgorithmC. Bao, X. Li, F. Baker, T. Anderson, F. Gont | Proposed Standard | June 2016 |
| 7857 | Updates to Network Address Translation (NAT) Behavioral RequirementsR. Penno, S. Perreault, M. Boucadair, Ed., S. Sivakumar, K. Naito | Best Current Practice | April 2016 |
| 7768 | Port Management to Reduce Logging in Large-Scale NATsT. Tsou, W. Li, T. Taylor, J. Huang | Informational | January 2016 |
| 7659 | Definitions of Managed Objects for Network Address Translators (NATs)S. Perreault, T. Tsou, S. Sivakumar, T. Taylor | Proposed Standard | October 2015 |
| 7604 | Comparison of Different NAT Traversal Techniques for Media Controlled by the Real-Time Streaming Protocol (RTSP)M. Westerlund, T. Zeng | Informational | September 2015 |
| 7599 | Mapping of Address and Port using Translation (MAP-T)X. Li, C. Bao, W. Dec, Ed., O. Troan, S. Matsushima, T. Murakami | Proposed Standard | July 2015 |
| 7597 | Mapping of Address and Port with Encapsulation (MAP-E)O. Troan, Ed., W. Dec, X. Li, C. Bao, S. Matsushima, T. Murakami, T. Taylor, Ed. | Proposed Standard | July 2015 |
| 7596 | Lightweight 4over6: An Extension to the Dual-Stack Lite ArchitectureY. Cui, Q. Sun, M. Boucadair, T. Tsou, Y. Lee, I. Farrer | Proposed Standard | July 2015 |
| 7422 | Deterministic Address Mapping to Reduce Logging in Carrier-Grade NAT DeploymentsC. Donley, C. Grundemann, V. Sarawat, K. Sundaresan, O. Vautrin | Informational | December 2014 |
| 7413 | TCP Fast OpenY. Cheng, J. Chu, S. Radhakrishnan, A. Jain | Experimental | December 2014 |
| 7269 | NAT64 Deployment Options and ExperienceG. Chen, Z. Cao, C. Xie, D. Binet | Informational | June 2014 |
| 6889 | Analysis of Stateful 64 TranslationR. Penno, T. Saxena, M. Boucadair, S. Sivakumar | Informational | April 2013 |
| 6888 | Common Requirements for Carrier-Grade NATs (CGNs)S. Perreault, Ed., I. Yamagata, S. Miyakawa, A. Nakagawa, H. Ashida | Best Current Practice | April 2013 |
| 6887 | Port Control Protocol (PCP)D. Wing, Ed., S. Cheshire, M. Boucadair, R. Penno, P. Selkirk | Proposed Standard | April 2013 |
| 6708 | Application-Layer Traffic Optimization (ALTO) RequirementsS. Kiesel, Ed., S. Previdi, M. Stiemerling, R. Woundy, Y. Yang | Informational | September 2012 |
| 6619 | Scalable Operation of Address Translators with Per-Interface BindingsJ. Arkko, L. Eggert, M. Townsley | Proposed Standard | June 2012 |
| 6544 | TCP Candidates with Interactive Connectivity Establishment (ICE)J. Rosenberg, A. Keranen, B. B. Lowekamp, A. B. Roach | Proposed Standard | March 2012 |
| 6535 | Dual-Stack Hosts Using "Bump-in-the-Host" (BIH)B. Huang, H. Deng, T. Savolainen | Proposed Standard | February 2012 |
| 6333 | Dual-Stack Lite Broadband Deployments Following IPv4 ExhaustionA. Durand, R. Droms, J. Woodyatt, Y. Lee | Proposed Standard | August 2011 |
| 6263 | Application Mechanism for Keeping Alive the NAT Mappings Associated with RTP / RTP Control Protocol (RTCP) FlowsX. Marjou, A. Sollaud | Proposed Standard | June 2011 |
| 6146 | Stateful NAT64: Network Address and Protocol Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6145 | IP/ICMP Translation AlgorithmX. Li, C. Bao, F. Baker · obsoleted by RFC 7915 | Proposed Standard | April 2011 |
| 6135 | An Alternative Connection Model for the Message Session Relay Protocol (MSRP)C. Holmberg, S. Blau | Proposed Standard | February 2011 |
| 6092 | Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet ServiceJ. Woodyatt, Ed. | Informational | January 2011 |
| 6056 | Recommendations for Transport-Protocol Port RandomizationM. Larsen, F. Gont | Best Current Practice | January 2011 |
| 5684 | Unintended Consequences of NAT Deployments with Overlapping Address SpaceP. Srisuresh, B. Ford | Informational | February 2010 |
| 5677 | IEEE 802.21 Mobility Services Framework Design (MSFD)T. Melia, Ed., G. Bajko, S. Das, N. Golmie, JC. Zuniga | Proposed Standard | December 2009 |
| 5597 | Network Address Translation (NAT) Behavioral Requirements for the Datagram Congestion Control ProtocolR. Denis-Courmont | Best Current Practice | September 2009 |
| 5596 | Datagram Congestion Control Protocol (DCCP) Simultaneous-Open Technique to Facilitate NAT/Middlebox TraversalG. Fairhurst | Proposed Standard | September 2009 |
| 5508 | NAT Behavioral Requirements for ICMPP. Srisuresh, B. Ford, S. Sivakumar, S. Guha | Best Current Practice | April 2009 |
| 5461 | TCP's Reaction to Soft ErrorsF. Gont | Informational | February 2009 |
| 5383 | Deployment Considerations for Lemonade-Compliant Mobile EmailR. Gellens | Best Current Practice | October 2008 |
| 5245 | Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer ProtocolsJ. Rosenberg · obsoleted by RFC 8445, RFC 8839 | Proposed Standard | April 2010 |