| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1123 | Requirements for Internet Hosts - Application and SupportR. Braden, Ed. | Internet Standard | October 1989 |
| 1422 | Privacy Enhancement for Internet Electronic Mail: Part II: Certificate-Based Key ManagementS. Kent | Historic | February 1993 |
| 2044 | UTF-8, a transformation format of Unicode and ISO 10646F. Yergeau · obsoleted by RFC 2279 | Informational | October 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2277 | IETF Policy on Character Sets and LanguagesH. Alvestrand | Best Current Practice | January 1998 |
| 2279 | UTF-8, a transformation format of ISO 10646F. Yergeau · obsoleted by RFC 3629 | Draft Standard | January 1998 |
| 2459 | Internet X.509 Public Key Infrastructure Certificate and CRL ProfileR. Housley, W. Ford, W. Polk, D. Solo · obsoleted by RFC 3280 | Proposed Standard | January 1999 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2560 | X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSPM. Myers, R. Ankney, A. Malpani, S. Galperin, C. Adams · obsoleted by RFC 6960 | Proposed Standard | June 1999 |
| 2585 | Internet X.509 Public Key Infrastructure Operational Protocols: FTP and HTTPR. Housley, P. Hoffman | Proposed Standard | May 1999 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2797 | Certificate Management Messages over CMSM. Myers, X. Liu, J. Schaad, J. Weinstein · obsoleted by RFC 5272 | Proposed Standard | April 2000 |
| 2821 | Simple Mail Transfer ProtocolJ. Klensin, Ed. · obsoleted by RFC 5321 | Proposed Standard | April 2001 |
| 2985 | PKCS #9: Selected Object Classes and Attribute Types Version 2.0M. Nystrom, B. Kaliski | Informational | November 2000 |
| 3161 | Internet X.509 Public Key Infrastructure Time-Stamp Protocol (TSP)C. Adams, P. Cain, D. Pinkas, R. Zuccherato | Proposed Standard | August 2001 |
| 3279 | Algorithms and Identifiers for the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileL. Bassham, W. Polk, R. Housley | Proposed Standard | May 2002 |
| 3280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileR. Housley, W. Polk, W. Ford, D. Solo · obsoleted by RFC 5280 | Proposed Standard | May 2002 |
| 3454 | Preparation of Internationalized Strings ("stringprep")P. Hoffman, M. Blanchet · obsoleted by RFC 7564 | Proposed Standard | January 2003 |
| 3490 | Internationalizing Domain Names in Applications (IDNA)P. Faltstrom, P. Hoffman, A. Costello · obsoleted by RFC 5890, RFC 5891 | Proposed Standard | March 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 3987 | Internationalized Resource Identifiers (IRIs)M. Duerst, M. Suignard | Proposed Standard | January 2005 |
| 4055 | Additional Algorithms and Identifiers for RSA Cryptography for use in the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileJ. Schaad, B. Kaliski, R. Housley | Proposed Standard | June 2005 |
| 4120 | The Kerberos Network Authentication Service (V5)C. Neuman, T. Yu, S. Hartman, K. Raeburn | Proposed Standard | July 2005 |
| 4210 | Internet X.509 Public Key Infrastructure Certificate Management Protocol (CMP)C. Adams, S. Farrell, T. Kause, T. Mononen · obsoleted by RFC 9810 | Proposed Standard | September 2005 |
| 4325 | Internet X.509 Public Key Infrastructure Authority Information Access Certificate Revocation List (CRL) ExtensionS. Santesson, R. Housley · obsoleted by RFC 5280 | Proposed Standard | December 2005 |
| 4491 | Using the GOST R 34.10-94, GOST R 34.10-2001, and GOST R 34.11-94 Algorithms with the Internet X.509 Public Key Infrastructure Certificate and CRL ProfileS. Leontiev, Ed., D. Shefanovski, Ed. | Proposed Standard | May 2006 |
| 4510 | Lightweight Directory Access Protocol (LDAP): Technical Specification Road MapK. Zeilenga, Ed. | Proposed Standard | June 2006 |
| 4512 | Lightweight Directory Access Protocol (LDAP): Directory Information ModelsK. Zeilenga, Ed. | Proposed Standard | June 2006 |
| 4514 | Lightweight Directory Access Protocol (LDAP): String Representation of Distinguished NamesK. Zeilenga, Ed. | Proposed Standard | June 2006 |
| 4516 | Lightweight Directory Access Protocol (LDAP): Uniform Resource LocatorM. Smith, Ed., T. Howes | Proposed Standard | June 2006 |
| 4518 | Lightweight Directory Access Protocol (LDAP): Internationalized String PreparationK. Zeilenga | Proposed Standard | June 2006 |
| 4519 | Lightweight Directory Access Protocol (LDAP): Schema for User ApplicationsA. Sciberras, Ed. | Proposed Standard | June 2006 |
| 4523 | Lightweight Directory Access Protocol (LDAP) Schema Definitions for X.509 CertificatesK. Zeilenga | Proposed Standard | June 2006 |
| 4630 | Update to DirectoryString Processing in the Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileR. Housley, S. Santesson · obsoleted by RFC 5280 | Proposed Standard | August 2006 |
| 4632 | Classless Inter-domain Routing (CIDR): The Internet Address Assignment and Aggregation PlanV. Fuller, T. Li | Best Current Practice | August 2006 |