| 1661 | The Point-to-Point Protocol (PPP)W. Simpson, Ed. | Internet Standard | July 1994 |
| 1968 | The PPP Encryption Control Protocol (ECP)G. Meyer | Proposed Standard | June 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2230 | Key Exchange Delegation Record for the DNSR. Atkinson | Informational | November 1997 |
| 2409 | The Internet Key Exchange (IKE)D. Harkins, D. Carrel · obsoleted by RFC 4306 | Historic | November 1998 |
| 2516 | A Method for Transmitting PPP Over Ethernet (PPPoE)L. Mamakos, K. Lidl, J. Evarts, D. Carrel, D. Simone, R. Wheeler | Informational | February 1999 |
| 2548 | Microsoft Vendor-specific RADIUS AttributesG. Zorn | Informational | March 1999 |
| 2607 | Proxy Chaining and Policy Implementation in RoamingB. Aboba, J. Vollbrecht | Informational | June 1999 |
| 2716 | PPP EAP TLS Authentication ProtocolB. Aboba, D. Simon · obsoleted by RFC 5216 | Experimental | October 1999 |
| 2782 | A DNS RR for specifying the location of services (DNS SRV)A. Gulbrandsen, P. Vixie, L. Esibov | Proposed Standard | February 2000 |
| 2845 | Secret Key Transaction Authentication for DNS (TSIG)P. Vixie, O. Gudmundsson, D. Eastlake 3rd, B. Wellington · obsoleted by RFC 8945 | Proposed Standard | May 2000 |
| 2865 | Remote Authentication Dial In User Service (RADIUS)C. Rigney, S. Willens, A. Rubens, W. Simpson | Draft Standard | June 2000 |
| 3007 | Secure Domain Name System (DNS) Dynamic UpdateB. Wellington | Proposed Standard | November 2000 |
| 3162 | RADIUS and IPv6B. Aboba, G. Zorn, D. Mitton | Proposed Standard | August 2001 |
| 3547 | The Group Domain of InterpretationM. Baugher, B. Weis, T. Hardjono, H. Harney · obsoleted by RFC 6407 | Proposed Standard | July 2003 |
| 3579 | RADIUS (Remote Authentication Dial In User Service) Support For Extensible Authentication Protocol (EAP)B. Aboba, P. Calhoun | Informational | September 2003 |
| 3580 | IEEE 802.1X Remote Authentication Dial In User Service (RADIUS) Usage GuidelinesP. Congdon, B. Aboba, A. Smith, G. Zorn, J. Roese | Informational | September 2003 |
| 3588 | Diameter Base ProtocolP. Calhoun, J. Loughney, E. Guttman, G. Zorn, J. Arkko · obsoleted by RFC 6733 | Proposed Standard | September 2003 |
| 3748 | Extensible Authentication Protocol (EAP)B. Aboba, L. Blunk, J. Vollbrecht, J. Carlson, H. Levkowetz, Ed. | Proposed Standard | June 2004 |
| 3766 | Determining Strengths For Public Keys Used For Exchanging Symmetric KeysH. Orman, P. Hoffman | Best Current Practice | April 2004 |
| 3830 | MIKEY: Multimedia Internet KEYingJ. Arkko, E. Carrara, F. Lindholm, M. Naslund, K. Norrman | Proposed Standard | August 2004 |
| 4005 | Diameter Network Access Server ApplicationP. Calhoun, G. Zorn, D. Spence, D. Mitton · obsoleted by RFC 7155 | Proposed Standard | August 2005 |
| 4017 | Extensible Authentication Protocol (EAP) Method Requirements for Wireless LANsD. Stanley, J. Walker, B. Aboba | Informational | March 2005 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4035 | Protocol Modifications for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4067 | Context Transfer Protocol (CXTP)J. Loughney, Ed., M. Nakhjiri, C. Perkins, R. Koodli | Experimental | July 2005 |
| 4072 | Diameter Extensible Authentication Protocol (EAP) ApplicationP. Eronen, Ed., T. Hiller, G. Zorn | Proposed Standard | August 2005 |
| 4118 | Architecture Taxonomy for Control and Provisioning of Wireless Access Points (CAPWAP)L. Yang, P. Zerfos, E. Sadot | Informational | June 2005 |
| 4186 | Extensible Authentication Protocol Method for Global System for Mobile Communications (GSM) Subscriber Identity Modules (EAP-SIM)H. Haverinen, Ed., J. Salowey, Ed. | Informational | January 2006 |
| 4187 | Extensible Authentication Protocol Method for 3rd Generation Authentication and Key Agreement (EAP-AKA)J. Arkko, H. Haverinen | Informational | January 2006 |
| 4282 | The Network Access IdentifierB. Aboba, M. Beadles, J. Arkko, P. Eronen · obsoleted by RFC 7542 | Proposed Standard | December 2005 |
| 4284 | Identity Selection Hints for the Extensible Authentication Protocol (EAP)F. Adrangi, V. Lortz, F. Bari, P. Eronen | Informational | January 2006 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4306 | Internet Key Exchange (IKEv2) ProtocolC. Kaufman, Ed. · obsoleted by RFC 5996 | Proposed Standard | December 2005 |
| 4334 | Certificate Extensions and Attributes Supporting Authentication in Point-to-Point Protocol (PPP) and Wireless Local Area Networks (WLAN)R. Housley, T. Moore | Proposed Standard | February 2006 |
| 4372 | Chargeable User IdentityF. Adrangi, A. Lior, J. Korhonen, J. Loughney | Proposed Standard | January 2006 |
| 4535 | GSAKMP: Group Secure Association Key Management ProtocolH. Harney, U. Meth, A. Colegrove, G. Gross | Proposed Standard | June 2006 |
| 4675 | RADIUS Attributes for Virtual LAN and Priority SupportP. Congdon, M. Sanchez, B. Aboba | Proposed Standard | September 2006 |
| 4718 | IKEv2 Clarifications and Implementation GuidelinesP. Eronen, P. Hoffman · obsoleted by RFC 5996 | Informational | October 2006 |
| 4763 | Extensible Authentication Protocol Method for Shared-secret Authentication and Key Establishment (EAP-SAKE)M. Vanderveen, H. Soliman | Informational | November 2006 |
| 4764 | The EAP-PSK Protocol: A Pre-Shared Key Extensible Authentication Protocol (EAP) MethodF. Bersani, H. Tschofenig | Experimental | January 2007 |
| 4962 | Guidance for Authentication, Authorization, and Accounting (AAA) Key ManagementR. Housley, B. Aboba | Best Current Practice | July 2007 |
| 5176 | Dynamic Authorization Extensions to Remote Authentication Dial In User Service (RADIUS)M. Chiba, G. Dommety, M. Eklund, D. Mitton, B. Aboba | Informational | January 2008 |
| 5216 | The EAP-TLS Authentication ProtocolD. Simon, B. Aboba, R. Hurst | Proposed Standard | March 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |