| 10015 | Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2N. Aviram | Proposed Standard | July 2026 |
| 10006 | Automatic SIP Trunking and PeeringK. Inamdar, S. Narayanan, C. Jennings | Proposed Standard | August 2026 |
| 9973 | TLS 1.3 Extension for Using Certificates with an External Pre-Shared KeyR. Housley | Proposed Standard | July 2026 |
| 9930 | Tunnel Extensible Authentication Protocol (TEAP) Version 1A. DeKok, Ed. | Proposed Standard | February 2026 |
| 9918 | Updates to Using the NETCONF Protocol over Transport Layer Security (TLS) with Mutual X.509 AuthenticationS. Turner, R. Housley | Proposed Standard | July 2026 |
| 9916 | Updates to the Usage of TLS to Provide a Secure Transport for the Path Computation Element Communication Protocol (PCEP)D. Dhody, S. Turner, R. Housley | Proposed Standard | July 2026 |
| 9852 | New Protocols Using TLS Must Require TLS 1.3R. Salz, N. Aviram | Best Current Practice | July 2026 |
| 9851 | TLS 1.2 is in Feature FreezeR. Salz, N. Aviram | Proposed Standard | July 2026 |
| 9850 | The SSLKEYLOGFILE Format for TLSM. Thomson, Y. Rosomakho, H. Tschofenig | Informational | July 2026 |
| 9846 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla | Proposed Standard | July 2026 |
| 9826 | A YANG Data Model for the Path Computation Element Communication Protocol (PCEP)D. Dhody, Ed., V. Beeram, J. Hardwick, J. Tantsura | Proposed Standard | September 2025 |
| 9811 | Internet X.509 Public Key Infrastructure -- HTTP Transfer for the Certificate Management Protocol (CMP)H. Brockhaus, D. von Oheimb, M. Ounsworth, J. Gray | Proposed Standard | July 2025 |
| 9809 | X.509 Certificate Extended Key Usage (EKU) for Configuration, Updates, and Safety-Critical CommunicationH. Brockhaus, D. Goltzsche | Proposed Standard | July 2025 |
| 9761 | Manufacturer Usage Description (MUD) for TLS and DTLS Profiles for Internet of Things (IoT) DevicesT. Reddy.K, D. Wing, B. Anderson | Proposed Standard | April 2025 |
| 9662 | Updates to the Cipher Suites in Secure SyslogC. Lonvick, S. Turner, J. Salowey | Proposed Standard | October 2024 |
| 9645 | YANG Groupings for TLS Clients and TLS ServersK. Watsen | Proposed Standard | October 2024 |
| 9509 | X.509 Certificate Extended Key Usage (EKU) for 5G Network FunctionsT. Reddy.K, J. Ekman, D. Migault | Proposed Standard | March 2024 |
| 9483 | Lightweight Certificate Management Protocol (CMP) ProfileH. Brockhaus, D. von Oheimb, S. Fries | Proposed Standard | November 2023 |
| 9456 | Updates to the TLS Transport Model for SNMPK. Vaughn, Ed. | Proposed Standard | November 2023 |
| 9440 | Client-Cert HTTP Header FieldB. Campbell, M. Bishop | Informational | July 2023 |
| 9345 | Delegated Credentials for TLS and DTLSR. Barnes, S. Iyengar, N. Sullivan, E. Rescorla | Proposed Standard | July 2023 |
| 9329 | TCP Encapsulation of Internet Key Exchange Protocol (IKE) and IPsec PacketsT. Pauly, V. Smyslov | Proposed Standard | November 2022 |
| 9325 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, P. Saint-Andre, T. Fossati | Best Current Practice | November 2022 |
| 9310 | X.509 Certificate Extension for 5G Network Function TypesR. Housley, S. Turner, J. Preuß Mattsson, D. Migault | Proposed Standard | January 2023 |
| 9266 | Channel Bindings for TLS 1.3S. Whited | Proposed Standard | July 2022 |
| 9261 | Exported Authenticators in TLSN. Sullivan | Proposed Standard | July 2022 |
| 9258 | Importing External Pre-Shared Keys (PSKs) for TLS 1.3D. Benjamin, C. A. Wood | Proposed Standard | July 2022 |
| 9191 | Handling Large Certificates and Long Certificate Chains in TLS-Based EAP MethodsM. Sethi, J. Preuß Mattsson, S. Turner | Informational | February 2022 |
| 9190 | EAP-TLS 1.3: Using the Extensible Authentication Protocol with TLS 1.3J. Preuß Mattsson, M. Sethi | Proposed Standard | February 2022 |
| 9189 | GOST Cipher Suites for Transport Layer Security (TLS) Protocol Version 1.2S. Smyshlyaev, Ed., D. Belyavsky, E. Alekseev | Informational | March 2022 |
| 9170 | Long-Term Viability of Protocol Extension MechanismsM. Thomson, T. Pauly | Informational | December 2021 |
| 9162 | Certificate Transparency Version 2.0B. Laurie, E. Messeri, R. Stradling | Experimental | December 2021 |
| 9155 | Deprecating MD5 and SHA-1 Signature Hashes in TLS 1.2 and DTLS 1.2L. Velvindron, K. Moriarty, A. Ghedini | Proposed Standard | December 2021 |
| 9151 | Commercial National Security Algorithm (CNSA) Suite Profile for TLS and DTLS 1.2 and 1.3D. Cooley | Informational | April 2022 |
| 9150 | TLS 1.3 Authentication and Integrity-Only Cipher SuitesN. Cam-Winget, J. Visoky | Informational | April 2022 |
| 9148 | EST-coaps: Enrollment over Secure Transport with the Secure Constrained Application ProtocolP. van der Stok, P. Kampanakis, M. Richardson, S. Raza | Proposed Standard | April 2022 |
| 9147 | The Datagram Transport Layer Security (DTLS) Protocol Version 1.3E. Rescorla, H. Tschofenig, N. Modadugu | Proposed Standard | April 2022 |
| 9132 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationM. Boucadair, Ed., J. Shallow, T. Reddy.K | Proposed Standard | September 2021 |
| 9113 | HTTP/2M. Thomson, Ed., C. Benfield, Ed. | Proposed Standard | June 2022 |
| 9102 | TLS DNSSEC Chain ExtensionV. Dukhovni, S. Huque, W. Toorop, P. Wouters, M. Shore | Experimental | August 2021 |
| 9051 | Internet Message Access Protocol (IMAP) - Version 4rev2A. Melnikov, Ed., B. Leiba, Ed. | Proposed Standard | August 2021 |
| 8997 | Deprecation of TLS 1.1 for Email Submission and AccessL. Velvindron, S. Farrell | Proposed Standard | March 2021 |
| 8996 | Deprecating TLS 1.0 and TLS 1.1K. Moriarty, S. Farrell | Best Current Practice | March 2021 |
| 8994 | An Autonomic Control Plane (ACP)T. Eckert, Ed., M. Behringer, Ed., S. Bjarnason | Proposed Standard | May 2021 |
| 8936 | Poll-Based Security Event Token (SET) Delivery Using HTTPA. Backman, Ed., M. Jones, Ed., M. Scurtescu, M. Ansari, A. Nadalin | Proposed Standard | November 2020 |
| 8935 | Push-Based Security Event Token (SET) Delivery Using HTTPA. Backman, Ed., M. Jones, Ed., M. Scurtescu, M. Ansari, A. Nadalin | Proposed Standard | November 2020 |
| 8922 | A Survey of the Interaction between Security Protocols and Transport ServicesT. Enghardt, T. Pauly, C. Perkins, K. Rose, C. Wood | Informational | October 2020 |
| 8896 | Application-Layer Traffic Optimization (ALTO) Cost CalendarS. Randriamasy, R. Yang, Q. Wu, L. Deng, N. Schwan | Proposed Standard | November 2020 |
| 8887 | A JSON Meta Application Protocol (JMAP) Subprotocol for WebSocketK. Murchison | Proposed Standard | August 2020 |
| 8879 | TLS Certificate CompressionA. Ghedini, V. Vasiliev | Proposed Standard | December 2020 |
| 8855 | The Binary Floor Control Protocol (BFCP)G. Camarillo, K. Drage, T. Kristensen, J. Ott, C. Eckel | Proposed Standard | January 2021 |
| 8811 | DDoS Open Threat Signaling (DOTS) ArchitectureA. Mortensen, Ed., T. Reddy.K, Ed., F. Andreasen, N. Teague, R. Compton | Informational | August 2020 |
| 8782 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationT. Reddy.K, Ed., M. Boucadair, Ed., P. Patil, A. Mortensen, N. Teague · obsoleted by RFC 9132 | Proposed Standard | May 2020 |
| 8773 | TLS 1.3 Extension for Certificate-Based Authentication with an External Pre-Shared KeyR. Housley · obsoleted by RFC 9973 | Experimental | March 2020 |
| 8744 | Issues and Requirements for Server Name Identification (SNI) Encryption in TLSC. Huitema | Informational | July 2020 |
| 8740 | Using TLS 1.3 with HTTP/2D. Benjamin · obsoleted by RFC 9113 | Proposed Standard | February 2020 |
| 8737 | Automated Certificate Management Environment (ACME) TLS Application-Layer Protocol Negotiation (ALPN) Challenge ExtensionR.B. Shoemaker | Proposed Standard | February 2020 |
| 8705 | OAuth 2.0 Mutual-TLS Client Authentication and Certificate-Bound Access TokensB. Campbell, J. Bradley, N. Sakimura, T. Lodderstedt | Proposed Standard | February 2020 |
| 8701 | Applying Generate Random Extensions And Sustain Extensibility (GREASE) to TLS ExtensibilityD. Benjamin | Informational | January 2020 |
| 8672 | TLS Server Identity Pinning with TicketsY. Sheffer, D. Migault | Experimental | October 2019 |
| 8639 | Subscription to YANG NotificationsE. Voit, A. Clemm, A. Gonzalez Prieto, E. Nilsen-Nygaard, A. Tripathy | Proposed Standard | September 2019 |
| 8620 | The JSON Meta Application Protocol (JMAP)N. Jenkins, C. Newman | Proposed Standard | July 2019 |
| 8521 | Registration Data Access Protocol (RDAP) Object TaggingS. Hollenbeck, A. Newton | Best Current Practice | November 2018 |
| 8492 | Secure Password Ciphersuites for Transport Layer Security (TLS)D. Harkins, Ed. | Informational | February 2019 |
| 8473 | Token Binding over HTTPA. Popov, M. Nystroem, D. Balfanz, Ed., N. Harper, J. Hodges | Proposed Standard | October 2018 |
| 8472 | Transport Layer Security (TLS) Extension for Token Binding Protocol NegotiationA. Popov, Ed., M. Nystroem, D. Balfanz | Proposed Standard | October 2018 |
| 8471 | The Token Binding Protocol Version 1.0A. Popov, Ed., M. Nystroem, D. Balfanz, J. Hodges | Proposed Standard | October 2018 |
| 8461 | SMTP MTA Strict Transport Security (MTA-STS)D. Margolis, M. Risher, B. Ramakrishnan, A. Brotman, J. Jones | Proposed Standard | September 2018 |
| 8449 | Record Size Limit Extension for TLSM. Thomson | Proposed Standard | August 2018 |
| 8447 | IANA Registry Updates for TLS and DTLSJ. Salowey, S. Turner | Proposed Standard | August 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8442 | ECDHE_PSK with AES-GCM and AES-CCM Cipher Suites for TLS 1.2 and DTLS 1.2J. Mattsson, D. Migault | Proposed Standard | September 2018 |
| 8422 | Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS) Versions 1.2 and EarlierY. Nir, S. Josefsson, M. Pegourie-Gonnard · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8417 | Security Event Token (SET)P. Hunt, Ed., M. Jones, W. Denniss, M. Ansari | Proposed Standard | July 2018 |
| 8414 | OAuth 2.0 Authorization Server MetadataM. Jones, N. Sakimura, J. Bradley | Proposed Standard | June 2018 |
| 8387 | Practical Considerations and Implementation Experiences in Securing Smart Object NetworksM. Sethi, J. Arkko, A. Keranen, H. Back | Informational | May 2018 |
| 8376 | Low-Power Wide Area Network (LPWAN) OverviewS. Farrell, Ed. | Informational | May 2018 |
| 8368 | Using an Autonomic Control Plane for Stable Connectivity of Network Operations, Administration, and Maintenance (OAM)T. Eckert, Ed., M. Behringer | Informational | May 2018 |
| 8366 | A Voucher Artifact for Bootstrapping ProtocolsK. Watsen, M. Richardson, M. Pritikin, T. Eckert | Proposed Standard | May 2018 |
| 8349 | A YANG Data Model for Routing Management (NMDA Version)L. Lhotka, A. Lindem, Y. Qu | Proposed Standard | March 2018 |
| 8348 | A YANG Data Model for Hardware ManagementA. Bierman, M. Bjorklund, J. Dong, D. Romascanu | Proposed Standard | March 2018 |
| 8347 | A YANG Data Model for the Virtual Router Redundancy Protocol (VRRP)X. Liu, Ed., A. Kyparlis, R. Parikh, A. Lindem, M. Zhang | Proposed Standard | March 2018 |
| 8346 | A YANG Data Model for Layer 3 TopologiesA. Clemm, J. Medved, R. Varga, X. Liu, H. Ananthakrishnan, N. Bahadur | Proposed Standard | March 2018 |
| 8345 | A YANG Data Model for Network TopologiesA. Clemm, J. Medved, R. Varga, N. Bahadur, H. Ananthakrishnan, X. Liu | Proposed Standard | March 2018 |
| 8344 | A YANG Data Model for IP ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8343 | A YANG Data Model for Interface ManagementM. Bjorklund | Proposed Standard | March 2018 |
| 8341 | Network Configuration Access Control ModelA. Bierman, M. Bjorklund | Internet Standard | March 2018 |
| 8323 | CoAP (Constrained Application Protocol) over TCP, TLS, and WebSocketsC. Bormann, S. Lemay, H. Tschofenig, K. Hartke, B. Silverajan, B. Raymor, Ed. | Proposed Standard | February 2018 |
| 8314 | Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and AccessK. Moore, C. Newman | Proposed Standard | January 2018 |
| 8310 | Usage Profiles for DNS over TLS and DNS over DTLSS. Dickinson, D. Gillmor, T. Reddy | Proposed Standard | March 2018 |
| 8299 | YANG Data Model for L3VPN Service DeliveryQ. Wu, Ed., S. Litkowski, L. Tomotaki, K. Ogaki | Proposed Standard | January 2018 |
| 8295 | EST (Enrollment over Secure Transport) ExtensionsS. Turner | Proposed Standard | January 2018 |
| 8280 | Research into Human Rights Protocol ConsiderationsN. ten Oever, C. Cath | Informational | October 2017 |
| 8264 | PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application ProtocolsP. Saint-Andre, M. Blanchet | Proposed Standard | October 2017 |
| 8253 | PCEPS: Usage of TLS to Provide a Secure Transport for the Path Computation Element Communication Protocol (PCEP)D. Lopez, O. Gonzalez de Dios, Q. Wu, D. Dhody | Proposed Standard | October 2017 |
| 8241 | Interface to the Routing System (I2RS) Security-Related RequirementsS. Hares, D. Migault, J. Halpern | Informational | September 2017 |
| 8229 | TCP Encapsulation of IKE and IPsec PacketsT. Pauly, S. Touati, R. Mantha · obsoleted by RFC 9329 | Proposed Standard | August 2017 |
| 8210 | The Resource Public Key Infrastructure (RPKI) to Router Protocol, Version 1R. Bush, R. Austein | Proposed Standard | September 2017 |
| 8194 | A YANG Data Model for LMAP Measurement AgentsJ. Schoenwaelder, V. Bajpai | Proposed Standard | August 2017 |
| 8188 | Encrypted Content-Encoding for HTTPM. Thomson | Proposed Standard | June 2017 |
| 8177 | YANG Data Model for Key ChainsA. Lindem, Ed., Y. Qu, D. Yeung, I. Chen, J. Zhang | Proposed Standard | June 2017 |
| 8175 | Dynamic Link Exchange Protocol (DLEP)S. Ratliff, S. Jury, D. Satterwhite, R. Taylor, B. Berry | Proposed Standard | June 2017 |
| 8164 | Opportunistic Security for HTTP/2M. Nottingham, M. Thomson | Historic | May 2017 |
| 8156 | DHCPv6 Failover ProtocolT. Mrugalski, K. Kinnear | Proposed Standard | June 2017 |
| 8143 | Using Transport Layer Security (TLS) with Network News Transfer Protocol (NNTP)J. Elie | Proposed Standard | April 2017 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8125 | Requirements for Password-Authenticated Key Agreement (PAKE) SchemesJ. Schmidt | Informational | April 2017 |
| 8124 | The Session Description Protocol (SDP) WebSocket Connection URI AttributeR. Ravindranath, G. Salgueiro | Proposed Standard | March 2017 |
| 8122 | Connection-Oriented Media Transport over the Transport Layer Security (TLS) Protocol in the Session Description Protocol (SDP)J. Lennox, C. Holmberg | Proposed Standard | March 2017 |
| 8120 | Mutual Authentication Protocol for HTTPY. Oiwa, H. Watanabe, H. Takagi, K. Maeda, T. Hayashi, Y. Ioku | Experimental | April 2017 |
| 8095 | Services Provided by IETF Transport Protocols and Congestion Control MechanismsG. Fairhurst, Ed., B. Trammell, Ed., M. Kuehlewind, Ed. | Informational | March 2017 |
| 8075 | Guidelines for Mapping Implementations: HTTP to the Constrained Application Protocol (CoAP)A. Castellani, S. Loreto, A. Rahman, T. Fossati, E. Dijk | Proposed Standard | February 2017 |
| 8071 | NETCONF Call Home and RESTCONF Call HomeK. Watsen | Proposed Standard | February 2017 |
| 8054 | Network News Transfer Protocol (NNTP) Extension for CompressionK. Murchison, J. Elie | Proposed Standard | January 2017 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8017 | PKCS #1: RSA Cryptography Specifications Version 2.2K. Moriarty, Ed., B. Kaliski, J. Jonsson, A. Rusch | Informational | November 2016 |
| 8011 | Internet Printing Protocol/1.1: Model and SemanticsM. Sweet, I. McDonald | Internet Standard | January 2017 |
| 8010 | Internet Printing Protocol/1.1: Encoding and TransportM. Sweet, I. McDonald | Internet Standard | January 2017 |
| 7983 | Multiplexing Scheme Updates for Secure Real-time Transport Protocol (SRTP) Extension for Datagram Transport Layer Security (DTLS)M. Petit-Huguenin, G. Salgueiro | Proposed Standard | September 2016 |
| 7977 | The WebSocket Protocol as a Transport for the Message Session Relay Protocol (MSRP)P. Dunkley, G. Llewellyn, V. Pascual, G. Salgueiro, R. Ravindranath | Proposed Standard | September 2016 |
| 7970 | The Incident Object Description Exchange Format Version 2R. Danyliw | Proposed Standard | November 2016 |
| 7966 | Security at the Attribute-Value Pair (AVP) Level for Non-neighboring Diameter Nodes: Scenarios and RequirementsH. Tschofenig, J. Korhonen, Ed., G. Zorn, K. Pillay | Informational | September 2016 |
| 7927 | Information-Centric Networking (ICN) Research ChallengesD. Kutscher, Ed., S. Eum, K. Pentikousis, I. Psaras, D. Corujo, D. Saucez, T. Schmidt, M. Waehlisch | Informational | July 2016 |
| 7926 | Problem Statement and Architecture for Information Exchange between Interconnected Traffic-Engineered NetworksA. Farrel, Ed., J. Drake, N. Bitar, G. Swallow, D. Ceccarelli, X. Zhang | Best Current Practice | July 2016 |
| 7925 | Transport Layer Security (TLS) / Datagram Transport Layer Security (DTLS) Profiles for the Internet of ThingsH. Tschofenig, Ed., T. Fossati | Proposed Standard | July 2016 |
| 7924 | Transport Layer Security (TLS) Cached Information ExtensionS. Santesson, H. Tschofenig | Proposed Standard | July 2016 |
| 7919 | Negotiated Finite Field Diffie-Hellman Ephemeral Parameters for Transport Layer Security (TLS)D. Gillmor | Proposed Standard | August 2016 |
| 7918 | Transport Layer Security (TLS) False StartA. Langley, N. Modadugu, B. Moeller | Informational | August 2016 |
| 7905 | ChaCha20-Poly1305 Cipher Suites for Transport Layer Security (TLS)A. Langley, W. Chang, N. Mavrogiannopoulos, J. Strombergson, S. Josefsson | Proposed Standard | June 2016 |
| 7878 | Session Peering Provisioning (SPP) Protocol over SOAPK. Cartwright, V. Bhatia, J-F. Mule, A. Mayrhofer | Proposed Standard | August 2016 |
| 7877 | Session Peering Provisioning Framework (SPPF)K. Cartwright, V. Bhatia, S. Ali, D. Schwartz | Proposed Standard | August 2016 |
| 7869 | The "vnc" URI SchemeD. Warden, I. Iordanov | Informational | May 2016 |
| 7858 | Specification for DNS over Transport Layer Security (TLS)Z. Hu, L. Zhu, J. Heidemann, A. Mankin, D. Wessels, P. Hoffman | Proposed Standard | May 2016 |
| 7850 | Registering Values of the SDP 'proto' Field for Transporting RTP Media over TCP under Various RTP ProfilesS. Nandakumar | Proposed Standard | April 2016 |
| 7846 | Peer-to-Peer Streaming Tracker Protocol (PPSTP)R. Cruz, M. Nunes, J. Xia, R. Huang, Ed., J. Taveira, D. Lingli | Proposed Standard | May 2016 |
| 7838 | HTTP Alternative ServicesM. Nottingham, P. McManus, J. Reschke | Proposed Standard | April 2016 |
| 7836 | Guidelines on the Cryptographic Algorithms to Accompany the Usage of Standards GOST R 34.10-2012 and GOST R 34.11-2012S. Smyshlyaev, Ed., E. Alekseev, I. Oshkin, V. Popov, S. Leontiev, V. Podobaev, D. Belyavsky | Informational | March 2016 |
| 7831 | Application Bridging for Federated Access Beyond Web (ABFAB) ArchitectureJ. Howlett, S. Hartman, H. Tschofenig, J. Schaad | Informational | May 2016 |
| 7826 | Real-Time Streaming Protocol Version 2.0H. Schulzrinne, A. Rao, R. Lanphier, M. Westerlund, M. Stiemerling, Ed. | Proposed Standard | December 2016 |
| 7808 | Time Zone Data Distribution ServiceM. Douglass, C. Daboo | Proposed Standard | March 2016 |
| 7800 | Proof-of-Possession Key Semantics for JSON Web Tokens (JWTs)M. Jones, J. Bradley, H. Tschofenig | Proposed Standard | April 2016 |
| 7787 | Distributed Node Consensus ProtocolM. Stenberg, S. Barth | Proposed Standard | April 2016 |
| 7754 | Technical Considerations for Internet Service Blocking and FilteringR. Barnes, A. Cooper, O. Kolkman, D. Thaler, E. Nordmark | Informational | March 2016 |
| 7733 | Applicability Statement: The Use of the Routing Protocol for Low-Power and Lossy Networks (RPL) Protocol Suite in Home Automation and Building ControlA. Brandt, E. Baccelli, R. Cragie, P. van der Stok | Proposed Standard | February 2016 |
| 7724 | Active DHCPv4 Lease QueryK. Kinnear, M. Stapp, B. Volz, N. Russell | Proposed Standard | December 2015 |
| 7711 | PKIX over Secure HTTP (POSH)M. Miller, P. Saint-Andre | Proposed Standard | November 2015 |
| 7701 | Multi-party Chat Using the Message Session Relay Protocol (MSRP)A. Niemi, M. Garcia-Martin, G. Sandbakken | Proposed Standard | December 2015 |
| 7696 | Guidelines for Cryptographic Algorithm Agility and Selecting Mandatory-to-Implement AlgorithmsR. Housley | Best Current Practice | November 2015 |
| 7685 | A Transport Layer Security (TLS) ClientHello Padding ExtensionA. Langley | Proposed Standard | October 2015 |
| 7682 | Considerations for Internet Routing Registries (IRRs) and Routing Policy ConfigurationD. McPherson, S. Amante, E. Osterweil, L. Blunk, D. Mitchell | Informational | December 2015 |
| 7677 | SCRAM-SHA-256 and SCRAM-SHA-256-PLUS Simple Authentication and Security Layer (SASL) MechanismsT. Hansen | Proposed Standard | November 2015 |
| 7672 | SMTP Security via Opportunistic DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS)V. Dukhovni, W. Hardaker | Proposed Standard | October 2015 |
| 7671 | The DNS-Based Authentication of Named Entities (DANE) Protocol: Updates and Operational GuidanceV. Dukhovni, W. Hardaker | Proposed Standard | October 2015 |
| 7670 | Generic Raw Public-Key Support for IKEv2T. Kivinen, P. Wouters, H. Tschofenig | Proposed Standard | January 2016 |
| 7662 | OAuth 2.0 Token IntrospectionJ. Richer, Ed. | Proposed Standard | October 2015 |
| 7653 | DHCPv6 Active LeasequeryD. Raghuvanshi, K. Kinnear, D. Kukrety | Proposed Standard | October 2015 |
| 7644 | System for Cross-domain Identity Management: ProtocolP. Hunt, Ed., K. Grizzle, M. Ansari, E. Wahlstroem, C. Mortimore | Proposed Standard | September 2015 |
| 7639 | The ALPN HTTP Header FieldA. Hutton, J. Uberti, M. Thomson | Proposed Standard | August 2015 |
| 7635 | Session Traversal Utilities for NAT (STUN) Extension for Third-Party AuthorizationT. Reddy, P. Patil, R. Ravindranath, J. Uberti | Proposed Standard | August 2015 |
| 7633 | X.509v3 Transport Layer Security (TLS) Feature ExtensionP. Hallam-Baker | Proposed Standard | October 2015 |
| 7628 | A Set of Simple Authentication and Security Layer (SASL) Mechanisms for OAuthW. Mills, T. Showalter, H. Tschofenig | Proposed Standard | August 2015 |
| 7627 | Transport Layer Security (TLS) Session Hash and Extended Master Secret ExtensionK. Bhargavan, Ed., A. Delignat-Lavaud, A. Pironti, A. Langley, M. Ray · obsoleted by RFC 9846 | Proposed Standard | September 2015 |
| 7624 | Confidentiality in the Face of Pervasive Surveillance: A Threat Model and Problem StatementR. Barnes, B. Schneier, C. Jennings, T. Hardie, B. Trammell, C. Huitema, D. Borkmann | Informational | August 2015 |
| 7617 | The 'Basic' HTTP Authentication SchemeJ. Reschke | Proposed Standard | September 2015 |
| 7612 | Lightweight Directory Access Protocol (LDAP): Schema for Printer ServicesP. Fleming, I. McDonald | Informational | June 2015 |
| 7605 | Recommendations on Using Assigned Transport Port NumbersJ. Touch | Best Current Practice | August 2015 |
| 7593 | The eduroam Architecture for Network RoamingK. Wierenga, S. Winter, T. Wolniewicz | Informational | September 2015 |
| 7592 | OAuth 2.0 Dynamic Client Registration Management ProtocolJ. Richer, Ed., M. Jones, J. Bradley, M. Machulak | Experimental | July 2015 |
| 7591 | OAuth 2.0 Dynamic Client Registration ProtocolJ. Richer, Ed., M. Jones, J. Bradley, M. Machulak, P. Hunt | Proposed Standard | July 2015 |
| 7590 | Use of Transport Layer Security (TLS) in the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre, T. Alkemade | Proposed Standard | June 2015 |
| 7589 | Using the NETCONF Protocol over Transport Layer Security (TLS) with Mutual X.509 AuthenticationM. Badra, A. Luchuk, J. Schoenwaelder | Proposed Standard | June 2015 |
| 7568 | Deprecating Secure Sockets Layer Version 3.0R. Barnes, M. Thomson, A. Pironti, A. Langley | Proposed Standard | June 2015 |
| 7564 | PRECIS Framework: Preparation, Enforcement, and Comparison of Internationalized Strings in Application ProtocolsP. Saint-Andre, M. Blanchet · obsoleted by RFC 8264 | Proposed Standard | May 2015 |
| 7562 | Transport Layer Security (TLS) Authorization Using Digital Transmission Content Protection (DTCP) CertificatesD. Thakore | Informational | July 2015 |
| 7545 | Protocol to Access White-Space (PAWS) DatabasesV. Chen, Ed., S. Das, L. Zhu, J. Malyar, P. McCann | Proposed Standard | May 2015 |
| 7541 | HPACK: Header Compression for HTTP/2R. Peon, H. Ruellan | Proposed Standard | May 2015 |
| 7540 | Hypertext Transfer Protocol Version 2 (HTTP/2)M. Belshe, R. Peon, M. Thomson, Ed. · obsoleted by RFC 9113 | Proposed Standard | May 2015 |
| 7533 | Administration Protocol for Federated File SystemsJ. Lentini, R. Tewari, C. Lever, Ed. | Proposed Standard | March 2015 |
| 7532 | Namespace Database (NSDB) Protocol for Federated File SystemsJ. Lentini, R. Tewari, C. Lever, Ed. | Proposed Standard | March 2015 |
| 7530 | Network File System (NFS) Version 4 ProtocolT. Haynes, Ed., D. Noveck, Ed. | Proposed Standard | March 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7517 | JSON Web Key (JWK)M. Jones | Proposed Standard | May 2015 |
| 7515 | JSON Web Signature (JWS)M. Jones, J. Bradley, N. Sakimura | Proposed Standard | May 2015 |
| 7507 | TLS Fallback Signaling Cipher Suite Value (SCSV) for Preventing Protocol Downgrade AttacksB. Moeller, A. Langley · obsoleted by RFC 8996 | Proposed Standard | April 2015 |
| 7486 | HTTP Origin-Bound Authentication (HOBA)S. Farrell, P. Hoffman, M. Thomas | Experimental | March 2015 |
| 7484 | Finding the Authoritative Registration Data (RDAP) ServiceM. Blanchet · obsoleted by RFC 9224 | Proposed Standard | March 2015 |
| 7481 | Security Services for the Registration Data Access Protocol (RDAP)S. Hollenbeck, N. Kong | Internet Standard | March 2015 |
| 7472 | Internet Printing Protocol (IPP) over HTTPS Transport Binding and the 'ipps' URI SchemeI. McDonald, M. Sweet | Proposed Standard | March 2015 |
| 7469 | Public Key Pinning Extension for HTTPC. Evans, C. Palmer, R. Sleevi | Proposed Standard | April 2015 |
| 7465 | Prohibiting RC4 Cipher SuitesA. Popov | Proposed Standard | February 2015 |
| 7462 | URNs for the Alert-Info Header Field of the Session Initiation Protocol (SIP)L. Liess, Ed., R. Jesske, A. Johnston, D. Worley, P. Kyzivat | Proposed Standard | March 2015 |
| 7457 | Summarizing Known Attacks on Transport Layer Security (TLS) and Datagram TLS (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre | Informational | February 2015 |
| 7443 | Application-Layer Protocol Negotiation (ALPN) Labels for Session Traversal Utilities for NAT (STUN) UsagesP. Patil, T. Reddy, G. Salgueiro, M. Petit-Huguenin | Informational | January 2015 |
| 7435 | Opportunistic Security: Some Protection Most of the TimeV. Dukhovni | Informational | December 2014 |
| 7433 | A Mechanism for Transporting User-to-User Call Control Information in SIPA. Johnston, J. Rafferty | Proposed Standard | January 2015 |
| 7423 | Diameter Applications Design GuidelinesL. Morand, Ed., V. Fajardo, H. Tschofenig | Best Current Practice | November 2014 |
| 7407 | A YANG Data Model for SNMP ConfigurationM. Bjorklund, J. Schoenwaelder | Proposed Standard | December 2014 |
| 7378 | Trustworthy LocationH. Tschofenig, H. Schulzrinne, B. Aboba, Ed. | Informational | December 2014 |
| 7366 | Encrypt-then-MAC for Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)P. Gutmann | Proposed Standard | September 2014 |
| 7360 | Datagram Transport Layer Security (DTLS) as a Transport Layer for RADIUSA. DeKok | Experimental | September 2014 |
| 7355 | Indicating WebSocket Protocol as a Transport in the Session Initiation Protocol (SIP) Common Log Format (CLF)G. Salgueiro, V. Pascual, A. Roman, S. Garcia | Informational | September 2014 |
| 7353 | Security Requirements for BGP Path ValidationS. Bellovin, R. Bush, D. Ward | Informational | August 2014 |
| 7350 | Datagram Transport Layer Security (DTLS) as Transport for Session Traversal Utilities for NAT (STUN)M. Petit-Huguenin, G. Salgueiro | Proposed Standard | August 2014 |
| 7345 | UDP Transport Layer (UDPTL) over Datagram Transport Layer Security (DTLS)C. Holmberg, I. Sedlacek, G. Salgueiro | Proposed Standard | August 2014 |
| 7301 | Transport Layer Security (TLS) Application-Layer Protocol Negotiation ExtensionS. Friedl, A. Popov, A. Langley, E. Stephan | Proposed Standard | July 2014 |
| 7285 | Application-Layer Traffic Optimization (ALTO) ProtocolR. Alimi, Ed., R. Penno, Ed., Y. Yang, Ed., S. Kiesel, S. Previdi, W. Roome, S. Shalunov, R. Woundy | Proposed Standard | September 2014 |
| 7255 | Using the International Mobile station Equipment Identity (IMEI) Uniform Resource Name (URN) as an Instance IDA. Allen, Ed. | Informational | May 2014 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 7251 | AES-CCM Elliptic Curve Cryptography (ECC) Cipher Suites for TLSD. McGrew, D. Bailey, M. Campagna, R. Dugal | Informational | June 2014 |
| 7250 | Using Raw Public Keys in Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)P. Wouters, Ed., H. Tschofenig, Ed., J. Gilmore, S. Weiler, T. Kivinen | Proposed Standard | June 2014 |
| 7247 | Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Architecture, Addresses, and Error HandlingP. Saint-Andre, A. Houri, J. Hildebrand | Proposed Standard | May 2014 |
| 7242 | Delay-Tolerant Networking TCP Convergence-Layer ProtocolM. Demmer, J. Ott, S. Perreault | Experimental | June 2014 |
| 7235 | Hypertext Transfer Protocol (HTTP/1.1): AuthenticationR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7231 | Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7201 | Options for Securing RTP SessionsM. Westerlund, C. Perkins | Informational | April 2014 |
| 7199 | Location Configuration Extensions for Policy ManagementR. Barnes, M. Thomson, J. Winterbottom, H. Tschofenig | Proposed Standard | April 2014 |
| 7194 | Default Port for Internet Relay Chat (IRC) via TLS/SSLR. Hartmann | Informational | August 2014 |
| 7171 | PT-EAP: Posture Transport (PT) Protocol for Extensible Authentication Protocol (EAP) Tunnel MethodsN. Cam-Winget, P. Sangster | Proposed Standard | May 2014 |
| 7170 | Tunnel Extensible Authentication Protocol (TEAP) Version 1H. Zhou, N. Cam-Winget, J. Salowey, S. Hanna · obsoleted by RFC 9930 | Proposed Standard | May 2014 |
| 7165 | Use Cases and Requirements for JSON Object Signing and Encryption (JOSE)R. Barnes | Informational | April 2014 |
| 7155 | Diameter Network Access Server ApplicationG. Zorn, Ed. | Proposed Standard | April 2014 |
| 7123 | Security Implications of IPv6 on IPv4 NetworksF. Gont, W. Liu | Informational | February 2014 |
| 7118 | The WebSocket Protocol as a Transport for the Session Initiation Protocol (SIP)I. Baz Castillo, J. Millan Villegas, V. Pascual | Proposed Standard | January 2014 |
| 7086 | Host Identity Protocol-Based Overlay Networking Environment (HIP BONE) Instance Specification for REsource LOcation And Discovery (RELOAD)A. Keranen, G. Camarillo, J. Maenpaa | Experimental | January 2014 |
| 7081 | CUSAX: Combined Use of the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP)E. Ivov, P. Saint-Andre, E. Marocco | Informational | November 2013 |
| 7066 | IPv6 for Third Generation Partnership Project (3GPP) Cellular HostsJ. Korhonen, Ed., J. Arkko, Ed., T. Savolainen, S. Krishnan | Informational | November 2013 |
| 7047 | The Open vSwitch Database Management ProtocolB. Pfaff, B. Davie, Ed. | Informational | December 2013 |
| 7044 | An Extension to the Session Initiation Protocol (SIP) for Request History InformationM. Barnes, F. Audet, S. Schubert, J. van Elburg, C. Holmberg | Proposed Standard | February 2014 |
| 7035 | Relative Location RepresentationM. Thomson, B. Rosen, D. Stanley, G. Bajko, A. Thomson | Proposed Standard | October 2013 |
| 7030 | Enrollment over Secure TransportM. Pritikin, Ed., P. Yee, Ed., D. Harkins, Ed. | Proposed Standard | October 2013 |
| 7027 | Elliptic Curve Cryptography (ECC) Brainpool Curves for Transport Layer Security (TLS)J. Merkle, M. Lochter | Informational | October 2013 |
| 7011 | Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of Flow InformationB. Claise, Ed., B. Trammell, Ed., P. Aitken | Internet Standard | September 2013 |
| 7009 | OAuth 2.0 Token RevocationT. Lodderstedt, Ed., S. Dronia, M. Scurtescu | Proposed Standard | August 2013 |
| 6979 | Deterministic Usage of the Digital Signature Algorithm (DSA) and Elliptic Curve Digital Signature Algorithm (ECDSA)T. Pornin | Informational | August 2013 |
| 6973 | Privacy Considerations for Internet ProtocolsA. Cooper, H. Tschofenig, B. Aboba, J. Peterson, J. Morris, M. Hansen, R. Smith | Informational | July 2013 |
| 6962 | Certificate TransparencyB. Laurie, A. Langley, E. Kasper · obsoleted by RFC 9162 | Experimental | June 2013 |
| 6961 | The Transport Layer Security (TLS) Multiple Certificate Status Request ExtensionY. Pettersen · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | June 2013 |
| 6945 | Definitions of Managed Objects for the Resource Public Key Infrastructure (RPKI) to Router ProtocolR. Bush, B. Wijnen, K. Patel, M. Baer | Proposed Standard | May 2013 |
| 6942 | Diameter Support for the EAP Re-authentication Protocol (ERP)J. Bournelle, L. Morand, S. Decugis, Q. Wu, G. Zorn | Proposed Standard | May 2013 |
| 6940 | REsource LOcation And Discovery (RELOAD) Base ProtocolC. Jennings, B. Lowekamp, Ed., E. Rescorla, S. Baset, H. Schulzrinne | Proposed Standard | January 2014 |
| 6897 | Multipath TCP (MPTCP) Application Interface ConsiderationsM. Scharf, A. Ford | Informational | March 2013 |
| 6896 | SCS: KoanLogic's Secure Cookie Sessions for HTTPS. Barbato, S. Dorigotti, T. Fossati, Ed. | Informational | March 2013 |
| 6883 | IPv6 Guidance for Internet Content Providers and Application Service ProvidersB. Carpenter, S. Jiang | Informational | March 2013 |
| 6876 | A Posture Transport Protocol over TLS (PT-TLS)P. Sangster, N. Cam-Winget, J. Salowey | Proposed Standard | February 2013 |
| 6872 | The Common Log Format (CLF) for the Session Initiation Protocol (SIP): Framework and Information ModelV. Gurbani, Ed., E. Burger, Ed., T. Anjali, H. Abdelnur, O. Festor | Proposed Standard | February 2013 |
| 6837 | NERD: A Not-so-novel Endpoint ID (EID) to Routing Locator (RLOC) DatabaseE. Lear | Experimental | January 2013 |
| 6819 | OAuth 2.0 Threat Model and Security ConsiderationsT. Lodderstedt, Ed., M. McGloin, P. Hunt | Informational | January 2013 |
| 6810 | The Resource Public Key Infrastructure (RPKI) to Router ProtocolR. Bush, R. Austein | Proposed Standard | January 2013 |
| 6809 | Mechanism to Indicate Support of Features and Capabilities in the Session Initiation Protocol (SIP)C. Holmberg, I. Sedlacek, H. Kaplan | Proposed Standard | November 2012 |
| 6797 | HTTP Strict Transport Security (HSTS)J. Hodges, C. Jackson, A. Barth | Proposed Standard | November 2012 |
| 6795 | A Session Initiation Protocol (SIP) Event Package for Session-Specific PoliciesV. Hilt, G. Camarillo | Proposed Standard | December 2012 |
| 6794 | A Framework for Session Initiation Protocol (SIP) Session PoliciesV. Hilt, G. Camarillo, J. Rosenberg | Proposed Standard | December 2012 |
| 6787 | Media Resource Control Protocol Version 2 (MRCPv2)D. Burnett, S. Shanmugham | Proposed Standard | November 2012 |
| 6781 | DNSSEC Operational Practices, Version 2O. Kolkman, W. Mekking, R. Gieben | Informational | December 2012 |
| 6764 | Locating Services for Calendaring Extensions to WebDAV (CalDAV) and vCard Extensions to WebDAV (CardDAV)C. Daboo | Proposed Standard | February 2013 |
| 6753 | A Location Dereference Protocol Using HTTP-Enabled Location Delivery (HELD)J. Winterbottom, H. Tschofenig, H. Schulzrinne, M. Thomson | Proposed Standard | October 2012 |
| 6750 | The OAuth 2.0 Authorization Framework: Bearer Token UsageM. Jones, D. Hardt | Proposed Standard | October 2012 |
| 6749 | The OAuth 2.0 Authorization FrameworkD. Hardt, Ed. | Proposed Standard | October 2012 |
| 6739 | Synchronizing Service Boundaries and <mapping> Elements Based on the Location-to-Service Translation (LoST) ProtocolH. Schulzrinne, H. Tschofenig | Experimental | October 2012 |
| 6733 | Diameter Base ProtocolV. Fajardo, Ed., J. Arkko, J. Loughney, G. Zorn, Ed. | Proposed Standard | October 2012 |
| 6728 | Configuration Data Model for the IP Flow Information Export (IPFIX) and Packet Sampling (PSAMP) ProtocolsG. Muenz, B. Claise, P. Aitken | Proposed Standard | October 2012 |
| 6717 | kx509 Kerberized Certificate Issuance Protocol in Use in 2012H. Hotz, R. Allbery | Informational | August 2012 |
| 6714 | Connection Establishment for Media Anchoring (CEMA) for the Message Session Relay Protocol (MSRP)C. Holmberg, S. Blau, E. Burger | Proposed Standard | August 2012 |
| 6712 | Internet X.509 Public Key Infrastructure -- HTTP Transfer for the Certificate Management Protocol (CMP)T. Kause, M. Peylo · obsoleted by RFC 9811 | Proposed Standard | September 2012 |
| 6709 | Design Considerations for Protocol ExtensionsB. Carpenter, B. Aboba, Ed., S. Cheshire | Informational | September 2012 |
| 6698 | The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSAP. Hoffman, J. Schlyter | Proposed Standard | August 2012 |
| 6682 | RTP Payload Format for Raptor Forward Error Correction (FEC)M. Watson, T. Stockhammer, M. Luby | Proposed Standard | August 2012 |
| 6678 | Requirements for a Tunnel-Based Extensible Authentication Protocol (EAP) MethodK. Hoeper, S. Hanna, H. Zhou, J. Salowey, Ed. | Informational | July 2012 |
| 6655 | AES-CCM Cipher Suites for Transport Layer Security (TLS)D. McGrew, D. Bailey | Proposed Standard | July 2012 |
| 6632 | An Overview of the IETF Network Management StandardsM. Ersue, Ed., B. Claise | Informational | June 2012 |
| 6618 | Mobile IPv6 Security Framework Using Transport Layer Security for Communication between the Mobile Node and Home AgentJ. Korhonen, Ed., B. Patil, H. Tschofenig, D. Kroeselberg | Experimental | May 2012 |
| 6616 | A Simple Authentication and Security Layer (SASL) and Generic Security Service Application Program Interface (GSS-API) Mechanism for OpenIDE. Lear, H. Tschofenig, H. Mauldin, S. Josefsson | Proposed Standard | May 2012 |
| 6614 | Transport Layer Security (TLS) Encryption for RADIUSS. Winter, M. McCauley, S. Venaas, K. Wierenga | Experimental | May 2012 |
| 6613 | RADIUS over TCPA. DeKok | Experimental | May 2012 |
| 6597 | RTP Payload Format for Society of Motion Picture and Television Engineers (SMPTE) ST 336 Encoded DataJ. Downs, Ed., J. Arbeiter, Ed. | Proposed Standard | April 2012 |
| 6595 | A Simple Authentication and Security Layer (SASL) and GSS-API Mechanism for the Security Assertion Markup Language (SAML)K. Wierenga, E. Lear, S. Josefsson | Proposed Standard | April 2012 |
| 6574 | Report from the Smart Object WorkshopH. Tschofenig, J. Arkko | Informational | April 2012 |
| 6546 | Transport of Real-time Inter-network Defense (RID) Messages over HTTP/TLSB. Trammell | Proposed Standard | April 2012 |
| 6520 | Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS) Heartbeat ExtensionR. Seggelmann, M. Tuexen, M. Williams | Proposed Standard | February 2012 |
| 6503 | Centralized Conferencing Manipulation ProtocolM. Barnes, C. Boulton, S. Romano, H. Schulzrinne | Proposed Standard | March 2012 |
| 6476 | Using Message Authentication Code (MAC) Encryption in the Cryptographic Message Syntax (CMS)P. Gutmann | Proposed Standard | January 2012 |
| 6460 | Suite B Profile for Transport Layer Security (TLS)M. Salter, R. Housley | Historic | January 2012 |
| 6455 | The WebSocket ProtocolI. Fette, A. Melnikov | Proposed Standard | December 2011 |
| 6454 | The Web Origin ConceptA. Barth | Proposed Standard | December 2011 |
| 6448 | The Unencrypted Form of Kerberos 5 KRB-CRED MessageR. Yount | Proposed Standard | November 2011 |
| 6416 | RTP Payload Format for MPEG-4 Audio/Visual StreamsM. Schmidt, F. de Bont, S. Doehla, J. Kim | Proposed Standard | October 2011 |
| 6406 | Session PEERing for Multimedia INTerconnect (SPEERMINT) ArchitectureD. Malas, Ed., J. Livingood, Ed. | Informational | November 2011 |
| 6405 | Voice over IP (VoIP) SIP Peering Use CasesA. Uzelac, Ed., Y. Lee, Ed. | Informational | November 2011 |
| 6404 | Session PEERing for Multimedia INTerconnect (SPEERMINT) Security Threats and Suggested CountermeasuresJ. Seedorf, S. Niccolini, E. Chen, H. Scholz | Informational | November 2011 |
| 6394 | Use Cases and Requirements for DNS-Based Authentication of Named Entities (DANE)R. Barnes | Informational | October 2011 |
| 6367 | Addition of the Camellia Cipher Suites to Transport Layer Security (TLS)S. Kanno, M. Kanda | Informational | September 2011 |
| 6358 | Additional Master Secret Inputs for TLSP. Hoffman | Experimental | January 2012 |
| 6353 | Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP)W. Hardaker | Internet Standard | July 2011 |
| 6352 | CardDAV: vCard Extensions to Web Distributed Authoring and Versioning (WebDAV)C. Daboo | Proposed Standard | August 2011 |
| 6347 | Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147 | Proposed Standard | January 2012 |
| 6338 | Definition of a Uniform Resource Name (URN) Namespace for the Schema for Academia (SCHAC)V. Giralt, R. McDuff | Informational | August 2011 |
| 6320 | Protocol for Access Node Control Mechanism in Broadband NetworksS. Wadhwa, J. Moisand, T. Haag, N. Voigt, T. Taylor, Ed. | Proposed Standard | October 2011 |
| 6306 | Hierarchical IPv4 FrameworkP. Frejborg | Experimental | July 2011 |
| 6287 | OCRA: OATH Challenge-Response AlgorithmD. M'Raihi, J. Rydell, S. Bajaj, S. Machani, D. Naccache | Informational | June 2011 |
| 6282 | Compression Format for IPv6 Datagrams over IEEE 802.15.4-Based NetworksJ. Hui, Ed., P. Thubert | Proposed Standard | September 2011 |
| 6281 | Understanding Apple's Back to My Mac (BTMM) ServiceS. Cheshire, Z. Zhu, R. Wakikawa, L. Zhang | Informational | June 2011 |
| 6280 | An Architecture for Location and Location Privacy in Internet ApplicationsR. Barnes, M. Lepinski, A. Cooper, J. Morris, H. Tschofenig, H. Schulzrinne | Best Current Practice | July 2011 |
| 6272 | Internet Protocols for the Smart GridF. Baker, D. Meyer | Informational | June 2011 |
| 6262 | RTP Payload Format for IP-MR Speech CodecS. Ikonin | Proposed Standard | August 2011 |
| 6251 | Using Kerberos Version 5 over the Transport Layer Security (TLS) ProtocolS. Josefsson | Informational | May 2011 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6238 | TOTP: Time-Based One-Time Password AlgorithmD. M'Raihi, S. Machani, M. Pei, J. Rydell | Informational | May 2011 |
| 6235 | IP Flow Anonymization SupportE. Boschi, B. Trammell | Experimental | May 2011 |
| 6230 | Media Control Channel FrameworkC. Boulton, T. Melanchuk, S. McGlashan | Proposed Standard | May 2011 |
| 6223 | Indication of Support for Keep-AliveC. Holmberg | Proposed Standard | April 2011 |
| 6216 | Example Call Flows Using Session Initiation Protocol (SIP) Security MechanismsC. Jennings, K. Ono, R. Sparks, B. Hibbard, Ed. | Informational | April 2011 |
| 6209 | Addition of the ARIA Cipher Suites to Transport Layer Security (TLS)W. Kim, J. Lee, J. Park, D. Kwon | Informational | April 2011 |
| 6193 | Media Description for the Internet Key Exchange Protocol (IKE) in the Session Description Protocol (SDP)M. Saito, D. Wing, M. Toyama | Informational | April 2011 |
| 6186 | Use of SRV Records for Locating Email Submission/Access ServicesC. Daboo | Proposed Standard | March 2011 |
| 6183 | IP Flow Information Export (IPFIX) Mediation: FrameworkA. Kobayashi, B. Claise, G. Muenz, K. Ishibashi | Informational | April 2011 |
| 6176 | Prohibiting Secure Sockets Layer (SSL) Version 2.0S. Turner, T. Polk | Proposed Standard | March 2011 |
| 6155 | Use of Device Identity in HTTP-Enabled Location Delivery (HELD)J. Winterbottom, M. Thomson, H. Tschofenig, R. Barnes | Proposed Standard | March 2011 |
| 6142 | ANSI C12.22, IEEE 1703, and MC12.22 Transport Over IPA. Moise, J. Brodkin | Informational | March 2011 |
| 6140 | Registration for Multiple Phone Numbers in the Session Initiation Protocol (SIP)A.B. Roach | Proposed Standard | March 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6121 | Extensible Messaging and Presence Protocol (XMPP): Instant Messaging and PresenceP. Saint-Andre | Proposed Standard | March 2011 |
| 6120 | Extensible Messaging and Presence Protocol (XMPP): CoreP. Saint-Andre | Proposed Standard | March 2011 |
| 6109 | La Posta Elettronica Certificata - Italian Certified Electronic MailC. Petrucci, F. Gennai, A. Shahin, A. Vinciarelli | Informational | April 2011 |
| 6091 | Using OpenPGP Keys for Transport Layer Security (TLS) AuthenticationN. Mavrogiannopoulos, D. Gillmor | Informational | February 2011 |
| 6086 | Session Initiation Protocol (SIP) INFO Method and Package FrameworkC. Holmberg, E. Burger, H. Kaplan | Proposed Standard | January 2011 |
| 6080 | A Framework for Session Initiation Protocol User Agent Profile DeliveryD. Petrie, S. Channabasappa, Ed. | Proposed Standard | March 2011 |
| 6072 | Certificate Management Service for the Session Initiation Protocol (SIP)C. Jennings, J. Fischl, Ed. | Proposed Standard | February 2011 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6063 | Dynamic Symmetric Key Provisioning Protocol (DSKPP)A. Doherty, M. Pei, S. Machani, M. Nystrom | Proposed Standard | December 2010 |
| 6046 | Transport of Real-time Inter-network Defense (RID) MessagesK. Moriarty, B. Trammell · obsoleted by RFC 6546 | Informational | November 2010 |
| 6042 | Transport Layer Security (TLS) Authorization Using KeyNoteA. Keromytis | Informational | October 2010 |
| 6030 | Portable Symmetric Key Container (PSKC)P. Hoyer, M. Pei, S. Machani | Proposed Standard | October 2010 |
| 6015 | RTP Payload Format for 1-D Interleaved Parity Forward Error Correction (FEC)A. Begen | Proposed Standard | October 2010 |
| 6012 | Datagram Transport Layer Security (DTLS) Transport Mapping for SyslogJ. Salowey, T. Petch, R. Gerhards, H. Feng | Proposed Standard | October 2010 |
| 6011 | Session Initiation Protocol (SIP) User Agent ConfigurationS. Lawrence, Ed., J. Elwell | Informational | October 2010 |
| 5993 | RTP Payload Format for Global System for Mobile Communications Half Rate (GSM-HR)X. Duan, S. Wang, M. Westerlund, K. Hellwig, I. Johansson | Proposed Standard | October 2010 |
| 5985 | HTTP-Enabled Location Delivery (HELD)M. Barnes, Ed. | Proposed Standard | September 2010 |
| 5982 | IP Flow Information Export (IPFIX) Mediation: Problem StatementA. Kobayashi, Ed., B. Claise, Ed. | Informational | August 2010 |
| 5971 | GIST: General Internet Signalling TransportH. Schulzrinne, R. Hancock | Experimental | October 2010 |
| 5953 | Transport Layer Security (TLS) Transport Model for the Simple Network Management Protocol (SNMP)W. Hardaker · obsoleted by RFC 6353 | Proposed Standard | August 2010 |
| 5932 | Camellia Cipher Suites for TLSA. Kato, M. Kanda, S. Kanno | Proposed Standard | June 2010 |
| 5929 | Channel Bindings for TLSJ. Altman, N. Williams, L. Zhu | Proposed Standard | July 2010 |
| 5928 | Traversal Using Relays around NAT (TURN) Resolution MechanismM. Petit-Huguenin | Proposed Standard | August 2010 |
| 5925 | The TCP Authentication OptionJ. Touch, A. Mankin, R. Bonica | Proposed Standard | June 2010 |
| 5923 | Connection Reuse in the Session Initiation Protocol (SIP)V. Gurbani, Ed., R. Mahy, B. Tate | Proposed Standard | June 2010 |
| 5922 | Domain Certificates in the Session Initiation Protocol (SIP)V. Gurbani, S. Lawrence, A. Jeffrey | Proposed Standard | June 2010 |
| 5920 | Security Framework for MPLS and GMPLS NetworksL. Fang, Ed. | Informational | July 2010 |
| 5890 | Internationalized Domain Names for Applications (IDNA): Definitions and Document FrameworkJ. Klensin | Proposed Standard | August 2010 |
| 5888 | The Session Description Protocol (SDP) Grouping FrameworkG. Camarillo, H. Schulzrinne | Proposed Standard | June 2010 |
| 5878 | Transport Layer Security (TLS) Authorization ExtensionsM. Brown, R. Housley | Experimental | May 2010 |
| 5875 | An Extensible Markup Language (XML) Configuration Access Protocol (XCAP) Diff Event PackageJ. Urpalainen, D. Willis, Ed. | Proposed Standard | May 2010 |
| 5874 | An Extensible Markup Language (XML) Document Format for Indicating a Change in XML Configuration Access Protocol (XCAP) ResourcesJ. Rosenberg, J. Urpalainen | Proposed Standard | May 2010 |
| 5866 | Diameter Quality-of-Service ApplicationD. Sun, Ed., P. McCann, H. Tschofenig, T. Tsou, A. Doria, G. Zorn, Ed. | Proposed Standard | May 2010 |
| 5804 | A Protocol for Remotely Managing Sieve ScriptsA. Melnikov, Ed., T. Martin | Proposed Standard | July 2010 |
| 5802 | Salted Challenge Response Authentication Mechanism (SCRAM) SASL and GSS-API MechanismsC. Newman, A. Menon-Sen, A. Melnikov, N. Williams | Proposed Standard | July 2010 |
| 5801 | Using Generic Security Service Application Program Interface (GSS-API) Mechanisms in Simple Authentication and Security Layer (SASL): The GS2 Mechanism FamilyS. Josefsson, N. Williams | Proposed Standard | July 2010 |
| 5764 | Datagram Transport Layer Security (DTLS) Extension to Establish Keys for the Secure Real-time Transport Protocol (SRTP)D. McGrew, E. Rescorla | Proposed Standard | May 2010 |
| 5763 | Framework for Establishing a Secure Real-time Transport Protocol (SRTP) Security Context Using Datagram Transport Layer Security (DTLS)J. Fischl, H. Tschofenig, E. Rescorla | Proposed Standard | May 2010 |
| 5746 | Transport Layer Security (TLS) Renegotiation Indication ExtensionE. Rescorla, M. Ray, S. Dispensa, N. Oskov | Proposed Standard | February 2010 |
| 5734 | Extensible Provisioning Protocol (EPP) Transport over TCPS. Hollenbeck | Internet Standard | August 2009 |
| 5716 | Requirements for Federated File SystemsJ. Lentini, C. Everhart, D. Ellard, R. Tewari, M. Naik | Informational | January 2010 |
| 5705 | Keying Material Exporters for Transport Layer Security (TLS)E. Rescorla | Proposed Standard | March 2010 |
| 5697 | Other Certificates ExtensionS. Farrell | Experimental | November 2009 |
| 5691 | RTP Payload Format for Elementary Streams with MPEG Surround Multi-Channel AudioF. de Bont, S. Doehla, M. Schmidt, R. Sperschneider | Proposed Standard | October 2009 |
| 5677 | IEEE 802.21 Mobility Services Framework Design (MSFD)T. Melia, Ed., G. Bajko, S. Das, N. Golmie, JC. Zuniga | Proposed Standard | December 2009 |
| 5636 | Traceable Anonymous CertificateS. Park, H. Park, Y. Won, J. Lee, S. Kent | Experimental | August 2009 |
| 5630 | The Use of the SIPS URI Scheme in the Session Initiation Protocol (SIP)F. Audet | Proposed Standard | October 2009 |
| 5626 | Managing Client-Initiated Connections in the Session Initiation Protocol (SIP)C. Jennings, Ed., R. Mahy, Ed., F. Audet, Ed. | Proposed Standard | October 2009 |
| 5616 | Streaming Internet Messaging AttachmentsN. Cook | Informational | August 2009 |
| 5590 | Transport Subsystem for the Simple Network Management Protocol (SNMP)D. Harrington, J. Schoenwaelder | Internet Standard | June 2009 |
| 5582 | Location-to-URL Mapping Architecture and FrameworkH. Schulzrinne | Informational | September 2009 |
| 5577 | RTP Payload Format for ITU-T Recommendation G.722.1P. Luthi, R. Even | Proposed Standard | July 2009 |
| 5567 | An Architectural Framework for Media Server ControlT. Melanchuk, Ed. | Informational | June 2009 |
| 5550 | The Internet Email to Support Diverse Service Environments (Lemonade) ProfileD. Cridland, Ed., A. Melnikov, Ed., S. Maes, Ed. | Proposed Standard | August 2009 |
| 5539 | NETCONF over Transport Layer Security (TLS)M. Badra · obsoleted by RFC 7589 | Proposed Standard | May 2009 |
| 5505 | Principles of Internet Host ConfigurationB. Aboba, D. Thaler, L. Andersson, S. Cheshire | Informational | May 2009 |
| 5489 | ECDHE_PSK Cipher Suites for Transport Layer Security (TLS)M. Badra, I. Hajjeh | Informational | March 2009 |
| 5487 | Pre-Shared Key Cipher Suites for TLS with SHA-256/384 and AES Galois Counter ModeM. Badra | Proposed Standard | March 2009 |
| 5486 | Session Peering for Multimedia Interconnect (SPEERMINT) TerminologyD. Malas, Ed., D. Meyer, Ed. | Informational | March 2009 |
| 5482 | TCP User Timeout OptionL. Eggert, F. Gont | Proposed Standard | March 2009 |
| 5479 | Requirements and Analysis of Media Security Management ProtocolsD. Wing, Ed., S. Fries, H. Tschofenig, F. Audet | Informational | April 2009 |
| 5469 | DES and IDEA Cipher Suites for Transport Layer Security (TLS)P. Eronen, Ed. · obsoleted by RFC 8996 | Historic | February 2009 |
| 5458 | Security Requirements for the Unidirectional Lightweight Encapsulation (ULE) ProtocolH. Cruickshank, P. Pillai, M. Noisternig, S. Iyengar | Informational | March 2009 |
| 5440 | Path Computation Element (PCE) Communication Protocol (PCEP)JP. Vasseur, Ed., JL. Le Roux, Ed. | Proposed Standard | March 2009 |
| 5430 | Suite B Profile for Transport Layer Security (TLS)M. Salter, E. Rescorla, R. Housley · obsoleted by RFC 6460 | Historic | March 2009 |
| 5425 | Transport Layer Security (TLS) Transport Mapping for SyslogF. Miao, Ed., Y. Ma, Ed., J. Salowey, Ed. | Proposed Standard | March 2009 |
| 5422 | Dynamic Provisioning Using Flexible Authentication via Secure Tunneling Extensible Authentication Protocol (EAP-FAST)N. Cam-Winget, D. McGrew, J. Salowey, H. Zhou | Informational | March 2009 |
| 5415 | Control And Provisioning of Wireless Access Points (CAPWAP) Protocol SpecificationP. Calhoun, Ed., M. Montemurro, Ed., D. Stanley, Ed. | Proposed Standard | March 2009 |
| 5413 | SLAPP: Secure Light Access Point ProtocolP. Narasimhan, D. Harkins, S. Ponnuswamy | Historic | February 2010 |
| 5409 | Using the Boneh-Franklin and Boneh-Boyen Identity-Based Encryption Algorithms with the Cryptographic Message Syntax (CMS)L. Martin, M. Schertler | Informational | January 2009 |
| 5408 | Identity-Based Encryption Architecture and Supporting Data StructuresG. Appenzeller, L. Martin, M. Schertler | Informational | January 2009 |
| 5404 | RTP Payload Format for G.719M. Westerlund, I. Johansson | Proposed Standard | January 2009 |
| 5387 | Problem and Applicability Statement for Better-Than-Nothing Security (BTNS)J. Touch, D. Black, Y. Wang | Informational | November 2008 |
| 5371 | RTP Payload Format for JPEG 2000 Video StreamsS. Futemma, E. Itakura, A. Leung | Proposed Standard | October 2008 |
| 5370 | The Session Initiation Protocol (SIP) Conference Bridge Transcoding ModelG. Camarillo | Proposed Standard | October 2008 |
| 5369 | Framework for Transcoding with the Session Initiation Protocol (SIP)G. Camarillo | Informational | October 2008 |
| 5355 | Threats Introduced by Reliable Server Pooling (RSerPool) and Requirements for Security in Response to ThreatsM. Stillman, Ed., R. Gopal, E. Guttman, S. Sengodan, M. Holdrege | Informational | September 2008 |
| 5353 | Endpoint Handlespace Redundancy Protocol (ENRP)Q. Xie, R. Stewart, M. Stillman, M. Tuexen, A. Silverton | Experimental | September 2008 |
| 5352 | Aggregate Server Access Protocol (ASAP)R. Stewart, Q. Xie, M. Stillman, M. Tuexen | Experimental | September 2008 |
| 5333 | IANA Registration of Enumservices for Internet CalendaringR. Mahy, B. Hoeneisen | Proposed Standard | October 2009 |
| 5327 | Licklider Transmission Protocol - Security ExtensionsS. Farrell, M. Ramadas, S. Burleigh | Experimental | September 2008 |
| 5289 | TLS Elliptic Curve Cipher Suites with SHA-256/384 and AES Galois Counter Mode (GCM)E. Rescorla | Proposed Standard | August 2008 |
| 5288 | AES Galois Counter Mode (GCM) Cipher Suites for TLSJ. Salowey, A. Choudhury, D. McGrew | Proposed Standard | August 2008 |
| 5247 | Extensible Authentication Protocol (EAP) Key Management FrameworkB. Aboba, D. Simon, P. Eronen | Proposed Standard | August 2008 |