| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 826 | An Ethernet Address Resolution Protocol: Or Converting Network Protocol Addresses to 48.bit Ethernet Address for Transmission on Ethernet HardwareD. Plummer | Internet Standard | November 1982 |
| 959 | File Transfer ProtocolJ. Postel, J. Reynolds | Internet Standard | October 1985 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1058 | Routing Information ProtocolC.L. Hedrick | Historic | June 1988 |
| 1436 | The Internet Gopher Protocol (a distributed document search and retrieval protocol)F. Anklesaria, M. McCahill, P. Lindner, D. Johnson, D. Torrey, B. Alberti | Informational | March 1993 |
| 1661 | The Point-to-Point Protocol (PPP)W. Simpson, Ed. | Internet Standard | July 1994 |
| 1866 | Hypertext Markup Language - 2.0T. Berners-Lee, D. Connolly · obsoleted by RFC 2854 | Historic | November 1995 |
| 1958 | Architectural Principles of the InternetB. Carpenter, Ed. | Informational | June 1996 |
| 2131 | Dynamic Host Configuration ProtocolR. Droms | Draft Standard | March 1997 |
| 2328 | OSPF Version 2J. Moy | Internet Standard | April 1998 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2821 | Simple Mail Transfer ProtocolJ. Klensin, Ed. · obsoleted by RFC 5321 | Proposed Standard | April 2001 |
| 2865 | Remote Authentication Dial In User Service (RADIUS)C. Rigney, S. Willens, A. Rubens, W. Simpson | Draft Standard | June 2000 |
| 3022 | Traditional IP Network Address Translator (Traditional NAT)P. Srisuresh, K. Egevang | Informational | January 2001 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 3552 | Guidelines for Writing RFC Text on Security ConsiderationsE. Rescorla, B. Korver | Best Current Practice | July 2003 |
| 3954 | Cisco Systems NetFlow Services Export Version 9B. Claise, Ed. | Informational | October 2004 |
| 4120 | The Kerberos Network Authentication Service (V5)C. Neuman, T. Yu, S. Hartman, K. Raeburn | Proposed Standard | July 2005 |
| 4251 | The Secure Shell (SSH) Protocol ArchitectureT. Ylonen, C. Lonvick, Ed. | Proposed Standard | January 2006 |
| 4271 | A Border Gateway Protocol 4 (BGP-4)Y. Rekhter, Ed., T. Li, Ed., S. Hares, Ed. | Draft Standard | January 2006 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4436 | Detecting Network Attachment in IPv4 (DNAv4)B. Aboba, J. Carlson, S. Cheshire | Proposed Standard | March 2006 |
| 4864 | Local Network Protection for IPv6G. Van de Velde, T. Hain, R. Droms, B. Carpenter, E. Klein | Informational | May 2007 |