| 768 | User Datagram ProtocolJ. Postel | Internet Standard | August 1980 |
| 792 | Internet Control Message ProtocolJ. Postel | Internet Standard | September 1981 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2404 | The Use of HMAC-SHA-1-96 within ESP and AHC. Madson, R. Glenn | Proposed Standard | November 1998 |
| 2412 | The OAKLEY Key Determination ProtocolH. Orman | Informational | November 1998 |
| 2434 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 5226 | Best Current Practice | October 1998 |
| 2451 | The ESP CBC-Mode Cipher AlgorithmsR. Pereira, R. Adams | Proposed Standard | November 1998 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2463 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering · obsoleted by RFC 4443 | Draft Standard | December 1998 |
| 2536 | DSA KEYs and SIGs in the Domain Name System (DNS)D. Eastlake 3rd | Proposed Standard | March 1999 |
| 2898 | PKCS #5: Password-Based Cryptography Specification Version 2.0B. Kaliski · obsoleted by RFC 8018 | Informational | September 2000 |
| 3110 | RSA/SHA-1 SIGs and RSA KEYs in the Domain Name System (DNS)D. Eastlake 3rd | Proposed Standard | May 2001 |
| 3484 | Default Address Selection for Internet Protocol version 6 (IPv6)R. Draves · obsoleted by RFC 6724 | Proposed Standard | March 2003 |
| 3526 | More Modular Exponential (MODP) Diffie-Hellman groups for Internet Key Exchange (IKE)T. Kivinen, M. Kojo | Proposed Standard | May 2003 |
| 3602 | The AES-CBC Cipher Algorithm and Its Use with IPsecS. Frankel, R. Glenn, S. Kelly | Proposed Standard | September 2003 |
| 3972 | Cryptographically Generated Addresses (CGA)T. Aura | Proposed Standard | March 2005 |
| 4034 | Resource Records for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4282 | The Network Access IdentifierB. Aboba, M. Beadles, J. Arkko, P. Eronen · obsoleted by RFC 7542 | Proposed Standard | December 2005 |
| 4306 | Internet Key Exchange (IKEv2) ProtocolC. Kaufman, Ed. · obsoleted by RFC 5996 | Proposed Standard | December 2005 |
| 4307 | Cryptographic Algorithms for Use in the Internet Key Exchange Version 2 (IKEv2)J. Schiller · obsoleted by RFC 8247 | Proposed Standard | December 2005 |
| 4423 | Host Identity Protocol (HIP) ArchitectureR. Moskowitz, P. Nikander · obsoleted by RFC 9063 | Informational | May 2006 |
| 4843 | An IPv6 Prefix for Overlay Routable Cryptographic Hash Identifiers (ORCHID)P. Nikander, J. Laganier, F. Dupont · obsoleted by RFC 7343 | Experimental | April 2007 |
| 5202 | Using the Encapsulating Security Payload (ESP) Transport Format with the Host Identity Protocol (HIP)P. Jokela, R. Moskowitz, P. Nikander · obsoleted by RFC 7402 | Experimental | April 2008 |
| 5204 | Host Identity Protocol (HIP) Rendezvous ExtensionJ. Laganier, L. Eggert · obsoleted by RFC 8004 | Experimental | April 2008 |
| 5205 | Host Identity Protocol (HIP) Domain Name System (DNS) ExtensionsP. Nikander, J. Laganier · obsoleted by RFC 8005 | Experimental | April 2008 |
| 5206 | End-Host Mobility and Multihoming with the Host Identity ProtocolP. Nikander, T. Henderson, Ed., C. Vogt, J. Arkko · obsoleted by RFC 8046 | Experimental | April 2008 |