| 7401 | Host Identity Protocol Version 2 (HIPv2)R. Moskowitz, Ed., T. Heer, P. Jokela, T. Henderson | Proposed Standard | April 2015 |
| 7086 | Host Identity Protocol-Based Overlay Networking Environment (HIP BONE) Instance Specification for REsource LOcation And Discovery (RELOAD)A. Keranen, G. Camarillo, J. Maenpaa | Experimental | January 2014 |
| 7045 | Transmission and Processing of IPv6 Extension HeadersB. Carpenter, S. Jiang | Proposed Standard | December 2013 |
| 6967 | Analysis of Potential Solutions for Revealing a Host Identifier (HOST_ID) in Shared Address DeploymentsM. Boucadair, J. Touch, P. Levis, R. Penno | Informational | June 2013 |
| 6940 | REsource LOcation And Discovery (RELOAD) Base ProtocolC. Jennings, B. Lowekamp, Ed., E. Rescorla, S. Baset, H. Schulzrinne | Proposed Standard | January 2014 |
| 6709 | Design Considerations for Protocol ExtensionsB. Carpenter, B. Aboba, Ed., S. Cheshire | Informational | September 2012 |
| 6629 | Considerations on the Application of the Level 3 Multihoming Shim Protocol for IPv6 (Shim6)J. Abley, M. Bagnulo, A. Garcia-Martinez | Informational | June 2012 |
| 6538 | The Host Identity Protocol (HIP) Experiment ReportT. Henderson, A. Gurtov | Informational | March 2012 |
| 6537 | Host Identity Protocol Distributed Hash Table InterfaceJ. Ahrenholz | Experimental | February 2012 |
| 6317 | Basic Socket Interface Extensions for the Host Identity Protocol (HIP)M. Komu, T. Henderson | Experimental | July 2011 |
| 6301 | A Survey of Mobility Support in the InternetZ. Zhu, R. Wakikawa, L. Zhang | Informational | July 2011 |
| 6261 | Encrypted Signaling Transport Modes for the Host Identity ProtocolA. Keranen | Experimental | May 2011 |
| 6253 | Host Identity Protocol CertificatesT. Heer, S. Varjonen · obsoleted by RFC 8002 | Experimental | May 2011 |
| 6252 | A Framework of Media-Independent Pre-Authentication (MPA) for Inter-Domain Handover OptimizationA. Dutta, Ed., V. Fajardo, Y. Ohba, K. Taniuchi, H. Schulzrinne | Informational | June 2011 |
| 6115 | Recommendation for a Routing ArchitectureT. Li, Ed. | Informational | February 2011 |
| 6092 | Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet ServiceJ. Woodyatt, Ed. | Informational | January 2011 |
| 6079 | HIP BONE: Host Identity Protocol (HIP) Based Overlay Networking Environment (BONE)G. Camarillo, P. Nikander, J. Hautakorpi, A. Keranen, A. Johnston | Experimental | January 2011 |
| 6078 | Host Identity Protocol (HIP) Immediate Carriage and Conveyance of Upper-Layer Protocol Signaling (HICCUPS)G. Camarillo, J. Melen | Experimental | January 2011 |
| 6071 | IP Security (IPsec) and Internet Key Exchange (IKE) Document RoadmapS. Frankel, S. Krishnan | Informational | February 2011 |
| 6028 | Host Identity Protocol (HIP) Multi-Hop Routing ExtensionG. Camarillo, A. Keranen | Experimental | October 2010 |
| 5770 | Basic Host Identity Protocol (HIP) Extensions for Traversal of Network Address TranslatorsM. Komu, T. Henderson, H. Tschofenig, J. Melen, A. Keranen, Ed. | Experimental | April 2010 |
| 5687 | GEOPRIV Layer 7 Location Configuration Protocol: Problem Statement and RequirementsH. Tschofenig, H. Schulzrinne | Informational | March 2010 |
| 5533 | Shim6: Level 3 Multihoming Shim Protocol for IPv6E. Nordmark, M. Bagnulo | Proposed Standard | June 2009 |
| 5387 | Problem and Applicability Statement for Better-Than-Nothing Security (BTNS)J. Touch, D. Black, Y. Wang | Informational | November 2008 |
| 5338 | Using the Host Identity Protocol with Legacy ApplicationsT. Henderson, P. Nikander, M. Komu | Experimental | September 2008 |
| 5207 | NAT and Firewall Traversal Issues of Host Identity Protocol (HIP) CommunicationM. Stiemerling, J. Quittek, L. Eggert | Informational | April 2008 |
| 5206 | End-Host Mobility and Multihoming with the Host Identity ProtocolP. Nikander, T. Henderson, Ed., C. Vogt, J. Arkko · obsoleted by RFC 8046 | Experimental | April 2008 |
| 5205 | Host Identity Protocol (HIP) Domain Name System (DNS) ExtensionsP. Nikander, J. Laganier · obsoleted by RFC 8005 | Experimental | April 2008 |
| 5204 | Host Identity Protocol (HIP) Rendezvous ExtensionJ. Laganier, L. Eggert · obsoleted by RFC 8004 | Experimental | April 2008 |
| 5203 | Host Identity Protocol (HIP) Registration ExtensionJ. Laganier, T. Koponen, L. Eggert · obsoleted by RFC 8003 | Experimental | April 2008 |
| 5202 | Using the Encapsulating Security Payload (ESP) Transport Format with the Host Identity Protocol (HIP)P. Jokela, R. Moskowitz, P. Nikander · obsoleted by RFC 7402 | Experimental | April 2008 |