| 9929 | IGP Unreachable Prefix AnnouncementP. Psenak, Ed., C. Filsfils, D. Voyer, S. Hegde, G. Mishra | Proposed Standard | February 2026 |
| 9885 | Multi-Part TLVs in IS-ISP. Kaneriya, T. Li, A. Przygienda, S. Hegde, L. Ginsberg | Proposed Standard | October 2025 |
| 9843 | IGP Flexible Algorithms: Bandwidth, Delay, Metrics, and ConstraintsS. Hegde, W. Britto, R. Shetty, B. Decraene, P. Psenak, T. Li | Proposed Standard | September 2025 |
| 9692 | RIFT: Routing in Fat TreesT. Przygienda, Ed., J. Head, Ed., A. Sharma, P. Thubert, B. Rijsman, D. Afanasiev | Proposed Standard | April 2025 |
| 9666 | Area Proxy for IS-IST. Li, S. Chen, V. Ilangovan, G. Mishra | Experimental | October 2024 |
| 9658 | Multipoint LDP Extensions for Multi-Topology RoutingIJ. Wijnands, M. Mishra, Ed., K. Raza, Z. Zhang, A. Gulko | Proposed Standard | October 2024 |
| 9552 | Distribution of Link-State and Traffic Engineering Information Using BGPK. Talaulikar, Ed. | Proposed Standard | December 2023 |
| 9502 | IGP Flexible Algorithm in IP NetworksW. Britto, S. Hegde, P. Kaneriya, R. Shetty, R. Bonica, P. Psenak | Proposed Standard | November 2023 |
| 9352 | IS-IS Extensions to Support Segment Routing over the IPv6 Data PlaneP. Psenak, Ed., C. Filsfils, A. Bashandy, B. Decraene, Z. Hu | Proposed Standard | February 2023 |
| 9130 | YANG Data Model for the IS-IS ProtocolS. Litkowski, Ed., D. Yeung, A. Lindem, J. Zhang, L. Lhotka | Proposed Standard | October 2022 |
| 9085 | Border Gateway Protocol - Link State (BGP-LS) Extensions for Segment RoutingS. Previdi, K. Talaulikar, Ed., C. Filsfils, H. Gredler, M. Chen | Proposed Standard | August 2021 |
| 8939 | Deterministic Networking (DetNet) Data Plane: IPB. Varga, Ed., J. Farkas, L. Berger, D. Fedyk, S. Bryant | Proposed Standard | November 2020 |
| 8667 | IS-IS Extensions for Segment RoutingS. Previdi, Ed., L. Ginsberg, Ed., C. Filsfils, A. Bashandy, H. Gredler, B. Decraene | Proposed Standard | December 2019 |
| 8570 | IS-IS Traffic Engineering (TE) Metric ExtensionsL. Ginsberg, Ed., S. Previdi, Ed., S. Giacalone, D. Ward, J. Drake, Q. Wu | Proposed Standard | March 2019 |
| 8518 | Selection of Loop-Free Alternates for Multi-Homed PrefixesP. Sarkar, Ed., U. Chunduri, Ed., S. Hegde, J. Tantsura, H. Gredler | Proposed Standard | March 2019 |
| 8500 | IS-IS Routing with Reverse MetricN. Shen, S. Amante, M. Abrahamsson | Proposed Standard | February 2019 |
| 8430 | RIB Information ModelN. Bahadur, Ed., S. Kini, Ed., J. Medved | Informational | September 2018 |
| 8402 | Segment Routing ArchitectureC. Filsfils, Ed., S. Previdi, Ed., L. Ginsberg, B. Decraene, S. Litkowski, R. Shakir | Proposed Standard | July 2018 |
| 8401 | Bit Index Explicit Replication (BIER) Support via IS-ISL. Ginsberg, Ed., T. Przygienda, S. Aldrin, Z. Zhang | Proposed Standard | June 2018 |
| 8377 | Transparent Interconnection of Lots of Links (TRILL): Multi-TopologyD. Eastlake 3rd, M. Zhang, A. Banerjee | Proposed Standard | July 2018 |
| 8202 | IS-IS Multi-InstanceL. Ginsberg, S. Previdi, W. Henderickx | Proposed Standard | June 2017 |
| 7961 | Transparent Interconnection of Lots of Links (TRILL): Interface Addresses APPsub-TLVD. Eastlake 3rd, L. Yizhou | Proposed Standard | August 2016 |
| 7917 | Advertising Node Administrative Tags in IS-ISP. Sarkar, Ed., H. Gredler, S. Hegde, S. Litkowski, B. Decraene | Proposed Standard | July 2016 |
| 7810 | IS-IS Traffic Engineering (TE) Metric ExtensionsS. Previdi, Ed., S. Giacalone, D. Ward, J. Drake, Q. Wu · obsoleted by RFC 8570 | Proposed Standard | May 2016 |
| 7794 | IS-IS Prefix Attributes for Extended IPv4 and IPv6 ReachabilityL. Ginsberg, Ed., B. Decraene, S. Previdi, X. Xu, U. Chunduri | Proposed Standard | March 2016 |
| 7775 | IS-IS Route Preference for Extended IP and IPv6 ReachabilityL. Ginsberg, S. Litkowski, S. Previdi | Proposed Standard | February 2016 |
| 7752 | North-Bound Distribution of Link-State and Traffic Engineering (TE) Information Using BGPH. Gredler, Ed., J. Medved, S. Previdi, A. Farrel, S. Ray · obsoleted by RFC 9552 | Proposed Standard | March 2016 |
| 7297 | IP Connectivity Provisioning Profile (CPP)M. Boucadair, C. Jacquenet, N. Wang | Informational | July 2014 |
| 7177 | Transparent Interconnection of Lots of Links (TRILL): AdjacencyD. Eastlake 3rd, R. Perlman, A. Ghanwani, H. Yang, V. Manral | Proposed Standard | May 2014 |
| 7176 | Transparent Interconnection of Lots of Links (TRILL) Use of IS-ISD. Eastlake 3rd, T. Senevirathne, A. Ghanwani, D. Dutt, A. Banerjee | Proposed Standard | May 2014 |
| 6822 | IS-IS Multi-InstanceS. Previdi, Ed., L. Ginsberg, M. Shand, A. Roy, D. Ward · obsoleted by RFC 8202 | Proposed Standard | December 2012 |
| 6550 | RPL: IPv6 Routing Protocol for Low-Power and Lossy NetworksT. Winter, Ed., P. Thubert, Ed., A. Brandt, J. Hui, R. Kelsey, P. Levis, K. Pister, R. Struik, JP. Vasseur, R. Alexander | Proposed Standard | March 2012 |
| 6420 | PIM Multi-Topology ID (MT-ID) Join AttributeY. Cai, H. Ou | Proposed Standard | November 2011 |
| 6329 | IS-IS Extensions Supporting IEEE 802.1aq Shortest Path BridgingD. Fedyk, Ed., P. Ashwood-Smith, Ed., D. Allan, A. Bragg, P. Unbehagen | Proposed Standard | April 2012 |
| 6213 | IS-IS BFD-Enabled TLVC. Hopps, L. Ginsberg | Proposed Standard | April 2011 |
| 5330 | A Link-Type sub-TLV to Convey the Number of Traffic Engineering Label Switched Paths Signalled with Zero Reserved Bandwidth across a LinkJP. Vasseur, Ed., M. Meyer, K. Kumaki, A. Bonda | Proposed Standard | October 2008 |
| 5311 | Simplified Extension of Link State PDU (LSP) Space for IS-ISD. McPherson, Ed., L. Ginsberg, S. Previdi, M. Shand | Proposed Standard | February 2009 |
| 5286 | Basic Specification for IP Fast Reroute: Loop-Free AlternatesA. Atlas, Ed., A. Zinin, Ed. | Proposed Standard | September 2008 |
| 5130 | A Policy Control Mechanism in IS-IS Using Administrative TagsS. Previdi, M. Shand, Ed., C. Martin | Proposed Standard | February 2008 |