| 10032 | The AEGIS Authenticated Encryption AlgorithmsF. Denis, S. Lucas | Informational | September 2026 |
| 9846 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla | Proposed Standard | July 2026 |
| 9771 | Properties of Authenticated Encryption with Associated Data (AEAD) AlgorithmsA. Bozhko, Ed. | Informational | May 2025 |
| 9750 | The Messaging Layer Security (MLS) ArchitectureB. Beurdouche, E. Rescorla, E. Omara, S. Inguva, A. Duric | Informational | April 2025 |
| 9605 | Secure Frame (SFrame): Lightweight Authenticated Encryption for Real-Time MediaE. Omara, J. Uberti, S. G. Murillo, R. Barnes, Ed., Y. Fablet | Proposed Standard | August 2024 |
| 9528 | Ephemeral Diffie-Hellman Over COSE (EDHOC)G. Selander, J. Preuß Mattsson, F. Palombini | Proposed Standard | March 2024 |
| 9459 | CBOR Object Signing and Encryption (COSE): AES-CTR and AES-CBCR. Housley, H. Tschofenig | Proposed Standard | September 2023 |
| 9420 | The Messaging Layer Security (MLS) ProtocolR. Barnes, B. Beurdouche, R. Robert, J. Millican, E. Omara, K. Cohn-Gordon | Proposed Standard | July 2023 |
| 9325 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, P. Saint-Andre, T. Fossati | Best Current Practice | November 2022 |
| 9206 | Commercial National Security Algorithm (CNSA) Suite Cryptography for Internet Protocol Security (IPsec)L. Corcoran, M. Jenkins | Informational | March 2022 |
| 9180 | Hybrid Public Key EncryptionR. Barnes, K. Bhargavan, B. Lipp, C. Wood | Informational | February 2022 |
| 9145 | Integrity Protection for the Network Service Header (NSH) and Encryption of Sensitive Context HeadersM. Boucadair, T. Reddy.K, D. Wing | Proposed Standard | December 2021 |
| 9053 | CBOR Object Signing and Encryption (COSE): Initial AlgorithmsJ. Schaad | Informational | August 2022 |
| 9052 | CBOR Object Signing and Encryption (COSE): Structures and ProcessJ. Schaad | Internet Standard | August 2022 |
| 9001 | Using TLS to Secure QUICM. Thomson, Ed., S. Turner, Ed. | Proposed Standard | May 2021 |
| 9000 | QUIC: A UDP-Based Multiplexed and Secure TransportJ. Iyengar, Ed., M. Thomson, Ed. | Proposed Standard | May 2021 |
| 8999 | Version-Independent Properties of QUICM. Thomson | Proposed Standard | May 2021 |
| 8998 | ShangMi (SM) Cipher Suites for TLS 1.3P. Yang | Informational | March 2021 |
| 8915 | Network Time Security for the Network Time ProtocolD. Franke, D. Sibold, K. Teichel, M. Dansarie, R. Sundblad | Proposed Standard | September 2020 |
| 8824 | Static Context Header Compression (SCHC) for the Constrained Application Protocol (CoAP)A. Minaburo, L. Toutain, R. Andreasen | Proposed Standard | June 2021 |
| 8613 | Object Security for Constrained RESTful Environments (OSCORE)G. Selander, J. Mattsson, F. Palombini, L. Seitz | Proposed Standard | July 2019 |
| 8548 | Cryptographic Protection of TCP Streams (tcpcrypt)A. Bittau, D. Giffin, M. Handley, D. Mazieres, Q. Slack, E. Smith | Experimental | May 2019 |
| 8547 | TCP-ENO: Encryption Negotiation OptionA. Bittau, D. Giffin, M. Handley, D. Mazieres, E. Smith | Experimental | May 2019 |
| 8452 | AES-GCM-SIV: Nonce Misuse-Resistant Authenticated EncryptionS. Gueron, A. Langley, Y. Lindell | Informational | April 2019 |
| 8449 | Record Size Limit Extension for TLSM. Thomson | Proposed Standard | August 2018 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8442 | ECDHE_PSK with AES-GCM and AES-CCM Cipher Suites for TLS 1.2 and DTLS 1.2J. Mattsson, D. Migault | Proposed Standard | September 2018 |
| 8439 | ChaCha20 and Poly1305 for IETF ProtocolsY. Nir, A. Langley | Informational | June 2018 |
| 8269 | The ARIA Algorithm and Its Use with the Secure Real-Time Transport Protocol (SRTP)W. Kim, J. Lee, J. Park, D. Kwon, D. Kim | Informational | October 2017 |
| 8188 | Encrypted Content-Encoding for HTTPM. Thomson | Proposed Standard | June 2017 |
| 8152 | CBOR Object Signing and Encryption (COSE)J. Schaad · obsoleted by RFC 9052, RFC 9053 | Proposed Standard | July 2017 |
| 8103 | Using ChaCha20-Poly1305 Authenticated Encryption in the Cryptographic Message Syntax (CMS)R. Housley | Proposed Standard | February 2017 |
| 8061 | Locator/ID Separation Protocol (LISP) Data-Plane ConfidentialityD. Farinacci, B. Weis | Experimental | February 2017 |
| 7925 | Transport Layer Security (TLS) / Datagram Transport Layer Security (DTLS) Profiles for the Internet of ThingsH. Tschofenig, Ed., T. Fossati | Proposed Standard | July 2016 |
| 7905 | ChaCha20-Poly1305 Cipher Suites for Transport Layer Security (TLS)A. Langley, W. Chang, N. Mavrogiannopoulos, J. Strombergson, S. Josefsson | Proposed Standard | June 2016 |
| 7733 | Applicability Statement: The Use of the Routing Protocol for Low-Power and Lossy Networks (RPL) Protocol Suite in Home Automation and Building ControlA. Brandt, E. Baccelli, R. Cragie, P. van der Stok | Proposed Standard | February 2016 |
| 7714 | AES-GCM Authenticated Encryption in the Secure Real-time Transport Protocol (SRTP)D. McGrew, K. Igoe | Proposed Standard | December 2015 |
| 7696 | Guidelines for Cryptographic Algorithm Agility and Selecting Mandatory-to-Implement AlgorithmsR. Housley | Best Current Practice | November 2015 |
| 7635 | Session Traversal Utilities for NAT (STUN) Extension for Third-Party AuthorizationT. Reddy, P. Patil, R. Ravindranath, J. Uberti | Proposed Standard | August 2015 |
| 7606 | Revised Error Handling for BGP UPDATE MessagesE. Chen, Ed., J. Scudder, Ed., P. Mohapatra, K. Patel | Proposed Standard | August 2015 |
| 7539 | ChaCha20 and Poly1305 for IETF ProtocolsY. Nir, A. Langley · obsoleted by RFC 8439 | Informational | May 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7518 | JSON Web Algorithms (JWA)M. Jones | Proposed Standard | May 2015 |
| 7321 | Cryptographic Algorithm Implementation Requirements and Usage Guidance for Encapsulating Security Payload (ESP) and Authentication Header (AH)D. McGrew, P. Hoffman · obsoleted by RFC 8221 | Proposed Standard | August 2014 |
| 7253 | The OCB Authenticated-Encryption AlgorithmT. Krovetz, P. Rogaway | Informational | May 2014 |
| 7251 | AES-CCM Elliptic Curve Cryptography (ECC) Cipher Suites for TLSD. McGrew, D. Bailey, M. Campagna, R. Dugal | Informational | June 2014 |
| 6655 | AES-CCM Cipher Suites for Transport Layer Security (TLS)D. McGrew, D. Bailey | Proposed Standard | July 2012 |
| 6367 | Addition of the Camellia Cipher Suites to Transport Layer Security (TLS)S. Kanno, M. Kanda | Informational | September 2011 |
| 6209 | Addition of the ARIA Cipher Suites to Transport Layer Security (TLS)W. Kim, J. Lee, J. Park, D. Kwon | Informational | April 2011 |
| 6054 | Using Counter Modes with Encapsulating Security Payload (ESP) and Authentication Header (AH) to Protect Group TrafficD. McGrew, B. Weis | Proposed Standard | November 2010 |
| 5647 | AES Galois Counter Mode for the Secure Shell Transport Layer ProtocolK. Igoe, J. Solinas | Informational | August 2009 |
| 5487 | Pre-Shared Key Cipher Suites for TLS with SHA-256/384 and AES Galois Counter ModeM. Badra | Proposed Standard | March 2009 |
| 5297 | Synthetic Initialization Vector (SIV) Authenticated Encryption Using the Advanced Encryption Standard (AES)D. Harkins | Informational | October 2008 |
| 5289 | TLS Elliptic Curve Cipher Suites with SHA-256/384 and AES Galois Counter Mode (GCM)E. Rescorla | Proposed Standard | August 2008 |
| 5288 | AES Galois Counter Mode (GCM) Cipher Suites for TLSJ. Salowey, A. Choudhury, D. McGrew | Proposed Standard | August 2008 |
| 5282 | Using Authenticated Encryption Algorithms with the Encrypted Payload of the Internet Key Exchange version 2 (IKEv2) ProtocolD. Black, D. McGrew | Proposed Standard | August 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |