| 2488 | Enhancing TCP Over Satellite Channels using Standard MechanismsM. Allman, D. Glover, L. Sanchez | Best Current Practice | January 1999 |
| 2581 | TCP Congestion ControlM. Allman, V. Paxson, W. Stevens · obsoleted by RFC 5681 | Proposed Standard | April 1999 |
| 2914 | Congestion Control PrinciplesS. Floyd | Best Current Practice | September 2000 |
| 2960 | Stream Control Transmission ProtocolR. Stewart, Q. Xie, K. Morneault, C. Sharp, H. Schwarzbauer, T. Taylor, I. Rytina, M. Kalla, L. Zhang, V. Paxson · obsoleted by RFC 4960 | Proposed Standard | October 2000 |
| 2988 | Computing TCP's Retransmission TimerV. Paxson, M. Allman · obsoleted by RFC 6298 | Proposed Standard | November 2000 |
| 3150 | End-to-end Performance Implications of Slow LinksS. Dawkins, G. Montenegro, M. Kojo, V. Magret | Best Current Practice | July 2001 |
| 3155 | End-to-end Performance Implications of Links with ErrorsS. Dawkins, G. Montenegro, M. Kojo, V. Magret, N. Vaidya | Best Current Practice | August 2001 |
| 3649 | HighSpeed TCP for Large Congestion WindowsS. Floyd | Experimental | December 2003 |
| 3714 | IAB Concerns Regarding Congestion Control for Voice Traffic in the InternetS. Floyd, Ed., J. Kempf, Ed. | Informational | March 2004 |
| 3819 | Advice for Internet Subnetwork DesignersP. Karn, Ed., C. Bormann, G. Fairhurst, D. Grossman, R. Ludwig, J. Mahdavi, G. Montenegro, J. Touch, L. Wood | Best Current Practice | July 2004 |
| 4340 | Datagram Congestion Control Protocol (DCCP)E. Kohler, M. Handley, S. Floyd | Proposed Standard | March 2006 |
| 4653 | Improving the Robustness of TCP to Non-Congestion EventsS. Bhandarkar, A. L. N. Reddy, M. Allman, E. Blanton | Experimental | August 2006 |
| 4782 | Quick-Start for TCP and IPS. Floyd, M. Allman, A. Jain, P. Sarolahti | Experimental | January 2007 |