| 9955 | Hybrid Signature SpectrumsN. Bindel, B. Hale, D. Connolly, F. Driscoll | Informational | July 2026 |
| 9943 | An Architecture for Trustworthy and Transparent Digital Supply ChainsH. Birkholz, A. Delignat-Lavaud, C. Fournet, Y. Deshpande, S. Lasker | Proposed Standard | June 2026 |
| 9930 | Tunnel Extensible Authentication Protocol (TEAP) Version 1A. DeKok, Ed. | Proposed Standard | February 2026 |
| 9802 | Use of the HSS and XMSS Hash-Based Signature Algorithms in Internet X.509 Public Key InfrastructureD. Van Geest, K. Bashiri, S. Fluhrer, S. Gazdag, S. Kousidis | Proposed Standard | June 2025 |
| 9794 | Terminology for Post-Quantum Traditional Hybrid SchemesF. Driscoll, M. Parsons, B. Hale | Informational | June 2025 |
| 9781 | A Concise Binary Object Representation (CBOR) Tag for Unprotected CBOR Web Token Claims Sets (UCCS)H. Birkholz, J. O'Donoghue, N. Cam-Winget, C. Bormann | Proposed Standard | May 2025 |
| 9711 | The Entity Attestation Token (EAT)L. Lundblade, G. Mandyam, J. O'Donoghue, C. Wallace | Proposed Standard | April 2025 |
| 9675 | Delay-Tolerant Networking Management Architecture (DTNMA)E. Birrane, III, S. Heiner, E. Annis | Informational | November 2024 |
| 9620 | Guidelines for Human Rights Protocol and Architecture ConsiderationsG. Grover, N. ten Oever | Informational | September 2024 |
| 9560 | Federated Authentication for the Registration Data Access Protocol (RDAP) Using OpenID ConnectS. Hollenbeck | Proposed Standard | April 2024 |
| 9525 | Service Identity in TLSP. Saint-Andre, R. Salz | Proposed Standard | November 2023 |
| 9449 | OAuth 2.0 Demonstrating Proof of Possession (DPoP)D. Fett, B. Campbell, J. Bradley, T. Lodderstedt, M. Jones, D. Waite | Proposed Standard | September 2023 |
| 9431 | Message Queuing Telemetry Transport (MQTT) and Transport Layer Security (TLS) Profile of Authentication and Authorization for Constrained Environments (ACE) FrameworkC. Sengul, A. Kirby | Proposed Standard | July 2023 |
| 9397 | Trusted Execution Environment Provisioning (TEEP) ArchitectureM. Pei, H. Tschofenig, D. Thaler, D. Wheeler | Informational | July 2023 |
| 9334 | Remote ATtestation procedureS (RATS) ArchitectureH. Birkholz, D. Thaler, M. Richardson, N. Smith, W. Pan | Informational | January 2023 |
| 9325 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, P. Saint-Andre, T. Fossati | Best Current Practice | November 2022 |
| 9237 | An Authorization Information Format (AIF) for Authentication and Authorization for Constrained Environments (ACE)C. Bormann | Proposed Standard | August 2022 |
| 9203 | The Object Security for Constrained RESTful Environments (OSCORE) Profile of the Authentication and Authorization for Constrained Environments (ACE) FrameworkF. Palombini, L. Seitz, G. Selander, M. Gunnarsson | Proposed Standard | August 2022 |
| 9200 | Authentication and Authorization for Constrained Environments Using the OAuth 2.0 Framework (ACE-OAuth)L. Seitz, G. Selander, E. Wahlstroem, S. Erdtman, H. Tschofenig | Proposed Standard | August 2022 |
| 9153 | Drone Remote Identification Protocol (DRIP) Requirements and TerminologyS. Card, Ed., A. Wiethuechter, R. Moskowitz, A. Gurtov | Informational | February 2022 |
| 9118 | Enhanced JSON Web Token (JWT) Claim Constraints for Secure Telephone Identity Revisited (STIR) CertificatesR. Housley | Proposed Standard | August 2021 |
| 9066 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Call HomeT. Reddy.K, M. Boucadair, Ed., J. Shallow | Proposed Standard | December 2021 |
| 9052 | CBOR Object Signing and Encryption (COSE): Structures and ProcessJ. Schaad | Internet Standard | August 2022 |
| 8953 | Coordinating Attack Response at Internet Scale 2 (CARIS2) Workshop ReportK. Moriarty | Informational | December 2020 |
| 8793 | Information-Centric Networking (ICN): Content-Centric Networking (CCNx) and Named Data Networking (NDN) TerminologyB. Wissingh, C. Wood, A. Afanasyev, L. Zhang, D. Oran, C. Tschudin | Informational | June 2020 |
| 8612 | DDoS Open Threat Signaling (DOTS) RequirementsA. Mortensen, T. Reddy, R. Moskowitz | Informational | May 2019 |
| 8551 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Message SpecificationJ. Schaad, B. Ramsdell, S. Turner | Proposed Standard | April 2019 |
| 8295 | EST (Enrollment over Secure Transport) ExtensionsS. Turner | Proposed Standard | January 2018 |
| 8280 | Research into Human Rights Protocol ConsiderationsN. ten Oever, C. Cath | Informational | October 2017 |
| 8241 | Interface to the Routing System (I2RS) Security-Related RequirementsS. Hares, D. Migault, J. Halpern | Informational | September 2017 |
| 8176 | Authentication Method Reference ValuesM. Jones, P. Hunt, A. Nadalin | Proposed Standard | June 2017 |
| 8165 | Design Considerations for Metadata InsertionT. Hardie | Informational | May 2017 |
| 8152 | CBOR Object Signing and Encryption (COSE)J. Schaad · obsoleted by RFC 9052, RFC 9053 | Proposed Standard | July 2017 |
| 7985 | Security Threats to Simplified Multicast Forwarding (SMF)J. Yi, T. Clausen, U. Herberg | Informational | November 2016 |
| 7877 | Session Peering Provisioning Framework (SPPF)K. Cartwright, V. Bhatia, S. Ali, D. Schwartz | Proposed Standard | August 2016 |
| 7862 | Network File System (NFS) Version 4 Minor Version 2 ProtocolT. Haynes | Proposed Standard | November 2016 |
| 7861 | Remote Procedure Call (RPC) Security Version 3A. Adamson, N. Williams | Proposed Standard | November 2016 |
| 7804 | Salted Challenge Response HTTP Authentication MechanismA. Melnikov | Experimental | March 2016 |
| 7754 | Technical Considerations for Internet Service Blocking and FilteringR. Barnes, A. Cooper, O. Kolkman, D. Thaler, E. Nordmark | Informational | March 2016 |
| 7712 | Domain Name Associations (DNA) in the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre, M. Miller, P. Hancke | Proposed Standard | November 2015 |
| 7672 | SMTP Security via Opportunistic DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS)V. Dukhovni, W. Hardaker | Proposed Standard | October 2015 |
| 7624 | Confidentiality in the Face of Pervasive Surveillance: A Threat Model and Problem StatementR. Barnes, B. Schneier, C. Jennings, T. Hardie, B. Trammell, C. Huitema, D. Borkmann | Informational | August 2015 |
| 7590 | Use of Transport Layer Security (TLS) in the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre, T. Alkemade | Proposed Standard | June 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7519 | JSON Web Token (JWT)M. Jones, J. Bradley, N. Sakimura | Proposed Standard | May 2015 |
| 7518 | JSON Web Algorithms (JWA)M. Jones | Proposed Standard | May 2015 |
| 7517 | JSON Web Key (JWK)M. Jones | Proposed Standard | May 2015 |
| 7516 | JSON Web Encryption (JWE)M. Jones, J. Hildebrand | Proposed Standard | May 2015 |
| 7515 | JSON Web Signature (JWS)M. Jones, J. Bradley, N. Sakimura | Proposed Standard | May 2015 |
| 7489 | Domain-based Message Authentication, Reporting, and Conformance (DMARC)M. Kucherawy, Ed., E. Zwicky, Ed. · obsoleted by RFC 9989, RFC 9990, RFC 9991 | Informational | March 2015 |
| 7481 | Security Services for the Registration Data Access Protocol (RDAP)S. Hollenbeck, N. Kong | Internet Standard | March 2015 |
| 7435 | Opportunistic Security: Some Protection Most of the TimeV. Dukhovni | Informational | December 2014 |
| 7416 | A Security Threat Analysis for the Routing Protocol for Low-Power and Lossy Networks (RPLs)T. Tsao, R. Alexander, M. Dohler, V. Daza, A. Lozano, M. Richardson, Ed. | Informational | January 2015 |
| 7397 | Report from the Smart Object Security WorkshopJ. Gilger, H. Tschofenig | Informational | December 2014 |
| 7321 | Cryptographic Algorithm Implementation Requirements and Usage Guidance for Encapsulating Security Payload (ESP) and Authentication Header (AH)D. McGrew, P. Hoffman · obsoleted by RFC 8221 | Proposed Standard | August 2014 |
| 7288 | Reflections on Host FirewallsD. Thaler | Informational | June 2014 |
| 7258 | Pervasive Monitoring Is an AttackS. Farrell, H. Tschofenig | Best Current Practice | May 2014 |
| 7204 | Requirements for Labeled NFST. Haynes | Informational | April 2014 |
| 7201 | Options for Securing RTP SessionsM. Westerlund, C. Perkins | Informational | April 2014 |
| 7186 | Security Threats for the Neighborhood Discovery Protocol (NHDP)J. Yi, U. Herberg, T. Clausen | Informational | April 2014 |
| 7165 | Use Cases and Requirements for JSON Object Signing and Encryption (JOSE)R. Barnes | Informational | April 2014 |
| 7126 | Recommendations on Filtering of IPv4 Packets Containing IPv4 OptionsF. Gont, R. Atkinson, C. Pignataro | Best Current Practice | February 2014 |
| 6973 | Privacy Considerations for Internet ProtocolsA. Cooper, H. Tschofenig, B. Aboba, J. Peterson, J. Morris, M. Hansen, R. Smith | Informational | July 2013 |
| 6943 | Issues in Identifier Comparison for Security PurposesD. Thaler, Ed. | Informational | May 2013 |
| 6862 | Keying and Authentication for Routing Protocols (KARP) Overview, Threats, and RequirementsG. Lebovitz, M. Bhatia, B. Weis | Informational | March 2013 |
| 6797 | HTTP Strict Transport Security (HSTS)J. Hodges, C. Jackson, A. Barth | Proposed Standard | November 2012 |
| 6781 | DNSSEC Operational Practices, Version 2O. Kolkman, W. Mekking, R. Gieben | Informational | December 2012 |
| 6749 | The OAuth 2.0 Authorization FrameworkD. Hardt, Ed. | Proposed Standard | October 2012 |
| 6711 | An IANA Registry for Level of Assurance (LoA) ProfilesL. Johansson | Informational | August 2012 |
| 6341 | Use Cases and Requirements for SIP-Based Media Recording (SIPREC)K. Rehor, Ed., L. Portman, Ed., A. Hutton, R. Jain | Informational | August 2011 |
| 6280 | An Architecture for Location and Location Privacy in Internet ApplicationsR. Barnes, M. Lepinski, A. Cooper, J. Morris, H. Tschofenig, H. Schulzrinne | Best Current Practice | July 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6120 | Extensible Messaging and Presence Protocol (XMPP): CoreP. Saint-Andre | Proposed Standard | March 2011 |
| 6092 | Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet ServiceJ. Woodyatt, Ed. | Informational | January 2011 |
| 6029 | A Survey on Research on the Application-Layer Traffic Optimization (ALTO) ProblemI. Rimac, V. Hilt, M. Tomsu, V. Gurbani, E. Marocco | Informational | October 2010 |
| 5802 | Salted Challenge Response Authentication Mechanism (SCRAM) SASL and GSS-API MechanismsC. Newman, A. Menon-Sen, A. Melnikov, N. Williams | Proposed Standard | July 2010 |
| 5479 | Requirements and Analysis of Media Security Management ProtocolsD. Wing, Ed., S. Fries, H. Tschofenig, F. Audet | Informational | April 2009 |
| 5217 | Memorandum for Multi-Domain Public Key Infrastructure InteroperabilityM. Shimaoka, Ed., N. Hastings, R. Nielsen | Informational | July 2008 |
| 5197 | On the Applicability of Various Multimedia Internet KEYing (MIKEY) Modes and ExtensionsS. Fries, D. Ignjatic | Informational | June 2008 |
| 5042 | Direct Data Placement Protocol (DDP) / Remote Direct Memory Access Protocol (RDMAP) SecurityJ. Pinkerton, E. Deleganes | Proposed Standard | October 2007 |