| 1958 | Architectural Principles of the InternetB. Carpenter, Ed. | Informational | June 1996 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |
| 2597 | Assured Forwarding PHB GroupJ. Heinanen, F. Baker, W. Weiss, J. Wroclawski | Proposed Standard | June 1999 |
| 2747 | RSVP Cryptographic AuthenticationF. Baker, B. Lindell, M. Talwar | Proposed Standard | January 2000 |
| 2775 | Internet TransparencyB. Carpenter | Informational | February 2000 |
| 2826 | IAB Technical Comment on the Unique DNS RootInternet Architecture Board | Informational | May 2000 |
| 3182 | Identity Representation for RSVPS. Yadav, R. Yavatkar, R. Pabbati, P. Ford, T. Moore, S. Herzog, R. Hess | Proposed Standard | October 2001 |
| 3246 | An Expedited Forwarding PHB (Per-Hop Behavior)B. Davie, A. Charny, J.C.R. Bennet, K. Benson, J.Y. Le Boudec, W. Courtney, S. Davari, V. Firoiu, D. Stiliadis | Proposed Standard | March 2002 |
| 3489 | STUN - Simple Traversal of User Datagram Protocol (UDP) Through Network Address Translators (NATs)J. Rosenberg, J. Weinberger, C. Huitema, R. Mahy · obsoleted by RFC 5389 | Proposed Standard | March 2003 |
| 3633 | IPv6 Prefix Options for Dynamic Host Configuration Protocol (DHCP) version 6O. Troan, R. Droms · obsoleted by RFC 8415 | Proposed Standard | December 2003 |
| 3662 | A Lower Effort Per-Domain Behavior (PDB) for Differentiated ServicesR. Bless, K. Nichols, K. Wehrle · obsoleted by RFC 8622 | Informational | December 2003 |
| 3724 | The Rise of the Middle and the Future of End-to-End: Reflections on the Evolution of the Internet ArchitectureJ. Kempf, Ed., R. Austein, Ed., IAB | Informational | March 2004 |
| 3947 | Negotiation of NAT-Traversal in the IKET. Kivinen, B. Swander, A. Huttunen, V. Volpe | Proposed Standard | January 2005 |
| 4035 | Protocol Modifications for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4084 | Terminology for Describing Internet ConnectivityJ. Klensin | Best Current Practice | May 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4306 | Internet Key Exchange (IKEv2) ProtocolC. Kaufman, Ed. · obsoleted by RFC 5996 | Proposed Standard | December 2005 |
| 4380 | Teredo: Tunneling IPv6 over UDP through Network Address Translations (NATs)C. Huitema | Proposed Standard | February 2006 |
| 4592 | The Role of Wildcards in the Domain Name SystemE. Lewis | Proposed Standard | July 2006 |
| 4718 | IKEv2 Clarifications and Implementation GuidelinesP. Eronen, P. Hoffman · obsoleted by RFC 5996 | Informational | October 2006 |
| 4966 | Reasons to Move the Network Address Translator - Protocol Translator (NAT-PT) to Historic StatusC. Aoun, E. Davies | Informational | July 2007 |