| 816 | Fault isolation and recoveryD.D. Clark · obsoleted by RFC 7805 | Historic | July 1982 |
| 1058 | Routing Information ProtocolC.L. Hedrick | Historic | June 1988 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1131 | OSPF specificationJ. Moy · obsoleted by RFC 1247 | Proposed Standard | October 1989 |
| 1191 | Path MTU discoveryJ. Mogul, S. Deering | Draft Standard | November 1990 |
| 1256 | ICMP Router Discovery MessagesS. Deering, Ed. | Proposed Standard | September 1991 |
| 1305 | Network Time Protocol (Version 3) Specification, Implementation and AnalysisD. Mills · obsoleted by RFC 5905 | Historic | March 1992 |
| 1307 | Dynamically Switched Link Control ProtocolJ. Young, A. Nicholson | Experimental | March 1992 |
| 1661 | The Point-to-Point Protocol (PPP)W. Simpson, Ed. | Internet Standard | July 1994 |
| 1812 | Requirements for IP Version 4 RoutersF. Baker, Ed. | Proposed Standard | June 1995 |
| 1918 | Address Allocation for Private InternetsY. Rekhter, B. Moskowitz, D. Karrenberg, G. J. de Groot, E. Lear | Best Current Practice | February 1996 |
| 1981 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul · obsoleted by RFC 8201 | Draft Standard | August 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2131 | Dynamic Host Configuration ProtocolR. Droms | Draft Standard | March 1997 |
| 2328 | OSPF Version 2J. Moy | Internet Standard | April 1998 |
| 2461 | Neighbor Discovery for IP Version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson · obsoleted by RFC 4861 | Draft Standard | December 1998 |
| 2778 | A Model for Presence and Instant MessagingM. Day, J. Rosenberg, H. Sugano | Informational | February 2000 |
| 2861 | TCP Congestion Window ValidationM. Handley, J. Padhye, S. Floyd · obsoleted by RFC 7661 | Historic | June 2000 |
| 2914 | Congestion Control PrinciplesS. Floyd | Best Current Practice | September 2000 |
| 2923 | TCP Problems with Path MTU DiscoveryK. Lahey | Informational | September 2000 |
| 2960 | Stream Control Transmission ProtocolR. Stewart, Q. Xie, K. Morneault, C. Sharp, H. Schwarzbauer, T. Taylor, I. Rytina, M. Kalla, L. Zhang, V. Paxson · obsoleted by RFC 4960 | Proposed Standard | October 2000 |
| 3118 | Authentication for DHCP MessagesR. Droms, Ed., W. Arbaugh, Ed. | Proposed Standard | June 2001 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3366 | Advice to link designers on link Automatic Repeat reQuest (ARQ)G. Fairhurst, L. Wood | Best Current Practice | September 2002 |
| 3428 | Session Initiation Protocol (SIP) Extension for Instant MessagingB. Campbell, Ed., J. Rosenberg, H. Schulzrinne, C. Huitema, D. Gurle | Proposed Standard | December 2002 |
| 3748 | Extensible Authentication Protocol (EAP)B. Aboba, L. Blunk, J. Vollbrecht, J. Carlson, H. Levkowetz, Ed. | Proposed Standard | June 2004 |
| 3775 | Mobility Support in IPv6D. Johnson, C. Perkins, J. Arkko · obsoleted by RFC 6275 | Proposed Standard | June 2004 |
| 3921 | Extensible Messaging and Presence Protocol (XMPP): Instant Messaging and PresenceP. Saint-Andre, Ed. · obsoleted by RFC 6121 | Proposed Standard | October 2004 |
| 3927 | Dynamic Configuration of IPv4 Link-Local AddressesS. Cheshire, B. Aboba, E. Guttman | Proposed Standard | May 2005 |
| 3971 | SEcure Neighbor Discovery (SEND)J. Arkko, Ed., J. Kempf, B. Zill, P. Nikander | Proposed Standard | March 2005 |
| 4340 | Datagram Congestion Control Protocol (DCCP)E. Kohler, M. Handley, S. Floyd | Proposed Standard | March 2006 |
| 4423 | Host Identity Protocol (HIP) ArchitectureR. Moskowitz, P. Nikander · obsoleted by RFC 9063 | Informational | May 2006 |
| 4429 | Optimistic Duplicate Address Detection (DAD) for IPv6N. Moore | Proposed Standard | April 2006 |
| 4436 | Detecting Network Attachment in IPv4 (DNAv4)B. Aboba, J. Carlson, S. Cheshire | Proposed Standard | March 2006 |
| 4821 | Packetization Layer Path MTU DiscoveryM. Mathis, J. Heffner | Proposed Standard | March 2007 |