| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 925 | Multi-LAN address resolutionJ. Postel | Unknown | October 1984 |
| 950 | Internet Standard Subnetting ProcedureJ.C. Mogul, J. Postel | Internet Standard | August 1985 |
| 1001 | Protocol standard for a NetBIOS service on a TCP/UDP transport: Concepts and methodsNetBIOS Working Group in the Defense Advanced Research Projects Agency, Internet Activities Board, End-to-End Services Task Force | Internet Standard | March 1987 |
| 1027 | Using ARP to implement transparent subnet gatewaysS. Carl-Mitchell, J.S. Quarterman | Unknown | October 1987 |
| 1075 | Distance Vector Multicast Routing ProtocolD. Waitzman, C. Partridge, S.E. Deering | Experimental | November 1988 |
| 1812 | Requirements for IP Version 4 RoutersF. Baker, Ed. | Proposed Standard | June 1995 |
| 1884 | IP Version 6 Addressing ArchitectureR. Hinden, Ed., S. Deering, Ed. · obsoleted by RFC 2373 | Historic | December 1995 |
| 2080 | RIPng for IPv6G. Malkin, R. Minnear | Proposed Standard | January 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2131 | Dynamic Host Configuration ProtocolR. Droms | Draft Standard | March 1997 |
| 2328 | OSPF Version 2J. Moy | Internet Standard | April 1998 |
| 2373 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering · obsoleted by RFC 3513 | Proposed Standard | July 1998 |
| 2453 | RIP Version 2G. Malkin | Internet Standard | November 1998 |
| 2461 | Neighbor Discovery for IP Version 6 (IPv6)T. Narten, E. Nordmark, W. Simpson · obsoleted by RFC 4861 | Draft Standard | December 1998 |
| 2462 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten · obsoleted by RFC 4862 | Draft Standard | December 1998 |
| 2644 | Changing the Default for Directed Broadcasts in RoutersD. Senie | Best Current Practice | August 1999 |
| 3024 | Reverse Tunneling for Mobile IP, revisedG. Montenegro, Ed. | Proposed Standard | January 2001 |
| 3056 | Connection of IPv6 Domains via IPv4 CloudsB. Carpenter, K. Moore | Proposed Standard | February 2001 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3513 | Internet Protocol Version 6 (IPv6) Addressing ArchitectureR. Hinden, S. Deering · obsoleted by RFC 4291 | Proposed Standard | April 2003 |
| 3633 | IPv6 Prefix Options for Dynamic Host Configuration Protocol (DHCP) version 6O. Troan, R. Droms · obsoleted by RFC 8415 | Proposed Standard | December 2003 |
| 3753 | Mobility Related TerminologyJ. Manner, Ed., M. Kojo, Ed. | Informational | June 2004 |
| 3775 | Mobility Support in IPv6D. Johnson, C. Perkins, J. Arkko · obsoleted by RFC 6275 | Proposed Standard | June 2004 |
| 3810 | Multicast Listener Discovery Version 2 (MLDv2) for IPv6R. Vida, Ed., L. Costa, Ed. · obsoleted by RFC 9777 | Proposed Standard | June 2004 |
| 3927 | Dynamic Configuration of IPv4 Link-Local AddressesS. Cheshire, B. Aboba, E. Guttman | Proposed Standard | May 2005 |
| 3971 | SEcure Neighbor Discovery (SEND)J. Arkko, Ed., J. Kempf, B. Zill, P. Nikander | Proposed Standard | March 2005 |
| 4007 | IPv6 Scoped Address ArchitectureS. Deering, B. Haberman, T. Jinmei, E. Nordmark, B. Zill | Proposed Standard | March 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4380 | Teredo: Tunneling IPv6 over UDP through Network Address Translations (NATs)C. Huitema | Proposed Standard | February 2006 |
| 4389 | Neighbor Discovery Proxies (ND Proxy)D. Thaler, M. Talwar, C. Patel | Experimental | April 2006 |
| 4541 | Considerations for Internet Group Management Protocol (IGMP) and Multicast Listener Discovery (MLD) Snooping SwitchesM. Christensen, K. Kimball, F. Solensky | Informational | May 2006 |
| 4795 | Link-local Multicast Name Resolution (LLMNR)B. Aboba, D. Thaler, L. Esibov | Informational | January 2007 |