| 9580 | OpenPGPP. Wouters, Ed., D. Huigens, J. Winter, Y. Niibe | Proposed Standard | July 2024 |
| 9361 | ICANN Trademark Clearinghouse (TMCH) Functional SpecificationsG. Lozano | Informational | March 2023 |
| 9116 | A File Format to Aid in Security Vulnerability DisclosureE. Foudil, Y. Shafranovich | Informational | April 2022 |
| 8976 | Message Digest for DNS ZonesD. Wessels, P. Barber, M. Weinberg, W. Kumari, W. Hardaker | Proposed Standard | February 2021 |
| 8904 | DNS Whitelist (DNSWL) Email Authentication Method ExtensionA. Vesely | Informational | September 2020 |
| 8689 | SMTP Require TLS OptionJ. Fenton | Proposed Standard | November 2019 |
| 8315 | Cancel-Locks in Netnews ArticlesM. Baeuerle | Proposed Standard | February 2018 |
| 8188 | Encrypted Content-Encoding for HTTPM. Thomson | Proposed Standard | June 2017 |
| 8085 | UDP Usage GuidelinesL. Eggert, G. Fairhurst, G. Shepherd | Best Current Practice | March 2017 |
| 7958 | DNSSEC Trust Anchor Publication for the Root ZoneJ. Abley, J. Schlyter, G. Bailey, P. Hoffman · obsoleted by RFC 9718 | Informational | August 2016 |
| 7929 | DNS-Based Authentication of Named Entities (DANE) Bindings for OpenPGPP. Wouters | Experimental | August 2016 |
| 7681 | Email Exchange of Secondary School TranscriptsJ. Davin | Informational | October 2015 |
| 7468 | Textual Encodings of PKIX, PKCS, and CMS StructuresS. Josefsson, S. Leonard | Proposed Standard | April 2015 |
| 7208 | Sender Policy Framework (SPF) for Authorizing Use of Domains in Email, Version 1S. Kitterman | Proposed Standard | April 2014 |
| 7070 | An Architecture for Reputation ReportingN. Borenstein, M. Kucherawy | Proposed Standard | November 2013 |
| 6637 | Elliptic Curve Cryptography (ECC) in OpenPGPA. Jivsov · obsoleted by RFC 9580 | Proposed Standard | June 2012 |
| 6476 | Using Message Authentication Code (MAC) Encryption in the Cryptographic Message Syntax (CMS)P. Gutmann | Proposed Standard | January 2012 |
| 6409 | Message Submission for MailR. Gellens, J. Klensin | Internet Standard | November 2011 |
| 6376 | DomainKeys Identified Mail (DKIM) SignaturesD. Crocker, Ed., T. Hansen, Ed., M. Kucherawy, Ed. | Internet Standard | September 2011 |
| 6350 | vCard Format SpecificationS. Perreault | Proposed Standard | August 2011 |
| 6189 | ZRTP: Media Path Key Agreement for Unicast Secure RTPP. Zimmermann, A. Johnston, Ed., J. Callas | Informational | April 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6091 | Using OpenPGP Keys for Transport Layer Security (TLS) AuthenticationN. Mavrogiannopoulos, D. Gillmor | Informational | February 2011 |
| 5981 | Authorization for NSIS Signaling Layer ProtocolsJ. Manner, M. Stiemerling, H. Tschofenig, R. Bless, Ed. | Experimental | February 2011 |
| 5929 | Channel Bindings for TLSJ. Altman, N. Williams, L. Zhu | Proposed Standard | July 2010 |
| 5854 | The Metalink Download Description FormatA. Bryan, T. Tsujikawa, N. McNab, P. Poeml | Proposed Standard | June 2010 |
| 5848 | Signed Syslog MessagesJ. Kelsey, J. Callas, A. Clemm | Proposed Standard | May 2010 |
| 5703 | Sieve Email Filtering: MIME Part Tests, Iteration, Extraction, Replacement, and EnclosureT. Hansen, C. Daboo | Proposed Standard | October 2009 |
| 5598 | Internet Mail ArchitectureD. Crocker | Informational | July 2009 |
| 5585 | DomainKeys Identified Mail (DKIM) Service OverviewT. Hansen, D. Crocker, P. Hallam-Baker | Informational | July 2009 |
| 5581 | The Camellia Cipher in OpenPGPD. Shaw · obsoleted by RFC 9580 | Informational | June 2009 |
| 5405 | Unicast UDP Usage Guidelines for Application DesignersL. Eggert, G. Fairhurst · obsoleted by RFC 8085 | Best Current Practice | November 2008 |
| 5321 | Simple Mail Transfer ProtocolJ. Klensin | Draft Standard | October 2008 |
| 5081 | Using OpenPGP Keys for Transport Layer Security (TLS) AuthenticationN. Mavrogiannopoulos · obsoleted by RFC 6091 | Experimental | November 2007 |