| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2460 | Internet Protocol, Version 6 (IPv6) SpecificationS. Deering, R. Hinden · obsoleted by RFC 8200 | Draft Standard | December 1998 |
| 2545 | Use of BGP-4 Multiprotocol Extensions for IPv6 Inter-Domain RoutingP. Marques, F. Dupont | Proposed Standard | March 1999 |
| 3031 | Multiprotocol Label Switching ArchitectureE. Rosen, A. Viswanathan, R. Callon | Proposed Standard | January 2001 |
| 3032 | MPLS Label Stack EncodingE. Rosen, D. Tappan, G. Fedorkow, Y. Rekhter, D. Farinacci, T. Li, A. Conta | Proposed Standard | January 2001 |
| 3036 | LDP SpecificationL. Andersson, P. Doolan, N. Feldman, A. Fredette, B. Thomas · obsoleted by RFC 5036 | Proposed Standard | January 2001 |
| 3107 | Carrying Label Information in BGP-4Y. Rekhter, E. Rosen · obsoleted by RFC 8277 | Proposed Standard | May 2001 |
| 3270 | Multi-Protocol Label Switching (MPLS) Support of Differentiated ServicesF. Le Faucheur, Ed., L. Wu, B. Davie, S. Davari, P. Vaananen, R. Krishnan, P. Cheval, J. Heinanen | Proposed Standard | May 2002 |
| 4029 | Scenarios and Analysis for Introducing IPv6 into ISP NetworksM. Lind, V. Ksinant, S. Park, A. Baudot, P. Savola | Informational | March 2005 |
| 4182 | Removing a Restriction on the use of MPLS Explicit NULLE. Rosen | Proposed Standard | September 2005 |
| 4271 | A Border Gateway Protocol 4 (BGP-4)Y. Rekhter, Ed., T. Li, Ed., S. Hares, Ed. | Draft Standard | January 2006 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4364 | BGP/MPLS IP Virtual Private Networks (VPNs)E. Rosen, Y. Rekhter | Proposed Standard | February 2006 |
| 4443 | Internet Control Message Protocol (ICMPv6) for the Internet Protocol Version 6 (IPv6) SpecificationA. Conta, S. Deering, M. Gupta, Ed. | Internet Standard | March 2006 |
| 4659 | BGP-MPLS IP Virtual Private Network (VPN) Extension for IPv6 VPNJ. De Clercq, D. Ooms, M. Carugi, F. Le Faucheur | Proposed Standard | September 2006 |
| 4760 | Multiprotocol Extensions for BGP-4T. Bates, R. Chandra, D. Katz, Y. Rekhter | Draft Standard | January 2007 |