| 10054 | Computing-Aware Traffic Steering (CATS) Problem Statement, Use Cases, and RequirementsK. Yao, L. M. Contreras, H. Shi, S. Zhang, Q. An | Informational | October 2026 |
| 10039 | Interconnecting EVPN and IPVPN DomainsJ. Rabadan, Ed., A. Sajassi, Ed., J. Drake, W. Lin, J. Uttaro, A. Simpson | Proposed Standard | September 2026 |
| 9972 | Advanced BGP Monitoring Protocol (BMP) Statistics TypesM. Srivastava, Ed., Y. Liu, C. Lin, Ed., J. Li | Proposed Standard | May 2026 |
| 9871 | BGP Color-Aware Routing (CAR)D. Rao, Ed., S. Agrawal, Ed. | Experimental | November 2025 |
| 9832 | BGP Classful Transport PlanesK. Vairavakkalai, Ed., N. Venkataraman, Ed. | Experimental | September 2025 |
| 9830 | Advertising Segment Routing Policies in BGPS. Previdi, C. Filsfils, K. Talaulikar, Ed., P. Mattes, D. Jain | Proposed Standard | September 2025 |
| 9816 | Usage and Applicability of BGP Link State (BGP-LS) Shortest Path First (SPF) Routing in Data CentersK. Patel, A. Lindem, S. Zandi, G. Dawra, J. Dong | Informational | July 2025 |
| 9815 | BGP Link State (BGP-LS) Shortest Path First (SPF) RoutingK. Patel, A. Lindem, S. Zandi, W. Henderickx | Proposed Standard | July 2025 |
| 9793 | BGP Extensions for Bit Index Explicit Replication (BIER)X. Xu, M. Chen, K. Patel, IJ. Wijnands, T. Przygienda, Z. Zhang, Ed. | Proposed Standard | June 2025 |
| 9552 | Distribution of Link-State and Traffic Engineering Information Using BGPK. Talaulikar, Ed. | Proposed Standard | December 2023 |
| 9542 | IANA Considerations and IETF Protocol and Documentation Usage for IEEE 802 ParametersD. Eastlake 3rd, J. Abley, Y. Li | Best Current Practice | April 2024 |
| 9494 | Long-Lived Graceful Restart for BGPJ. Uttaro, E. Chen, B. Decraene, J. Scudder | Proposed Standard | November 2023 |
| 9489 | Label Switched Path (LSP) Ping Mechanisms for EVPN and Provider Backbone Bridging EVPN (PBB-EVPN)P. Jain, A. Sajassi, S. Salam, S. Boutros, G. Mirsky | Proposed Standard | November 2023 |
| 9469 | Applicability of Ethernet Virtual Private Network (EVPN) to Network Virtualization over Layer 3 (NVO3) NetworksJ. Rabadan, Ed., M. Bocci, S. Boutros, A. Sajassi | Informational | September 2023 |
| 9300 | The Locator/ID Separation Protocol (LISP)D. Farinacci, V. Fuller, D. Meyer, D. Lewis, A. Cabellos, Ed. | Proposed Standard | October 2022 |
| 9256 | Segment Routing Policy ArchitectureC. Filsfils, K. Talaulikar, Ed., D. Voyer, A. Bogdanov, P. Mattes | Proposed Standard | July 2022 |
| 9252 | BGP Overlay Services Based on Segment Routing over IPv6 (SRv6)G. Dawra, Ed., K. Talaulikar, Ed., R. Raszuk, B. Decraene, S. Zhuang, J. Rabadan | Proposed Standard | July 2022 |
| 9168 | Path Computation Element Communication Protocol (PCEP) Extension for Flow SpecificationD. Dhody, A. Farrel, Z. Li | Proposed Standard | January 2022 |
| 9125 | Gateway Auto-Discovery and Route Advertisement for Site Interconnection Using Segment RoutingA. Farrel, J. Drake, E. Rosen, K. Patel, L. Jalil | Proposed Standard | August 2021 |
| 9117 | Revised Validation Procedure for BGP Flow SpecificationsJ. Uttaro, J. Alcaide, C. Filsfils, D. Smith, P. Mohapatra | Proposed Standard | August 2021 |
| 9015 | BGP Control Plane for the Network Service Header in Service Function ChainingA. Farrel, J. Drake, E. Rosen, J. Uttaro, L. Jalil | Proposed Standard | June 2021 |
| 9012 | The BGP Tunnel Encapsulation AttributeK. Patel, G. Van de Velde, S. Sangli, J. Scudder | Proposed Standard | April 2021 |
| 8956 | Dissemination of Flow Specification Rules for IPv6C. Loibl, Ed., R. Raszuk, Ed., S. Hares, Ed. | Proposed Standard | December 2020 |
| 8955 | Dissemination of Flow Specification RulesC. Loibl, S. Hares, R. Raszuk, D. McPherson, M. Bacher | Proposed Standard | December 2020 |
| 8950 | Advertising IPv4 Network Layer Reachability Information (NLRI) with an IPv6 Next HopS. Litkowski, S. Agrawal, K. Ananthamurthy, K. Patel | Proposed Standard | November 2020 |
| 8669 | Segment Routing Prefix Segment Identifier Extensions for BGPS. Previdi, C. Filsfils, A. Lindem, Ed., A. Sreekantiah, H. Gredler | Proposed Standard | December 2019 |
| 8638 | IPv4 Multicast over an IPv6 Multicast in Softwire Mesh NetworksM. Xu, Y. Cui, J. Wu, S. Yang, C. Metz | Proposed Standard | September 2019 |
| 8522 | Looking Glass Command SetM. Stubbig | Informational | February 2019 |
| 8374 | BGPsec Design Choices and Summary of Supporting DiscussionsK. Sriram, Ed. | Informational | April 2018 |
| 8313 | Use of Multicast across Inter-domain Peering PointsP. Tarapore, Ed., R. Sayko, G. Shepherd, T. Eckert, Ed., R. Krishnan | Best Current Practice | January 2018 |
| 8299 | YANG Data Model for L3VPN Service DeliveryQ. Wu, Ed., S. Litkowski, L. Tomotaki, K. Ogaki | Proposed Standard | January 2018 |
| 8294 | Common YANG Data Types for the Routing AreaX. Liu, Y. Qu, A. Lindem, C. Hopps, L. Berger | Proposed Standard | December 2017 |
| 8277 | Using BGP to Bind MPLS Labels to Address PrefixesE. Rosen | Proposed Standard | October 2017 |
| 8205 | BGPsec Protocol SpecificationM. Lepinski, Ed., K. Sriram, Ed. | Proposed Standard | September 2017 |
| 8049 | YANG Data Model for L3VPN Service DeliveryS. Litkowski, L. Tomotaki, K. Ogaki · obsoleted by RFC 8299 | Proposed Standard | February 2017 |
| 7911 | Advertisement of Multiple Paths in BGPD. Walton, A. Retana, E. Chen, J. Scudder | Proposed Standard | July 2016 |
| 7761 | Protocol Independent Multicast - Sparse Mode (PIM-SM): Protocol Specification (Revised)B. Fenner, M. Handley, H. Holbrook, I. Kouvelas, R. Parekh, Z. Zhang, L. Zheng | Internet Standard | March 2016 |
| 7752 | North-Bound Distribution of Link-State and Traffic Engineering (TE) Information Using BGPH. Gredler, Ed., J. Medved, S. Previdi, A. Farrel, S. Ray · obsoleted by RFC 9552 | Proposed Standard | March 2016 |
| 7747 | Basic BGP Convergence Benchmarking Methodology for Data-Plane ConvergenceR. Papneja, B. Parise, S. Hares, D. Lee, I. Varlashkin | Informational | April 2016 |
| 7606 | Revised Error Handling for BGP UPDATE MessagesE. Chen, Ed., J. Scudder, Ed., P. Mohapatra, K. Patel | Proposed Standard | August 2015 |
| 7543 | Covering Prefixes Outbound Route Filter for BGP-4H. Jeng, L. Jalil, R. Bonica, K. Patel, L. Yong | Proposed Standard | May 2015 |
| 7524 | Inter-Area Point-to-Multipoint (P2MP) Segmented Label Switched Paths (LSPs)Y. Rekhter, E. Rosen, R. Aggarwal, T. Morin, I. Grosclaude, N. Leymann, S. Saad | Proposed Standard | May 2015 |
| 7432 | BGP MPLS-Based Ethernet VPNA. Sajassi, Ed., R. Aggarwal, N. Bitar, A. Isaac, J. Uttaro, J. Drake, W. Henderickx | Proposed Standard | February 2015 |
| 7297 | IP Connectivity Provisioning Profile (CPP)M. Boucadair, C. Jacquenet, N. Wang | Informational | July 2014 |
| 7267 | Dynamic Placement of Multi-Segment PseudowiresL. Martini, Ed., M. Bocci, Ed., F. Balus, Ed. | Proposed Standard | June 2014 |
| 7117 | Multicast in Virtual Private LAN Service (VPLS)R. Aggarwal, Ed., Y. Kamite, L. Fang, Y. Rekhter, C. Kodeboniya | Proposed Standard | February 2014 |
| 7042 | IANA Considerations and IETF Protocol and Documentation Usage for IEEE 802 ParametersD. Eastlake 3rd, J. Abley · obsoleted by RFC 9542 | Best Current Practice | October 2013 |
| 6883 | IPv6 Guidance for Internet Content Providers and Application Service ProvidersB. Carpenter, S. Jiang | Informational | March 2013 |
| 6836 | Locator/ID Separation Protocol Alternative Logical Topology (LISP+ALT)V. Fuller, D. Farinacci, D. Meyer, D. Lewis | Experimental | January 2013 |
| 6831 | The Locator/ID Separation Protocol (LISP) for Multicast EnvironmentsD. Farinacci, D. Meyer, J. Zwiebel, S. Venaas | Experimental | January 2013 |
| 6774 | Distribution of Diverse BGP PathsR. Raszuk, Ed., R. Fernando, K. Patel, D. McPherson, K. Kumaki | Informational | November 2012 |
| 6625 | Wildcards in Multicast VPN Auto-Discovery RoutesE. Rosen, Ed., Y. Rekhter, Ed., W. Hendrickx, R. Qiu | Proposed Standard | May 2012 |
| 6565 | OSPFv3 as a Provider Edge to Customer Edge (PE-CE) Routing ProtocolP. Pillay-Esnault, P. Moyer, J. Doyle, E. Ertekin, M. Lundberg | Proposed Standard | June 2012 |
| 6515 | IPv4 and IPv6 Infrastructure Addresses in BGP Updates for Multicast VPNR. Aggarwal, E. Rosen | Proposed Standard | February 2012 |
| 6514 | BGP Encodings and Procedures for Multicast in MPLS/BGP IP VPNsR. Aggarwal, E. Rosen, T. Morin, Y. Rekhter | Proposed Standard | February 2012 |
| 6396 | Multi-Threaded Routing Toolkit (MRT) Routing Information Export FormatL. Blunk, M. Karir, C. Labovitz | Proposed Standard | October 2011 |
| 6272 | Internet Protocols for the Smart GridF. Baker, D. Meyer | Informational | June 2011 |
| 6198 | Requirements for the Graceful Shutdown of BGP SessionsB. Decraene, P. Francois, C. Pelsser, Z. Ahmad, A.J. Elizondo Armengol, T. Takeda | Informational | April 2011 |
| 6074 | Provisioning, Auto-Discovery, and Signaling in Layer 2 Virtual Private Networks (L2VPNs)E. Rosen, B. Davie, V. Radoaca, W. Luo | Proposed Standard | January 2011 |
| 5963 | IPv6 Deployment in Internet Exchange Points (IXPs)R. Gagliano | Informational | August 2010 |
| 5773 | Analysis of Inter-Domain Routing Requirements and HistoryE. Davies, A. Doria | Historic | February 2010 |
| 5760 | RTP Control Protocol (RTCP) Extensions for Single-Source Multicast Sessions with Unicast FeedbackJ. Ott, J. Chesterfield, E. Schooler | Proposed Standard | February 2010 |
| 5757 | Multicast Mobility in Mobile IP Version 6 (MIPv6): Problem Statement and Brief SurveyT. Schmidt, M. Waehlisch, G. Fairhurst | Informational | February 2010 |
| 5747 | 4over6 Transit Solution Using IP Encapsulation and MP-BGP ExtensionsJ. Wu, Y. Cui, X. Li, M. Xu, C. Metz | Experimental | March 2010 |
| 5575 | Dissemination of Flow Specification RulesP. Marques, N. Sheth, R. Raszuk, B. Greene, J. Mauch, D. McPherson · obsoleted by RFC 8955 | Proposed Standard | August 2009 |
| 5549 | Advertising IPv4 Network Layer Reachability Information with an IPv6 Next HopF. Le Faucheur, E. Rosen · obsoleted by RFC 8950 | Proposed Standard | May 2009 |
| 5512 | The BGP Encapsulation Subsequent Address Family Identifier (SAFI) and the BGP Tunnel Encapsulation AttributeP. Mohapatra, E. Rosen · obsoleted by RFC 9012 | Proposed Standard | April 2009 |
| 5492 | Capabilities Advertisement with BGP-4J. Scudder, R. Chandra | Draft Standard | February 2009 |
| 5292 | Address-Prefix-Based Outbound Route Filter for BGP-4E. Chen, S. Sangli | Proposed Standard | August 2008 |
| 5291 | Outbound Route Filtering Capability for BGP-4E. Chen, Y. Rekhter | Proposed Standard | August 2008 |
| 5283 | LDP Extension for Inter-Area Label Switched Paths (LSPs)B. Decraene, JL. Le Roux, I. Minei | Proposed Standard | July 2008 |
| 5195 | BGP-Based Auto-Discovery for Layer-1 VPNsH. Ould-Brahim, D. Fedyk, Y. Rekhter | Proposed Standard | June 2008 |
| 5160 | Considerations of Provider-to-Provider Agreements for Internet-Scale Quality of Service (QoS)P. Levis, M. Boucadair | Informational | March 2008 |
| 5110 | Overview of the Internet Multicast Routing ArchitectureP. Savola | Informational | January 2008 |
| 5015 | Bidirectional Protocol Independent Multicast (BIDIR-PIM)M. Handley, I. Kouvelas, T. Speakman, L. Vicisano | Proposed Standard | October 2007 |
| 4852 | IPv6 Enterprise Network Analysis - IP Layer 3 FocusJ. Bound, Y. Pouffary, S. Klynsma, T. Chown, D. Green | Informational | April 2007 |
| 4798 | Connecting IPv6 Islands over IPv4 MPLS Using IPv6 Provider Edge Routers (6PE)J. De Clercq, D. Ooms, S. Prevost, F. Le Faucheur | Proposed Standard | February 2007 |
| 4797 | Use of Provider Edge to Provider Edge (PE-PE) Generic Routing Encapsulation (GRE) or IP in BGP/MPLS IP Virtual Private NetworksY. Rekhter, R. Bonica, E. Rosen | Informational | January 2007 |
| 4761 | Virtual Private LAN Service (VPLS) Using BGP for Auto-Discovery and SignalingK. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | January 2007 |