| 1750 | Randomness Recommendations for SecurityD. Eastlake 3rd, S. Crocker, J. Schiller · obsoleted by RFC 4086 | Informational | December 1994 |
| 2015 | MIME Security with Pretty Good Privacy (PGP)M. Elkins | Proposed Standard | October 1996 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2246 | The TLS Protocol Version 1.0T. Dierks, C. Allen · obsoleted by RFC 4346 | Historic | January 1999 |
| 2434 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 5226 | Best Current Practice | October 1998 |
| 2733 | An RTP Payload Format for Generic Forward Error CorrectionJ. Rosenberg, H. Schulzrinne · obsoleted by RFC 5109 | Proposed Standard | December 1999 |
| 2828 | Internet Security GlossaryR. Shirey · obsoleted by RFC 4949 | Informational | May 2000 |
| 2974 | Session Announcement ProtocolM. Handley, C. Perkins, E. Whelan | Experimental | October 2000 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 3264 | An Offer/Answer Model with Session Description Protocol (SDP)J. Rosenberg, H. Schulzrinne | Proposed Standard | July 2002 |
| 3311 | The Session Initiation Protocol (SIP) UPDATE MethodJ. Rosenberg | Proposed Standard | October 2002 |
| 3312 | Integration of Resource Management and Session Initiation Protocol (SIP)G. Camarillo, Ed., W. Marshall, Ed., J. Rosenberg | Proposed Standard | October 2002 |
| 3407 | Session Description Protocol (SDP) Simple Capability DeclarationF. Andreasen | Proposed Standard | October 2002 |
| 3547 | The Group Domain of InterpretationM. Baugher, B. Weis, T. Hardjono, H. Harney · obsoleted by RFC 6407 | Proposed Standard | July 2003 |
| 3548 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson, Ed. · obsoleted by RFC 4648 | Informational | July 2003 |
| 3550 | RTP: A Transport Protocol for Real-Time ApplicationsH. Schulzrinne, S. Casner, R. Frederick, V. Jacobson | Internet Standard | July 2003 |
| 3711 | The Secure Real-time Transport Protocol (SRTP)M. Baugher, D. McGrew, M. Naslund, E. Carrara, K. Norrman | Proposed Standard | March 2004 |
| 3830 | MIKEY: Multimedia Internet KEYingJ. Arkko, E. Carrara, F. Lindholm, M. Naslund, K. Norrman | Proposed Standard | August 2004 |
| 3851 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.1 Message SpecificationB. Ramsdell, Ed. · obsoleted by RFC 5751 | Proposed Standard | July 2004 |
| 4234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell · obsoleted by RFC 5234 | Draft Standard | October 2005 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |
| 4566 | SDP: Session Description ProtocolM. Handley, V. Jacobson, C. Perkins · obsoleted by RFC 8866 | Proposed Standard | July 2006 |
| 4567 | Key Management Extensions for Session Description Protocol (SDP) and Real Time Streaming Protocol (RTSP)J. Arkko, F. Lindholm, M. Naslund, K. Norrman, E. Carrara | Proposed Standard | July 2006 |