| 9766 | Extensions for Weak Cache Consistency in NFSv4.2's Flexible File LayoutT. Haynes, T. Myklebust | Proposed Standard | April 2025 |
| 9754 | Extensions for Opening and Delegating Files in NFSv4.2T. Haynes, T. Myklebust | Proposed Standard | March 2025 |
| 9737 | Reporting Errors in NFSv4.2 via LAYOUTRETURNT. Haynes, T. Myklebust | Proposed Standard | February 2025 |
| 9561 | Using the Parallel NFS (pNFS) SCSI Layout to Access Non-Volatile Memory Express (NVMe) Storage DevicesC. Hellwig, Ed., C. Lever, S. Faibish, D. Black | Proposed Standard | April 2024 |
| 8881 | Network File System (NFS) Version 4 Minor Version 1 ProtocolD. Noveck, Ed., C. Lever | Proposed Standard | August 2020 |
| 8797 | Remote Direct Memory Access - Connection Manager (RDMA-CM) Private Data for RPC-over-RDMA Version 1C. Lever | Proposed Standard | June 2020 |
| 8554 | Leighton-Micali Hash-Based SignaturesD. McGrew, M. Curcio, S. Fluhrer | Informational | April 2019 |
| 8435 | Parallel NFS (pNFS) Flexible File LayoutB. Halevy, T. Haynes | Proposed Standard | August 2018 |
| 8391 | XMSS: eXtended Merkle Signature SchemeA. Huelsing, D. Butin, S. Gazdag, J. Rijneveld, A. Mohaisen | Informational | May 2018 |
| 8276 | File System Extended Attributes in NFSv4M. Naik, M. Eshel | Proposed Standard | December 2017 |
| 8275 | Allowing Inheritable NFSv4 Access Control Entries to Override the UmaskJ. Fields, A. Gruenbacher | Proposed Standard | December 2017 |
| 8166 | Remote Direct Memory Access Transport for Remote Procedure Call Version 1C. Lever, Ed., W. Simpson, T. Talpey | Proposed Standard | June 2017 |
| 8154 | Parallel NFS (pNFS) Small Computer System Interface (SCSI) LayoutC. Hellwig | Proposed Standard | May 2017 |
| 7863 | Network File System (NFS) Version 4 Minor Version 2 External Data Representation Standard (XDR) DescriptionT. Haynes | Proposed Standard | November 2016 |
| 7862 | Network File System (NFS) Version 4 Minor Version 2 ProtocolT. Haynes | Proposed Standard | November 2016 |
| 7861 | Remote Procedure Call (RPC) Security Version 3A. Adamson, N. Williams | Proposed Standard | November 2016 |
| 7533 | Administration Protocol for Federated File SystemsJ. Lentini, R. Tewari, C. Lever, Ed. | Proposed Standard | March 2015 |
| 7531 | Network File System (NFS) Version 4 External Data Representation Standard (XDR) DescriptionT. Haynes, Ed., D. Noveck, Ed. | Proposed Standard | March 2015 |
| 7530 | Network File System (NFS) Version 4 ProtocolT. Haynes, Ed., D. Noveck, Ed. | Proposed Standard | March 2015 |
| 7139 | GMPLS Signaling Extensions for Control of Evolving G.709 Optical Transport NetworksF. Zhang, Ed., G. Zhang, S. Belotti, D. Ceccarelli, K. Pithewan | Proposed Standard | March 2014 |
| 6003 | Ethernet Traffic ParametersD. Papadimitriou | Proposed Standard | October 2010 |
| 5975 | QSPEC Template for the Quality-of-Service NSIS Signaling Layer Protocol (NSLP)G. Ash, Ed., A. Bader, Ed., C. Kappler, Ed., D. Oran, Ed. | Experimental | October 2010 |
| 5666 | Remote Direct Memory Access Transport for Remote Procedure CallT. Talpey, B. Callaghan · obsoleted by RFC 8166 | Proposed Standard | January 2010 |
| 5664 | Object-Based Parallel NFS (pNFS) OperationsB. Halevy, B. Welch, J. Zelenka | Proposed Standard | January 2010 |
| 5663 | Parallel NFS (pNFS) Block/Volume LayoutD. Black, S. Fridella, J. Glasgow | Proposed Standard | January 2010 |
| 5662 | Network File System (NFS) Version 4 Minor Version 1 External Data Representation Standard (XDR) DescriptionS. Shepler, Ed., M. Eisler, Ed., D. Noveck, Ed. | Proposed Standard | January 2010 |
| 5661 | Network File System (NFS) Version 4 Minor Version 1 ProtocolS. Shepler, Ed., M. Eisler, Ed., D. Noveck, Ed. · obsoleted by RFC 8881 | Proposed Standard | January 2010 |
| 5532 | Network File System (NFS) Remote Direct Memory Access (RDMA) Problem StatementT. Talpey, C. Juszczak | Informational | May 2009 |
| 5531 | RPC: Remote Procedure Call Protocol Specification Version 2R. Thurlow | Draft Standard | May 2009 |
| 5403 | RPCSEC_GSS Version 2M. Eisler | Proposed Standard | February 2009 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |