| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 2136 | Dynamic Updates in the Domain Name System (DNS UPDATE)P. Vixie, Ed., S. Thomson, Y. Rekhter, J. Bound | Proposed Standard | April 1997 |
| 2181 | Clarifications to the DNS SpecificationR. Elz, R. Bush | Proposed Standard | July 1997 |
| 2182 | Selection and Operation of Secondary DNS ServersR. Elz, R. Bush, S. Bradner, M. Patton | Best Current Practice | July 1997 |
| 2462 | IPv6 Stateless Address AutoconfigurationS. Thomson, T. Narten · obsoleted by RFC 4862 | Draft Standard | December 1998 |
| 2671 | Extension Mechanisms for DNS (EDNS0)P. Vixie · obsoleted by RFC 6891 | Proposed Standard | August 1999 |
| 2766 | Network Address Translation - Protocol Translation (NAT-PT)G. Tsirtsis, P. Srisuresh · obsoleted by RFC 4966 | Historic | February 2000 |
| 2782 | A DNS RR for specifying the location of services (DNS SRV)A. Gulbrandsen, P. Vixie, L. Esibov | Proposed Standard | February 2000 |
| 2821 | Simple Mail Transfer ProtocolJ. Klensin, Ed. · obsoleted by RFC 5321 | Proposed Standard | April 2001 |
| 2826 | IAB Technical Comment on the Unique DNS RootInternet Architecture Board | Informational | May 2000 |
| 3007 | Secure Domain Name System (DNS) Dynamic UpdateB. Wellington | Proposed Standard | November 2000 |
| 3041 | Privacy Extensions for Stateless Address Autoconfiguration in IPv6T. Narten, R. Draves · obsoleted by RFC 4941 | Proposed Standard | January 2001 |
| 3056 | Connection of IPv6 Domains via IPv4 CloudsB. Carpenter, K. Moore | Proposed Standard | February 2001 |
| 3152 | Delegation of IP6.ARPAR. Bush · obsoleted by RFC 3596 | Best Current Practice | August 2001 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3363 | Representing Internet Protocol version 6 (IPv6) Addresses in the Domain Name System (DNS)R. Bush, A. Durand, B. Fink, O. Gudmundsson, T. Hain | Informational | August 2002 |
| 3364 | Tradeoffs in Domain Name System (DNS) Support for Internet Protocol version 6 (IPv6)R. Austein | Informational | August 2002 |
| 3596 | DNS Extensions to Support IP Version 6S. Thomson, C. Huitema, V. Ksinant, M. Souissi | Internet Standard | October 2003 |
| 3646 | DNS Configuration options for Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed. | Proposed Standard | December 2003 |
| 3704 | Ingress Filtering for Multihomed NetworksF. Baker, P. Savola | Best Current Practice | March 2004 |
| 3736 | Stateless Dynamic Host Configuration Protocol (DHCP) Service for IPv6R. Droms · obsoleted by RFC 8415 | Proposed Standard | April 2004 |
| 3879 | Deprecating Site Local AddressesC. Huitema, B. Carpenter | Proposed Standard | September 2004 |
| 3901 | DNS IPv6 Transport Operational GuidelinesA. Durand, J. Ihren · obsoleted by RFC 10001 | Best Current Practice | September 2004 |
| 3972 | Cryptographically Generated Addresses (CGA)T. Aura | Proposed Standard | March 2005 |
| 4025 | A Method for Storing IPsec Keying Material in DNSM. Richardson | Proposed Standard | March 2005 |
| 4038 | Application Aspects of IPv6 TransitionM-K. Shin, Ed., Y-G. Hong, J. Hagino, P. Savola, E. M. Castro | Informational | March 2005 |
| 4074 | Common Misbehavior Against DNS Queries for IPv6 AddressesY. Morishita, T. Jinmei | Informational | June 2005 |
| 4192 | Procedures for Renumbering an IPv6 Network without a Flag DayF. Baker, E. Lear, R. Droms | Informational | September 2005 |
| 4193 | Unique Local IPv6 Unicast AddressesR. Hinden, B. Haberman | Proposed Standard | October 2005 |
| 4213 | Basic Transition Mechanisms for IPv6 Hosts and RoutersE. Nordmark, R. Gilligan | Proposed Standard | October 2005 |
| 4215 | Analysis on IPv6 Transition in Third Generation Partnership Project (3GPP) NetworksJ. Wiljakka, Ed. | Informational | October 2005 |
| 4291 | IP Version 6 Addressing ArchitectureR. Hinden, S. Deering | Draft Standard | February 2006 |
| 4339 | IPv6 Host Configuration of DNS Server Information ApproachesJ. Jeong, Ed. | Informational | February 2006 |
| 4380 | Teredo: Tunneling IPv6 over UDP through Network Address Translations (NATs)C. Huitema | Proposed Standard | February 2006 |