| 791 | Internet ProtocolJ. Postel | Internet Standard | September 1981 |
| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1072 | TCP extensions for long-delay pathsV. Jacobson, R.T. Braden · obsoleted by RFC 1323, RFC 2018, RFC 6247 | Historic | October 1988 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1144 | Compressing TCP/IP Headers for Low-Speed Serial LinksV. Jacobson | Proposed Standard | February 1990 |
| 1146 | TCP alternate checksum optionsJ. Zweig, C. Partridge · obsoleted by RFC 6247 | Historic | March 1990 |
| 1191 | Path MTU discoveryJ. Mogul, S. Deering | Draft Standard | November 1990 |
| 1323 | TCP Extensions for High PerformanceV. Jacobson, R. Braden, D. Borman · obsoleted by RFC 7323 | Proposed Standard | May 1992 |
| 1349 | Type of Service in the Internet Protocol SuiteP. Almquist · obsoleted by RFC 2474 | Proposed Standard | July 1992 |
| 1644 | T/TCP -- TCP Extensions for Transactions Functional SpecificationR. Braden · obsoleted by RFC 6247 | Historic | July 1994 |
| 1693 | An Extension to TCP : Partial Order ServiceT. Connolly, P. Amer, P. Conrad · obsoleted by RFC 6247 | Historic | November 1994 |
| 1945 | Hypertext Transfer Protocol -- HTTP/1.0T. Berners-Lee, R. Fielding, H. Frystyk | Informational | May 1996 |
| 1948 | Defending Against Sequence Number AttacksS. Bellovin · obsoleted by RFC 6528 | Informational | May 1996 |
| 1981 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul · obsoleted by RFC 8201 | Draft Standard | August 1996 |
| 2018 | TCP Selective Acknowledgment OptionsM. Mathis, J. Mahdavi, S. Floyd, A. Romanow | Proposed Standard | October 1996 |
| 2385 | Protection of BGP Sessions via the TCP MD5 Signature OptionA. Heffernan · obsoleted by RFC 5925 | Proposed Standard | August 1998 |
| 2402 | IP Authentication HeaderS. Kent, R. Atkinson · obsoleted by RFC 4302, RFC 4305 | Proposed Standard | November 1998 |
| 2406 | IP Encapsulating Security Payload (ESP)S. Kent, R. Atkinson · obsoleted by RFC 4303, RFC 4305 | Proposed Standard | November 1998 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |
| 2481 | A Proposal to add Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd · obsoleted by RFC 3168 | Experimental | January 1999 |
| 2507 | IP Header CompressionM. Degermark, B. Nordgren, S. Pink | Proposed Standard | February 1999 |
| 2508 | Compressing IP/UDP/RTP Headers for Low-Speed Serial LinksS. Casner, V. Jacobson | Proposed Standard | February 1999 |
| 2581 | TCP Congestion ControlM. Allman, V. Paxson, W. Stevens · obsoleted by RFC 5681 | Proposed Standard | April 1999 |
| 2780 | IANA Allocation Guidelines For Values In the Internet Protocol and Related HeadersS. Bradner, V. Paxson | Best Current Practice | March 2000 |
| 2883 | An Extension to the Selective Acknowledgement (SACK) Option for TCPS. Floyd, J. Mahdavi, M. Mathis, M. Podolsky | Proposed Standard | July 2000 |
| 3095 | RObust Header Compression (ROHC): Framework and four profiles: RTP, UDP, ESP, and uncompressedC. Bormann, C. Burmeister, M. Degermark, H. Fukushima, H. Hannu, L-E. Jonsson, R. Hakenberg, T. Koren, K. Le, Z. Liu, A. Martensson, A. Miyazaki, K. Svanbro, T. Wiebke, T. Yoshimura, H. Zheng | Proposed Standard | July 2001 |
| 3150 | End-to-end Performance Implications of Slow LinksS. Dawkins, G. Montenegro, M. Kojo, V. Magret | Best Current Practice | July 2001 |
| 3168 | The Addition of Explicit Congestion Notification (ECN) to IPK. Ramakrishnan, S. Floyd, D. Black | Proposed Standard | September 2001 |
| 3449 | TCP Performance Implications of Network Path AsymmetryH. Balakrishnan, V. Padmanabhan, G. Fairhurst, M. Sooriyabandara | Best Current Practice | December 2002 |
| 3481 | TCP over Second (2.5G) and Third (3G) Generation Wireless NetworksH. Inamura, Ed., G. Montenegro, Ed., R. Ludwig, A. Gurtov, F. Khafizov | Best Current Practice | February 2003 |
| 3522 | The Eifel Detection Algorithm for TCPR. Ludwig, M. Meyer | Experimental | April 2003 |
| 3544 | IP Header Compression over PPPT. Koren, S. Casner, C. Bormann | Proposed Standard | July 2003 |
| 3819 | Advice for Internet Subnetwork DesignersP. Karn, Ed., C. Bormann, G. Fairhurst, D. Grossman, R. Ludwig, J. Mahdavi, G. Montenegro, J. Touch, L. Wood | Best Current Practice | July 2004 |