| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2246 | The TLS Protocol Version 1.0T. Dierks, C. Allen · obsoleted by RFC 4346 | Historic | January 1999 |
| 2247 | Using Domains in LDAP/X.500 Distinguished NamesS. Kille, M. Wahl, A. Grimstad, R. Huber, S. Sataluri | Proposed Standard | January 1998 |
| 2434 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 5226 | Best Current Practice | October 1998 |
| 2440 | OpenPGP Message FormatJ. Callas, L. Donnerhacke, H. Finney, R. Thayer · obsoleted by RFC 4880 | Proposed Standard | November 1998 |
| 2538 | Storing Certificates in the Domain Name System (DNS)D. Eastlake 3rd, O. Gudmundsson · obsoleted by RFC 4398 | Proposed Standard | March 1999 |
| 2692 | SPKI RequirementsC. Ellison | Experimental | September 1999 |
| 2693 | SPKI Certificate TheoryC. Ellison, B. Frantz, B. Lampson, R. Rivest, B. Thomas, T. Ylonen | Experimental | September 1999 |
| 2822 | Internet Message FormatP. Resnick, Ed. · obsoleted by RFC 5322 | Proposed Standard | April 2001 |
| 3280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileR. Housley, W. Polk, W. Ford, D. Solo · obsoleted by RFC 5280 | Proposed Standard | May 2002 |
| 3281 | An Internet Attribute Certificate Profile for AuthorizationS. Farrell, R. Housley · obsoleted by RFC 5755 | Proposed Standard | May 2002 |
| 3548 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson, Ed. · obsoleted by RFC 4648 | Informational | July 2003 |
| 3851 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.1 Message SpecificationB. Ramsdell, Ed. · obsoleted by RFC 5751 | Proposed Standard | July 2004 |
| 3986 | Uniform Resource Identifier (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter | Internet Standard | January 2005 |
| 4025 | A Method for Storing IPsec Keying Material in DNSM. Richardson | Proposed Standard | March 2005 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4034 | Resource Records for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4301 | Security Architecture for the Internet ProtocolS. Kent, K. Seo | Proposed Standard | December 2005 |