| 9868 | Transport Options for UDPJ. Touch, C. Heard, Ed. | Proposed Standard | October 2025 |
| 9601 | Propagating Explicit Congestion Notification across IP Tunnel Headers Separated by a ShimB. Briscoe | Proposed Standard | August 2024 |
| 9599 | Guidelines for Adding Congestion Notification to Protocols that Encapsulate IPB. Briscoe, J. Kaippallimalil | Best Current Practice | August 2024 |
| 9099 | Operational Security Considerations for IPv6 NetworksÉ. Vyncke, K. Chittimaneni, M. Kaeo, E. Rey | Informational | August 2021 |
| 9063 | Host Identity Protocol ArchitectureR. Moskowitz, Ed., M. Komu | Informational | July 2021 |
| 8892 | Guidelines and Registration Procedures for Interface Types and Tunnel TypesD. Thaler, D. Romascanu | Proposed Standard | August 2020 |
| 8855 | The Binary Floor Control Protocol (BFCP)G. Camarillo, K. Drage, T. Kristensen, J. Ott, C. Eckel | Proposed Standard | January 2021 |
| 8675 | A YANG Data Model for Tunnel Interface TypesM. Boucadair, I. Farrer, R. Asati | Proposed Standard | November 2019 |
| 8504 | IPv6 Node RequirementsT. Chown, J. Loughney, T. Winters | Best Current Practice | January 2019 |
| 8190 | Updates to the Special-Purpose IP Address RegistriesR. Bonica, M. Cotton, B. Haberman, L. Vegoda | Best Current Practice | June 2017 |
| 8170 | Planning for Protocol Adoption and Subsequent TransitionsD. Thaler, Ed. | Informational | May 2017 |
| 8085 | UDP Usage GuidelinesL. Eggert, G. Fairhurst, G. Shepherd | Best Current Practice | March 2017 |
| 7721 | Security and Privacy Considerations for IPv6 Address Generation MechanismsA. Cooper, F. Gont, D. Thaler | Informational | March 2016 |
| 7707 | Network Reconnaissance in IPv6 NetworksF. Gont, T. Chown | Informational | March 2016 |
| 7421 | Analysis of the 64-bit Boundary in IPv6 AddressingB. Carpenter, Ed., T. Chown, F. Gont, S. Jiang, A. Petrescu, A. Yourtchenko | Informational | January 2015 |
| 7123 | Security Implications of IPv6 on IPv4 NetworksF. Gont, W. Liu | Informational | February 2014 |
| 7059 | A Comparison of IPv6-over-IPv4 Tunnel MechanismsS. Steffann, I. van Beijnum, R. van Rein | Informational | November 2013 |
| 7021 | Assessing the Impact of Carrier-Grade NAT on Network ApplicationsC. Donley, Ed., L. Howard, V. Kuarsingh, J. Berg, J. Doshi | Informational | September 2013 |
| 6964 | Operational Guidance for IPv6 Deployment in IPv4 Sites Using the Intra-Site Automatic Tunnel Addressing Protocol (ISATAP)F. Templin | Informational | May 2013 |
| 6890 | Special-Purpose IP Address RegistriesM. Cotton, L. Vegoda, R. Bonica, Ed., B. Haberman | Best Current Practice | April 2013 |
| 6782 | Wireline Incremental IPv6V. Kuarsingh, Ed., L. Howard | Informational | November 2012 |
| 6751 | Native IPv6 behind IPv4-to-IPv4 NAT Customer Premises Equipment (6a44)R. Despres, Ed., B. Carpenter, D. Wing, S. Jiang | Experimental | October 2012 |
| 6724 | Default Address Selection for Internet Protocol Version 6 (IPv6)D. Thaler, Ed., R. Draves, A. Matsumoto, T. Chown | Proposed Standard | September 2012 |
| 6544 | TCP Candidates with Interactive Connectivity Establishment (ICE)J. Rosenberg, A. Keranen, B. B. Lowekamp, A. B. Roach | Proposed Standard | March 2012 |
| 6538 | The Host Identity Protocol (HIP) Experiment ReportT. Henderson, A. Gurtov | Informational | March 2012 |
| 6491 | Resource Public Key Infrastructure (RPKI) Objects Issued by IANAT. Manderson, L. Vegoda, S. Kent | Proposed Standard | February 2012 |
| 6434 | IPv6 Node RequirementsE. Jankiewicz, J. Loughney, T. Narten · obsoleted by RFC 8504 | Informational | December 2011 |
| 6324 | Routing Loop Attack Using IPv6 Automatic Tunnels: Problem Statement and Proposed MitigationsG. Nakibly, F. Templin | Informational | August 2011 |
| 6269 | Issues with IP Address SharingM. Ford, Ed., M. Boucadair, A. Durand, P. Levis, P. Roberts | Informational | June 2011 |
| 6250 | Evolution of the IP ModelD. Thaler | Informational | May 2011 |
| 6219 | The China Education and Research Network (CERNET) IVI Translation Design and Deployment for the IPv4/IPv6 Coexistence and TransitionX. Li, C. Bao, M. Chen, H. Zhang, J. Wu | Informational | May 2011 |
| 6180 | Guidelines for Using IPv6 Transition Mechanisms during IPv6 DeploymentJ. Arkko, F. Baker | Informational | May 2011 |
| 6169 | Security Concerns with IP TunnelingS. Krishnan, D. Thaler, J. Hoagland | Informational | April 2011 |
| 6144 | Framework for IPv4/IPv6 TranslationF. Baker, X. Li, C. Bao, K. Yin | Informational | April 2011 |
| 6139 | Routing and Addressing in Networks with Global Enterprise Recursion (RANGER) ScenariosS. Russert, Ed., E. Fleischman, Ed., F. Templin, Ed. | Informational | February 2011 |
| 6127 | IPv4 Run-Out and IPv4-IPv6 Co-Existence ScenariosJ. Arkko, M. Townsley | Informational | May 2011 |
| 6081 | Teredo ExtensionsD. Thaler | Proposed Standard | January 2011 |
| 5991 | Teredo Security UpdatesD. Thaler, S. Krishnan, J. Hoagland | Proposed Standard | September 2010 |
| 5902 | IAB Thoughts on IPv6 Network Address TranslationD. Thaler, L. Zhang, G. Lebovitz | Informational | July 2010 |
| 5558 | Virtual Enterprise Traversal (VET)F. Templin, Ed. | Informational | February 2010 |
| 5320 | The Subnetwork Encapsulation and Adaptation Layer (SEAL)F. Templin, Ed. | Experimental | February 2010 |
| 5157 | IPv6 Implications for Network ScanningT. Chown · obsoleted by RFC 7707 | Informational | March 2008 |
| 5156 | Special-Use IPv6 AddressesM. Blanchet · obsoleted by RFC 6890 | Informational | April 2008 |
| 5128 | State of Peer-to-Peer (P2P) Communication across Network Address Translators (NATs)P. Srisuresh, B. Ford, D. Kegel | Informational | March 2008 |
| 4942 | IPv6 Transition/Co-existence Security ConsiderationsE. Davies, S. Krishnan, P. Savola | Informational | September 2007 |
| 4924 | Reflections on Internet TransparencyB. Aboba, Ed., E. Davies | Informational | July 2007 |
| 4903 | Multi-Link Subnet IssuesD. Thaler | Informational | June 2007 |
| 4890 | Recommendations for Filtering ICMPv6 Messages in FirewallsE. Davies, J. Mohacsi | Informational | May 2007 |
| 4852 | IPv6 Enterprise Network Analysis - IP Layer 3 FocusJ. Bound, Y. Pouffary, S. Klynsma, T. Chown, D. Green | Informational | April 2007 |
| 4787 | Network Address Translation (NAT) Behavioral Requirements for Unicast UDPF. Audet, Ed., C. Jennings | Best Current Practice | January 2007 |
| 4779 | ISP IPv6 Deployment Scenarios in Broadband Access NetworksS. Asadullah, A. Ahmed, C. Popoviciu, P. Savola, J. Palet | Informational | January 2007 |
| 4472 | Operational Considerations and Issues with IPv6 DNSA. Durand, J. Ihren, P. Savola | Informational | April 2006 |