| 10015 | Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2N. Aviram | Proposed Standard | July 2026 |
| 9847 | IANA Registry Updates for TLS and DTLSJ. Salowey, S. Turner | Proposed Standard | December 2025 |
| 9846 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla | Proposed Standard | July 2026 |
| 9325 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, P. Saint-Andre, T. Fossati | Best Current Practice | November 2022 |
| 9190 | EAP-TLS 1.3: Using the Extensible Authentication Protocol with TLS 1.3J. Preuß Mattsson, M. Sethi | Proposed Standard | February 2022 |
| 9147 | The Datagram Transport Layer Security (DTLS) Protocol Version 1.3E. Rescorla, H. Tschofenig, N. Modadugu | Proposed Standard | April 2022 |
| 8997 | Deprecation of TLS 1.1 for Email Submission and AccessL. Velvindron, S. Farrell | Proposed Standard | March 2021 |
| 8996 | Deprecating TLS 1.0 and TLS 1.1K. Moriarty, S. Farrell | Best Current Practice | March 2021 |
| 8744 | Issues and Requirements for Server Name Identification (SNI) Encryption in TLSC. Huitema | Informational | July 2020 |
| 8446 | The Transport Layer Security (TLS) Protocol Version 1.3E. Rescorla · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8422 | Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS) Versions 1.2 and EarlierY. Nir, S. Josefsson, M. Pegourie-Gonnard · obsoleted by RFC 9846 | Proposed Standard | August 2018 |
| 8314 | Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and AccessK. Moore, C. Newman | Proposed Standard | January 2018 |
| 7919 | Negotiated Finite Field Diffie-Hellman Ephemeral Parameters for Transport Layer Security (TLS)D. Gillmor | Proposed Standard | August 2016 |
| 7568 | Deprecating Secure Sockets Layer Version 3.0R. Barnes, M. Thomson, A. Pironti, A. Langley | Proposed Standard | June 2015 |
| 7562 | Transport Layer Security (TLS) Authorization Using Digital Transmission Content Protection (DTCP) CertificatesD. Thakore | Informational | July 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7507 | TLS Fallback Signaling Cipher Suite Value (SCSV) for Preventing Protocol Downgrade AttacksB. Moeller, A. Langley · obsoleted by RFC 8996 | Proposed Standard | April 2015 |
| 7465 | Prohibiting RC4 Cipher SuitesA. Popov | Proposed Standard | February 2015 |
| 7030 | Enrollment over Secure TransportM. Pritikin, Ed., P. Yee, Ed., D. Harkins, Ed. | Proposed Standard | October 2013 |
| 6876 | A Posture Transport Protocol over TLS (PT-TLS)P. Sangster, N. Cam-Winget, J. Salowey | Proposed Standard | February 2013 |
| 6614 | Transport Layer Security (TLS) Encryption for RADIUSS. Winter, M. McCauley, S. Venaas, K. Wierenga | Experimental | May 2012 |
| 6546 | Transport of Real-time Inter-network Defense (RID) Messages over HTTP/TLSB. Trammell | Proposed Standard | April 2012 |
| 6460 | Suite B Profile for Transport Layer Security (TLS)M. Salter, R. Housley | Historic | January 2012 |
| 6367 | Addition of the Camellia Cipher Suites to Transport Layer Security (TLS)S. Kanno, M. Kanda | Informational | September 2011 |
| 6347 | Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147 | Proposed Standard | January 2012 |
| 6176 | Prohibiting Secure Sockets Layer (SSL) Version 2.0S. Turner, T. Polk | Proposed Standard | March 2011 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6042 | Transport Layer Security (TLS) Authorization Using KeyNoteA. Keromytis | Informational | October 2010 |
| 5878 | Transport Layer Security (TLS) Authorization ExtensionsM. Brown, R. Housley | Experimental | May 2010 |
| 5734 | Extensible Provisioning Protocol (EPP) Transport over TCPS. Hollenbeck | Internet Standard | August 2009 |
| 5469 | DES and IDEA Cipher Suites for Transport Layer Security (TLS)P. Eronen, Ed. · obsoleted by RFC 8996 | Historic | February 2009 |
| 5430 | Suite B Profile for Transport Layer Security (TLS)M. Salter, E. Rescorla, R. Housley · obsoleted by RFC 6460 | Historic | March 2009 |
| 5364 | Extensible Markup Language (XML) Format Extension for Representing Copy Control Attributes in Resource ListsM. Garcia-Martin, G. Camarillo | Proposed Standard | October 2008 |
| 5298 | Analysis of Inter-Domain Label Switched Path (LSP) RecoveryT. Takeda, Ed., A. Farrel, Ed., Y. Ikejiri, JP. Vasseur | Informational | August 2008 |
| 5295 | Specification for the Derivation of Root Keys from an Extended Master Session Key (EMSK)J. Salowey, L. Dondeti, V. Narayanan, M. Nakhjiri | Proposed Standard | August 2008 |
| 5289 | TLS Elliptic Curve Cipher Suites with SHA-256/384 and AES Galois Counter Mode (GCM)E. Rescorla | Proposed Standard | August 2008 |
| 5281 | Extensible Authentication Protocol Tunneled Transport Layer Security Authenticated Protocol Version 0 (EAP-TTLSv0)P. Funk, S. Blake-Wilson | Informational | August 2008 |
| 5273 | Certificate Management over CMS (CMC): Transport ProtocolsJ. Schaad, M. Myers · obsoleted by RFC 10003 | Proposed Standard | June 2008 |
| 5263 | Session Initiation Protocol (SIP) Extension for Partial Notification of Presence InformationM. Lonnfors, J. Costa-Requena, E. Leppanen, H. Khartabil | Proposed Standard | September 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5238 | Datagram Transport Layer Security (DTLS) over the Datagram Congestion Control Protocol (DCCP)T. Phelan | Proposed Standard | May 2008 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5216 | The EAP-TLS Authentication ProtocolD. Simon, B. Aboba, R. Hurst | Proposed Standard | March 2008 |
| 5209 | Network Endpoint Assessment (NEA): Overview and RequirementsP. Sangster, H. Khosravi, M. Mani, K. Narayan, J. Tardo | Informational | June 2008 |
| 5189 | Middlebox Communication (MIDCOM) Protocol SemanticsM. Stiemerling, J. Quittek, T. Taylor | Proposed Standard | March 2008 |
| 5158 | 6to4 Reverse DNS Delegation SpecificationG. Huston | Informational | March 2008 |
| 5153 | IP Flow Information Export (IPFIX) Implementation GuidelinesE. Boschi, L. Mark, J. Quittek, M. Stiemerling, P. Aitken | Informational | April 2008 |
| 5126 | CMS Advanced Electronic Signatures (CAdES)D. Pinkas, N. Pope, J. Ross | Informational | March 2008 |
| 5114 | Additional Diffie-Hellman Groups for Use with IETF StandardsM. Lepinski, S. Kent | Informational | January 2008 |
| 5101 | Specification of the IP Flow Information Export (IPFIX) Protocol for the Exchange of IP Traffic Flow InformationB. Claise, Ed. · obsoleted by RFC 7011 | Proposed Standard | January 2008 |
| 5091 | Identity-Based Cryptography Standard (IBCS) #1: Supersingular Curve Implementations of the BF and BB1 CryptosystemsX. Boyen, L. Martin | Informational | December 2007 |
| 5090 | RADIUS Extension for Digest AuthenticationB. Sterman, D. Sadolevsky, D. Schwartz, D. Williams, W. Beck | Proposed Standard | February 2008 |
| 5081 | Using OpenPGP Keys for Transport Layer Security (TLS) AuthenticationN. Mavrogiannopoulos · obsoleted by RFC 6091 | Experimental | November 2007 |
| 5077 | Transport Layer Security (TLS) Session Resumption without Server-Side StateJ. Salowey, H. Zhou, P. Eronen, H. Tschofenig · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | January 2008 |
| 5056 | On the Use of Channel Bindings to Secure ChannelsN. Williams | Proposed Standard | November 2007 |
| 5055 | Server-Based Certificate Validation Protocol (SCVP)T. Freeman, R. Housley, A. Malpani, D. Cooper, W. Polk | Proposed Standard | December 2007 |
| 5054 | Using the Secure Remote Password (SRP) Protocol for TLS AuthenticationD. Taylor, T. Wu, N. Mavrogiannopoulos, T. Perrin | Informational | November 2007 |
| 5049 | Applying Signaling Compression (SigComp) to the Session Initiation Protocol (SIP)C. Bormann, Z. Liu, R. Price, G. Camarillo, Ed. | Proposed Standard | December 2007 |
| 5045 | Applicability of Remote Direct Memory Access Protocol (RDMA) and Direct Data Placement (DDP)C. Bestler, Ed., L. Coene | Informational | October 2007 |
| 5042 | Direct Data Placement Protocol (DDP) / Remote Direct Memory Access Protocol (RDMAP) SecurityJ. Pinkerton, E. Deleganes | Proposed Standard | October 2007 |
| 5041 | Direct Data Placement over Reliable TransportsH. Shah, J. Pinkerton, R. Recio, P. Culley | Proposed Standard | October 2007 |
| 5040 | A Remote Direct Memory Access Protocol SpecificationR. Recio, B. Metzler, P. Culley, J. Hilland, D. Garcia | Proposed Standard | October 2007 |
| 5039 | The Session Initiation Protocol (SIP) and SpamJ. Rosenberg, C. Jennings | Informational | January 2008 |
| 5034 | The Post Office Protocol (POP3) Simple Authentication and Security Layer (SASL) Authentication MechanismR. Siemborski, A. Menon-Sen | Proposed Standard | July 2007 |
| 5024 | ODETTE File Transfer Protocol 2.0I. Friend | Informational | November 2007 |
| 5023 | The Atom Publishing ProtocolJ. Gregorio, Ed., B. de hOra, Ed. | Proposed Standard | October 2007 |
| 5019 | The Lightweight Online Certificate Status Protocol (OCSP) Profile for High-Volume EnvironmentsA. Deacon, R. Hurst · obsoleted by RFC 9919 | Proposed Standard | September 2007 |
| 5018 | Connection Establishment in the Binary Floor Control Protocol (BFCP)G. Camarillo | Proposed Standard | September 2007 |
| 5005 | Feed Paging and ArchivingM. Nottingham | Proposed Standard | September 2007 |
| 4992 | XML Pipelining with Chunks for the Internet Registry Information ServiceA. Newton | Proposed Standard | August 2007 |
| 4978 | The IMAP COMPRESS ExtensionA. Gulbrandsen | Proposed Standard | August 2007 |
| 4976 | Relay Extensions for the Message Sessions Relay Protocol (MSRP)C. Jennings, R. Mahy, A. B. Roach | Proposed Standard | September 2007 |
| 4975 | The Message Session Relay Protocol (MSRP)B. Campbell, Ed., R. Mahy, Ed., C. Jennings, Ed. | Proposed Standard | September 2007 |
| 4964 | The P-Answer-State Header Extension to the Session Initiation Protocol for the Open Mobile Alliance Push to Talk over CellularA. Allen, Ed., J. Holm, T. Hallin | Informational | September 2007 |
| 4959 | IMAP Extension for Simple Authentication and Security Layer (SASL) Initial Client ResponseR. Siemborski, A. Gulbrandsen | Proposed Standard | September 2007 |
| 4954 | SMTP Service Extension for AuthenticationR. Siemborski, Ed., A. Melnikov, Ed. | Proposed Standard | July 2007 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 4947 | Address Resolution Mechanisms for IP Datagrams over MPEG-2 NetworksG. Fairhurst, M. Montpetit | Informational | July 2007 |
| 4934 | Extensible Provisioning Protocol (EPP) Transport Over TCPS. Hollenbeck · obsoleted by RFC 5734 | Draft Standard | May 2007 |
| 4867 | RTP Payload Format and File Storage Format for the Adaptive Multi-Rate (AMR) and Adaptive Multi-Rate Wideband (AMR-WB) Audio CodecsJ. Sjoberg, M. Westerlund, A. Lakaniemi, Q. Xie | Proposed Standard | April 2007 |
| 4851 | The Flexible Authentication via Secure Tunneling Extensible Authentication Protocol Method (EAP-FAST)N. Cam-Winget, D. McGrew, J. Salowey, H. Zhou | Informational | May 2007 |
| 4823 | FTP Transport for Secure Peer-to-Peer Business Data Interchange over the InternetT. Harding, R. Scott | Informational | April 2007 |
| 4796 | The Session Description Protocol (SDP) Content AttributeJ. Hautakorpi, G. Camarillo | Proposed Standard | February 2007 |
| 4791 | Calendaring Extensions to WebDAV (CalDAV)C. Daboo, B. Desruisseaux, L. Dusseault | Proposed Standard | March 2007 |
| 4785 | Pre-Shared Key (PSK) Ciphersuites with NULL Encryption for Transport Layer Security (TLS)U. Blumenthal, P. Goel | Proposed Standard | January 2007 |
| 4744 | Using the NETCONF Protocol over the Blocks Extensible Exchange Protocol (BEEP)E. Lear, K. Crozier | Historic | December 2006 |
| 4743 | Using NETCONF over the Simple Object Access Protocol (SOAP)T. Goddard | Historic | December 2006 |
| 4741 | NETCONF Configuration ProtocolR. Enns, Ed. · obsoleted by RFC 6241 | Proposed Standard | December 2006 |
| 4740 | Diameter Session Initiation Protocol (SIP) ApplicationM. Garcia-Martin, Ed., M. Belinchon, M. Pallares-Lopez, C. Canales-Valenzuela, K. Tammi | Proposed Standard | November 2006 |
| 4732 | Internet Denial-of-Service ConsiderationsM. Handley, Ed., E. Rescorla, Ed., IAB | Informational | December 2006 |
| 4712 | Transport Mappings for Real-time Application Quality-of-Service Monitoring (RAQMON) Protocol Data Unit (PDU)A. Siddiqui, D. Romascanu, E. Golovinsky, M. Rahman, Y. Kim | Proposed Standard | October 2006 |
| 4681 | TLS User Mapping ExtensionS. Santesson, A. Medvinsky, J. Ball | Proposed Standard | October 2006 |
| 4680 | TLS Handshake Message for Supplemental DataS. Santesson | Proposed Standard | October 2006 |
| 4650 | HMAC-Authenticated Diffie-Hellman for Multimedia Internet KEYing (MIKEY)M. Euchner | Proposed Standard | September 2006 |
| 4642 | Using Transport Layer Security (TLS) with Network News Transfer Protocol (NNTP)K. Murchison, J. Vinocur, C. Newman | Proposed Standard | October 2006 |
| 4616 | The PLAIN Simple Authentication and Security Layer (SASL) MechanismK. Zeilenga, Ed. | Proposed Standard | August 2006 |
| 4590 | RADIUS Extension for Digest AuthenticationB. Sterman, D. Sadolevsky, D. Schwartz, D. Williams, W. Beck · obsoleted by RFC 5090 | Proposed Standard | July 2006 |
| 4582 | The Binary Floor Control Protocol (BFCP)G. Camarillo, J. Ott, K. Drage · obsoleted by RFC 8855 | Proposed Standard | November 2006 |
| 4572 | Connection-Oriented Media Transport over the Transport Layer Security (TLS) Protocol in the Session Description Protocol (SDP)J. Lennox · obsoleted by RFC 8122 | Proposed Standard | July 2006 |
| 4540 | NEC's Simple Middlebox Configuration (SIMCO) Protocol Version 3.0M. Stiemerling, J. Quittek, C. Cadar | Experimental | May 2006 |
| 4531 | Lightweight Directory Access Protocol (LDAP) Turn OperationK. Zeilenga | Experimental | June 2006 |
| 4521 | Considerations for Lightweight Directory Access Protocol (LDAP) ExtensionsK. Zeilenga | Best Current Practice | June 2006 |
| 4513 | Lightweight Directory Access Protocol (LDAP): Authentication Methods and Security MechanismsR. Harrison, Ed. | Proposed Standard | June 2006 |
| 4511 | Lightweight Directory Access Protocol (LDAP): The ProtocolJ. Sermersheim, Ed. | Proposed Standard | June 2006 |
| 4507 | Transport Layer Security (TLS) Session Resumption without Server-Side StateJ. Salowey, H. Zhou, P. Eronen, H. Tschofenig · obsoleted by RFC 5077 | Proposed Standard | May 2006 |
| 4492 | Elliptic Curve Cryptography (ECC) Cipher Suites for Transport Layer Security (TLS)S. Blake-Wilson, N. Bolyard, V. Gupta, C. Hawk, B. Moeller · obsoleted by RFC 8422 | Informational | May 2006 |
| 4422 | Simple Authentication and Security Layer (SASL)A. Melnikov, Ed., K. Zeilenga, Ed. | Proposed Standard | June 2006 |
| 4366 | Transport Layer Security (TLS) ExtensionsS. Blake-Wilson, M. Nystrom, D. Hopwood, J. Mikkelsen, T. Wright · obsoleted by RFC 5246, RFC 6066 | Proposed Standard | April 2006 |
| 4347 | Datagram Transport Layer SecurityE. Rescorla, N. Modadugu · obsoleted by RFC 6347 | Historic | April 2006 |