| 9911 | Common YANG Data TypesJ. Schönwälder, Ed. | Proposed Standard | December 2025 |
| 9897 | Datagram Congestion Control Protocol (DCCP) Extensions for Multipath Operation with Multiple AddressesM. Amend, Ed., A. Brunstrom, A. Kassler, V. Rakocevic, S. Johnson | Proposed Standard | January 2026 |
| 9870 | Export of UDP Options Information in IP Flow Information Export (IPFIX)M. Boucadair, T. Reddy.K | Proposed Standard | October 2025 |
| 9868 | Transport Options for UDPJ. Touch, C. Heard, Ed. | Proposed Standard | October 2025 |
| 9743 | Specifying New Congestion Control AlgorithmsM. Duke, Ed., G. Fairhurst, Ed. | Best Current Practice | March 2025 |
| 9710 | Simple Fixes to the IP Flow Information Export (IPFIX) Entities IANA RegistryM. Boucadair, B. Claise | Proposed Standard | February 2025 |
| 9693 | Benchmarking Methodology for Stateful NATxy GatewaysG. Lencse, K. Shima | Informational | January 2025 |
| 9522 | Overview and Principles of Internet Traffic EngineeringA. Farrel, Ed. | Informational | January 2024 |
| 9331 | The Explicit Congestion Notification (ECN) Protocol for Low Latency, Low Loss, and Scalable Throughput (L4S)K. De Schepper, B. Briscoe, Ed. | Experimental | January 2023 |
| 9330 | Low Latency, Low Loss, and Scalable Throughput (L4S) Internet Service: ArchitectureB. Briscoe, Ed., K. De Schepper, M. Bagnulo, G. White | Informational | January 2023 |
| 9265 | Forward Erasure Correction (FEC) Coding and Congestion Control in TransportN. Kuhn, E. Lochin, F. Michel, M. Welzl | Informational | July 2022 |
| 9147 | The Datagram Transport Layer Security (DTLS) Protocol Version 1.3E. Rescorla, H. Tschofenig, N. Modadugu | Proposed Standard | April 2022 |
| 9132 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationM. Boucadair, Ed., J. Shallow, T. Reddy.K | Proposed Standard | September 2021 |
| 9066 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel Call HomeT. Reddy.K, M. Boucadair, Ed., J. Shallow | Proposed Standard | December 2021 |
| 9064 | Considerations in the Development of a QoS Architecture for CCNx-Like Information-Centric Networking ProtocolsD. Oran | Informational | June 2021 |
| 9040 | TCP Control Block InterdependenceJ. Touch, M. Welzl, S. Islam | Informational | July 2021 |
| 8900 | IP Fragmentation Considered FragileR. Bonica, F. Baker, G. Huston, R. Hinden, O. Troan, F. Gont | Best Current Practice | September 2020 |
| 8899 | Packetization Layer Path MTU Discovery for Datagram TransportsG. Fairhurst, T. Jones, M. Tüxen, I. Rüngeler, T. Völker | Proposed Standard | September 2020 |
| 8783 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Data Channel SpecificationM. Boucadair, Ed., T. Reddy.K, Ed. | Proposed Standard | May 2020 |
| 8782 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationT. Reddy.K, Ed., M. Boucadair, Ed., P. Patil, A. Mortensen, N. Teague · obsoleted by RFC 9132 | Proposed Standard | May 2020 |
| 8201 | Path MTU Discovery for IP version 6J. McCann, S. Deering, J. Mogul, R. Hinden, Ed. | Internet Standard | July 2017 |
| 8126 | Guidelines for Writing an IANA Considerations Section in RFCsM. Cotton, B. Leiba, T. Narten | Best Current Practice | June 2017 |
| 8095 | Services Provided by IETF Transport Protocols and Congestion Control MechanismsG. Fairhurst, Ed., B. Trammell, Ed., M. Kuehlewind, Ed. | Informational | March 2017 |
| 8087 | The Benefits of Using Explicit Congestion Notification (ECN)G. Fairhurst, M. Welzl | Informational | March 2017 |
| 8085 | UDP Usage GuidelinesL. Eggert, G. Fairhurst, G. Shepherd | Best Current Practice | March 2017 |
| 8045 | RADIUS Extensions for IP Port Configuration and ReportingD. Cheng, J. Korhonen, M. Boucadair, S. Sivakumar | Proposed Standard | January 2017 |
| 7915 | IP/ICMP Translation AlgorithmC. Bao, X. Li, F. Baker, T. Anderson, F. Gont | Proposed Standard | June 2016 |
| 7825 | A Network Address Translator (NAT) Traversal Mechanism for Media Controlled by the Real-Time Streaming Protocol (RTSP)J. Goldberg, M. Westerlund, T. Zeng | Proposed Standard | December 2016 |
| 7657 | Differentiated Services (Diffserv) and Real-Time CommunicationD. Black, Ed., P. Jones | Informational | November 2015 |
| 7605 | Recommendations on Using Assigned Transport Port NumbersJ. Touch | Best Current Practice | August 2015 |
| 7567 | IETF Recommendations Regarding Active Queue ManagementF. Baker, Ed., G. Fairhurst, Ed. | Best Current Practice | July 2015 |
| 7414 | A Roadmap for Transmission Control Protocol (TCP) Specification DocumentsM. Duke, R. Braden, W. Eddy, E. Blanton, A. Zimmermann | Informational | February 2015 |
| 7325 | MPLS Forwarding Compliance and Performance RequirementsC. Villamizar, Ed., K. Kompella, S. Amante, A. Malis, C. Pignataro | Informational | August 2014 |
| 7202 | Securing the RTP Framework: Why RTP Does Not Mandate a Single Media Security SolutionC. Perkins, M. Westerlund | Informational | April 2014 |
| 7122 | Datagram Convergence Layers for the Delay- and Disruption-Tolerant Networking (DTN) Bundle Protocol and Licklider Transmission Protocol (LTP)H. Kruse, S. Jero, S. Ostermann | Experimental | March 2014 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 6940 | REsource LOcation And Discovery (RELOAD) Base ProtocolC. Jennings, B. Lowekamp, Ed., E. Rescorla, S. Baset, H. Schulzrinne | Proposed Standard | January 2014 |
| 6915 | Flow Identity Extension for HTTP-Enabled Location Delivery (HELD)R. Bellis | Proposed Standard | April 2013 |
| 6887 | Port Control Protocol (PCP)D. Wing, Ed., S. Cheshire, M. Boucadair, R. Penno, P. Selkirk | Proposed Standard | April 2013 |
| 6773 | DCCP-UDP: A Datagram Congestion Control Protocol UDP Encapsulation for NAT TraversalT. Phelan, G. Fairhurst, C. Perkins | Proposed Standard | November 2012 |
| 6763 | DNS-Based Service DiscoveryS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6679 | Explicit Congestion Notification (ECN) for RTP over UDPM. Westerlund, I. Johansson, C. Perkins, P. O'Hanlon, K. Carlberg | Proposed Standard | August 2012 |
| 6633 | Deprecation of ICMP Source Quench MessagesF. Gont | Proposed Standard | May 2012 |
| 6574 | Report from the Smart Object WorkshopH. Tschofenig, J. Arkko | Informational | April 2012 |
| 6347 | Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147 | Proposed Standard | January 2012 |
| 6335 | Internet Assigned Numbers Authority (IANA) Procedures for the Management of the Service Name and Transport Protocol Port Number RegistryM. Cotton, L. Eggert, J. Touch, M. Westerlund, S. Cheshire | Best Current Practice | August 2011 |
| 6323 | Sender RTT Estimate Option for the Datagram Congestion Control Protocol (DCCP)G. Renker, G. Fairhurst | Proposed Standard | July 2011 |
| 6272 | Internet Protocols for the Smart GridF. Baker, D. Meyer | Informational | June 2011 |
| 6155 | Use of Device Identity in HTTP-Enabled Location Delivery (HELD)J. Winterbottom, M. Thomson, H. Tschofenig, R. Barnes | Proposed Standard | March 2011 |
| 6145 | IP/ICMP Translation AlgorithmX. Li, C. Bao, F. Baker · obsoleted by RFC 7915 | Proposed Standard | April 2011 |
| 6092 | Recommended Simple Security Capabilities in Customer Premises Equipment (CPE) for Providing Residential IPv6 Internet ServiceJ. Woodyatt, Ed. | Informational | January 2011 |
| 6077 | Open Research Issues in Internet Congestion ControlD. Papadimitriou, Ed., M. Welzl, M. Scharf, B. Briscoe | Informational | February 2011 |
| 6056 | Recommendations for Transport-Protocol Port RandomizationM. Larsen, F. Gont | Best Current Practice | January 2011 |
| 6021 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 6991 | Proposed Standard | October 2010 |
| 6013 | TCP Cookie Transactions (TCPCT)W. Simpson · obsoleted by RFC 7805 | Historic | January 2011 |
| 6012 | Datagram Transport Layer Security (DTLS) Transport Mapping for SyslogJ. Salowey, T. Petch, R. Gerhards, H. Feng | Proposed Standard | October 2010 |
| 5887 | Renumbering Still Needs WorkB. Carpenter, R. Atkinson, H. Flinck | Informational | May 2010 |
| 5783 | Congestion Control in the RFC SeriesM. Welzl, W. Eddy | Informational | February 2010 |
| 5762 | RTP and the Datagram Congestion Control Protocol (DCCP)C. Perkins | Proposed Standard | April 2010 |
| 5690 | Adding Acknowledgement Congestion Control to TCPS. Floyd, A. Arcia, D. Ros, J. Iyengar | Informational | February 2010 |
| 5634 | Quick-Start for the Datagram Congestion Control Protocol (DCCP)G. Fairhurst, A. Sathiaseelan | Experimental | August 2009 |
| 5626 | Managing Client-Initiated Connections in the Session Initiation Protocol (SIP)C. Jennings, Ed., R. Mahy, Ed., F. Audet, Ed. | Proposed Standard | October 2009 |
| 5622 | Profile for Datagram Congestion Control Protocol (DCCP) Congestion ID 4: TCP-Friendly Rate Control for Small Packets (TFRC-SP)S. Floyd, E. Kohler | Experimental | August 2009 |
| 5597 | Network Address Translation (NAT) Behavioral Requirements for the Datagram Congestion Control ProtocolR. Denis-Courmont | Best Current Practice | September 2009 |
| 5596 | Datagram Congestion Control Protocol (DCCP) Simultaneous-Open Technique to Facilitate NAT/Middlebox TraversalG. Fairhurst | Proposed Standard | September 2009 |
| 5595 | The Datagram Congestion Control Protocol (DCCP) Service CodesG. Fairhurst | Proposed Standard | September 2009 |
| 5405 | Unicast UDP Usage Guidelines for Application DesignersL. Eggert, G. Fairhurst · obsoleted by RFC 8085 | Best Current Practice | November 2008 |
| 5348 | TCP Friendly Rate Control (TFRC): Protocol SpecificationS. Floyd, M. Handley, J. Padhye, J. Widmer | Proposed Standard | September 2008 |
| 5245 | Interactive Connectivity Establishment (ICE): A Protocol for Network Address Translator (NAT) Traversal for Offer/Answer ProtocolsJ. Rosenberg · obsoleted by RFC 8445, RFC 8839 | Proposed Standard | April 2010 |
| 5238 | Datagram Transport Layer Security (DTLS) over the Datagram Congestion Control Protocol (DCCP)T. Phelan | Proposed Standard | May 2008 |
| 5226 | Guidelines for Writing an IANA Considerations Section in RFCsT. Narten, H. Alvestrand · obsoleted by RFC 8126 | Best Current Practice | May 2008 |
| 5129 | Explicit Congestion Marking in MPLSB. Davie, B. Briscoe, J. Tay | Proposed Standard | January 2008 |
| 5104 | Codec Control Messages in the RTP Audio-Visual Profile with Feedback (AVPF)S. Wenger, U. Chandra, M. Westerlund, B. Burman | Proposed Standard | February 2008 |
| 5097 | MIB for the UDP-Lite protocolG. Renker, G. Fairhurst | Proposed Standard | January 2008 |
| 5033 | Specifying New Congestion Control AlgorithmsS. Floyd, M. Allman · obsoleted by RFC 9743 | Best Current Practice | August 2007 |
| 4953 | Defending TCP Against Spoofing AttacksJ. Touch | Informational | July 2007 |
| 4907 | Architectural Implications of Link IndicationsB. Aboba, Ed. | Informational | June 2007 |
| 4828 | TCP Friendly Rate Control (TFRC): The Small-Packet (SP) VariantS. Floyd, E. Kohler | Experimental | April 2007 |
| 4821 | Packetization Layer Path MTU DiscoveryM. Mathis, J. Heffner | Proposed Standard | March 2007 |
| 4782 | Quick-Start for TCP and IPS. Floyd, M. Allman, A. Jain, P. Sarolahti | Experimental | January 2007 |
| 4774 | Specifying Alternate Semantics for the Explicit Congestion Notification (ECN) FieldS. Floyd | Best Current Practice | November 2006 |
| 4737 | Packet Reordering MetricsA. Morton, L. Ciavattone, G. Ramachandran, S. Shalunov, J. Perser | Proposed Standard | November 2006 |
| 4585 | Extended RTP Profile for Real-time Transport Control Protocol (RTCP)-Based Feedback (RTP/AVPF)J. Ott, S. Wenger, N. Sato, C. Burmeister, J. Rey | Proposed Standard | July 2006 |
| 4342 | Profile for Datagram Congestion Control Protocol (DCCP) Congestion Control ID 3: TCP-Friendly Rate Control (TFRC)S. Floyd, E. Kohler, J. Padhye | Proposed Standard | April 2006 |
| 4341 | Profile for Datagram Congestion Control Protocol (DCCP) Congestion Control ID 2: TCP-like Congestion ControlS. Floyd, E. Kohler | Proposed Standard | March 2006 |
| 4336 | Problem Statement for the Datagram Congestion Control Protocol (DCCP)S. Floyd, M. Handley, E. Kohler | Informational | March 2006 |