| 10015 | Deprecating Obsolete Key Exchange Methods in TLS 1.2 and DTLS 1.2N. Aviram | Proposed Standard | July 2026 |
| 9813 | Operational Considerations for Using TLS Pre-Shared Keys (TLS-PSKs) with RADIUSA. DeKok | Best Current Practice | July 2025 |
| 9645 | YANG Groupings for TLS Clients and TLS ServersK. Watsen | Proposed Standard | October 2024 |
| 9257 | Guidance for External Pre-Shared Key (PSK) Usage in TLSR. Housley, J. Hoyland, M. Sethi, C. A. Wood | Informational | July 2022 |
| 9202 | Datagram Transport Layer Security (DTLS) Profile for Authentication and Authorization for Constrained Environments (ACE)S. Gerdes, O. Bergmann, C. Bormann, G. Selander, L. Seitz | Proposed Standard | August 2022 |
| 9132 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationM. Boucadair, Ed., J. Shallow, T. Reddy.K | Proposed Standard | September 2021 |
| 8996 | Deprecating TLS 1.0 and TLS 1.1K. Moriarty, S. Farrell | Best Current Practice | March 2021 |
| 8803 | 0-RTT TCP Convert ProtocolO. Bonaventure, Ed., M. Boucadair, Ed., S. Gundavelli, S. Seo, B. Hesmans | Experimental | July 2020 |
| 8782 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationT. Reddy.K, Ed., M. Boucadair, Ed., P. Patil, A. Mortensen, N. Teague · obsoleted by RFC 9132 | Proposed Standard | May 2020 |
| 8442 | ECDHE_PSK with AES-GCM and AES-CCM Cipher Suites for TLS 1.2 and DTLS 1.2J. Mattsson, D. Migault | Proposed Standard | September 2018 |
| 8075 | Guidelines for Mapping Implementations: HTTP to the Constrained Application Protocol (CoAP)A. Castellani, S. Loreto, A. Rahman, T. Fossati, E. Dijk | Proposed Standard | February 2017 |
| 7978 | Transparent Interconnection of Lots of Links (TRILL): RBridge Channel Header ExtensionD. Eastlake 3rd, M. Umair, Y. Li | Proposed Standard | September 2016 |
| 7925 | Transport Layer Security (TLS) / Datagram Transport Layer Security (DTLS) Profiles for the Internet of ThingsH. Tschofenig, Ed., T. Fossati | Proposed Standard | July 2016 |
| 7733 | Applicability Statement: The Use of the Routing Protocol for Low-Power and Lossy Networks (RPL) Protocol Suite in Home Automation and Building ControlA. Brandt, E. Baccelli, R. Cragie, P. van der Stok | Proposed Standard | February 2016 |
| 7593 | The eduroam Architecture for Network RoamingK. Wierenga, S. Winter, T. Wolniewicz | Informational | September 2015 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 6940 | REsource LOcation And Discovery (RELOAD) Base ProtocolC. Jennings, B. Lowekamp, Ed., E. Rescorla, S. Baset, H. Schulzrinne | Proposed Standard | January 2014 |
| 6885 | Stringprep Revision and Problem Statement for the Preparation and Comparison of Internationalized Strings (PRECIS)M. Blanchet, A. Sullivan | Informational | March 2013 |
| 6655 | AES-CCM Cipher Suites for Transport Layer Security (TLS)D. McGrew, D. Bailey | Proposed Standard | July 2012 |
| 6618 | Mobile IPv6 Security Framework Using Transport Layer Security for Communication between the Mobile Node and Home AgentJ. Korhonen, Ed., B. Patil, H. Tschofenig, D. Kroeselberg | Experimental | May 2012 |
| 6614 | Transport Layer Security (TLS) Encryption for RADIUSS. Winter, M. McCauley, S. Venaas, K. Wierenga | Experimental | May 2012 |
| 6545 | Real-time Inter-network Defense (RID)K. Moriarty | Proposed Standard | April 2012 |
| 6434 | IPv6 Node RequirementsE. Jankiewicz, J. Loughney, T. Narten · obsoleted by RFC 8504 | Informational | December 2011 |
| 6367 | Addition of the Camellia Cipher Suites to Transport Layer Security (TLS)S. Kanno, M. Kanda | Informational | September 2011 |
| 6347 | Datagram Transport Layer Security Version 1.2E. Rescorla, N. Modadugu · obsoleted by RFC 9147 | Proposed Standard | January 2012 |
| 6209 | Addition of the ARIA Cipher Suites to Transport Layer Security (TLS)W. Kim, J. Lee, J. Park, D. Kwon | Informational | April 2011 |
| 6045 | Real-time Inter-network Defense (RID)K. Moriarty · obsoleted by RFC 6545 | Informational | November 2010 |
| 5971 | GIST: General Internet Signalling TransportH. Schulzrinne, R. Hancock | Experimental | October 2010 |
| 5489 | ECDHE_PSK Cipher Suites for Transport Layer Security (TLS)M. Badra, I. Hajjeh | Informational | March 2009 |
| 5487 | Pre-Shared Key Cipher Suites for TLS with SHA-256/384 and AES Galois Counter ModeM. Badra | Proposed Standard | March 2009 |
| 5415 | Control And Provisioning of Wireless Access Points (CAPWAP) Protocol SpecificationP. Calhoun, Ed., M. Montemurro, Ed., D. Stanley, Ed. | Proposed Standard | March 2009 |
| 5077 | Transport Layer Security (TLS) Session Resumption without Server-Side StateJ. Salowey, H. Zhou, P. Eronen, H. Tschofenig · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | January 2008 |
| 5054 | Using the Secure Remote Password (SRP) Protocol for TLS AuthenticationD. Taylor, T. Wu, N. Mavrogiannopoulos, T. Perrin | Informational | November 2007 |
| 5018 | Connection Establishment in the Binary Floor Control Protocol (BFCP)G. Camarillo | Proposed Standard | September 2007 |
| 4785 | Pre-Shared Key (PSK) Ciphersuites with NULL Encryption for Transport Layer Security (TLS)U. Blumenthal, P. Goel | Proposed Standard | January 2007 |
| 4764 | The EAP-PSK Protocol: A Pre-Shared Key Extensible Authentication Protocol (EAP) MethodF. Bersani, H. Tschofenig | Experimental | January 2007 |
| 4712 | Transport Mappings for Real-time Application Quality-of-Service Monitoring (RAQMON) Protocol Data Unit (PDU)A. Siddiqui, D. Romascanu, E. Golovinsky, M. Rahman, Y. Kim | Proposed Standard | October 2006 |
| 4507 | Transport Layer Security (TLS) Session Resumption without Server-Side StateJ. Salowey, H. Zhou, P. Eronen, H. Tschofenig · obsoleted by RFC 5077 | Proposed Standard | May 2006 |