| 1350 | The TFTP Protocol (Revision 2)K. Sollins | Internet Standard | July 1992 |
| 1497 | BOOTP Vendor Information ExtensionsJ. Reynolds · obsoleted by RFC 1533 | Draft Standard | August 1993 |
| 1534 | Interoperation Between DHCP and BOOTPR. Droms | Draft Standard | October 1993 |
| 1542 | Clarifications and Extensions for the Bootstrap ProtocolW. Wimer | Draft Standard | October 1993 |
| 1931 | Dynamic RARP Extensions for Automatic Network Address AcquisitionD. Brownell | Informational | April 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2132 | DHCP Options and BOOTP Vendor ExtensionsS. Alexander, R. Droms | Draft Standard | March 1997 |
| 2396 | Uniform Resource Identifiers (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter · obsoleted by RFC 3986 | Draft Standard | August 1998 |
| 2608 | Service Location Protocol, Version 2E. Guttman, C. Perkins, J. Veizades, M. Day | Proposed Standard | June 1999 |
| 2732 | Format for Literal IPv6 Addresses in URL'sR. Hinden, B. Carpenter, L. Masinter · obsoleted by RFC 3986 | Proposed Standard | December 1999 |
| 3118 | Authentication for DHCP MessagesR. Droms, Ed., W. Arbaugh, Ed. | Proposed Standard | June 2001 |
| 3315 | Dynamic Host Configuration Protocol for IPv6 (DHCPv6)R. Droms, Ed., J. Bound, B. Volz, T. Lemon, C. Perkins, M. Carney · obsoleted by RFC 8415 | Proposed Standard | July 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 3720 | Internet Small Computer Systems Interface (iSCSI)J. Satran, K. Meth, C. Sapuntzakis, M. Chadalapaka, E. Zeidner · obsoleted by RFC 7143 | Proposed Standard | April 2004 |
| 3722 | String Profile for Internet Small Computer Systems Interface (iSCSI) NamesM. Bakke | Proposed Standard | April 2004 |
| 3723 | Securing Block Storage Protocols over IPB. Aboba, J. Tseng, J. Walker, V. Rangan, F. Travostino | Proposed Standard | April 2004 |
| 4018 | Finding Internet Small Computer Systems Interface (iSCSI) Targets and Name Servers by Using Service Location Protocol version 2 (SLPv2)M. Bakke, J. Hufferd, K. Voruganti, M. Krueger, T. Sperry | Proposed Standard | May 2005 |
| 4171 | Internet Storage Name Service (iSNS)J. Tseng, K. Gibbons, F. Travostino, C. Du Laney, J. Souza | Proposed Standard | September 2005 |