| 977 | Network News Transfer ProtocolB. Kantor, P. Lapsley · obsoleted by RFC 3977 | Proposed Standard | February 1986 |
| 1421 | Privacy Enhancement for Internet Electronic Mail: Part I: Message Encryption and Authentication ProceduresJ. Linn | Historic | February 1993 |
| 1422 | Privacy Enhancement for Internet Electronic Mail: Part II: Certificate-Based Key ManagementS. Kent | Historic | February 1993 |
| 1423 | Privacy Enhancement for Internet Electronic Mail: Part III: Algorithms, Modes, and IdentifiersD. Balenson | Historic | February 1993 |
| 1424 | Privacy Enhancement for Internet Electronic Mail: Part IV: Key Certification and Related ServicesB. Kaliski | Historic | February 1993 |
| 1750 | Randomness Recommendations for SecurityD. Eastlake 3rd, S. Crocker, J. Schiller · obsoleted by RFC 4086 | Informational | December 1994 |
| 1948 | Defending Against Sequence Number AttacksS. Bellovin · obsoleted by RFC 6528 | Informational | May 1996 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2246 | The TLS Protocol Version 1.0T. Dierks, C. Allen · obsoleted by RFC 4346 | Historic | January 1999 |
| 2401 | Security Architecture for the Internet ProtocolS. Kent, R. Atkinson · obsoleted by RFC 4301 | Proposed Standard | November 1998 |
| 2440 | OpenPGP Message FormatJ. Callas, L. Donnerhacke, H. Finney, R. Thayer · obsoleted by RFC 4880 | Proposed Standard | November 1998 |
| 2631 | Diffie-Hellman Key Agreement MethodE. Rescorla | Proposed Standard | June 1999 |
| 2632 | S/MIME Version 3 Certificate HandlingB. Ramsdell, Ed. · obsoleted by RFC 3850 | Proposed Standard | June 1999 |
| 2633 | S/MIME Version 3 Message SpecificationB. Ramsdell, Ed. · obsoleted by RFC 3851 | Proposed Standard | June 1999 |
| 2634 | Enhanced Security Services for S/MIMEP. Hoffman, Ed. | Proposed Standard | June 1999 |
| 2980 | Common NNTP ExtensionsS. Barber | Informational | October 2000 |
| 3156 | MIME Security with OpenPGPM. Elkins, D. Del Torto, R. Levien, T. Roessler | Proposed Standard | August 2001 |
| 3174 | US Secure Hash Algorithm 1 (SHA1)D. Eastlake 3rd, P. Jones | Informational | September 2001 |
| 3766 | Determining Strengths For Public Keys Used For Exchanging Symmetric KeysH. Orman, P. Hoffman | Best Current Practice | April 2004 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4034 | Resource Records for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4035 | Protocol Modifications for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |