| 9474 | RSA Blind SignaturesF. Denis, F. Jacobs, C. A. Wood | Informational | October 2023 |
| 9231 | Additional XML Security Uniform Resource Identifiers (URIs)D. Eastlake 3rd | Proposed Standard | July 2022 |
| 8881 | Network File System (NFS) Version 4 Minor Version 1 ProtocolD. Noveck, Ed., C. Lever | Proposed Standard | August 2020 |
| 8756 | Commercial National Security Algorithm (CNSA) Suite Profile of Certificate Management over CMSM. Jenkins, L. Zieglar | Informational | March 2020 |
| 8755 | Using Commercial National Security Algorithm Suite Algorithms in Secure/Multipurpose Internet Mail ExtensionsM. Jenkins | Informational | March 2020 |
| 8702 | Use of the SHAKE One-Way Hash Functions in the Cryptographic Message Syntax (CMS)P. Kampanakis, Q. Dang | Proposed Standard | January 2020 |
| 8692 | Internet X.509 Public Key Infrastructure: Additional Algorithm Identifiers for RSASSA-PSS and ECDSA Using SHAKEsP. Kampanakis, Q. Dang | Proposed Standard | December 2019 |
| 8603 | Commercial National Security Algorithm (CNSA) Suite Certificate and Certificate Revocation List (CRL) ProfileM. Jenkins, L. Zieglar | Informational | May 2019 |
| 8550 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Certificate HandlingJ. Schaad, B. Ramsdell, S. Turner | Proposed Standard | April 2019 |
| 8410 | Algorithm Identifiers for Ed25519, Ed448, X25519, and X448 for Use in the Internet X.509 Public Key InfrastructureS. Josefsson, J. Schaad | Proposed Standard | August 2018 |
| 8122 | Connection-Oriented Media Transport over the Transport Layer Security (TLS) Protocol in the Session Description Protocol (SDP)J. Lennox, C. Holmberg | Proposed Standard | March 2017 |
| 7935 | The Profile for Algorithms and Key Sizes for Use in the Resource Public Key InfrastructureG. Huston, G. Michaelson, Ed. | Proposed Standard | August 2016 |
| 7670 | Generic Raw Public-Key Support for IKEv2T. Kivinen, P. Wouters, H. Tschofenig | Proposed Standard | January 2016 |
| 7427 | Signature Authentication in the Internet Key Exchange Version 2 (IKEv2)T. Kivinen, J. Snyder | Proposed Standard | January 2015 |
| 7299 | Object Identifier Registry for the PKIX Working GroupR. Housley | Informational | July 2014 |
| 6960 | X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSPS. Santesson, M. Myers, R. Ankney, A. Malpani, S. Galperin, C. Adams | Proposed Standard | June 2013 |
| 6931 | Additional XML Security Uniform Resource Identifiers (URIs)D. Eastlake 3rd · obsoleted by RFC 9231 | Proposed Standard | April 2013 |
| 6664 | S/MIME Capabilities for Public Key DefinitionsJ. Schaad | Informational | July 2012 |
| 6485 | The Profile for Algorithms and Key Sizes for Use in the Resource Public Key Infrastructure (RPKI)G. Huston · obsoleted by RFC 7935 | Proposed Standard | February 2012 |
| 6277 | Online Certificate Status Protocol Algorithm AgilityS. Santesson, P. Hallam-Baker · obsoleted by RFC 6960 | Proposed Standard | June 2011 |
| 6257 | Bundle Security Protocol SpecificationS. Symington, S. Farrell, H. Weiss, P. Lovell | Experimental | May 2011 |
| 6234 | US Secure Hash Algorithms (SHA and SHA-based HMAC and HKDF)D. Eastlake 3rd, T. Hansen | Informational | May 2011 |
| 5912 | New ASN.1 Modules for the Public Key Infrastructure Using X.509 (PKIX)P. Hoffman, J. Schaad | Informational | June 2010 |
| 5758 | Internet X.509 Public Key Infrastructure: Additional Algorithms and Identifiers for DSA and ECDSAQ. Dang, S. Santesson, K. Moriarty, D. Brown, T. Polk | Proposed Standard | January 2010 |
| 5756 | Updates for RSAES-OAEP and RSASSA-PSS Algorithm ParametersS. Turner, D. Brown, K. Yiu, R. Housley, T. Polk | Proposed Standard | January 2010 |
| 5755 | An Internet Attribute Certificate Profile for AuthorizationS. Farrell, R. Housley, S. Turner | Proposed Standard | January 2010 |
| 5754 | Using SHA2 Algorithms with Cryptographic Message SyntaxS. Turner | Proposed Standard | January 2010 |
| 5753 | Use of Elliptic Curve Cryptography (ECC) Algorithms in Cryptographic Message Syntax (CMS)S. Turner, D. Brown | Informational | January 2010 |
| 5750 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Certificate HandlingB. Ramsdell, S. Turner · obsoleted by RFC 8550 | Proposed Standard | January 2010 |
| 5698 | Data Structure for the Security Suitability of Cryptographic Algorithms (DSSC)T. Kunz, S. Okunick, U. Pordesch | Proposed Standard | November 2009 |
| 5661 | Network File System (NFS) Version 4 Minor Version 1 ProtocolS. Shepler, Ed., M. Eisler, Ed., D. Noveck, Ed. · obsoleted by RFC 8881 | Proposed Standard | January 2010 |
| 5480 | Elliptic Curve Cryptography Subject Public Key InformationS. Turner, D. Brown, K. Yiu, R. Housley, T. Polk | Proposed Standard | March 2009 |
| 5403 | RPCSEC_GSS Version 2M. Eisler | Proposed Standard | February 2009 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5274 | Certificate Management Messages over CMS (CMC): Compliance RequirementsJ. Schaad, M. Myers · obsoleted by RFC 10004 | Proposed Standard | June 2008 |
| 5105 | ENUM Validation Token Format DefinitionO. Lendl | Proposed Standard | December 2007 |
| 5055 | Server-Based Certificate Validation Protocol (SCVP)T. Freeman, R. Housley, A. Malpani, D. Cooper, W. Polk | Proposed Standard | December 2007 |
| 4945 | The Internet IP Security PKI Profile of IKEv1/ISAKMP, IKEv2, and PKIXB. Korver | Proposed Standard | August 2007 |
| 4572 | Connection-Oriented Media Transport over the Transport Layer Security (TLS) Protocol in the Session Description Protocol (SDP)J. Lennox · obsoleted by RFC 8122 | Proposed Standard | July 2006 |
| 4056 | Use of the RSASSA-PSS Signature Algorithm in Cryptographic Message Syntax (CMS)J. Schaad | Proposed Standard | June 2005 |