| 10008 | The HTTP QUERY MethodJ. Reschke, J.M. Snell, M. Bishop | Proposed Standard | June 2026 |
| 9975 | Clarifications on CDS/CDNSKEY and CSYNC ConsistencyP. Thomassen | Proposed Standard | May 2026 |
| 9824 | Compact Denial of Existence in DNSSECS. Huque, C. Elmerot, O. Gudmundsson | Proposed Standard | September 2025 |
| 9715 | IP Fragmentation Avoidance in DNS over UDPK. Fujiwara, P. Vixie | Informational | January 2025 |
| 9704 | Establishing Local DNS Authority in Validated Split-Horizon EnvironmentsT. Reddy.K, D. Wing, K. Smith, B. Schwartz | Proposed Standard | January 2025 |
| 9665 | Service Registration Protocol for DNS-Based Service DiscoveryT. Lemon, S. Cheshire | Proposed Standard | June 2025 |
| 9563 | SM2 Digital Signature Algorithm for DNSSECC. Zhang, Y. Liu, F. Leng, Q. Zhao, Z. He | Informational | December 2024 |
| 9558 | Use of GOST 2012 Signature Algorithms in DNSKEY and RRSIG Resource Records for DNSSECB. Makarenko, V. Dolmatov, Ed. | Informational | April 2024 |
| 9520 | Negative Caching of DNS Resolution FailuresD. Wessels, W. Carroll, M. Thomas | Proposed Standard | December 2023 |
| 9499 | DNS TerminologyP. Hoffman, K. Fujiwara | Best Current Practice | March 2024 |
| 9471 | DNS Glue Requirements in Referral ResponsesM. Andrews, S. Huque, P. Wouters, D. Wessels | Proposed Standard | September 2023 |
| 9364 | DNS Security Extensions (DNSSEC)P. Hoffman | Best Current Practice | February 2023 |
| 9276 | Guidance for NSEC3 Parameter SettingsW. Hardaker, V. Dukhovni | Best Current Practice | August 2022 |
| 9199 | Considerations for Large Authoritative DNS Server OperatorsG. Moura, W. Hardaker, J. Heidemann, M. Davids | Informational | March 2022 |
| 9157 | Revised IANA Considerations for DNSSECP. Hoffman | Proposed Standard | December 2021 |
| 9102 | TLS DNSSEC Chain ExtensionV. Dukhovni, S. Huque, W. Toorop, P. Wouters, M. Shore | Experimental | August 2021 |
| 9077 | NSEC and NSEC3: TTLs and Aggressive UseP. van Dijk | Proposed Standard | July 2021 |
| 8976 | Message Digest for DNS ZonesD. Wessels, P. Barber, M. Weinberg, W. Kumari, W. Hardaker | Proposed Standard | February 2021 |
| 8945 | Secret Key Transaction Authentication for DNS (TSIG)F. Dupont, S. Morris, P. Vixie, D. Eastlake 3rd, O. Gudmundsson, B. Wellington | Internet Standard | November 2020 |
| 8932 | Recommendations for DNS Privacy Service OperatorsS. Dickinson, B. Overeinder, R. van Rijswijk-Deij, A. Mankin | Best Current Practice | October 2020 |
| 8914 | Extended DNS ErrorsW. Kumari, E. Hunt, R. Arends, W. Hardaker, D. Lawrence | Proposed Standard | October 2020 |
| 8906 | A Common Operational Problem in DNS Servers: Failure to CommunicateM. Andrews, R. Bellis | Best Current Practice | September 2020 |
| 8901 | Multi-Signer DNSSEC ModelsS. Huque, P. Aras, J. Dickinson, J. Vcelak, D. Blacka | Informational | September 2020 |
| 8749 | Moving DNSSEC Lookaside Validation (DLV) to Historic StatusW. Mekking, D. Mahoney | Proposed Standard | March 2020 |
| 8689 | SMTP Require TLS OptionJ. Fenton | Proposed Standard | November 2019 |
| 8659 | DNS Certification Authority Authorization (CAA) Resource RecordP. Hallam-Baker, R. Stradling, J. Hoffman-Andrews | Proposed Standard | November 2019 |
| 8509 | A Root Key Trust Anchor Sentinel for DNSSECG. Huston, J. Damas, W. Kumari | Proposed Standard | December 2018 |
| 8504 | IPv6 Node RequirementsT. Chown, J. Loughney, T. Winters | Best Current Practice | January 2019 |
| 8501 | Reverse DNS in IPv6 for Internet Service ProvidersL. Howard | Informational | November 2018 |
| 8499 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 9499 | Best Current Practice | January 2019 |
| 8375 | Special-Use Domain 'home.arpa.'P. Pfister, T. Lemon | Proposed Standard | May 2018 |
| 8198 | Aggressive Use of DNSSEC-Validated CacheK. Fujiwara, A. Kato, W. Kumari | Proposed Standard | July 2017 |
| 8162 | Using Secure DNS to Associate Certificates with Domain Names for S/MIMEP. Hoffman, J. Schlyter | Experimental | May 2017 |
| 8145 | Signaling Trust Anchor Knowledge in DNS Security Extensions (DNSSEC)D. Wessels, W. Kumari, P. Hoffman | Proposed Standard | April 2017 |
| 8080 | Edwards-Curve Digital Security Algorithm (EdDSA) for DNSSECO. Sury, R. Edmonds | Proposed Standard | February 2017 |
| 8027 | DNSSEC Roadblock AvoidanceW. Hardaker, O. Gudmundsson, S. Krishnaswamy | Best Current Practice | November 2016 |
| 8020 | NXDOMAIN: There Really Is Nothing UnderneathS. Bortzmeyer, S. Huque | Proposed Standard | November 2016 |
| 8005 | Host Identity Protocol (HIP) Domain Name System (DNS) ExtensionJ. Laganier | Proposed Standard | October 2016 |
| 7958 | DNSSEC Trust Anchor Publication for the Root ZoneJ. Abley, J. Schlyter, G. Bailey, P. Hoffman · obsoleted by RFC 9718 | Informational | August 2016 |
| 7929 | DNS-Based Authentication of Named Entities (DANE) Bindings for OpenPGPP. Wouters | Experimental | August 2016 |
| 7901 | CHAIN Query Requests in DNSP. Wouters | Experimental | June 2016 |
| 7873 | Domain Name System (DNS) CookiesD. Eastlake 3rd, M. Andrews | Proposed Standard | May 2016 |
| 7871 | Client Subnet in DNS QueriesC. Contavalli, W. van der Gaast, D. Lawrence, W. Kumari | Informational | May 2016 |
| 7849 | An IPv6 Profile for 3GPP Mobile DevicesD. Binet, M. Boucadair, A. Vizdal, G. Chen, N. Heatley, R. Chandler, D. Michaud, D. Lopez, W. Haeffner | Informational | May 2016 |
| 7817 | Updated Transport Layer Security (TLS) Server Identity Check Procedure for Email-Related ProtocolsA. Melnikov | Proposed Standard | March 2016 |
| 7720 | DNS Root Name Service Protocol and Deployment RequirementsM. Blanchet, L-J. Liman | Best Current Practice | December 2015 |
| 7719 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 8499 | Informational | December 2015 |
| 7673 | Using DNS-Based Authentication of Named Entities (DANE) TLSA Records with SRV RecordsT. Finch, M. Miller, P. Saint-Andre | Proposed Standard | October 2015 |
| 7672 | SMTP Security via Opportunistic DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS)V. Dukhovni, W. Hardaker | Proposed Standard | October 2015 |
| 7671 | The DNS-Based Authentication of Named Entities (DANE) Protocol: Updates and Operational GuidanceV. Dukhovni, W. Hardaker | Proposed Standard | October 2015 |
| 7583 | DNSSEC Key Rollover Timing ConsiderationsS. Morris, J. Ihren, J. Dickinson, W. Mekking | Informational | October 2015 |
| 7477 | Child-to-Parent Synchronization in DNSW. Hardaker | Proposed Standard | March 2015 |
| 7344 | Automating DNSSEC Delegation Trust MaintenanceW. Kumari, O. Gudmundsson, G. Barwood | Proposed Standard | September 2014 |
| 7269 | NAT64 Deployment Options and ExperienceG. Chen, Z. Cao, C. Xie, D. Binet | Informational | June 2014 |
| 7225 | Discovering NAT64 IPv6 Prefixes Using the Port Control Protocol (PCP)M. Boucadair | Proposed Standard | May 2014 |
| 7129 | Authenticated Denial of Existence in the DNSR. Gieben, W. Mekking | Informational | February 2014 |
| 7123 | Security Implications of IPv6 on IPv4 NetworksF. Gont, W. Liu | Informational | February 2014 |
| 7050 | Discovery of the IPv6 Prefix Used for IPv6 Address SynthesisT. Savolainen, J. Korhonen, D. Wing | Proposed Standard | November 2013 |
| 6975 | Signaling Cryptographic Algorithm Understanding in DNS Security Extensions (DNSSEC)S. Crocker, S. Rose | Proposed Standard | July 2013 |
| 6944 | Applicability Statement: DNS Security (DNSSEC) DNSKEY Algorithm Implementation StatusS. Rose · obsoleted by RFC 8624 | Proposed Standard | April 2013 |
| 6908 | Deployment Considerations for Dual-Stack LiteY. Lee, R. Maglione, C. Williams, C. Jacquenet, M. Boucadair | Informational | March 2013 |
| 6895 | Domain Name System (DNS) IANA ConsiderationsD. Eastlake 3rd | Best Current Practice | April 2013 |
| 6844 | DNS Certification Authority Authorization (CAA) Resource RecordP. Hallam-Baker, R. Stradling · obsoleted by RFC 8659 | Proposed Standard | January 2013 |
| 6841 | A Framework for DNSSEC Policies and DNSSEC Practice StatementsF. Ljunggren, AM. Eklund Lowinder, T. Okubo | Informational | January 2013 |
| 6840 | Clarifications and Implementation Notes for DNS Security (DNSSEC)S. Weiler, Ed., D. Blacka, Ed. | Proposed Standard | February 2013 |
| 6781 | DNSSEC Operational Practices, Version 2O. Kolkman, W. Mekking, R. Gieben | Informational | December 2012 |
| 6725 | DNS Security (DNSSEC) DNSKEY Algorithm IANA Registry UpdatesS. Rose | Proposed Standard | August 2012 |
| 6698 | The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSAP. Hoffman, J. Schlyter | Proposed Standard | August 2012 |
| 6672 | DNAME Redirection in the DNSS. Rose, W. Wijngaards | Proposed Standard | June 2012 |
| 6605 | Elliptic Curve Digital Signature Algorithm (DSA) for DNSSECP. Hoffman, W.C.A. Wijngaards | Proposed Standard | April 2012 |
| 6604 | xNAME RCODE and Status Bits ClarificationD. Eastlake 3rd | Proposed Standard | April 2012 |
| 6594 | Use of the SHA-256 Algorithm with RSA, Digital Signature Algorithm (DSA), and Elliptic Curve DSA (ECDSA) in SSHFP Resource RecordsO. Sury | Proposed Standard | April 2012 |
| 6589 | Considerations for Transitioning Content to IPv6J. Livingood | Informational | April 2012 |
| 6434 | IPv6 Node RequirementsE. Jankiewicz, J. Loughney, T. Narten · obsoleted by RFC 8504 | Informational | December 2011 |
| 6404 | Session PEERing for Multimedia INTerconnect (SPEERMINT) Security Threats and Suggested CountermeasuresJ. Seedorf, S. Niccolini, E. Chen, H. Scholz | Informational | November 2011 |
| 6303 | Locally Served DNS ZonesM. Andrews | Best Current Practice | July 2011 |
| 6272 | Internet Protocols for the Smart GridF. Baker, D. Meyer | Informational | June 2011 |
| 6195 | Domain Name System (DNS) IANA ConsiderationsD. Eastlake 3rd · obsoleted by RFC 6895 | Best Current Practice | March 2011 |
| 6168 | Requirements for Management of Name Servers for the DNSW. Hardaker | Informational | May 2011 |
| 6147 | DNS64: DNS Extensions for Network Address Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, A. Sullivan, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6115 | Recommendation for a Routing ArchitectureT. Li, Ed. | Informational | February 2011 |
| 6014 | Cryptographic Algorithm Identifier Allocation for DNSSECP. Hoffman | Proposed Standard | November 2010 |
| 5936 | DNS Zone Transfer Protocol (AXFR)E. Lewis, A. Hoenes, Ed. | Proposed Standard | June 2010 |
| 5933 | Use of GOST Signature Algorithms in DNSKEY and RRSIG Resource Records for DNSSECV. Dolmatov, Ed., A. Chuprina, I. Ustinov | Historic | July 2010 |
| 5910 | Domain Name System (DNS) Security Extensions Mapping for the Extensible Provisioning Protocol (EPP)J. Gould, S. Hollenbeck | Proposed Standard | May 2010 |
| 5887 | Renumbering Still Needs WorkB. Carpenter, R. Atkinson, H. Flinck | Informational | May 2010 |
| 5702 | Use of SHA-2 Algorithms with RSA in DNSKEY and RRSIG Resource Records for DNSSECJ. Jansen | Proposed Standard | October 2009 |
| 5625 | DNS Proxy Implementation GuidelinesR. Bellis | Best Current Practice | August 2009 |
| 5507 | Design Choices When Expanding the DNSIAB, P. Faltstrom, Ed., R. Austein, Ed., P. Koch, Ed. | Informational | April 2009 |
| 5395 | Domain Name System (DNS) IANA ConsiderationsD. Eastlake 3rd · obsoleted by RFC 6195 | Best Current Practice | November 2008 |
| 5333 | IANA Registration of Enumservices for Internet CalendaringR. Mahy, B. Hoeneisen | Proposed Standard | October 2009 |
| 5247 | Extensible Authentication Protocol (EAP) Key Management FrameworkB. Aboba, D. Simon, P. Eronen | Proposed Standard | August 2008 |
| 5205 | Host Identity Protocol (HIP) Domain Name System (DNS) ExtensionsP. Nikander, J. Laganier · obsoleted by RFC 8005 | Experimental | April 2008 |
| 5155 | DNS Security (DNSSEC) Hashed Authenticated Denial of ExistenceB. Laurie, G. Sisson, R. Arends, D. Blacka | Proposed Standard | March 2008 |
| 5074 | DNSSEC Lookaside Validation (DLV)S. Weiler | Historic | November 2007 |
| 5011 | Automated Updates of DNS Security (DNSSEC) Trust AnchorsM. StJohns | Internet Standard | September 2007 |
| 4986 | Requirements Related to DNS Security (DNSSEC) Trust Anchor RolloverH. Eland, R. Mundy, S. Crocker, S. Krishnaswamy | Informational | August 2007 |
| 4956 | DNS Security (DNSSEC) Opt-InR. Arends, M. Kosters, D. Blacka | Experimental | July 2007 |
| 4955 | DNS Security (DNSSEC) ExperimentsD. Blacka | Proposed Standard | July 2007 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 4924 | Reflections on Internet TransparencyB. Aboba, Ed., E. Davies | Informational | July 2007 |
| 4641 | DNSSEC Operational PracticesO. Kolkman, R. Gieben · obsoleted by RFC 6781 | Informational | September 2006 |
| 4592 | The Role of Wildcards in the Domain Name SystemE. Lewis | Proposed Standard | July 2006 |
| 4509 | Use of SHA-256 in DNSSEC Delegation Signer (DS) Resource Records (RRs)W. Hardaker | Proposed Standard | May 2006 |
| 4470 | Minimally Covering NSEC Records and DNSSEC On-line SigningS. Weiler, J. Ihren | Proposed Standard | April 2006 |
| 4431 | The DNSSEC Lookaside Validation (DLV) DNS Resource RecordM. Andrews, S. Weiler | Historic | February 2006 |
| 4355 | IANA Registration for Enumservices email, fax, mms, ems, and smsR. Brandner, L. Conroy, R. Stastny | Proposed Standard | January 2006 |
| 4310 | Domain Name System (DNS) Security Extensions Mapping for the Extensible Provisioning Protocol (EPP)S. Hollenbeck · obsoleted by RFC 5910 | Proposed Standard | December 2005 |
| 4294 | IPv6 Node RequirementsJ. Loughney, Ed. · obsoleted by RFC 6434 | Informational | April 2006 |
| 4192 | Procedures for Renumbering an IPv6 Network without a Flag DayF. Baker, E. Lear, R. Droms | Informational | September 2005 |
| 4185 | National and Local Characters for DNS Top Level Domain (TLD) NamesJ. Klensin | Informational | October 2005 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4034 | Resource Records for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4033 | DNS Security Introduction and RequirementsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |