| 9975 | Clarifications on CDS/CDNSKEY and CSYNC ConsistencyP. Thomassen | Proposed Standard | May 2026 |
| 9718 | DNSSEC Trust Anchor Publication for the Root ZoneJ. Abley, J. Schlyter, G. Bailey, P. Hoffman | Informational | January 2025 |
| 9620 | Guidelines for Human Rights Protocol and Architecture ConsiderationsG. Grover, N. ten Oever | Informational | September 2024 |
| 9609 | Initializing a DNS Resolver with Priming QueriesP. Koch, M. Larson, P. Hoffman | Best Current Practice | February 2025 |
| 9563 | SM2 Digital Signature Algorithm for DNSSECC. Zhang, Y. Liu, F. Leng, Q. Zhao, Z. He | Informational | December 2024 |
| 9558 | Use of GOST 2012 Signature Algorithms in DNSKEY and RRSIG Resource Records for DNSSECB. Makarenko, V. Dolmatov, Ed. | Informational | April 2024 |
| 9540 | Discovery of Oblivious Services via Service Binding RecordsT. Pauly, T. Reddy.K | Proposed Standard | February 2024 |
| 9499 | DNS TerminologyP. Hoffman, K. Fujiwara | Best Current Practice | March 2024 |
| 9498 | The GNU Name SystemM. Schanzenbach, C. Grothoff, B. Fix | Informational | November 2023 |
| 9471 | DNS Glue Requirements in Referral ResponsesM. Andrews, S. Huque, P. Wouters, D. Wessels | Proposed Standard | September 2023 |
| 9364 | DNS Security Extensions (DNSSEC)P. Hoffman | Best Current Practice | February 2023 |
| 9199 | Considerations for Large Authoritative DNS Server OperatorsG. Moura, W. Hardaker, J. Heidemann, M. Davids | Informational | March 2022 |
| 9157 | Revised IANA Considerations for DNSSECP. Hoffman | Proposed Standard | December 2021 |
| 9110 | HTTP SemanticsR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9102 | TLS DNSSEC Chain ExtensionV. Dukhovni, S. Huque, W. Toorop, P. Wouters, M. Shore | Experimental | August 2021 |
| 9099 | Operational Security Considerations for IPv6 NetworksÉ. Vyncke, K. Chittimaneni, M. Kaeo, E. Rey | Informational | August 2021 |
| 9076 | DNS Privacy ConsiderationsT. Wicinski, Ed. | Informational | July 2021 |
| 9063 | Host Identity Protocol ArchitectureR. Moskowitz, Ed., M. Komu | Informational | July 2021 |
| 8980 | Report from the IAB Workshop on Design Expectations vs. Deployment Reality in Protocol DevelopmentJ. Arkko, T. Hardie | Informational | February 2021 |
| 8976 | Message Digest for DNS ZonesD. Wessels, P. Barber, M. Weinberg, W. Kumari, W. Hardaker | Proposed Standard | February 2021 |
| 8973 | DDoS Open Threat Signaling (DOTS) Agent DiscoveryM. Boucadair, T. Reddy.K | Proposed Standard | January 2021 |
| 8945 | Secret Key Transaction Authentication for DNS (TSIG)F. Dupont, S. Morris, P. Vixie, D. Eastlake 3rd, O. Gudmundsson, B. Wellington | Internet Standard | November 2020 |
| 8932 | Recommendations for DNS Privacy Service OperatorsS. Dickinson, B. Overeinder, R. van Rijswijk-Deij, A. Mankin | Best Current Practice | October 2020 |
| 8917 | The LoST-Validation Straightforward-Naming Authority PoinTeR (S-NAPTR) Application Service TagR. Gellens, B. Rosen | Proposed Standard | October 2020 |
| 8904 | DNS Whitelist (DNSWL) Email Authentication Method ExtensionA. Vesely | Informational | September 2020 |
| 8901 | Multi-Signer DNSSEC ModelsS. Huque, P. Aras, J. Dickinson, J. Vcelak, D. Blacka | Informational | September 2020 |
| 8881 | Network File System (NFS) Version 4 Minor Version 1 ProtocolD. Noveck, Ed., C. Lever | Proposed Standard | August 2020 |
| 8811 | DDoS Open Threat Signaling (DOTS) ArchitectureA. Mortensen, Ed., T. Reddy.K, Ed., F. Andreasen, N. Teague, R. Compton | Informational | August 2020 |
| 8806 | Running a Root Server Local to a ResolverW. Kumari, P. Hoffman | Informational | June 2020 |
| 8749 | Moving DNSSEC Lookaside Validation (DLV) to Historic StatusW. Mekking, D. Mahoney | Proposed Standard | March 2020 |
| 8689 | SMTP Require TLS OptionJ. Fenton | Proposed Standard | November 2019 |
| 8686 | Application-Layer Traffic Optimization (ALTO) Cross-Domain Server DiscoveryS. Kiesel, M. Stiemerling | Proposed Standard | February 2020 |
| 8659 | DNS Certification Authority Authorization (CAA) Resource RecordP. Hallam-Baker, R. Stradling, J. Hoffman-Andrews | Proposed Standard | November 2019 |
| 8587 | NFS Version 4.0 Trunking UpdateC. Lever, Ed., D. Noveck | Proposed Standard | May 2019 |
| 8567 | Customer Management DNS Resource RecordsE. Rye, R. Beverly | Informational | 1 April 2019 |
| 8509 | A Root Key Trust Anchor Sentinel for DNSSECG. Huston, J. Damas, W. Kumari | Proposed Standard | December 2018 |
| 8504 | IPv6 Node RequirementsT. Chown, J. Loughney, T. Winters | Best Current Practice | January 2019 |
| 8501 | Reverse DNS in IPv6 for Internet Service ProvidersL. Howard | Informational | November 2018 |
| 8499 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 9499 | Best Current Practice | January 2019 |
| 8461 | SMTP MTA Strict Transport Security (MTA-STS)D. Margolis, M. Risher, B. Ramakrishnan, A. Brotman, J. Jones | Proposed Standard | September 2018 |
| 8375 | Special-Use Domain 'home.arpa.'P. Pfister, T. Lemon | Proposed Standard | May 2018 |
| 8324 | DNS Privacy, Authorization, Special Uses, Encoding, Characters, Matching, and Root Structure: Time for Another Look?J. Klensin | Informational | February 2018 |
| 8314 | Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and AccessK. Moore, C. Newman | Proposed Standard | January 2018 |
| 8280 | Research into Human Rights Protocol ConsiderationsN. ten Oever, C. Cath | Informational | October 2017 |
| 8162 | Using Secure DNS to Associate Certificates with Domain Names for S/MIMEP. Hoffman, J. Schlyter | Experimental | May 2017 |
| 8155 | Traversal Using Relays around NAT (TURN) Server Auto DiscoveryP. Patil, T. Reddy, D. Wing | Proposed Standard | April 2017 |
| 8145 | Signaling Trust Anchor Knowledge in DNS Security Extensions (DNSSEC)D. Wessels, W. Kumari, P. Hoffman | Proposed Standard | April 2017 |
| 8109 | Initializing a DNS Resolver with Priming QueriesP. Koch, M. Larson, P. Hoffman · obsoleted by RFC 9609 | Best Current Practice | March 2017 |
| 8094 | DNS over Datagram Transport Layer Security (DTLS)T. Reddy, D. Wing, P. Patil | Experimental | February 2017 |
| 8080 | Edwards-Curve Digital Security Algorithm (EdDSA) for DNSSECO. Sury, R. Edmonds | Proposed Standard | February 2017 |
| 8005 | Host Identity Protocol (HIP) Domain Name System (DNS) ExtensionJ. Laganier | Proposed Standard | October 2016 |
| 7958 | DNSSEC Trust Anchor Publication for the Root ZoneJ. Abley, J. Schlyter, G. Bailey, P. Hoffman · obsoleted by RFC 9718 | Informational | August 2016 |
| 7929 | DNS-Based Authentication of Named Entities (DANE) Bindings for OpenPGPP. Wouters | Experimental | August 2016 |
| 7901 | CHAIN Query Requests in DNSP. Wouters | Experimental | June 2016 |
| 7873 | Domain Name System (DNS) CookiesD. Eastlake 3rd, M. Andrews | Proposed Standard | May 2016 |
| 7871 | Client Subnet in DNS QueriesC. Contavalli, W. van der Gaast, D. Lawrence, W. Kumari | Informational | May 2016 |
| 7858 | Specification for DNS over Transport Layer Security (TLS)Z. Hu, L. Zhu, J. Heidemann, A. Mankin, D. Wessels, P. Hoffman | Proposed Standard | May 2016 |
| 7849 | An IPv6 Profile for 3GPP Mobile DevicesD. Binet, M. Boucadair, A. Vizdal, G. Chen, N. Heatley, R. Chandler, D. Michaud, D. Lopez, W. Haeffner | Informational | May 2016 |
| 7831 | Application Bridging for Federated Access Beyond Web (ABFAB) ArchitectureJ. Howlett, S. Hartman, H. Tschofenig, J. Schaad | Informational | May 2016 |
| 7828 | The edns-tcp-keepalive EDNS0 OptionP. Wouters, J. Abley, S. Dickinson, R. Bellis | Proposed Standard | April 2016 |
| 7817 | Updated Transport Layer Security (TLS) Server Identity Check Procedure for Email-Related ProtocolsA. Melnikov | Proposed Standard | March 2016 |
| 7766 | DNS Transport over TCP - Implementation RequirementsJ. Dickinson, S. Dickinson, R. Bellis, A. Mankin, D. Wessels | Proposed Standard | March 2016 |
| 7754 | Technical Considerations for Internet Service Blocking and FilteringR. Barnes, A. Cooper, O. Kolkman, D. Thaler, E. Nordmark | Informational | March 2016 |
| 7745 | XML Schemas for Reverse DNS ManagementT. Manderson | Informational | January 2016 |
| 7719 | DNS TerminologyP. Hoffman, A. Sullivan, K. Fujiwara · obsoleted by RFC 8499 | Informational | December 2015 |
| 7712 | Domain Name Associations (DNA) in the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre, M. Miller, P. Hancke | Proposed Standard | November 2015 |
| 7711 | PKIX over Secure HTTP (POSH)M. Miller, P. Saint-Andre | Proposed Standard | November 2015 |
| 7706 | Decreasing Access Time to Root Servers by Running One on LoopbackW. Kumari, P. Hoffman · obsoleted by RFC 8806 | Informational | November 2015 |
| 7673 | Using DNS-Based Authentication of Named Entities (DANE) TLSA Records with SRV RecordsT. Finch, M. Miller, P. Saint-Andre | Proposed Standard | October 2015 |
| 7672 | SMTP Security via Opportunistic DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS)V. Dukhovni, W. Hardaker | Proposed Standard | October 2015 |
| 7671 | The DNS-Based Authentication of Named Entities (DANE) Protocol: Updates and Operational GuidanceV. Dukhovni, W. Hardaker | Proposed Standard | October 2015 |
| 7646 | Definition and Use of DNSSEC Negative Trust AnchorsP. Ebersman, W. Kumari, C. Griffiths, J. Livingood, R. Weber | Informational | September 2015 |
| 7626 | DNS Privacy ConsiderationsS. Bortzmeyer · obsoleted by RFC 9076 | Informational | August 2015 |
| 7624 | Confidentiality in the Face of Pervasive Surveillance: A Threat Model and Problem StatementR. Barnes, B. Schneier, C. Jennings, T. Hardie, B. Trammell, C. Huitema, D. Borkmann | Informational | August 2015 |
| 7590 | Use of Transport Layer Security (TLS) in the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre, T. Alkemade | Proposed Standard | June 2015 |
| 7583 | DNSSEC Key Rollover Timing ConsiderationsS. Morris, J. Ihren, J. Dickinson, W. Mekking | Informational | October 2015 |
| 7535 | AS112 Redirection Using DNAMEJ. Abley, B. Dickson, W. Kumari, G. Michaelson | Informational | May 2015 |
| 7534 | AS112 Nameserver OperationsJ. Abley, W. Sotomayor | Informational | May 2015 |
| 7489 | Domain-based Message Authentication, Reporting, and Conformance (DMARC)M. Kucherawy, Ed., E. Zwicky, Ed. · obsoleted by RFC 9989, RFC 9990, RFC 9991 | Informational | March 2015 |
| 7477 | Child-to-Parent Synchronization in DNSW. Hardaker | Proposed Standard | March 2015 |
| 7435 | Opportunistic Security: Some Protection Most of the TimeV. Dukhovni | Informational | December 2014 |
| 7368 | IPv6 Home Networking Architecture PrinciplesT. Chown, Ed., J. Arkko, A. Brandt, O. Troan, J. Weil | Informational | October 2014 |
| 7344 | Automating DNSSEC Delegation Trust MaintenanceW. Kumari, O. Gudmundsson, G. Barwood | Proposed Standard | September 2014 |
| 7286 | Application-Layer Traffic Optimization (ALTO) Server DiscoveryS. Kiesel, M. Stiemerling, N. Schwan, M. Scharf, H. Song | Proposed Standard | November 2014 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7225 | Discovering NAT64 IPv6 Prefixes Using the Port Control Protocol (PCP)M. Boucadair | Proposed Standard | May 2014 |
| 7208 | Sender Policy Framework (SPF) for Authorizing Use of Domains in Email, Version 1S. Kitterman | Proposed Standard | April 2014 |
| 7129 | Authenticated Denial of Existence in the DNSR. Gieben, W. Mekking | Informational | February 2014 |
| 7123 | Security Implications of IPv6 on IPv4 NetworksF. Gont, W. Liu | Informational | February 2014 |
| 7094 | Architectural Considerations of IP AnycastD. McPherson, D. Oran, D. Thaler, E. Osterweil | Informational | January 2014 |
| 7051 | Analysis of Solution Proposals for Hosts to Learn NAT64 PrefixJ. Korhonen, Ed., T. Savolainen, Ed. | Informational | November 2013 |
| 6975 | Signaling Cryptographic Algorithm Understanding in DNS Security Extensions (DNSSEC)S. Crocker, S. Rose | Proposed Standard | July 2013 |
| 6950 | Architectural Considerations on Application Features in the DNSJ. Peterson, O. Kolkman, H. Tschofenig, B. Aboba | Informational | October 2013 |
| 6944 | Applicability Statement: DNS Security (DNSSEC) DNSKEY Algorithm Implementation StatusS. Rose · obsoleted by RFC 8624 | Proposed Standard | April 2013 |
| 6895 | Domain Name System (DNS) IANA ConsiderationsD. Eastlake 3rd | Best Current Practice | April 2013 |
| 6844 | DNS Certification Authority Authorization (CAA) Resource RecordP. Hallam-Baker, R. Stradling · obsoleted by RFC 8659 | Proposed Standard | January 2013 |
| 6841 | A Framework for DNSSEC Policies and DNSSEC Practice StatementsF. Ljunggren, AM. Eklund Lowinder, T. Okubo | Informational | January 2013 |
| 6840 | Clarifications and Implementation Notes for DNS Security (DNSSEC)S. Weiler, Ed., D. Blacka, Ed. | Proposed Standard | February 2013 |
| 6797 | HTTP Strict Transport Security (HSTS)J. Hodges, C. Jackson, A. Barth | Proposed Standard | November 2012 |
| 6781 | DNSSEC Operational Practices, Version 2O. Kolkman, W. Mekking, R. Gieben | Informational | December 2012 |
| 6763 | DNS-Based Service DiscoveryS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6762 | Multicast DNSS. Cheshire, M. Krochmal | Proposed Standard | February 2013 |
| 6742 | DNS Resource Records for the Identifier-Locator Network Protocol (ILNP)RJ Atkinson, SN Bhatti, S. Rose | Experimental | November 2012 |
| 6740 | Identifier-Locator Network Protocol (ILNP) Architectural DescriptionRJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6725 | DNS Security (DNSSEC) DNSKEY Algorithm IANA Registry UpdatesS. Rose | Proposed Standard | August 2012 |
| 6698 | The DNS-Based Authentication of Named Entities (DANE) Transport Layer Security (TLS) Protocol: TLSAP. Hoffman, J. Schlyter | Proposed Standard | August 2012 |
| 6672 | DNAME Redirection in the DNSS. Rose, W. Wijngaards | Proposed Standard | June 2012 |
| 6641 | Using DNS SRV to Specify a Global File Namespace with NFS Version 4C. Everhart, W. Adamson, J. Zhang | Proposed Standard | June 2012 |
| 6605 | Elliptic Curve Digital Signature Algorithm (DSA) for DNSSECP. Hoffman, W.C.A. Wijngaards | Proposed Standard | April 2012 |
| 6604 | xNAME RCODE and Status Bits ClarificationD. Eastlake 3rd | Proposed Standard | April 2012 |
| 6594 | Use of the SHA-256 Algorithm with RSA, Digital Signature Algorithm (DSA), and Elliptic Curve DSA (ECDSA) in SSHFP Resource RecordsO. Sury | Proposed Standard | April 2012 |
| 6589 | Considerations for Transitioning Content to IPv6J. Livingood | Informational | April 2012 |
| 6434 | IPv6 Node RequirementsE. Jankiewicz, J. Loughney, T. Narten · obsoleted by RFC 8504 | Informational | December 2011 |
| 6404 | Session PEERing for Multimedia INTerconnect (SPEERMINT) Security Threats and Suggested CountermeasuresJ. Seedorf, S. Niccolini, E. Chen, H. Scholz | Informational | November 2011 |
| 6394 | Use Cases and Requirements for DNS-Based Authentication of Named Entities (DANE)R. Barnes | Informational | October 2011 |
| 6382 | Unique Origin Autonomous System Numbers (ASNs) per Node for Globally Anycasted ServicesD. McPherson, R. Donnelly, F. Scalzo | Best Current Practice | October 2011 |
| 6376 | DomainKeys Identified Mail (DKIM) SignaturesD. Crocker, Ed., T. Hansen, Ed., M. Kucherawy, Ed. | Internet Standard | September 2011 |
| 6333 | Dual-Stack Lite Broadband Deployments Following IPv4 ExhaustionA. Durand, R. Droms, J. Woodyatt, Y. Lee | Proposed Standard | August 2011 |
| 6315 | IANA Registration for Enumservice 'iax'E. Guy, K. Darilion | Informational | July 2011 |
| 6306 | Hierarchical IPv4 FrameworkP. Frejborg | Experimental | July 2011 |
| 6304 | AS112 Nameserver OperationsJ. Abley, W. Maton · obsoleted by RFC 7534 | Informational | July 2011 |
| 6275 | Mobility Support in IPv6C. Perkins, Ed., D. Johnson, J. Arkko | Proposed Standard | July 2011 |
| 6272 | Internet Protocols for the Smart GridF. Baker, D. Meyer | Informational | June 2011 |
| 6195 | Domain Name System (DNS) IANA ConsiderationsD. Eastlake 3rd · obsoleted by RFC 6895 | Best Current Practice | March 2011 |
| 6168 | Requirements for Management of Name Servers for the DNSW. Hardaker | Informational | May 2011 |
| 6147 | DNS64: DNS Extensions for Network Address Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, A. Sullivan, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6122 | Extensible Messaging and Presence Protocol (XMPP): Address FormatP. Saint-Andre · obsoleted by RFC 7622 | Proposed Standard | March 2011 |
| 6120 | Extensible Messaging and Presence Protocol (XMPP): CoreP. Saint-Andre | Proposed Standard | March 2011 |
| 6116 | The E.164 to Uniform Resource Identifiers (URI) Dynamic Delegation Discovery System (DDDS) Application (ENUM)S. Bradner, L. Conroy, K. Fujiwara | Proposed Standard | March 2011 |
| 6115 | Recommendation for a Routing ArchitectureT. Li, Ed. | Informational | February 2011 |
| 6014 | Cryptographic Algorithm Identifier Allocation for DNSSECP. Hoffman | Proposed Standard | November 2010 |
| 5986 | Discovering the Local Location Information Server (LIS)M. Thomson, J. Winterbottom | Proposed Standard | September 2010 |
| 5966 | DNS Transport over TCP - Implementation RequirementsR. Bellis · obsoleted by RFC 7766 | Proposed Standard | August 2010 |
| 5936 | DNS Zone Transfer Protocol (AXFR)E. Lewis, A. Hoenes, Ed. | Proposed Standard | June 2010 |
| 5933 | Use of GOST Signature Algorithms in DNSKEY and RRSIG Resource Records for DNSSECV. Dolmatov, Ed., A. Chuprina, I. Ustinov | Historic | July 2010 |
| 5910 | Domain Name System (DNS) Security Extensions Mapping for the Extensible Provisioning Protocol (EPP)J. Gould, S. Hollenbeck | Proposed Standard | May 2010 |
| 5887 | Renumbering Still Needs WorkB. Carpenter, R. Atkinson, H. Flinck | Informational | May 2010 |
| 5864 | DNS SRV Resource Records for AFSR. Allbery | Proposed Standard | April 2010 |
| 5801 | Using Generic Security Service Application Program Interface (GSS-API) Mechanisms in Simple Authentication and Security Layer (SASL): The GS2 Mechanism FamilyS. Josefsson, N. Williams | Proposed Standard | July 2010 |
| 5702 | Use of SHA-2 Algorithms with RSA in DNSKEY and RRSIG Resource Records for DNSSECJ. Jansen | Proposed Standard | October 2009 |
| 5679 | Locating IEEE 802.21 Mobility Services Using DNSG. Bajko | Proposed Standard | December 2009 |
| 5678 | Dynamic Host Configuration Protocol (DHCPv4 and DHCPv6) Options for IEEE 802.21 Mobility Services (MoS) DiscoveryG. Bajko, S. Das | Proposed Standard | December 2009 |
| 5677 | IEEE 802.21 Mobility Services Framework Design (MSFD)T. Melia, Ed., G. Bajko, S. Das, N. Golmie, JC. Zuniga | Proposed Standard | December 2009 |
| 5617 | DomainKeys Identified Mail (DKIM) Author Domain Signing Practices (ADSP)E. Allman, J. Fenton, M. Delany, J. Levine | Historic | August 2009 |
| 5507 | Design Choices When Expanding the DNSIAB, P. Faltstrom, Ed., R. Austein, Ed., P. Koch, Ed. | Informational | April 2009 |
| 5452 | Measures for Making DNS More Resilient against Forged AnswersA. Hubert, R. van Mook | Proposed Standard | January 2009 |
| 5395 | Domain Name System (DNS) IANA ConsiderationsD. Eastlake 3rd · obsoleted by RFC 6195 | Best Current Practice | November 2008 |
| 5358 | Preventing Use of Recursive Nameservers in Reflector AttacksJ. Damas, F. Neves | Best Current Practice | October 2008 |
| 5338 | Using the Host Identity Protocol with Legacy ApplicationsT. Henderson, P. Nikander, M. Komu | Experimental | September 2008 |
| 5247 | Extensible Authentication Protocol (EAP) Key Management FrameworkB. Aboba, D. Simon, P. Eronen | Proposed Standard | August 2008 |
| 5222 | LoST: A Location-to-Service Translation ProtocolT. Hardie, A. Newton, H. Schulzrinne, H. Tschofenig | Proposed Standard | August 2008 |
| 5205 | Host Identity Protocol (HIP) Domain Name System (DNS) ExtensionsP. Nikander, J. Laganier · obsoleted by RFC 8005 | Experimental | April 2008 |
| 5178 | Generic Security Service Application Program Interface (GSS-API) Internationalization and Domain-Based Service Names and Name TypeN. Williams, A. Melnikov | Proposed Standard | May 2008 |
| 5155 | DNS Security (DNSSEC) Hashed Authenticated Denial of ExistenceB. Laurie, G. Sisson, R. Arends, D. Blacka | Proposed Standard | March 2008 |
| 5074 | DNSSEC Lookaside Validation (DLV)S. Weiler | Historic | November 2007 |
| 5026 | Mobile IPv6 Bootstrapping in Split ScenarioG. Giaretta, Ed., J. Kempf, V. Devarapalli, Ed. | Proposed Standard | October 2007 |
| 5011 | Automated Updates of DNS Security (DNSSEC) Trust AnchorsM. StJohns | Internet Standard | September 2007 |
| 4986 | Requirements Related to DNS Security (DNSSEC) Trust Anchor RolloverH. Eland, R. Mundy, S. Crocker, S. Krishnaswamy | Informational | August 2007 |
| 4969 | IANA Registration for vCard EnumserviceA. Mayrhofer | Proposed Standard | August 2007 |
| 4966 | Reasons to Move the Network Address Translator - Protocol Translator (NAT-PT) to Historic StatusC. Aoun, E. Davies | Informational | July 2007 |
| 4956 | DNS Security (DNSSEC) Opt-InR. Arends, M. Kosters, D. Blacka | Experimental | July 2007 |
| 4955 | DNS Security (DNSSEC) ExperimentsD. Blacka | Proposed Standard | July 2007 |
| 4945 | The Internet IP Security PKI Profile of IKEv1/ISAKMP, IKEv2, and PKIXB. Korver | Proposed Standard | August 2007 |
| 4892 | Requirements for a Mechanism Identifying a Name Server InstanceS. Woolf, D. Conrad | Informational | June 2007 |
| 4871 | DomainKeys Identified Mail (DKIM) SignaturesE. Allman, J. Callas, M. Delany, M. Libbey, J. Fenton, M. Thomas · obsoleted by RFC 6376 | Proposed Standard | May 2007 |
| 4795 | Link-local Multicast Name Resolution (LLMNR)B. Aboba, D. Thaler, L. Esibov | Informational | January 2007 |
| 4786 | Operation of Anycast ServicesJ. Abley, K. Lindqvist | Best Current Practice | December 2006 |
| 4686 | Analysis of Threats Motivating DomainKeys Identified Mail (DKIM)J. Fenton | Informational | September 2006 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 4641 | DNSSEC Operational PracticesO. Kolkman, R. Gieben · obsoleted by RFC 6781 | Informational | September 2006 |
| 4592 | The Role of Wildcards in the Domain Name SystemE. Lewis | Proposed Standard | July 2006 |
| 4509 | Use of SHA-256 in DNSSEC Delegation Signer (DS) Resource Records (RRs)W. Hardaker | Proposed Standard | May 2006 |
| 4501 | Domain Name System Uniform Resource IdentifiersS. Josefsson | Proposed Standard | May 2006 |
| 4470 | Minimally Covering NSEC Records and DNSSEC On-line SigningS. Weiler, J. Ihren | Proposed Standard | April 2006 |
| 4431 | The DNSSEC Lookaside Validation (DLV) DNS Resource RecordM. Andrews, S. Weiler | Historic | February 2006 |
| 4423 | Host Identity Protocol (HIP) ArchitectureR. Moskowitz, P. Nikander · obsoleted by RFC 9063 | Informational | May 2006 |
| 4398 | Storing Certificates in the Domain Name System (DNS)S. Josefsson | Proposed Standard | March 2006 |
| 4339 | IPv6 Host Configuration of DNS Server Information ApproachesJ. Jeong, Ed. | Informational | February 2006 |
| 4322 | Opportunistic Encryption using the Internet Key Exchange (IKE)M. Richardson, D.H. Redelmeier | Informational | December 2005 |
| 4310 | Domain Name System (DNS) Security Extensions Mapping for the Extensible Provisioning Protocol (EPP)S. Hollenbeck · obsoleted by RFC 5910 | Proposed Standard | December 2005 |
| 4294 | IPv6 Node RequirementsJ. Loughney, Ed. · obsoleted by RFC 6434 | Informational | April 2006 |
| 4255 | Using DNS to Securely Publish Secure Shell (SSH) Key FingerprintsJ. Schlyter, W. Griffin | Proposed Standard | January 2006 |
| 4225 | Mobile IP Version 6 Route Optimization Security Design BackgroundP. Nikander, J. Arkko, T. Aura, G. Montenegro, E. Nordmark | Informational | December 2005 |
| 4192 | Procedures for Renumbering an IPv6 Network without a Flag DayF. Baker, E. Lear, R. Droms | Informational | September 2005 |
| 4185 | National and Local Characters for DNS Top Level Domain (TLD) NamesJ. Klensin | Informational | October 2005 |
| 4095 | Attaching Meaning to Solicitation Class KeywordsC. Malamud | Proposed Standard | May 2005 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 4035 | Protocol Modifications for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |
| 4034 | Resource Records for the DNS Security ExtensionsR. Arends, R. Austein, M. Larson, D. Massey, S. Rose | Proposed Standard | March 2005 |