| 952 | DoD Internet host table specificationK. Harrenstien, M.K. Stahl, E.J. Feinler | Unknown | October 1985 |
| 1034 | Domain names - concepts and facilitiesP. Mockapetris | Internet Standard | November 1987 |
| 1123 | Requirements for Internet Hosts - Application and SupportR. Braden, Ed. | Internet Standard | October 1989 |
| 1535 | A Security Problem and Proposed Correction With Widely Deployed DNS SoftwareE. Gavron | Informational | October 1993 |
| 1630 | Universal Resource Identifiers in WWW: A Unifying Syntax for the Expression of Names and Addresses of Objects on the Network as used in the World-Wide WebT. Berners-Lee | Informational | June 1994 |
| 1736 | Functional Recommendations for Internet Resource LocatorsJ. Kunze | Informational | February 1995 |
| 1737 | Functional Requirements for Uniform Resource NamesK. Sollins, L. Masinter | Informational | December 1994 |
| 1738 | Uniform Resource Locators (URL)T. Berners-Lee, L. Masinter, M. McCahill · obsoleted by RFC 4248, RFC 4266 | Proposed Standard | December 1994 |
| 1808 | Relative Uniform Resource LocatorsR. Fielding · obsoleted by RFC 3986 | Proposed Standard | June 1995 |
| 2046 | Multipurpose Internet Mail Extensions (MIME) Part Two: Media TypesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2141 | URN SyntaxR. Moats · obsoleted by RFC 8141 | Proposed Standard | May 1997 |
| 2234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell · obsoleted by RFC 4234 | Proposed Standard | November 1997 |
| 2396 | Uniform Resource Identifiers (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter · obsoleted by RFC 3986 | Draft Standard | August 1998 |
| 2518 | HTTP Extensions for Distributed Authoring -- WEBDAVY. Goland, E. Whitehead, A. Faizi, S. Carter, D. Jensen · obsoleted by RFC 4918 | Proposed Standard | February 1999 |
| 2557 | MIME Encapsulation of Aggregate Documents, such as HTML (MHTML)J. Palme, A. Hopmann, N. Shelness | Proposed Standard | March 1999 |
| 2717 | Registration Procedures for URL Scheme NamesR. Petke, I. King · obsoleted by RFC 4395 | Best Current Practice | November 1999 |
| 2718 | Guidelines for new URL SchemesL. Masinter, H. Alvestrand, D. Zigmond, R. Petke · obsoleted by RFC 4395 | Informational | November 1999 |
| 2732 | Format for Literal IPv6 Addresses in URL'sR. Hinden, B. Carpenter, L. Masinter · obsoleted by RFC 3986 | Proposed Standard | December 1999 |
| 2978 | IANA Charset Registration ProceduresN. Freed, J. Postel | Best Current Practice | October 2000 |
| 3305 | Report from the Joint W3C/IETF URI Planning Interest Group: Uniform Resource Identifiers (URIs), URLs, and Uniform Resource Names (URNs): Clarifications and RecommendationsM. Mealling, Ed., R. Denenberg, Ed. | Informational | August 2002 |
| 3490 | Internationalizing Domain Names in Applications (IDNA)P. Faltstrom, P. Hoffman, A. Costello · obsoleted by RFC 5890, RFC 5891 | Proposed Standard | March 2003 |
| 3513 | Internet Protocol Version 6 (IPv6) Addressing ArchitectureR. Hinden, S. Deering · obsoleted by RFC 4291 | Proposed Standard | April 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |