| 10049 | Roughtime: A Protocol for Rough Time SynchronizationW. Ladd, M. Dansarie | Experimental | October 2026 |
| 10023 | The "_for-sale" Underscored and Globally Scoped DNS Node NameM. Davids | Informational | July 2026 |
| 10008 | The HTTP QUERY MethodJ. Reschke, J.M. Snell, M. Bishop | Proposed Standard | June 2026 |
| 10003 | Certificate Management over CMS (CMC): Transport ProtocolsJ. Mandel, Ed., S. Turner, Ed. | Proposed Standard | July 2026 |
| 9999 | Remote ATtestation procedureS (RATS) Conceptual Message Wrapper (CMW)H. Birkholz, N. Smith, T. Fossati, H. Tschofenig | Proposed Standard | July 2026 |
| 9990 | Domain-Based Message Authentication, Reporting, and Conformance (DMARC) Aggregate ReportingA. Brotman, Ed. | Proposed Standard | May 2026 |
| 9989 | Domain-Based Message Authentication, Reporting, and Conformance (DMARC)T. Herr, Ed., J. Levine, Ed. | Proposed Standard | May 2026 |
| 9953 | DNS over CoAP (DoC)M. S. Lenders, C. Amsüss, C. Gündoğan, T. C. Schmidt, M. Wählisch | Proposed Standard | March 2026 |
| 9932 | Mutually Authenticating TLS in the Context of FederationsS. Halén, J. Schlyter | Informational | April 2026 |
| 9919 | The Lightweight Online Certificate Status Protocol (OCSP) Profile for High-Volume EnvironmentsT. Ito, C. Wilson, C. Bonnell, S. Turner | Proposed Standard | July 2026 |
| 9911 | Common YANG Data TypesJ. Schönwälder, Ed. | Proposed Standard | December 2025 |
| 9907 | Guidelines for Authors and Reviewers of Documents Containing YANG Data ModelsA. Bierman, M. Boucadair, Ed., Q. Wu | Best Current Practice | March 2026 |
| 9891 | Automated Certificate Management Environment (ACME) Delay-Tolerant Networking (DTN) Node ID Validation ExtensionB. Sipos | Experimental | November 2025 |
| 9880 | Semantic Definition Format (SDF) for Data and Interactions of ThingsM. Koster, Ed., C. Bormann, Ed., A. Keränen | Proposed Standard | January 2026 |
| 9865 | Cursor-Based Pagination of System of Cross-domain Identity Management (SCIM) ResourcesM. Peterson, Ed., D. Zollner, A. Sehgal | Proposed Standard | October 2025 |
| 9849 | TLS Encrypted Client HelloE. Rescorla, K. Oku, N. Sullivan, C. A. Wood | Proposed Standard | March 2026 |
| 9844 | Entering IPv6 Zone Identifiers in User InterfacesB. Carpenter, R. Hinden | Proposed Standard | August 2025 |
| 9842 | Compression Dictionary TransportP. Meenan, Ed., Y. Weiss, Ed. | Proposed Standard | September 2025 |
| 9828 | RTP Payload Format for JPEG 2000 Streaming with Sub-Codestream LatencyP.-A. Lemieux, Ed., D. Taubman | Proposed Standard | August 2025 |
| 9795 | Personal Assertion Token (PASSporT) Extension for Rich Call DataC. Wendt, J. Peterson | Proposed Standard | July 2025 |
| 9783 | Arm's Platform Security Architecture (PSA) Attestation TokenH. Tschofenig, S. Frost, M. Brossard, A. Shaw, T. Fossati | Informational | June 2025 |
| 9782 | Entity Attestation Token (EAT) Media TypesL. Lundblade, H. Birkholz, T. Fossati | Proposed Standard | May 2025 |
| 9767 | Grant Negotiation and Authorization Protocol Resource Server ConnectionsJ. Richer, Ed., F. Imbault | Proposed Standard | April 2025 |
| 9758 | Updates to the 'ipn' URI SchemeR. Taylor, E. Birrane III | Proposed Standard | May 2025 |
| 9729 | The Concealed HTTP Authentication SchemeD. Schinazi, D. Oliver, J. Hoyland | Proposed Standard | February 2025 |
| 9725 | WebRTC-HTTP Ingestion Protocol (WHIP)S. Garcia Murillo, A. Gouaillard | Proposed Standard | March 2025 |
| 9711 | The Entity Attestation Token (EAT)L. Lundblade, G. Mandyam, J. O'Donoghue, C. Wallace | Proposed Standard | April 2025 |
| 9700 | Best Current Practice for OAuth 2.0 SecurityT. Lodderstedt, J. Bradley, A. Labunets, D. Fett | Best Current Practice | January 2025 |
| 9676 | LEX: A Uniform Resource Name (URN) Namespace for Sources of LawP. Spinosa, E. Francesconi, C. Lupo | Informational | May 2025 |
| 9661 | The JSON Meta Application Protocol (JMAP) for Sieve ScriptsK. Murchison | Proposed Standard | September 2024 |
| 9652 | The Link-Template HTTP Header FieldM. Nottingham | Proposed Standard | September 2024 |
| 9651 | Structured Field Values for HTTPM. Nottingham, P-H. Kamp | Proposed Standard | September 2024 |
| 9639 | Free Lossless Audio Codec (FLAC)M.Q.C. van Beurden, A. Weaver | Proposed Standard | December 2024 |
| 9635 | Grant Negotiation and Authorization Protocol (GNAP)J. Richer, Ed., F. Imbault | Proposed Standard | October 2024 |
| 9594 | Key Provisioning for Group Communication Using Authentication and Authorization for Constrained Environments (ACE)F. Palombini, M. Tiloca | Proposed Standard | September 2024 |
| 9577 | The Privacy Pass HTTP Authentication SchemeT. Pauly, S. Valdez, C. A. Wood | Proposed Standard | June 2024 |
| 9569 | The Application-Layer Traffic Optimization (ALTO) Transport Information Publication Service (TIPS)K. Gao, R. Schott, Y. R. Yang, L. Delwiche, L. Keller | Proposed Standard | September 2024 |
| 9555 | JSContact: Converting from and to vCardM. Loffredo, R. Stepanek | Proposed Standard | May 2024 |
| 9554 | vCard Format Extensions for JSContactR. Stepanek, M. Loffredo | Proposed Standard | May 2024 |
| 9553 | JSContact: A JSON Representation of Contact DataR. Stepanek, M. Loffredo | Proposed Standard | May 2024 |
| 9532 | HTTP Proxy-Status Parameter for Next-Hop AliasesT. Pauly | Proposed Standard | January 2024 |
| 9525 | Service Identity in TLSP. Saint-Andre, R. Salz | Proposed Standard | November 2023 |
| 9517 | A URN Namespace for the Data Documentation Initiative (DDI)J. Wackerow | Informational | January 2024 |
| 9512 | YAML Media TypeR. Polli, E. Wilde, E. Aro | Informational | February 2024 |
| 9493 | Subject Identifiers for Security Event TokensA. Backman, Ed., M. Scurtescu, P. Jain | Proposed Standard | December 2023 |
| 9484 | Proxying IP in HTTPT. Pauly, Ed., D. Schinazi, A. Chernyakhovsky, M. Kühlewind, M. Westerlund | Proposed Standard | October 2023 |
| 9460 | Service Binding and Parameter Specification via the DNS (SVCB and HTTPS Resource Records)B. Schwartz, M. Bishop, E. Nygren | Proposed Standard | November 2023 |
| 9457 | Problem Details for HTTP APIsM. Nottingham, E. Wilde, S. Dalal | Proposed Standard | July 2023 |
| 9449 | OAuth 2.0 Demonstrating Proof of Possession (DPoP)D. Fett, B. Campbell, J. Bradley, T. Lodderstedt, M. Jones, D. Waite | Proposed Standard | September 2023 |
| 9421 | HTTP Message SignaturesA. Backman, Ed., J. Richer, Ed., M. Sporny | Proposed Standard | February 2024 |
| 9409 | The 'sip-trunking-capability' Link Relation TypeK. Inamdar, S. Narayanan, D. Engi, G. Salgueiro | Informational | July 2023 |
| 9399 | Internet X.509 Public Key Infrastructure: Logotypes in X.509 CertificatesS. Santesson, R. Housley, T. Freeman, L. Rosenthol | Proposed Standard | May 2023 |
| 9393 | Concise Software Identification TagsH. Birkholz, J. Fitzgerald-McKay, C. Schmidt, D. Waltermire | Proposed Standard | June 2023 |
| 9360 | CBOR Object Signing and Encryption (COSE): Header Parameters for Carrying and Referencing X.509 CertificatesJ. Schaad | Proposed Standard | February 2023 |
| 9309 | Robots Exclusion ProtocolM. Koster, G. Illyes, H. Zeller, L. Sassman | Proposed Standard | September 2022 |
| 9298 | Proxying UDP in HTTPD. Schinazi | Proposed Standard | August 2022 |
| 9290 | Concise Problem Details for Constrained Application Protocol (CoAP) APIsT. Fossati, C. Bormann | Proposed Standard | October 2022 |
| 9264 | Linkset: Media Types and a Link Relation Type for Link SetsE. Wilde, H. Van de Sompel | Proposed Standard | July 2022 |
| 9253 | Support for iCalendar RelationshipsM. Douglass | Proposed Standard | August 2022 |
| 9246 | URI Signing for Content Delivery Network Interconnection (CDNI)R. van Brandenburg, K. Leung, P. Sorber | Proposed Standard | June 2022 |
| 9240 | An Extension for Application-Layer Traffic Optimization (ALTO): Entity Property MapsW. Roome, S. Randriamasy, Y. Yang, J. Zhang, K. Gao | Proposed Standard | July 2022 |
| 9239 | Updates to ECMAScript Media TypesM. Miller, M. Borins, M. Bynens, B. Farias | Informational | May 2022 |
| 9238 | Loading Manufacturer Usage Description (MUD) URLs from QR CodesM. Richardson, J. Latour, H. Habibi Gharakheili | Informational | May 2022 |
| 9237 | An Authorization Information Format (AIF) for Authentication and Authorization for Constrained Environments (ACE)C. Bormann | Proposed Standard | August 2022 |
| 9231 | Additional XML Security Uniform Resource Identifiers (URIs)D. Eastlake 3rd | Proposed Standard | July 2022 |
| 9223 | Real-Time Transport Object Delivery over Unidirectional Transport (ROUTE)W. Zia, T. Stockhammer, L. Chaponniere, G. Mandyam, M. Luby | Informational | April 2022 |
| 9207 | OAuth 2.0 Authorization Server Issuer IdentificationK. Meyer zu Selhausen, D. Fett | Proposed Standard | March 2022 |
| 9205 | Building Protocols with HTTPM. Nottingham | Best Current Practice | June 2022 |
| 9200 | Authentication and Authorization for Constrained Environments Using the OAuth 2.0 Framework (ACE-OAuth)L. Seitz, G. Selander, E. Wahlstroem, S. Erdtman, H. Tschofenig | Proposed Standard | August 2022 |
| 9176 | Constrained RESTful Environments (CoRE) Resource DirectoryC. Amsüss, Ed., Z. Shelby, M. Koster, C. Bormann, P. van der Stok | Proposed Standard | April 2022 |
| 9174 | Delay-Tolerant Networking TCP Convergence-Layer Protocol Version 4B. Sipos, M. Demmer, J. Ott, S. Perreault | Proposed Standard | January 2022 |
| 9171 | Bundle Protocol Version 7S. Burleigh, K. Fall, E. Birrane, III | Proposed Standard | January 2022 |
| 9167 | Registry Maintenance Notification for the Extensible Provisioning Protocol (EPP)T. Sattler, R. Carney, J. Kolker | Proposed Standard | December 2021 |
| 9163 | Expect-CT Extension for HTTPE. Stark | Experimental | June 2022 |
| 9162 | Certificate Transparency Version 2.0B. Laurie, E. Messeri, R. Stradling | Experimental | December 2021 |
| 9140 | Nimble Out-of-Band Authentication for EAP (EAP-NOOB)T. Aura, M. Sethi, A. Peltonen | Proposed Standard | December 2021 |
| 9132 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationM. Boucadair, Ed., J. Shallow, T. Reddy.K | Proposed Standard | September 2021 |
| 9124 | A Manifest Information Model for Firmware Updates in Internet of Things (IoT) DevicesB. Moran, H. Tschofenig, H. Birkholz | Informational | January 2022 |
| 9116 | A File Format to Aid in Security Vulnerability DisclosureE. Foudil, Y. Shafranovich | Informational | April 2022 |
| 9114 | HTTP/3M. Bishop, Ed. | Proposed Standard | June 2022 |
| 9113 | HTTP/2M. Thomson, Ed., C. Benfield, Ed. | Proposed Standard | June 2022 |
| 9112 | HTTP/1.1R. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9110 | HTTP SemanticsR. Fielding, Ed., M. Nottingham, Ed., J. Reschke, Ed. | Internet Standard | June 2022 |
| 9101 | The OAuth 2.0 Authorization Framework: JWT-Secured Authorization Request (JAR)N. Sakimura, J. Bradley, M. Jones | Proposed Standard | August 2021 |
| 9083 | JSON Responses for the Registration Data Access Protocol (RDAP)S. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 9082 | Registration Data Access Protocol (RDAP) Query FormatS. Hollenbeck, A. Newton | Internet Standard | June 2021 |
| 9073 | Event Publishing Extensions to iCalendarM. Douglass | Proposed Standard | August 2021 |
| 9060 | Secure Telephone Identity Revisited (STIR) Certificate DelegationJ. Peterson | Proposed Standard | September 2021 |
| 9039 | Uniform Resource Names for Device IdentifiersJ. Arkko, C. Jennings, Z. Shelby | Proposed Standard | June 2021 |
| 8990 | GeneRic Autonomic Signaling Protocol (GRASP)C. Bormann, B. Carpenter, Ed., B. Liu, Ed. | Proposed Standard | May 2021 |
| 8984 | JSCalendar: A JSON Representation of Calendar DataN. Jenkins, R. Stepanek | Proposed Standard | July 2021 |
| 8959 | The "secret-token" URI SchemeM. Nottingham | Informational | January 2021 |
| 8952 | Captive Portal ArchitectureK. Larose, D. Dolson, H. Liu | Informational | November 2020 |
| 8949 | Concise Binary Object Representation (CBOR)C. Bormann, P. Hoffman | Internet Standard | December 2020 |
| 8941 | Structured Field Values for HTTPM. Nottingham, P-H. Kamp · obsoleted by RFC 9651 | Proposed Standard | February 2021 |
| 8911 | Registry for Performance MetricsM. Bagnulo, B. Claise, P. Eardley, A. Morton, A. Akhter | Proposed Standard | November 2021 |
| 8910 | Captive-Portal Identification in DHCP and Router Advertisements (RAs)W. Kumari, E. Kline | Proposed Standard | September 2020 |
| 8905 | The 'payto' URI Scheme for PaymentsF. Dold, C. Grothoff | Informational | October 2020 |
| 8895 | Application-Layer Traffic Optimization (ALTO) Incremental Updates Using Server-Sent Events (SSE)W. Roome, Y. Yang | Proposed Standard | November 2020 |
| 8894 | Simple Certificate Enrolment ProtocolP. Gutmann | Informational | September 2020 |
| 8876 | Non-interactive Emergency CallsB. Rosen, H. Schulzrinne, H. Tschofenig, R. Gellens | Proposed Standard | September 2020 |
| 8866 | SDP: Session Description ProtocolA. Begen, P. Kyzivat, C. Perkins, M. Handley | Proposed Standard | January 2021 |
| 8828 | WebRTC IP Address Handling RequirementsJ. Uberti, G. Shieh | Proposed Standard | January 2021 |
| 8827 | WebRTC Security ArchitectureE. Rescorla | Proposed Standard | January 2021 |
| 8820 | URI Design and OwnershipM. Nottingham | Best Current Practice | June 2020 |
| 8804 | Content Delivery Network Interconnection (CDNI) Request Routing ExtensionsO. Finkelman, S. Mishra | Proposed Standard | September 2020 |
| 8802 | The Quality for Service (Q4S) ProtocolJ.J. Aranda, M. Cortes, J. Salvachúa, M. Narganes, I. Martínez-Sarriegui | Informational | July 2020 |
| 8783 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Data Channel SpecificationM. Boucadair, Ed., T. Reddy.K, Ed. | Proposed Standard | May 2020 |
| 8782 | Distributed Denial-of-Service Open Threat Signaling (DOTS) Signal Channel SpecificationT. Reddy.K, Ed., M. Boucadair, Ed., P. Patil, A. Mortensen, N. Teague · obsoleted by RFC 9132 | Proposed Standard | May 2020 |
| 8727 | JSON Binding of the Incident Object Description Exchange FormatT. Takahashi, R. Danyliw, M. Suzuki | Proposed Standard | August 2020 |
| 8707 | Resource Indicators for OAuth 2.0B. Campbell, J. Bradley, H. Tschofenig | Proposed Standard | February 2020 |
| 8693 | OAuth 2.0 Token ExchangeM. Jones, A. Nadalin, B. Campbell, Ed., J. Bradley, C. Mortimore | Proposed Standard | January 2020 |
| 8677 | Name-Based Service Function Forwarder (nSFF) Component within a Service Function Chaining (SFC) FrameworkD. Trossen, D. Purkayastha, A. Rahman | Informational | November 2019 |
| 8657 | Certification Authority Authorization (CAA) Record Extensions for Account URI and Automatic Certificate Management Environment (ACME) Method BindingH. Landau | Proposed Standard | November 2019 |
| 8630 | Resource Public Key Infrastructure (RPKI) Trust Anchor LocatorG. Huston, S. Weiler, G. Michaelson, S. Kent, T. Bruijnzeels | Proposed Standard | August 2019 |
| 8618 | Compacted-DNS (C-DNS): A Format for DNS Packet CaptureJ. Dickinson, J. Hague, S. Dickinson, T. Manderson, J. Bond | Proposed Standard | September 2019 |
| 8615 | Well-Known Uniform Resource Identifiers (URIs)M. Nottingham | Proposed Standard | May 2019 |
| 8613 | Object Security for Constrained RESTful Environments (OSCORE)G. Selander, J. Mattsson, F. Palombini, L. Seitz | Proposed Standard | July 2019 |
| 8612 | DDoS Open Threat Signaling (DOTS) RequirementsA. Mortensen, T. Reddy, R. Moskowitz | Informational | May 2019 |
| 8605 | vCard Format Extensions: ICANN Extensions for the Registration Data Access Protocol (RDAP)S. Hollenbeck, R. Carney | Informational | May 2019 |
| 8589 | The 'leaptofrogans' URI SchemeA. Tamas, B. Phister, Ed., J-E. Rodriguez | Informational | May 2019 |
| 8555 | Automatic Certificate Management Environment (ACME)R. Barnes, J. Hoffman-Andrews, D. McCarney, J. Kasten | Proposed Standard | March 2019 |
| 8543 | Extensible Provisioning Protocol (EPP) Organization MappingL. Zhou, N. Kong, J. Yao, J. Gould, G. Zhou | Proposed Standard | March 2019 |
| 8521 | Registration Data Access Protocol (RDAP) Object TaggingS. Hollenbeck, A. Newton | Best Current Practice | November 2018 |
| 8520 | Manufacturer Usage Description SpecificationE. Lear, R. Droms, D. Romascanu | Proposed Standard | March 2019 |
| 8506 | Diameter Credit-Control ApplicationL. Bertz, Ed., D. Dolson, Ed., Y. Lifshitz, Ed. | Proposed Standard | March 2019 |
| 8493 | The BagIt File Packaging Format (V1.0)J. Kunze, J. Littman, E. Madden, J. Scancella, C. Adams | Informational | October 2018 |
| 8464 | A URN Namespace for Device Identity and Mobile Equipment Identity (MEID)R. Atarius | Informational | September 2018 |
| 8460 | SMTP TLS ReportingD. Margolis, A. Brotman, B. Ramakrishnan, J. Jones, M. Risher | Proposed Standard | September 2018 |
| 8458 | Using National Bibliography Numbers as Uniform Resource NamesJ. Hakala | Informational | October 2018 |
| 8428 | Sensor Measurement Lists (SenML)C. Jennings, Z. Shelby, J. Arkko, A. Keranen, C. Bormann | Proposed Standard | August 2018 |
| 8417 | Security Event Token (SET)P. Hunt, Ed., M. Jones, W. Denniss, M. Ansari | Proposed Standard | July 2018 |
| 8412 | Software Inventory Message and Attributes (SWIMA) for PA-TNCC. Schmidt, D. Haynes, C. Coffin, D. Waltermire, J. Fitzgerald-McKay | Proposed Standard | July 2018 |
| 8407 | Guidelines for Authors and Reviewers of Documents Containing YANG Data ModelsA. Bierman · obsoleted by RFC 9907 | Best Current Practice | October 2018 |
| 8324 | DNS Privacy, Authorization, Special Uses, Encoding, Characters, Matching, and Root Structure: Time for Another Look?J. Klensin | Informational | February 2018 |
| 8323 | CoAP (Constrained Application Protocol) over TCP, TLS, and WebSocketsC. Bormann, S. Lemay, H. Tschofenig, K. Hartke, B. Silverajan, B. Raymor, Ed. | Proposed Standard | February 2018 |
| 8322 | Resource-Oriented Lightweight Information Exchange (ROLIE)J. Field, S. Banghart, D. Waltermire | Proposed Standard | February 2018 |
| 8295 | EST (Enrollment over Secure Transport) ExtensionsS. Turner | Proposed Standard | January 2018 |
| 8288 | Web LinkingM. Nottingham | Proposed Standard | October 2017 |
| 8285 | A General Mechanism for RTP Header ExtensionsD. Singer, H. Desineni, R. Even, Ed. | Proposed Standard | October 2017 |
| 8252 | OAuth 2.0 for Native AppsW. Denniss, J. Bradley | Best Current Practice | October 2017 |
| 8226 | Secure Telephone Identity Credentials: CertificatesJ. Peterson, S. Turner | Proposed Standard | February 2018 |
| 8225 | PASSporT: Personal Assertion TokenC. Wendt, J. Peterson | Proposed Standard | February 2018 |
| 8224 | Authenticated Identity Management in the Session Initiation Protocol (SIP)J. Peterson, C. Jennings, E. Rescorla, C. Wendt | Proposed Standard | February 2018 |
| 8216 | HTTP Live StreamingR. Pantos, Ed., W. May | Informational | August 2017 |
| 8193 | Information Model for Large-Scale Measurement Platforms (LMAPs)T. Burbridge, P. Eardley, M. Bagnulo, J. Schoenwaelder | Proposed Standard | August 2017 |
| 8187 | Indicating Character Encoding and Language for HTTP Header Field ParametersJ. Reschke | Proposed Standard | September 2017 |
| 8181 | A Publication Protocol for the Resource Public Key Infrastructure (RPKI)S. Weiler, A. Sonalker, R. Austein | Proposed Standard | July 2017 |
| 8141 | Uniform Resource Names (URNs)P. Saint-Andre, J. Klensin | Proposed Standard | April 2017 |
| 8118 | The application/pdf Media TypeM. Hardy, L. Masinter, D. Markovic, D. Johnson, M. Bailey | Informational | March 2017 |
| 8089 | The "file" URI SchemeM. Kerwin | Proposed Standard | February 2017 |
| 8081 | The "font" Top-Level Media TypeC. Lilley | Proposed Standard | February 2017 |
| 8075 | Guidelines for Mapping Implementations: HTTP to the Constrained Application Protocol (CoAP)A. Castellani, S. Loreto, A. Rahman, T. Fossati, E. Dijk | Proposed Standard | February 2017 |
| 8060 | LISP Canonical Address Format (LCAF)D. Farinacci, D. Meyer, J. Snijders | Experimental | February 2017 |
| 8040 | RESTCONF ProtocolA. Bierman, M. Bjorklund, K. Watsen | Proposed Standard | January 2017 |
| 8011 | Internet Printing Protocol/1.1: Model and SemanticsM. Sweet, I. McDonald | Internet Standard | January 2017 |
| 8010 | Internet Printing Protocol/1.1: Encoding and TransportM. Sweet, I. McDonald | Internet Standard | January 2017 |
| 8007 | Content Delivery Network Interconnection (CDNI) Control Interface / TriggersR. Murray, B. Niven-Jenkins | Proposed Standard | December 2016 |
| 8006 | Content Delivery Network Interconnection (CDNI) MetadataB. Niven-Jenkins, R. Murray, M. Caulfield, K. Ma | Proposed Standard | December 2016 |
| 7991 | The "xml2rfc" Version 3 VocabularyP. Hoffman | Informational | December 2016 |
| 7977 | The WebSocket Protocol as a Transport for the Message Session Relay Protocol (MSRP)P. Dunkley, G. Llewellyn, V. Pascual, G. Salgueiro, R. Ravindranath | Proposed Standard | September 2016 |
| 7975 | Request Routing Redirection Interface for Content Delivery Network (CDN) InterconnectionB. Niven-Jenkins, Ed., R. van Brandenburg, Ed. | Proposed Standard | October 2016 |
| 7970 | The Incident Object Description Exchange Format Version 2R. Danyliw | Proposed Standard | November 2016 |
| 7950 | The YANG 1.1 Data Modeling LanguageM. Bjorklund, Ed. | Proposed Standard | August 2016 |
| 7937 | Content Distribution Network Interconnection (CDNI) Logging InterfaceF. Le Faucheur, Ed., G. Bertrand, Ed., I. Oprescu, Ed., R. Peterkofsky | Proposed Standard | August 2016 |
| 7909 | Securing Routing Policy Specification Language (RPSL) Objects with Resource Public Key Infrastructure (RPKI) SignaturesR. Kisteleki, B. Haberman | Proposed Standard | June 2016 |
| 7904 | A SIP Usage for REsource LOcation And Discovery (RELOAD)C. Jennings, B. Lowekamp, E. Rescorla, S. Baset, H. Schulzrinne, T. Schmidt, Ed. | Proposed Standard | October 2016 |
| 7890 | Concepts and Terminology for Peer-to-Peer SIP (P2PSIP)D. Bryan, P. Matthews, E. Shim, D. Willis, S. Dawkins | Informational | June 2016 |
| 7877 | Session Peering Provisioning Framework (SPPF)K. Cartwright, V. Bhatia, S. Ali, D. Schwartz | Proposed Standard | August 2016 |
| 7869 | The "vnc" URI SchemeD. Warden, I. Iordanov | Informational | May 2016 |
| 7862 | Network File System (NFS) Version 4 Minor Version 2 ProtocolT. Haynes | Proposed Standard | November 2016 |
| 7849 | An IPv6 Profile for 3GPP Mobile DevicesD. Binet, M. Boucadair, A. Vizdal, G. Chen, N. Heatley, R. Chandler, D. Michaud, D. Lopez, W. Haeffner | Informational | May 2016 |
| 7846 | Peer-to-Peer Streaming Tracker Protocol (PPSTP)R. Cruz, M. Nunes, J. Xia, R. Huang, Ed., J. Taveira, D. Lingli | Proposed Standard | May 2016 |
| 7838 | HTTP Alternative ServicesM. Nottingham, P. McManus, J. Reschke | Proposed Standard | April 2016 |
| 7826 | Real-Time Streaming Protocol Version 2.0H. Schulzrinne, A. Rao, R. Lanphier, M. Westerlund, M. Stiemerling, Ed. | Proposed Standard | December 2016 |
| 7825 | A Network Address Translator (NAT) Traversal Mechanism for Media Controlled by the Real-Time Streaming Protocol (RTSP)J. Goldberg, M. Westerlund, T. Zeng | Proposed Standard | December 2016 |
| 7817 | Updated Transport Layer Security (TLS) Server Identity Check Procedure for Email-Related ProtocolsA. Melnikov | Proposed Standard | March 2016 |
| 7807 | Problem Details for HTTP APIsM. Nottingham, E. Wilde · obsoleted by RFC 9457 | Proposed Standard | March 2016 |
| 7800 | Proof-of-Possession Key Semantics for JSON Web Tokens (JWTs)M. Jones, J. Bradley, H. Tschofenig | Proposed Standard | April 2016 |
| 7797 | JSON Web Signature (JWS) Unencoded Payload OptionM. Jones | Proposed Standard | February 2016 |
| 7763 | The text/markdown Media TypeS. Leonard | Informational | March 2016 |
| 7749 | The "xml2rfc" Version 2 VocabularyJ. Reschke · obsoleted by RFC 7991 | Informational | February 2016 |
| 7738 | A Uniform Resource Name (URN) Namespace for the Consultative Committee for Space Data Systems (CCSDS)M. Blanchet, A. Schiltknecht, P. Shames | Informational | January 2016 |
| 7725 | An HTTP Status Code to Report Legal ObstaclesT. Bray | Proposed Standard | February 2016 |
| 7710 | Captive-Portal Identification Using DHCP or Router Advertisements (RAs)W. Kumari, O. Gudmundsson, P. Ebersman, S. Sheng · obsoleted by RFC 8910 | Proposed Standard | December 2015 |
| 7686 | The ".onion" Special-Use Domain NameJ. Appelbaum, A. Muffett | Proposed Standard | October 2015 |
| 7650 | A Constrained Application Protocol (CoAP) Usage for REsource LOcation And Discovery (RELOAD)J. Jimenez, J. Lopez-Vega, J. Maenpaa, G. Camarillo | Proposed Standard | September 2015 |
| 7644 | System for Cross-domain Identity Management: ProtocolP. Hunt, Ed., K. Grizzle, M. Ansari, E. Wahlstroem, C. Mortimore | Proposed Standard | September 2015 |
| 7643 | System for Cross-domain Identity Management: Core SchemaP. Hunt, Ed., K. Grizzle, E. Wahlstroem, C. Mortimore | Proposed Standard | September 2015 |
| 7639 | The ALPN HTTP Header FieldA. Hutton, J. Uberti, M. Thomson | Proposed Standard | August 2015 |
| 7636 | Proof Key for Code Exchange by OAuth Public ClientsN. Sakimura, Ed., J. Bradley, N. Agarwal | Proposed Standard | September 2015 |
| 7622 | Extensible Messaging and Presence Protocol (XMPP): Address FormatP. Saint-Andre | Proposed Standard | September 2015 |
| 7617 | The 'Basic' HTTP Authentication SchemeJ. Reschke | Proposed Standard | September 2015 |
| 7616 | HTTP Digest Access AuthenticationR. Shekh-Yusef, Ed., D. Ahrens, S. Bremer | Proposed Standard | September 2015 |
| 7595 | Guidelines and Registration Procedures for URI SchemesD. Thaler, Ed., T. Hansen, T. Hardie | Best Current Practice | June 2015 |
| 7578 | Returning Values from Forms: multipart/form-dataL. Masinter | Proposed Standard | July 2015 |
| 7574 | Peer-to-Peer Streaming Peer Protocol (PPSPP)A. Bakker, R. Petrocco, V. Grishchenko | Proposed Standard | July 2015 |
| 7566 | Enumservice Registration for 'acct' URIL. Goix, K. Li | Experimental | June 2015 |
| 7565 | The 'acct' URI SchemeP. Saint-Andre | Proposed Standard | May 2015 |
| 7553 | The Uniform Resource Identifier (URI) DNS Resource RecordP. Faltstrom, O. Kolkman | Informational | June 2015 |
| 7540 | Hypertext Transfer Protocol Version 2 (HTTP/2)M. Belshe, R. Peon, M. Thomson, Ed. · obsoleted by RFC 9113 | Proposed Standard | May 2015 |
| 7538 | The Hypertext Transfer Protocol Status Code 308 (Permanent Redirect)J. Reschke · obsoleted by RFC 9110 | Proposed Standard | April 2015 |
| 7532 | Namespace Database (NSDB) Protocol for Federated File SystemsJ. Lentini, R. Tewari, C. Lever, Ed. | Proposed Standard | March 2015 |
| 7523 | JSON Web Token (JWT) Profile for OAuth 2.0 Client Authentication and Authorization GrantsM. Jones, B. Campbell, C. Mortimore | Proposed Standard | May 2015 |
| 7522 | Security Assertion Markup Language (SAML) 2.0 Profile for OAuth 2.0 Client Authentication and Authorization GrantsB. Campbell, C. Mortimore, M. Jones | Proposed Standard | May 2015 |
| 7521 | Assertion Framework for OAuth 2.0 Client Authentication and Authorization GrantsB. Campbell, C. Mortimore, M. Jones, Y. Goland | Proposed Standard | May 2015 |
| 7519 | JSON Web Token (JWT)M. Jones, J. Bradley, N. Sakimura | Proposed Standard | May 2015 |
| 7517 | JSON Web Key (JWK)M. Jones | Proposed Standard | May 2015 |
| 7515 | JSON Web Signature (JWS)M. Jones, J. Bradley, N. Sakimura | Proposed Standard | May 2015 |
| 7512 | The PKCS #11 URI SchemeJ. Pechanec, D. Moffat | Proposed Standard | April 2015 |
| 7495 | Enumeration Reference Format for the Incident Object Description Exchange Format (IODEF)A. Montville, D. Black | Proposed Standard | March 2015 |
| 7489 | Domain-based Message Authentication, Reporting, and Conformance (DMARC)M. Kucherawy, Ed., E. Zwicky, Ed. · obsoleted by RFC 9989, RFC 9990, RFC 9991 | Informational | March 2015 |
| 7486 | HTTP Origin-Bound Authentication (HOBA)S. Farrell, P. Hoffman, M. Thomas | Experimental | March 2015 |
| 7483 | JSON Responses for the Registration Data Access Protocol (RDAP)A. Newton, S. Hollenbeck · obsoleted by RFC 9083 | Proposed Standard | March 2015 |
| 7482 | Registration Data Access Protocol (RDAP) Query FormatA. Newton, S. Hollenbeck · obsoleted by RFC 9082 | Proposed Standard | March 2015 |
| 7480 | HTTP Usage in the Registration Data Access Protocol (RDAP)A. Newton, B. Ellacott, N. Kong | Internet Standard | March 2015 |
| 7469 | Public Key Pinning Extension for HTTPC. Evans, C. Palmer, R. Sleevi | Proposed Standard | April 2015 |
| 7467 | URN Namespace for the North Atlantic Treaty Organization (NATO)A. Murdock | Informational | April 2015 |
| 7444 | Security Labels in Internet EmailK. Zeilenga, A. Melnikov | Informational | February 2015 |
| 7425 | Adobe's RTMFP Profile for Flash CommunicationM. Thornburgh | Informational | December 2014 |
| 7393 | Using the Port Control Protocol (PCP) to Update Dynamic DNSX. Deng, M. Boucadair, Q. Zhao, J. Huang, C. Zhou | Informational | November 2014 |
| 7390 | Group Communication for the Constrained Application Protocol (CoAP)A. Rahman, Ed., E. Dijk, Ed. | Experimental | October 2014 |
| 7373 | Textual Representation of IP Flow Information Export (IPFIX) Abstract Data TypesB. Trammell | Proposed Standard | September 2014 |
| 7326 | Energy Management FrameworkJ. Parello, B. Claise, B. Schoening, J. Quittek | Informational | September 2014 |
| 7322 | RFC Style GuideH. Flanagan, S. Ginoza | Informational | September 2014 |
| 7320 | URI Design and OwnershipM. Nottingham · obsoleted by RFC 8820 | Best Current Practice | July 2014 |
| 7303 | XML Media TypesH. Thompson, C. Lilley | Proposed Standard | July 2014 |
| 7285 | Application-Layer Traffic Optimization (ALTO) ProtocolR. Alimi, Ed., R. Penno, Ed., Y. Yang, Ed., S. Kiesel, S. Previdi, W. Roome, S. Shalunov, R. Woundy | Proposed Standard | September 2014 |
| 7284 | The Profile URI RegistryM. Lanthaler | Informational | June 2014 |
| 7265 | jCal: The JSON Format for iCalendarP. Kewisch, C. Daboo, M. Douglass | Proposed Standard | May 2014 |
| 7259 | The Jabber-ID Header FieldP. Saint-Andre | Informational | May 2014 |
| 7252 | The Constrained Application Protocol (CoAP)Z. Shelby, K. Hartke, C. Bormann | Proposed Standard | June 2014 |
| 7247 | Interworking between the Session Initiation Protocol (SIP) and the Extensible Messaging and Presence Protocol (XMPP): Architecture, Addresses, and Error HandlingP. Saint-Andre, A. Houri, J. Hildebrand | Proposed Standard | May 2014 |
| 7239 | Forwarded HTTP ExtensionA. Petersson, M. Nilsson | Proposed Standard | June 2014 |
| 7238 | The Hypertext Transfer Protocol Status Code 308 (Permanent Redirect)J. Reschke · obsoleted by RFC 7538 | Experimental | June 2014 |
| 7235 | Hypertext Transfer Protocol (HTTP/1.1): AuthenticationR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7231 | Hypertext Transfer Protocol (HTTP/1.1): Semantics and ContentR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110 | Proposed Standard | June 2014 |
| 7230 | Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and RoutingR. Fielding, Ed., J. Reschke, Ed. · obsoleted by RFC 9110, RFC 9112 | Proposed Standard | June 2014 |
| 7227 | Guidelines for Creating New DHCPv6 OptionsD. Hankins, T. Mrugalski, M. Siodelski, S. Jiang, S. Krishnan | Best Current Practice | May 2014 |
| 7208 | Sender Policy Framework (SPF) for Authorizing Use of Domains in Email, Version 1S. Kitterman | Proposed Standard | April 2014 |
| 7207 | A Uniform Resource Name (URN) Namespace for Eurosystem MessagingM. Ortseifen, G. Dickfeld | Informational | April 2014 |
| 7203 | An Incident Object Description Exchange Format (IODEF) Extension for Structured Cybersecurity InformationT. Takahashi, K. Landfield, Y. Kadobayashi | Proposed Standard | April 2014 |
| 7151 | File Transfer Protocol HOST Command for Virtual HostsP. Hethmon, R. McMurray | Proposed Standard | March 2014 |
| 7143 | Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)M. Chadalapaka, J. Satran, K. Meth, D. Black | Proposed Standard | April 2014 |
| 7118 | The WebSocket Protocol as a Transport for the Session Initiation Protocol (SIP)I. Baz Castillo, J. Millan Villegas, V. Pascual | Proposed Standard | January 2014 |
| 7111 | URI Fragment Identifiers for the text/csv Media TypeM. Hausenblas, E. Wilde, J. Tennison | Informational | January 2014 |
| 7105 | Using Device-Provided Location-Related Measurements in Location Configuration ProtocolsM. Thomson, J. Winterbottom | Proposed Standard | January 2014 |
| 7103 | Advice for Safe Handling of Malformed MessagesM. Kucherawy, G. Shapiro, N. Freed | Informational | January 2014 |
| 7065 | Traversal Using Relays around NAT (TURN) Uniform Resource IdentifiersM. Petit-Huguenin, S. Nandakumar, G. Salgueiro, P. Jones | Proposed Standard | November 2013 |
| 7064 | URI Scheme for the Session Traversal Utilities for NAT (STUN) ProtocolS. Nandakumar, G. Salgueiro, P. Jones, M. Petit-Huguenin | Proposed Standard | November 2013 |
| 7056 | Name Attributes for the GSS-API Extensible Authentication Protocol (EAP) MechanismS. Hartman, J. Howlett | Proposed Standard | December 2013 |
| 7049 | Concise Binary Object Representation (CBOR)C. Bormann, P. Hoffman · obsoleted by RFC 8949 | Proposed Standard | October 2013 |
| 7046 | A Common API for Transparent Hybrid MulticastM. Waehlisch, T. Schmidt, S. Venaas | Experimental | December 2013 |
| 7035 | Relative Location RepresentationM. Thomson, B. Rosen, D. Stanley, G. Bajko, A. Thomson | Proposed Standard | October 2013 |
| 7034 | HTTP Header Field X-Frame-OptionsD. Ross, T. Gondrom | Informational | October 2013 |
| 7033 | WebFingerP. Jones, G. Salgueiro, M. Jones, J. Smarr | Proposed Standard | September 2013 |
| 7030 | Enrollment over Secure TransportM. Pritikin, Ed., P. Yee, Ed., D. Harkins, Ed. | Proposed Standard | October 2013 |
| 6993 | Instant Messaging and Presence Purpose for the Call-Info Header Field in the Session Initiation Protocol (SIP)P. Saint-Andre | Informational | July 2013 |
| 6991 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 9911 | Proposed Standard | July 2013 |
| 6983 | Models for HTTP-Adaptive-Streaming-Aware Content Distribution Network Interconnection (CDNI)R. van Brandenburg, O. van Deventer, F. Le Faucheur, K. Leung | Informational | July 2013 |
| 6960 | X.509 Internet Public Key Infrastructure Online Certificate Status Protocol - OCSPS. Santesson, M. Myers, R. Ankney, A. Malpani, S. Galperin, C. Adams | Proposed Standard | June 2013 |
| 6950 | Architectural Considerations on Application Features in the DNSJ. Peterson, O. Kolkman, H. Tschofenig, B. Aboba | Informational | October 2013 |
| 6943 | Issues in Identifier Comparison for Security PurposesD. Thaler, Ed. | Informational | May 2013 |
| 6940 | REsource LOcation And Discovery (RELOAD) Base ProtocolC. Jennings, B. Lowekamp, Ed., E. Rescorla, S. Baset, H. Schulzrinne | Proposed Standard | January 2014 |
| 6933 | Entity MIB (Version 4)A. Bierman, D. Romascanu, J. Quittek, M. Chandramouli | Proposed Standard | May 2013 |
| 6931 | Additional XML Security Uniform Resource Identifiers (URIs)D. Eastlake 3rd · obsoleted by RFC 9231 | Proposed Standard | April 2013 |
| 6920 | Naming Things with HashesS. Farrell, D. Kutscher, C. Dannewitz, B. Ohlman, A. Keranen, P. Hallam-Baker | Proposed Standard | April 2013 |
| 6915 | Flow Identity Extension for HTTP-Enabled Location Delivery (HELD)R. Bellis | Proposed Standard | April 2013 |
| 6901 | JavaScript Object Notation (JSON) PointerP. Bryan, Ed., K. Zyp, M. Nottingham, Ed. | Proposed Standard | April 2013 |
| 6880 | An Information Model for Kerberos Version 5L. Johansson | Proposed Standard | March 2013 |
| 6874 | Representing IPv6 Zone Identifiers in Address Literals and Uniform Resource IdentifiersB. Carpenter, S. Cheshire, R. Hinden · obsoleted by RFC 9844 | Proposed Standard | February 2013 |
| 6838 | Media Type Specifications and Registration ProceduresN. Freed, J. Klensin, T. Hansen | Best Current Practice | January 2013 |
| 6837 | NERD: A Not-so-novel Endpoint ID (EID) to Routing Locator (RLOC) DatabaseE. Lear | Experimental | January 2013 |
| 6797 | HTTP Strict Transport Security (HSTS)J. Hodges, C. Jackson, A. Barth | Proposed Standard | November 2012 |
| 6794 | A Framework for Session Initiation Protocol (SIP) Session PoliciesV. Hilt, G. Camarillo, J. Rosenberg | Proposed Standard | December 2012 |
| 6787 | Media Resource Control Protocol Version 2 (MRCPv2)D. Burnett, S. Shanmugham | Proposed Standard | November 2012 |
| 6783 | Mailing Lists and Non-ASCII AddressesJ. Levine, R. Gellens | Informational | November 2012 |
| 6764 | Locating Services for Calendaring Extensions to WebDAV (CalDAV) and vCard Extensions to WebDAV (CardDAV)C. Daboo | Proposed Standard | February 2013 |
| 6750 | The OAuth 2.0 Authorization Framework: Bearer Token UsageM. Jones, D. Hardt | Proposed Standard | October 2012 |
| 6749 | The OAuth 2.0 Authorization FrameworkD. Hardt, Ed. | Proposed Standard | October 2012 |
| 6733 | Diameter Base ProtocolV. Fajardo, Ed., J. Arkko, J. Loughney, G. Zorn, Ed. | Proposed Standard | October 2012 |
| 6726 | FLUTE - File Delivery over Unidirectional TransportT. Paila, R. Walsh, M. Luby, V. Roca, R. Lehtonen | Proposed Standard | November 2012 |
| 6721 | The Atom "deleted-entry" ElementJ. Snell | Proposed Standard | September 2012 |
| 6712 | Internet X.509 Public Key Infrastructure -- HTTP Transfer for the Certificate Management Protocol (CMP)T. Kause, M. Peylo · obsoleted by RFC 9811 | Proposed Standard | September 2012 |
| 6694 | The "about" URI SchemeS. Moonesamy, Ed. | Informational | August 2012 |
| 6690 | Constrained RESTful Environments (CoRE) Link FormatZ. Shelby | Proposed Standard | August 2012 |
| 6648 | Deprecating the "X-" Prefix and Similar Constructs in Application ProtocolsP. Saint-Andre, D. Crocker, M. Nottingham | Best Current Practice | June 2012 |
| 6632 | An Overview of the IETF Network Management StandardsM. Ersue, Ed., B. Claise | Informational | June 2012 |
| 6616 | A Simple Authentication and Security Layer (SASL) and Generic Security Service Application Program Interface (GSS-API) Mechanism for OpenIDE. Lear, H. Tschofenig, H. Mauldin, S. Josefsson | Proposed Standard | May 2012 |
| 6596 | The Canonical Link RelationM. Ohye, J. Kupke | Informational | April 2012 |
| 6595 | A Simple Authentication and Security Layer (SASL) and GSS-API Mechanism for the Security Assertion Markup Language (SAML)K. Wierenga, E. Lear, S. Josefsson | Proposed Standard | April 2012 |
| 6588 | A URN Namespace for ucodeC. Ishikawa | Informational | April 2012 |
| 6570 | URI TemplateJ. Gregorio, R. Fielding, M. Hadley, M. Nottingham, D. Orchard | Proposed Standard | March 2012 |
| 6560 | One-Time Password (OTP) Pre-AuthenticationG. Richards | Proposed Standard | April 2012 |
| 6545 | Real-time Inter-network Defense (RID)K. Moriarty | Proposed Standard | April 2012 |
| 6509 | MIKEY-SAKKE: Sakai-Kasahara Key Encryption in Multimedia Internet KEYing (MIKEY)M. Groves | Informational | February 2012 |
| 6501 | Conference Information Data Model for Centralized Conferencing (XCON)O. Novo, G. Camarillo, D. Morgan, J. Urpalainen | Proposed Standard | March 2012 |
| 6487 | A Profile for X.509 PKIX Resource CertificatesG. Huston, G. Michaelson, R. Loomans | Proposed Standard | February 2012 |
| 6481 | A Profile for Resource Certificate Repository StructureG. Huston, R. Loomans, G. Michaelson | Proposed Standard | February 2012 |
| 6455 | The WebSocket ProtocolI. Fette, A. Melnikov | Proposed Standard | December 2011 |
| 6454 | The Web Origin ConceptA. Barth | Proposed Standard | December 2011 |
| 6453 | A URN Namespace for the Open Grid Forum (OGF)F. Dijkstra, R. Hughes-Jones | Informational | December 2011 |
| 6443 | Framework for Emergency Calling Using Internet MultimediaB. Rosen, H. Schulzrinne, J. Polk, A. Newton | Informational | December 2011 |
| 6415 | Web Host MetadataE. Hammer-Lahav, Ed., B. Cook | Proposed Standard | October 2011 |
| 6350 | vCard Format SpecificationS. Perreault | Proposed Standard | August 2011 |
| 6315 | IANA Registration for Enumservice 'iax'E. Guy, K. Darilion | Informational | July 2011 |
| 6295 | RTP Payload Format for MIDIJ. Lazzaro, J. Wawrzynek | Proposed Standard | June 2011 |
| 6283 | Extensible Markup Language Evidence Record Syntax (XMLERS)A. Jerman Blazic, S. Saljic, T. Gondrom | Proposed Standard | July 2011 |
| 6271 | Requirements for SIP-Based Session PeeringJ-F. Mule | Informational | June 2011 |
| 6270 | The 'tn3270' URI SchemeM. Yevstifeyev | Proposed Standard | June 2011 |
| 6266 | Use of the Content-Disposition Header Field in the Hypertext Transfer Protocol (HTTP)J. Reschke | Proposed Standard | June 2011 |
| 6260 | Compressed Bundle Header Encoding (CBHE)S. Burleigh | Experimental | May 2011 |
| 6258 | Delay-Tolerant Networking Metadata Extension BlockS. Symington | Experimental | May 2011 |
| 6257 | Bundle Security Protocol SpecificationS. Symington, S. Farrell, H. Weiss, P. Lovell | Experimental | May 2011 |
| 6249 | Metalink/HTTP: Mirrors and HashesA. Bryan, N. McNab, T. Tsujikawa, P. Poeml, H. Nordstrom | Proposed Standard | June 2011 |
| 6241 | Network Configuration Protocol (NETCONF)R. Enns, Ed., M. Bjorklund, Ed., J. Schoenwaelder, Ed., A. Bierman, Ed. | Proposed Standard | June 2011 |
| 6231 | An Interactive Voice Response (IVR) Control Package for the Media Control Channel FrameworkS. McGlashan, T. Melanchuk, C. Boulton | Proposed Standard | May 2011 |
| 6217 | Regional Broadcast Using an Atmospheric Link LayerT. Ritter | Experimental | 31 March 2011 |
| 6208 | Cloud Data Management Interface (CDMI) Media TypesK. Sankar, Ed., A. Jones | Informational | April 2011 |
| 6207 | The Media Types application/mods+xml, application/mads+xml, application/mets+xml, application/marcxml+xml, and application/sru+xmlR. Denenberg, Ed. | Informational | April 2011 |
| 6167 | URI Scheme for Java(tm) Message Service 1.0M. Phillips, P. Adams, D. Rokicki, E. Johnson | Informational | April 2011 |
| 6155 | Use of Device Identity in HTTP-Enabled Location Delivery (HELD)J. Winterbottom, M. Thomson, H. Tschofenig, R. Barnes | Proposed Standard | March 2011 |
| 6134 | Sieve Extension: Externally Stored ListsA. Melnikov, B. Leiba | Proposed Standard | July 2011 |
| 6129 | The 'application/tei+xml' Media TypeL. Romary, S. Lundberg | Informational | February 2011 |
| 6125 | Representation and Verification of Domain-Based Application Service Identity within Internet Public Key Infrastructure Using X.509 (PKIX) Certificates in the Context of Transport Layer Security (TLS)P. Saint-Andre, J. Hodges · obsoleted by RFC 9525 | Proposed Standard | March 2011 |
| 6122 | Extensible Messaging and Presence Protocol (XMPP): Address FormatP. Saint-Andre · obsoleted by RFC 7622 | Proposed Standard | March 2011 |
| 6121 | Extensible Messaging and Presence Protocol (XMPP): Instant Messaging and PresenceP. Saint-Andre | Proposed Standard | March 2011 |
| 6120 | Extensible Messaging and Presence Protocol (XMPP): CoreP. Saint-Andre | Proposed Standard | March 2011 |
| 6117 | IANA Registration of Enumservices: Guide, Template, and IANA ConsiderationsB. Hoeneisen, A. Mayrhofer, J. Livingood | Proposed Standard | March 2011 |
| 6116 | The E.164 to Uniform Resource Identifiers (URI) Dynamic Delegation Discovery System (DDDS) Application (ENUM)S. Bradner, L. Conroy, K. Fujiwara | Proposed Standard | March 2011 |
| 6108 | Comcast's Web Notification System DesignC. Chung, A. Kasyanov, J. Livingood, N. Mody, B. Van Lieu | Historic | February 2011 |
| 6087 | Guidelines for Authors and Reviewers of YANG Data Model DocumentsA. Bierman · obsoleted by RFC 8407 | Informational | January 2011 |
| 6068 | The 'mailto' URI SchemeM. Duerst, L. Masinter, J. Zawinski | Proposed Standard | October 2010 |
| 6066 | Transport Layer Security (TLS) Extensions: Extension DefinitionsD. Eastlake 3rd | Proposed Standard | January 2011 |
| 6063 | Dynamic Symmetric Key Provisioning Protocol (DSKPP)A. Doherty, M. Pei, S. Machani, M. Nystrom | Proposed Standard | December 2010 |
| 6042 | Transport Layer Security (TLS) Authorization Using KeyNoteA. Keromytis | Informational | October 2010 |
| 6030 | Portable Symmetric Key Container (PSKC)P. Hoyer, M. Pei, S. Machani | Proposed Standard | October 2010 |
| 6021 | Common YANG Data TypesJ. Schoenwaelder, Ed. · obsoleted by RFC 6991 | Proposed Standard | October 2010 |
| 6020 | YANG - A Data Modeling Language for the Network Configuration Protocol (NETCONF)M. Bjorklund, Ed. | Proposed Standard | October 2010 |
| 6011 | Session Initiation Protocol (SIP) User Agent ConfigurationS. Lawrence, Ed., J. Elwell | Informational | October 2010 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |
| 5988 | Web LinkingM. Nottingham · obsoleted by RFC 8288 | Proposed Standard | October 2010 |
| 5987 | Character Set and Language Encoding for Hypertext Transfer Protocol (HTTP) Header Field ParametersJ. Reschke · obsoleted by RFC 8187 | Historic | August 2010 |
| 5985 | HTTP-Enabled Location Delivery (HELD)M. Barnes, Ed. | Proposed Standard | September 2010 |
| 5983 | Mailing Lists and Internationalized Email AddressesR. Gellens · obsoleted by RFC 6783 | Experimental | October 2010 |
| 5981 | Authorization for NSIS Signaling Layer ProtocolsJ. Manner, M. Stiemerling, H. Tschofenig, R. Bless, Ed. | Experimental | February 2011 |
| 5970 | DHCPv6 Options for Network BootT. Huth, J. Freimann, V. Zimmer, D. Thaler | Proposed Standard | September 2010 |
| 5965 | An Extensible Format for Email Feedback ReportsY. Shafranovich, J. Levine, M. Kucherawy | Proposed Standard | August 2010 |
| 5954 | Essential Correction for IPv6 ABNF and URI Comparison in RFC 3261V. Gurbani, Ed., B. Carpenter, Ed., B. Tate, Ed. | Proposed Standard | August 2010 |
| 5952 | A Recommendation for IPv6 Address Text RepresentationS. Kawamura, M. Kawashima | Proposed Standard | August 2010 |
| 5934 | Trust Anchor Management Protocol (TAMP)R. Housley, S. Ashmore, C. Wallace | Proposed Standard | August 2010 |
| 5891 | Internationalized Domain Names in Applications (IDNA): ProtocolJ. Klensin | Proposed Standard | August 2010 |
| 5890 | Internationalized Domain Names for Applications (IDNA): Definitions and Document FrameworkJ. Klensin | Proposed Standard | August 2010 |
| 5870 | A Uniform Resource Identifier for Geographic Locations ('geo' URI)A. Mayrhofer, C. Spanring | Proposed Standard | June 2010 |
| 5854 | The Metalink Download Description FormatA. Bryan, T. Tsujikawa, N. McNab, P. Poeml | Proposed Standard | June 2010 |
| 5849 | The OAuth 1.0 ProtocolE. Hammer-Lahav, Ed. · obsoleted by RFC 6749 | Informational | April 2010 |
| 5842 | Binding Extensions to Web Distributed Authoring and Versioning (WebDAV)G. Clemm, J. Crawford, J. Reschke, Ed., J. Whitehead | Experimental | April 2010 |
| 5804 | A Protocol for Remotely Managing Sieve ScriptsA. Melnikov, Ed., T. Martin | Proposed Standard | July 2010 |
| 5793 | PB-TNC: A Posture Broker (PB) Protocol Compatible with Trusted Network Connect (TNC)R. Sahita, S. Hanna, R. Hurst, K. Narayan | Proposed Standard | March 2010 |
| 5792 | PA-TNC: A Posture Attribute (PA) Protocol Compatible with Trusted Network Connect (TNC)P. Sangster, K. Narayan | Proposed Standard | March 2010 |
| 5785 | Defining Well-Known Uniform Resource Identifiers (URIs)M. Nottingham, E. Hammer-Lahav · obsoleted by RFC 8615 | Proposed Standard | April 2010 |
| 5781 | The rsync URI SchemeS. Weiler, D. Ward, R. Housley | Informational | February 2010 |
| 5728 | The SatLabs Group DVB-RCS MIBS. Combes, P. Amundsen, M. Lambert, H-P. Lexow | Informational | March 2010 |
| 5724 | URI Scheme for Global System for Mobile Communications (GSM) Short Message Service (SMS)E. Wilde, A. Vaha-Sipila | Proposed Standard | January 2010 |
| 5707 | Media Server Markup Language (MSML)A. Saleem, Y. Xin, G. Sharratt | Informational | February 2010 |
| 5674 | Alarms in SyslogS. Chisholm, R. Gerhards | Proposed Standard | October 2009 |
| 5626 | Managing Client-Initiated Connections in the Session Initiation Protocol (SIP)C. Jennings, Ed., R. Mahy, Ed., F. Audet, Ed. | Proposed Standard | October 2009 |
| 5616 | Streaming Internet Messaging AttachmentsN. Cook | Informational | August 2009 |
| 5592 | Secure Shell Transport Model for the Simple Network Management Protocol (SNMP)D. Harrington, J. Salowey, W. Hardaker | Proposed Standard | June 2009 |
| 5552 | SIP Interface to VoiceXML Media ServicesD. Burke, M. Scott | Proposed Standard | May 2009 |
| 5545 | Internet Calendaring and Scheduling Core Object Specification (iCalendar)B. Desruisseaux, Ed. | Proposed Standard | September 2009 |
| 5538 | The 'news' and 'nntp' URI SchemesF. Ellermann | Proposed Standard | April 2010 |
| 5536 | Netnews Article FormatK. Murchison, Ed., C. Lindsey, D. Kohn | Proposed Standard | November 2009 |
| 5527 | Combined User and Infrastructure ENUM in the e164.arpa TreeM. Haberler, O. Lendl, R. Stastny | Informational | May 2009 |
| 5509 | Internet Assigned Numbers Authority (IANA) Registration of Instant Messaging and Presence DNS SRV RRs for the Session Initiation Protocol (SIP)S. Loreto | Proposed Standard | April 2009 |
| 5483 | ENUM Implementation Issues and ExperiencesL. Conroy, K. Fujiwara | Informational | March 2009 |
| 5456 | IAX: Inter-Asterisk eXchange Version 2M. Spencer, B. Capouch, E. Guy, Ed., F. Miller, K. Shumard | Informational | February 2010 |
| 5438 | Instant Message Disposition Notification (IMDN)E. Burger, H. Khartabil | Proposed Standard | February 2009 |
| 5437 | Sieve Notification Mechanism: Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre, A. Melnikov | Proposed Standard | January 2009 |
| 5435 | Sieve Email Filtering: Extension for NotificationsA. Melnikov, Ed., B. Leiba, Ed., W. Segmuller, T. Martin | Proposed Standard | January 2009 |
| 5344 | Presence and Instant Messaging Peering Use CasesA. Houri, E. Aoki, S. Parameswar | Informational | October 2008 |
| 5333 | IANA Registration of Enumservices for Internet CalendaringR. Mahy, B. Hoeneisen | Proposed Standard | October 2009 |
| 5323 | Web Distributed Authoring and Versioning (WebDAV) SEARCHJ. Reschke, Ed., S. Reddy, J. Davis, A. Babich | Proposed Standard | November 2008 |
| 5285 | A General Mechanism for RTP Header ExtensionsD. Singer, H. Desineni · obsoleted by RFC 8285 | Proposed Standard | July 2008 |
| 5280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileD. Cooper, S. Santesson, S. Farrell, S. Boeyen, R. Housley, W. Polk | Proposed Standard | May 2008 |
| 5215 | RTP Payload Format for Vorbis Encoded AudioL. Barbato | Proposed Standard | August 2008 |
| 5147 | URI Fragment Identifiers for the text/plain Media TypeE. Wilde, M. Duerst | Proposed Standard | April 2008 |
| 5122 | Internationalized Resource Identifiers (IRIs) and Uniform Resource Identifiers (URIs) for the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre | Proposed Standard | February 2008 |
| 5092 | IMAP URL SchemeA. Melnikov, Ed., C. Newman | Proposed Standard | November 2007 |
| 5070 | The Incident Object Description Exchange FormatR. Danyliw, J. Meijer, Y. Demchenko · obsoleted by RFC 7970 | Proposed Standard | December 2007 |
| 5067 | Infrastructure ENUM RequirementsS. Lind, P. Pfautz | Informational | November 2007 |
| 5050 | Bundle Protocol SpecificationK. Scott, S. Burleigh | Experimental | November 2007 |
| 5028 | A Telephone Number Mapping (ENUM) Service Registration for Instant Messaging (IM) ServicesR. Mahy | Proposed Standard | October 2007 |
| 5023 | The Atom Publishing ProtocolJ. Gregorio, Ed., B. de hOra, Ed. | Proposed Standard | October 2007 |
| 5017 | MIB Textual Conventions for Uniform Resource Identifiers (URIs)D. McWalter, Ed. | Proposed Standard | September 2007 |
| 5013 | The Dublin Core Metadata Element SetJ. Kunze, T. Baker | Informational | August 2007 |
| 5005 | Feed Paging and ArchivingM. Nottingham | Proposed Standard | September 2007 |
| 4993 | A Lightweight UDP Transfer Protocol for the Internet Registry Information ServiceA. Newton | Proposed Standard | August 2007 |
| 4992 | XML Pipelining with Chunks for the Internet Registry Information ServiceA. Newton | Proposed Standard | August 2007 |
| 4979 | IANA Registration for Enumservice 'XMPP'A. Mayrhofer | Proposed Standard | August 2007 |
| 4975 | The Message Session Relay Protocol (MSRP)B. Campbell, Ed., R. Mahy, Ed., C. Jennings, Ed. | Proposed Standard | September 2007 |
| 4969 | IANA Registration for vCard EnumserviceA. Mayrhofer | Proposed Standard | August 2007 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 4946 | Atom License ExtensionJ. Snell | Experimental | July 2007 |
| 4918 | HTTP Extensions for Web Distributed Authoring and Versioning (WebDAV)L. Dusseault, Ed. | Proposed Standard | June 2007 |
| 4882 | IP Address Location Privacy and Mobile IPv6: Problem StatementR. Koodli | Informational | May 2007 |
| 4876 | A Configuration Profile Schema for Lightweight Directory Access Protocol (LDAP)-Based AgentsB. Neal-Joslin, Ed., L. Howard, M. Ansari | Informational | May 2007 |
| 4848 | Domain-Based Application Service Location Using URIs and the Dynamic Delegation Discovery Service (DDDS)L. Daigle | Proposed Standard | April 2007 |
| 4838 | Delay-Tolerant Networking ArchitectureV. Cerf, S. Burleigh, A. Hooke, L. Torgerson, R. Durst, K. Scott, K. Fall, H. Weiss | Informational | April 2007 |
| 4826 | Extensible Markup Language (XML) Formats for Representing Resource ListsJ. Rosenberg | Proposed Standard | May 2007 |
| 4825 | The Extensible Markup Language (XML) Configuration Access Protocol (XCAP)J. Rosenberg | Proposed Standard | May 2007 |
| 4790 | Internet Application Protocol Collation RegistryC. Newman, M. Duerst, A. Gulbrandsen | Proposed Standard | March 2007 |
| 4770 | vCard Extensions for Instant Messaging (IM)C. Jennings, J. Reschke, Ed. · obsoleted by RFC 6350 | Proposed Standard | January 2007 |
| 4767 | The Intrusion Detection Exchange Protocol (IDXP)B. Feinstein, G. Matthews | Experimental | March 2007 |
| 4765 | The Intrusion Detection Message Exchange Format (IDMEF)H. Debar, D. Curry, B. Feinstein | Experimental | March 2007 |
| 4741 | NETCONF Configuration ProtocolR. Enns, Ed. · obsoleted by RFC 6241 | Proposed Standard | December 2006 |
| 4725 | ENUM Validation ArchitectureA. Mayrhofer, B. Hoeneisen | Informational | November 2006 |
| 4709 | Mounting Web Distributed Authoring and Versioning (WebDAV) ServersJ. Reschke | Informational | October 2006 |
| 4695 | RTP Payload Format for MIDIJ. Lazzaro, J. Wawrzynek · obsoleted by RFC 6295 | Proposed Standard | November 2006 |
| 4690 | Review and Recommendations for Internationalized Domain Names (IDNs)J. Klensin, P. Faltstrom, C. Karp, IAB | Informational | September 2006 |
| 4688 | A Uniform Resource Name (URN) Namespace for Aerospace and Defence Industries Association of Europe (ASD) Specification 1000DS. Rushing | Informational | October 2006 |
| 4685 | Atom Threading ExtensionsJ. Snell | Proposed Standard | September 2006 |
| 4648 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson | Proposed Standard | October 2006 |
| 4622 | Internationalized Resource Identifiers (IRIs) and Uniform Resource Identifiers (URIs) for the Extensible Messaging and Presence Protocol (XMPP)P. Saint-Andre · obsoleted by RFC 5122 | Proposed Standard | August 2006 |
| 4617 | A Uniform Resource Name (URN) Formal Namespace for the Latvian National Government Integration ProjectJ. Kornijenko | Informational | August 2006 |
| 4567 | Key Management Extensions for Session Description Protocol (SDP) and Real Time Streaming Protocol (RTSP)J. Arkko, F. Lindholm, M. Naslund, K. Norrman, E. Carrara | Proposed Standard | July 2006 |
| 4566 | SDP: Session Description ProtocolM. Handley, V. Jacobson, C. Perkins · obsoleted by RFC 8866 | Proposed Standard | July 2006 |
| 4516 | Lightweight Directory Access Protocol (LDAP): Uniform Resource LocatorM. Smith, Ed., T. Howes | Proposed Standard | June 2006 |
| 4511 | Lightweight Directory Access Protocol (LDAP): The ProtocolJ. Sermersheim, Ed. | Proposed Standard | June 2006 |
| 4501 | Domain Name System Uniform Resource IdentifiersS. Josefsson | Proposed Standard | May 2006 |
| 4485 | Guidelines for Authors of Extensions to the Session Initiation Protocol (SIP)J. Rosenberg, H. Schulzrinne | Informational | May 2006 |
| 4483 | A Mechanism for Content Indirection in Session Initiation Protocol (SIP) MessagesE. Burger, Ed. | Proposed Standard | May 2006 |
| 4475 | Session Initiation Protocol (SIP) Torture Test MessagesR. Sparks, Ed., A. Hawrylyshen, A. Johnston, J. Rosenberg, H. Schulzrinne | Informational | May 2006 |
| 4468 | Message Submission BURL ExtensionC. Newman | Proposed Standard | May 2006 |
| 4452 | The "info" URI Scheme for Information Assets with Identifiers in Public NamespacesH. Van de Sompel, T. Hammond, E. Neylon, S. Weibel | Informational | April 2006 |
| 4437 | Web Distributed Authoring and Versioning (WebDAV) Redirect Reference ResourcesJ. Whitehead, G. Clemm, J. Reschke, Ed. | Experimental | March 2006 |
| 4408 | Sender Policy Framework (SPF) for Authorizing Use of Domains in E-Mail, Version 1M. Wong, W. Schlitt · obsoleted by RFC 7208 | Experimental | April 2006 |
| 4398 | Storing Certificates in the Domain Name System (DNS)S. Josefsson | Proposed Standard | March 2006 |
| 4395 | Guidelines and Registration Procedures for New URI SchemesT. Hansen, T. Hardie, L. Masinter · obsoleted by RFC 7595 | Best Current Practice | February 2006 |
| 4366 | Transport Layer Security (TLS) ExtensionsS. Blake-Wilson, M. Nystrom, D. Hopwood, J. Mikkelsen, T. Wright · obsoleted by RFC 5246, RFC 6066 | Proposed Standard | April 2006 |
| 4353 | A Framework for Conferencing with the Session Initiation Protocol (SIP)J. Rosenberg | Informational | February 2006 |
| 4350 | A Uniform Resource Name (URN) Formal Namespace for the New Zealand GovernmentF. Hendrikx, C. Wallis | Informational | February 2006 |
| 4329 | Scripting Media TypesB. Hoehrmann · obsoleted by RFC 9239 | Informational | April 2006 |
| 4324 | Calendar Access Protocol (CAP)D. Royer, G. Babics, S. Mansour | Experimental | December 2005 |
| 4288 | Media Type Specifications and Registration ProceduresN. Freed, J. Klensin · obsoleted by RFC 6838 | Best Current Practice | December 2005 |
| 4287 | The Atom Syndication FormatM. Nottingham, Ed., R. Sayre, Ed. | Proposed Standard | December 2005 |
| 4267 | The W3C Speech Interface Framework Media Types: application/voicexml+xml, application/ssml+xml, application/srgs, application/srgs+xml, application/ccxml+xml, and application/pls+xmlM. Froumentin | Informational | November 2005 |
| 4266 | The gopher URI SchemeP. Hoffman | Proposed Standard | November 2005 |
| 4249 | Implementer-Friendly Specification of Message and MIME-Part Header Fields and Field ComponentsB. Lilly | Informational | January 2006 |
| 4248 | The telnet URI SchemeP. Hoffman | Proposed Standard | October 2005 |
| 4240 | Basic Network Media Services with SIPE. Burger, Ed., J. Van Dyke, A. Spitzer | Informational | December 2005 |
| 4227 | Using the Simple Object Access Protocol (SOAP) in Blocks Extensible Exchange Protocol (BEEP)E. O'Tuathail, M. Rose | Proposed Standard | January 2006 |
| 4158 | Internet X.509 Public Key Infrastructure: Certification Path BuildingM. Cooper, Y. Dzambasow, P. Hesse, S. Joseph, R. Nicholas | Informational | September 2005 |
| 4157 | The prospero URI SchemeP. Hoffman | Historic | August 2005 |
| 4156 | The wais URI SchemeP. Hoffman | Historic | August 2005 |
| 4151 | The 'tag' URI SchemeT. Kindberg, S. Hawke | Informational | October 2005 |
| 4133 | Entity MIB (Version 3)A. Bierman, K. McCloghrie · obsoleted by RFC 6933 | Proposed Standard | August 2005 |
| 4112 | Electronic Commerce Modeling Language (ECML) Version 2 SpecificationD. Eastlake 3rd | Proposed Standard | June 2005 |
| 4095 | Attaching Meaning to Solicitation Class KeywordsC. Malamud | Proposed Standard | May 2005 |
| 4088 | Uniform Resource Identifier (URI) Scheme for the Simple Network Management Protocol (SNMP)D. Black, K. McCloghrie, J. Schoenwaelder | Proposed Standard | June 2005 |
| 4078 | The TV-Anytime Content Reference Identifier (CRID)N. Earnshaw, S. Aoki, A. Ashley, W. Kameyama | Informational | May 2005 |
| 4059 | Internet X.509 Public Key Infrastructure Warranty Certificate ExtensionD. Linsenbardt, S. Pontius, A. Sturgeon | Informational | May 2005 |
| 4007 | IPv6 Scoped Address ArchitectureS. Deering, B. Haberman, T. Jinmei, E. Nordmark, B. Zill | Proposed Standard | March 2005 |
| 3987 | Internationalized Resource Identifiers (IRIs)M. Duerst, M. Suignard | Proposed Standard | January 2005 |