| 9838 | Group Key Management Using the Internet Key Exchange Protocol Version 2 (IKEv2)V. Smyslov, B. Weis | Proposed Standard | November 2025 |
| 9329 | TCP Encapsulation of Internet Key Exchange Protocol (IKE) and IPsec PacketsT. Pauly, V. Smyslov | Proposed Standard | November 2022 |
| 9061 | A YANG Data Model for IPsec Flow Protection Based on Software-Defined Networking (SDN)R. Marin-Lopez, G. Lopez-Millan, F. Pereniguez-Garcia | Proposed Standard | July 2021 |
| 9028 | Native NAT Traversal Mode for the Host Identity ProtocolA. Keränen, J. Melén, M. Komu, Ed. | Experimental | July 2021 |
| 8743 | Multiple Access Management Services Multi-Access Management Services (MAMS)S. Kanugovi, F. Baboescu, J. Zhu, S. Seo | Informational | March 2020 |
| 8229 | TCP Encapsulation of IKE and IPsec PacketsT. Pauly, S. Touati, R. Mantha · obsoleted by RFC 9329 | Proposed Standard | August 2017 |
| 7915 | IP/ICMP Translation AlgorithmC. Bao, X. Li, F. Baker, T. Anderson, F. Gont | Proposed Standard | June 2016 |
| 7849 | An IPv6 Profile for 3GPP Mobile DevicesD. Binet, M. Boucadair, A. Vizdal, G. Chen, N. Heatley, R. Chandler, D. Michaud, D. Lopez, W. Haeffner | Informational | May 2016 |
| 7269 | NAT64 Deployment Options and ExperienceG. Chen, Z. Cao, C. Xie, D. Binet | Informational | June 2014 |
| 6889 | Analysis of Stateful 64 TranslationR. Penno, T. Saxena, M. Boucadair, S. Sivakumar | Informational | April 2013 |
| 6740 | Identifier-Locator Network Protocol (ILNP) Architectural DescriptionRJ Atkinson, SN Bhatti | Experimental | November 2012 |
| 6535 | Dual-Stack Hosts Using "Bump-in-the-Host" (BIH)B. Huang, H. Deng, T. Savolainen | Proposed Standard | February 2012 |
| 6193 | Media Description for the Internet Key Exchange Protocol (IKE) in the Session Description Protocol (SDP)M. Saito, D. Wing, M. Toyama | Informational | April 2011 |
| 6146 | Stateful NAT64: Network Address and Protocol Translation from IPv6 Clients to IPv4 ServersM. Bagnulo, P. Matthews, I. van Beijnum | Proposed Standard | April 2011 |
| 6145 | IP/ICMP Translation AlgorithmX. Li, C. Bao, F. Baker · obsoleted by RFC 7915 | Proposed Standard | April 2011 |
| 6071 | IP Security (IPsec) and Internet Key Exchange (IKE) Document RoadmapS. Frankel, S. Krishnan | Informational | February 2011 |
| 6054 | Using Counter Modes with Encapsulating Security Payload (ESP) and Authentication Header (AH) to Protect Group TrafficD. McGrew, B. Weis | Proposed Standard | November 2010 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |
| 5879 | Heuristics for Detecting ESP-NULL PacketsT. Kivinen, D. McDonald | Informational | May 2010 |
| 5840 | Wrapped Encapsulating Security Payload (ESP) for Traffic VisibilityK. Grewal, G. Montenegro, M. Bhatia | Proposed Standard | April 2010 |
| 5770 | Basic Host Identity Protocol (HIP) Extensions for Traversal of Network Address TranslatorsM. Komu, T. Henderson, H. Tschofenig, J. Melen, A. Keranen, Ed. | Experimental | April 2010 |
| 5619 | Softwire Security Analysis and RequirementsS. Yamamoto, C. Williams, H. Yokota, F. Parent | Proposed Standard | August 2009 |
| 5571 | Softwire Hub and Spoke Deployment Framework with Layer Two Tunneling Protocol Version 2 (L2TPv2)B. Storer, C. Pignataro, Ed., M. Dos Santos, B. Stevant, Ed., L. Toutain, J. Tremblay | Proposed Standard | June 2009 |
| 5555 | Mobile IPv6 Support for Dual Stack Hosts and RoutersH. Soliman, Ed. | Proposed Standard | June 2009 |
| 5406 | Guidelines for Specifying the Use of IPsec Version 2S. Bellovin | Best Current Practice | February 2009 |
| 5266 | Secure Connectivity and Mobility Using Mobile IPv4 and IKEv2 Mobility and Multihoming (MOBIKE)V. Devarapalli, P. Eronen | Best Current Practice | June 2008 |
| 5265 | Mobile IPv4 Traversal across IPsec-Based VPN GatewaysS. Vaarala, E. Klovning | Proposed Standard | June 2008 |
| 5207 | NAT and Firewall Traversal Issues of Host Identity Protocol (HIP) CommunicationM. Stiemerling, J. Quittek, L. Eggert | Informational | April 2008 |
| 4891 | Using IPsec to Secure IPv6-in-IPv4 TunnelsR. Graveman, M. Parthasarathy, P. Savola, H. Tschofenig | Informational | May 2007 |
| 4864 | Local Network Protection for IPv6G. Van de Velde, T. Hain, R. Droms, B. Carpenter, E. Klein | Informational | May 2007 |
| 4782 | Quick-Start for TCP and IPS. Floyd, M. Allman, A. Jain, P. Sarolahti | Experimental | January 2007 |
| 4718 | IKEv2 Clarifications and Implementation GuidelinesP. Eronen, P. Hoffman · obsoleted by RFC 5996 | Informational | October 2006 |
| 3947 | Negotiation of NAT-Traversal in the IKET. Kivinen, B. Swander, A. Huttunen, V. Volpe | Proposed Standard | January 2005 |