| 1035 | Domain names - implementation and specificationP. Mockapetris | Internet Standard | November 1987 |
| 1459 | Internet Relay Chat ProtocolJ. Oikarinen, D. Reed | Experimental | May 1993 |
| 1750 | Randomness Recommendations for SecurityD. Eastlake 3rd, S. Crocker, J. Schiller · obsoleted by RFC 4086 | Informational | December 1994 |
| 1939 | Post Office Protocol - Version 3J. Myers, M. Rose | Internet Standard | May 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2222 | Simple Authentication and Security Layer (SASL)J. Myers · obsoleted by RFC 4422, RFC 4752 | Proposed Standard | October 1997 |
| 2234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell · obsoleted by RFC 4234 | Proposed Standard | November 1997 |
| 2244 | ACAP -- Application Configuration Access ProtocolC. Newman, J. G. Myers | Proposed Standard | November 1997 |
| 2246 | The TLS Protocol Version 1.0T. Dierks, C. Allen · obsoleted by RFC 4346 | Historic | January 1999 |
| 2277 | IETF Policy on Character Sets and LanguagesH. Alvestrand | Best Current Practice | January 1998 |
| 2396 | Uniform Resource Identifiers (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter · obsoleted by RFC 3986 | Draft Standard | August 1998 |
| 2535 | Domain Name System Security ExtensionsD. Eastlake 3rd · obsoleted by RFC 4033, RFC 4034, RFC 4035 | Proposed Standard | March 1999 |
| 2595 | Using TLS with IMAP, POP3 and ACAPC. Newman | Proposed Standard | June 1999 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2743 | Generic Security Service Application Program Interface Version 2, Update 1J. Linn | Proposed Standard | January 2000 |
| 2779 | Instant Messaging / Presence Protocol RequirementsM. Day, S. Aggarwal, G. Mohr, J. Vincent | Informational | February 2000 |
| 2818 | HTTP Over TLSE. Rescorla · obsoleted by RFC 9110 | Informational | May 2000 |
| 2821 | Simple Mail Transfer ProtocolJ. Klensin, Ed. · obsoleted by RFC 5321 | Proposed Standard | April 2001 |
| 2831 | Using Digest Authentication as a SASL MechanismP. Leach, C. Newman · obsoleted by RFC 6331 | Historic | May 2000 |
| 3066 | Tags for the Identification of LanguagesH. Alvestrand · obsoleted by RFC 4646, RFC 4647 | Best Current Practice | January 2001 |
| 3280 | Internet X.509 Public Key Infrastructure Certificate and Certificate Revocation List (CRL) ProfileR. Housley, W. Polk, W. Ford, D. Solo · obsoleted by RFC 5280 | Proposed Standard | May 2002 |
| 3454 | Preparation of Internationalized Strings ("stringprep")P. Hoffman, M. Blanchet · obsoleted by RFC 7564 | Proposed Standard | January 2003 |
| 3490 | Internationalizing Domain Names in Applications (IDNA)P. Faltstrom, P. Hoffman, A. Costello · obsoleted by RFC 5890, RFC 5891 | Proposed Standard | March 2003 |
| 3501 | INTERNET MESSAGE ACCESS PROTOCOL - VERSION 4rev1M. Crispin · obsoleted by RFC 9051 | Proposed Standard | March 2003 |
| 3513 | Internet Protocol Version 6 (IPv6) Addressing ArchitectureR. Hinden, S. Deering · obsoleted by RFC 4291 | Proposed Standard | April 2003 |
| 3548 | The Base16, Base32, and Base64 Data EncodingsS. Josefsson, Ed. · obsoleted by RFC 4648 | Informational | July 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 3688 | The IETF XML RegistryM. Mealling | Best Current Practice | January 2004 |