| 1847 | Security Multiparts for MIME: Multipart/Signed and Multipart/EncryptedJ. Galvin, S. Murphy, S. Crocker, N. Freed | Proposed Standard | October 1995 |
| 2045 | Multipurpose Internet Mail Extensions (MIME) Part One: Format of Internet Message BodiesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2046 | Multipurpose Internet Mail Extensions (MIME) Part Two: Media TypesN. Freed, N. Borenstein | Draft Standard | November 1996 |
| 2048 | Multipurpose Internet Mail Extensions (MIME) Part Four: Registration ProceduresN. Freed, J. Klensin, J. Postel · obsoleted by RFC 4288, RFC 4289 | Best Current Practice | November 1996 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2141 | URN SyntaxR. Moats · obsoleted by RFC 8141 | Proposed Standard | May 1997 |
| 2234 | Augmented BNF for Syntax Specifications: ABNFD. Crocker, Ed., P. Overell · obsoleted by RFC 4234 | Proposed Standard | November 1997 |
| 2277 | IETF Policy on Character Sets and LanguagesH. Alvestrand | Best Current Practice | January 1998 |
| 2396 | Uniform Resource Identifiers (URI): Generic SyntaxT. Berners-Lee, R. Fielding, L. Masinter · obsoleted by RFC 3986 | Draft Standard | August 1998 |
| 2440 | OpenPGP Message FormatJ. Callas, L. Donnerhacke, H. Finney, R. Thayer · obsoleted by RFC 4880 | Proposed Standard | November 1998 |
| 2616 | Hypertext Transfer Protocol -- HTTP/1.1R. Fielding, J. Gettys, J. Mogul, H. Frystyk, L. Masinter, P. Leach, T. Berners-Lee · obsoleted by RFC 7230, RFC 7231, RFC 7232, RFC 7233, RFC 7234, RFC 7235 | Draft Standard | June 1999 |
| 2779 | Instant Messaging / Presence Protocol RequirementsM. Day, S. Aggarwal, G. Mohr, J. Vincent | Informational | February 2000 |
| 2822 | Internet Message FormatP. Resnick, Ed. · obsoleted by RFC 5322 | Proposed Standard | April 2001 |
| 3066 | Tags for the Identification of LanguagesH. Alvestrand · obsoleted by RFC 4646, RFC 4647 | Best Current Practice | January 2001 |
| 3261 | SIP: Session Initiation ProtocolJ. Rosenberg, H. Schulzrinne, G. Camarillo, A. Johnston, J. Peterson, R. Sparks, M. Handley, E. Schooler | Proposed Standard | July 2002 |
| 3339 | Date and Time on the Internet: TimestampsG. Klyne, C. Newman | Proposed Standard | July 2002 |
| 3553 | An IETF URN Sub-namespace for Registered Protocol ParametersM. Mealling, L. Masinter, T. Hardie, G. Klyne | Best Current Practice | June 2003 |
| 3629 | UTF-8, a transformation format of ISO 10646F. Yergeau | Internet Standard | November 2003 |
| 3631 | Security Mechanisms for the InternetS. Bellovin, Ed., J. Schiller, Ed., C. Kaufman, Ed. | Informational | December 2003 |
| 3859 | Common Profile for Presence (CPP)J. Peterson | Proposed Standard | August 2004 |