| 9709 | Encryption Key Derivation in the Cryptographic Message Syntax (CMS) Using HKDF with SHA-256R. Housley | Proposed Standard | January 2025 |
| 8551 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Message SpecificationJ. Schaad, B. Ramsdell, S. Turner | Proposed Standard | April 2019 |
| 8550 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Certificate HandlingJ. Schaad, B. Ramsdell, S. Turner | Proposed Standard | April 2019 |
| 7107 | Object Identifier Registry for the S/MIME Mail Security Working GroupR. Housley | Informational | January 2014 |
| 6268 | Additional New ASN.1 Modules for the Cryptographic Message Syntax (CMS) and the Public Key Infrastructure Using X.509 (PKIX)J. Schaad, S. Turner | Informational | July 2011 |
| 5934 | Trust Anchor Management Protocol (TAMP)R. Housley, S. Ashmore, C. Wallace | Proposed Standard | August 2010 |
| 5912 | New ASN.1 Modules for the Public Key Infrastructure Using X.509 (PKIX)P. Hoffman, J. Schaad | Informational | June 2010 |
| 5911 | New ASN.1 Modules for Cryptographic Message Syntax (CMS) and S/MIMEP. Hoffman, J. Schaad | Informational | June 2010 |
| 5753 | Use of Elliptic Curve Cryptography (ECC) Algorithms in Cryptographic Message Syntax (CMS)S. Turner, D. Brown | Informational | January 2010 |
| 5751 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Message SpecificationB. Ramsdell, S. Turner · obsoleted by RFC 8551 | Proposed Standard | January 2010 |
| 5750 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Certificate HandlingB. Ramsdell, S. Turner · obsoleted by RFC 8550 | Proposed Standard | January 2010 |
| 5655 | Specification of the IP Flow Information Export (IPFIX) File FormatB. Trammell, E. Boschi, L. Mark, T. Zseby, A. Wagner | Proposed Standard | October 2009 |
| 5652 | Cryptographic Message Syntax (CMS)R. Housley | Internet Standard | September 2009 |
| 5636 | Traceable Anonymous CertificateS. Park, H. Park, Y. Won, J. Lee, S. Kent | Experimental | August 2009 |
| 5405 | Unicast UDP Usage Guidelines for Application DesignersL. Eggert, G. Fairhurst · obsoleted by RFC 8085 | Best Current Practice | November 2008 |
| 5349 | Elliptic Curve Cryptography (ECC) Support for Public Key Cryptography for Initial Authentication in Kerberos (PKINIT)L. Zhu, K. Jaganathan, K. Lauter | Informational | September 2008 |
| 5274 | Certificate Management Messages over CMS (CMC): Compliance RequirementsJ. Schaad, M. Myers · obsoleted by RFC 10004 | Proposed Standard | June 2008 |
| 5272 | Certificate Management over CMS (CMC)J. Schaad, M. Myers · obsoleted by RFC 10002 | Proposed Standard | June 2008 |
| 5170 | Low Density Parity Check (LDPC) Staircase and Triangle Forward Error Correction (FEC) SchemesV. Roca, C. Neumann, D. Furodet | Proposed Standard | June 2008 |
| 5126 | CMS Advanced Electronic Signatures (CAdES)D. Pinkas, N. Pope, J. Ross | Informational | March 2008 |
| 5114 | Additional Diffie-Hellman Groups for Use with IETF StandardsM. Lepinski, S. Kent | Informational | January 2008 |
| 5083 | Cryptographic Message Syntax (CMS) Authenticated-Enveloped-Data Content TypeR. Housley | Proposed Standard | November 2007 |
| 5055 | Server-Based Certificate Validation Protocol (SCVP)T. Freeman, R. Housley, A. Malpani, D. Cooper, W. Polk | Proposed Standard | December 2007 |
| 5035 | Enhanced Security Services (ESS) Update: Adding CertID Algorithm AgilityJ. Schaad | Proposed Standard | August 2007 |
| 5008 | Suite B in Secure/Multipurpose Internet Mail Extensions (S/MIME)R. Housley, J. Solinas · obsoleted by RFC 6318 | Historic | September 2007 |
| 4998 | Evidence Record Syntax (ERS)T. Gondrom, R. Brandner, U. Pordesch | Proposed Standard | August 2007 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 4902 | Integrity, Privacy, and Security in Open Pluggable Edge Services (OPES) for SMTPM. Stecher | Informational | May 2007 |
| 4853 | Cryptographic Message Syntax (CMS) Multiple Signer ClarificationR. Housley | Proposed Standard | April 2007 |
| 4823 | FTP Transport for Secure Peer-to-Peer Business Data Interchange over the InternetT. Harding, R. Scott | Informational | April 2007 |
| 4556 | Public Key Cryptography for Initial Authentication in Kerberos (PKINIT)L. Zhu, B. Tung | Proposed Standard | June 2006 |
| 4534 | Group Security Policy Token v1A. Colegrove, H. Harney | Proposed Standard | June 2006 |
| 4501 | Domain Name System Uniform Resource IdentifiersS. Josefsson | Proposed Standard | May 2006 |
| 4387 | Internet X.509 Public Key Infrastructure Operational Protocols: Certificate Store Access via HTTPP. Gutmann, Ed. | Proposed Standard | February 2006 |
| 4231 | Identifiers and Test Vectors for HMAC-SHA-224, HMAC-SHA-256, HMAC-SHA-384, and HMAC-SHA-512M. Nystrom | Proposed Standard | December 2005 |
| 4189 | Requirements for End-to-Middle Security for the Session Initiation Protocol (SIP)K. Ono, S. Tachimoto | Informational | October 2005 |
| 4161 | Guidelines for Optional Services for Internet Fax GatewaysK. Mimura, K. Yokoyama, T. Satoh, K. Watanabe, C. Kanaide | Informational | September 2005 |
| 4160 | Internet Fax Gateway RequirementsK. Mimura, K. Yokoyama, T. Satoh, C. Kanaide, C. Allocchio | Informational | September 2005 |
| 4130 | MIME-Based Secure Peer-to-Peer Business Data Interchange Using HTTP, Applicability Statement 2 (AS2)D. Moberg, R. Drummond | Proposed Standard | July 2005 |
| 4119 | A Presence-based GEOPRIV Location Object FormatJ. Peterson | Proposed Standard | December 2005 |
| 4112 | Electronic Commerce Modeling Language (ECML) Version 2 SpecificationD. Eastlake 3rd | Proposed Standard | June 2005 |
| 4108 | Using Cryptographic Message Syntax (CMS) to Protect Firmware PackagesR. Housley | Proposed Standard | August 2005 |
| 4049 | BinaryTime: An Alternate Format for Representing Date and Time in ASN.1R. Housley · obsoleted by RFC 6019 | Experimental | April 2005 |
| 4043 | Internet X.509 Public Key Infrastructure Permanent IdentifierD. Pinkas, T. Gindin | Proposed Standard | May 2005 |
| 4027 | Domain Name System Media TypesS. Josefsson | Informational | May 2005 |
| 4010 | Use of the SEED Encryption Algorithm in Cryptographic Message Syntax (CMS)J. Park, S. Lee, J. Kim, J. Lee | Proposed Standard | February 2005 |
| 3930 | The Protocol versus Document Points of View in Computer ProtocolsD. Eastlake 3rd | Informational | October 2004 |
| 3860 | Common Profile for Instant Messaging (CPIM)J. Peterson | Proposed Standard | August 2004 |
| 3859 | Common Profile for Presence (CPP)J. Peterson | Proposed Standard | August 2004 |