| 793 | Transmission Control ProtocolJ. Postel · obsoleted by RFC 9293 | Internet Standard | September 1981 |
| 1122 | Requirements for Internet Hosts - Communication LayersR. Braden, Ed. | Internet Standard | October 1989 |
| 1323 | TCP Extensions for High PerformanceV. Jacobson, R. Braden, D. Borman · obsoleted by RFC 7323 | Proposed Standard | May 1992 |
| 1633 | Integrated Services in the Internet Architecture: an OverviewR. Braden, D. Clark, S. Shenker | Informational | June 1994 |
| 1750 | Randomness Recommendations for SecurityD. Eastlake 3rd, S. Crocker, J. Schiller · obsoleted by RFC 4086 | Informational | December 1994 |
| 2030 | Simple Network Time Protocol (SNTP) Version 4 for IPv4, IPv6 and OSID. Mills · obsoleted by RFC 4330 | Informational | October 1996 |
| 2104 | HMAC: Keyed-Hashing for Message AuthenticationH. Krawczyk, M. Bellare, R. Canetti | Informational | February 1997 |
| 2119 | Key words for use in RFCs to Indicate Requirement LevelsS. Bradner | Best Current Practice | March 1997 |
| 2401 | Security Architecture for the Internet ProtocolS. Kent, R. Atkinson · obsoleted by RFC 4301 | Proposed Standard | November 1998 |
| 2406 | IP Encapsulating Security Payload (ESP)S. Kent, R. Atkinson · obsoleted by RFC 4303, RFC 4305 | Proposed Standard | November 1998 |
| 2407 | The Internet IP Security Domain of Interpretation for ISAKMPD. Piper · obsoleted by RFC 4306 | Historic | November 1998 |
| 2409 | The Internet Key Exchange (IKE)D. Harkins, D. Carrel · obsoleted by RFC 4306 | Historic | November 1998 |
| 2410 | The NULL Encryption Algorithm and Its Use With IPsecR. Glenn, S. Kent | Proposed Standard | November 1998 |
| 2412 | The OAKLEY Key Determination ProtocolH. Orman | Informational | November 1998 |
| 2451 | The ESP CBC-Mode Cipher AlgorithmsR. Pereira, R. Adams | Proposed Standard | November 1998 |
| 2474 | Definition of the Differentiated Services Field (DS Field) in the IPv4 and IPv6 HeadersK. Nichols, S. Blake, F. Baker, D. Black | Proposed Standard | December 1998 |
| 2475 | An Architecture for Differentiated ServicesS. Blake, D. Black, M. Carlson, E. Davies, Z. Wang, W. Weiss | Informational | December 1998 |
| 2597 | Assured Forwarding PHB GroupJ. Heinanen, F. Baker, W. Weiss, J. Wroclawski | Proposed Standard | June 1999 |
| 2598 | An Expedited Forwarding PHBV. Jacobson, K. Nichols, K. Poduri · obsoleted by RFC 3246 | Proposed Standard | June 1999 |
| 2608 | Service Location Protocol, Version 2E. Guttman, C. Perkins, J. Veizades, M. Day | Proposed Standard | June 1999 |
| 2625 | IP and ARP over Fibre ChannelM. Rajagopal, R. Bhagwat, W. Rickard · obsoleted by RFC 4338 | Proposed Standard | June 1999 |
| 2883 | An Extension to the Selective Acknowledgement (SACK) Option for TCPS. Floyd, J. Mahdavi, M. Mathis, M. Podolsky | Proposed Standard | July 2000 |
| 3031 | Multiprotocol Label Switching ArchitectureE. Rosen, A. Viswanathan, R. Callon | Proposed Standard | January 2001 |
| 3456 | Dynamic Host Configuration Protocol (DHCPv4) Configuration of IPsec Tunnel ModeB. Patel, B. Aboba, S. Kelly, V. Gupta | Proposed Standard | January 2003 |
| 3566 | The AES-XCBC-MAC-96 Algorithm and Its Use With IPsecS. Frankel, H. Herbert | Proposed Standard | September 2003 |
| 3602 | The AES-CBC Cipher Algorithm and Its Use with IPsecS. Frankel, R. Glenn, S. Kelly | Proposed Standard | September 2003 |
| 3723 | Securing Block Storage Protocols over IPB. Aboba, J. Tseng, J. Walker, V. Rangan, F. Travostino | Proposed Standard | April 2004 |
| 3822 | Finding Fibre Channel over TCP/IP (FCIP) Entities Using Service Location Protocol version 2 (SLPv2)D. Peterson | Proposed Standard | July 2004 |