| 5305 | IS-IS Extensions for Traffic EngineeringT. Li, H. Smit | Proposed Standard | October 2008 |
| 5152 | A Per-Domain Path Computation Method for Establishing Inter-Domain Traffic Engineering (TE) Label Switched Paths (LSPs)JP. Vasseur, Ed., A. Ayyangar, Ed., R. Zhang | Proposed Standard | February 2008 |
| 5145 | Framework for MPLS-TE to GMPLS MigrationK. Shiomoto, Ed. | Informational | March 2008 |
| 5130 | A Policy Control Mechanism in IS-IS Using Administrative TagsS. Previdi, M. Shand, Ed., C. Martin | Proposed Standard | February 2008 |
| 5120 | M-ISIS: Multi Topology (MT) Routing in Intermediate System to Intermediate Systems (IS-ISs)T. Przygienda, N. Shen, N. Sheth | Proposed Standard | February 2008 |
| 5089 | IS-IS Protocol Extensions for Path Computation Element (PCE) DiscoveryJL. Le Roux, Ed., JP. Vasseur, Ed., Y. Ikejiri, R. Zhang | Proposed Standard | January 2008 |
| 5073 | IGP Routing Protocol Extensions for Discovery of Traffic Engineering Node CapabilitiesJ.P. Vasseur, Ed., J.L. Le Roux, Ed. | Proposed Standard | December 2007 |
| 5029 | Definition of an IS-IS Link Attribute Sub-TLVJP. Vasseur, S. Previdi | Proposed Standard | September 2007 |
| 4990 | Use of Addresses in Generalized Multiprotocol Label Switching (GMPLS) NetworksK. Shiomoto, R. Papneja, R. Rabbat | Informational | September 2007 |
| 4972 | Routing Extensions for Discovery of Multiprotocol (MPLS) Label Switch Router (LSR) Traffic Engineering (TE) Mesh MembershipJP. Vasseur, Ed., JL. Leroux, Ed., S. Yasukawa, S. Previdi, P. Psenak, P. Mabbey | Proposed Standard | July 2007 |
| 4971 | Intermediate System to Intermediate System (IS-IS) Extensions for Advertising Router InformationJP. Vasseur, Ed., N. Shen, Ed., R. Aggarwal, Ed. · obsoleted by RFC 7981 | Proposed Standard | July 2007 |
| 4874 | Exclude Routes - Extension to Resource ReserVation Protocol-Traffic Engineering (RSVP-TE)CY. Lee, A. Farrel, S. De Cnodder | Proposed Standard | April 2007 |
| 4726 | A Framework for Inter-Domain Multiprotocol Label Switching Traffic EngineeringA. Farrel, J.-P. Vasseur, A. Ayyangar | Informational | November 2006 |
| 4655 | A Path Computation Element (PCE)-Based ArchitectureA. Farrel, J.-P. Vasseur, J. Ash | Informational | August 2006 |
| 4652 | Evaluation of Existing Routing Protocols against Automatic Switched Optical Network (ASON) Routing RequirementsD. Papadimitriou, Ed., L. Ong, J. Sadler, S. Shew, D. Ward | Informational | October 2006 |
| 4561 | Definition of a Record Route Object (RRO) Node-Id Sub-ObjectJ.-P. Vasseur, Ed., Z. Ali, S. Sivabalan | Proposed Standard | June 2006 |
| 4558 | Node-ID Based Resource Reservation Protocol (RSVP) Hello: A Clarification StatementZ. Ali, R. Rahman, D. Prairie, D. Papadimitriou | Proposed Standard | June 2006 |
| 4444 | Management Information Base for Intermediate System to Intermediate System (IS-IS)J. Parker, Ed. | Proposed Standard | April 2006 |
| 4206 | Label Switched Paths (LSP) Hierarchy with Generalized Multi-Protocol Label Switching (GMPLS) Traffic Engineering (TE)K. Kompella, Y. Rekhter | Proposed Standard | October 2005 |
| 4205 | Intermediate System to Intermediate System (IS-IS) Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. · obsoleted by RFC 5307 | Informational | October 2005 |
| 4204 | Link Management Protocol (LMP)J. Lang, Ed. | Proposed Standard | October 2005 |
| 4202 | Routing Extensions in Support of Generalized Multi-Protocol Label Switching (GMPLS)K. Kompella, Ed., Y. Rekhter, Ed. | Proposed Standard | October 2005 |
| 4201 | Link Bundling in MPLS Traffic Engineering (TE)K. Kompella, Y. Rekhter, L. Berger | Proposed Standard | October 2005 |
| 4128 | Bandwidth Constraints Models for Differentiated Services (Diffserv)-aware MPLS Traffic Engineering: Performance EvaluationW. Lai | Informational | June 2005 |
| 4124 | Protocol Extensions for Support of Diffserv-aware MPLS Traffic EngineeringF. Le Faucheur, Ed. | Proposed Standard | June 2005 |
| 4105 | Requirements for Inter-Area MPLS Traffic EngineeringJ.-L. Le Roux, Ed., J.-P. Vasseur, Ed., J. Boyle, Ed. | Informational | June 2005 |
| 3945 | Generalized Multi-Protocol Label Switching (GMPLS) ArchitectureE. Mannie, Ed. | Proposed Standard | November 2004 |
| 3787 | Recommendations for Interoperable IP Networks using Intermediate System to Intermediate System (IS-IS)J. Parker, Ed. | Informational | May 2004 |
| 3786 | Extending the Number of Intermediate System to Intermediate System (IS-IS) Link State PDU (LSP) Fragments Beyond the 256 LimitA. Hermelin, S. Previdi, M. Shand · obsoleted by RFC 5311 | Informational | May 2004 |
| 3785 | Use of Interior Gateway Protocol (IGP) Metric as a second MPLS Traffic Engineering (TE) MetricF. Le Faucheur, R. Uppili, A. Vedrenne, P. Merckx, T. Telkamp | Best Current Practice | May 2004 |