| 9930 | Tunnel Extensible Authentication Protocol (TEAP) Version 1A. DeKok, Ed. | Proposed Standard | February 2026 |
| 9325 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, P. Saint-Andre, T. Fossati | Best Current Practice | November 2022 |
| 8635 | Router Keying for BGPsecR. Bush, S. Turner, K. Patel | Proposed Standard | August 2019 |
| 8551 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 4.0 Message SpecificationJ. Schaad, B. Ramsdell, S. Turner | Proposed Standard | April 2019 |
| 8268 | More Modular Exponentiation (MODP) Diffie-Hellman (DH) Key Exchange (KEX) Groups for Secure Shell (SSH)M. Baushke | Proposed Standard | December 2017 |
| 7696 | Guidelines for Cryptographic Algorithm Agility and Selecting Mandatory-to-Implement AlgorithmsR. Housley | Best Current Practice | November 2015 |
| 7525 | Recommendations for Secure Use of Transport Layer Security (TLS) and Datagram Transport Layer Security (DTLS)Y. Sheffer, R. Holz, P. Saint-Andre · obsoleted by RFC 9325 | Best Current Practice | May 2015 |
| 7516 | JSON Web Encryption (JWE)M. Jones, J. Hildebrand | Proposed Standard | May 2015 |
| 7170 | Tunnel Extensible Authentication Protocol (TEAP) Version 1H. Zhou, N. Cam-Winget, J. Salowey, S. Hanna · obsoleted by RFC 9930 | Proposed Standard | May 2014 |
| 6920 | Naming Things with HashesS. Farrell, D. Kutscher, C. Dannewitz, B. Ohlman, A. Keranen, P. Hallam-Baker | Proposed Standard | April 2013 |
| 6781 | DNSSEC Operational Practices, Version 2O. Kolkman, W. Mekking, R. Gieben | Informational | December 2012 |
| 6518 | Keying and Authentication for Routing Protocols (KARP) Design GuidelinesG. Lebovitz, M. Bhatia | Informational | February 2012 |
| 6376 | DomainKeys Identified Mail (DKIM) SignaturesD. Crocker, Ed., T. Hansen, Ed., M. Kucherawy, Ed. | Internet Standard | September 2011 |
| 6331 | Moving DIGEST-MD5 to HistoricA. Melnikov | Informational | July 2011 |
| 6256 | Using Self-Delimiting Numeric Values in ProtocolsW. Eddy, E. Davies | Informational | May 2011 |
| 5931 | Extensible Authentication Protocol (EAP) Authentication Using Only a PasswordD. Harkins, G. Zorn | Informational | August 2010 |
| 5751 | Secure/Multipurpose Internet Mail Extensions (S/MIME) Version 3.2 Message SpecificationB. Ramsdell, S. Turner · obsoleted by RFC 8551 | Proposed Standard | January 2010 |
| 5656 | Elliptic Curve Algorithm Integration in the Secure Shell Transport LayerD. Stebila, J. Green | Proposed Standard | December 2009 |
| 5349 | Elliptic Curve Cryptography (ECC) Support for Public Key Cryptography for Initial Authentication in Kerberos (PKINIT)L. Zhu, K. Jaganathan, K. Lauter | Informational | September 2008 |
| 5281 | Extensible Authentication Protocol Tunneled Transport Layer Security Authenticated Protocol Version 0 (EAP-TTLSv0)P. Funk, S. Blake-Wilson | Informational | August 2008 |
| 5247 | Extensible Authentication Protocol (EAP) Key Management FrameworkB. Aboba, D. Simon, P. Eronen | Proposed Standard | August 2008 |
| 5246 | The Transport Layer Security (TLS) Protocol Version 1.2T. Dierks, E. Rescorla · obsoleted by RFC 8446, RFC 9846 | Proposed Standard | August 2008 |
| 5216 | The EAP-TLS Authentication ProtocolD. Simon, B. Aboba, R. Hurst | Proposed Standard | March 2008 |
| 4962 | Guidance for Authentication, Authorization, and Accounting (AAA) Key ManagementR. Housley, B. Aboba | Best Current Practice | July 2007 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 4871 | DomainKeys Identified Mail (DKIM) SignaturesE. Allman, J. Callas, M. Delany, M. Libbey, J. Fenton, M. Thomas · obsoleted by RFC 6376 | Proposed Standard | May 2007 |
| 4851 | The Flexible Authentication via Secure Tunneling Extensible Authentication Protocol Method (EAP-FAST)N. Cam-Winget, D. McGrew, J. Salowey, H. Zhou | Informational | May 2007 |
| 4746 | Extensible Authentication Protocol (EAP) Password Authenticated ExchangeT. Clancy, W. Arbaugh | Informational | November 2006 |
| 4641 | DNSSEC Operational PracticesO. Kolkman, R. Gieben · obsoleted by RFC 6781 | Informational | September 2006 |
| 4556 | Public Key Cryptography for Initial Authentication in Kerberos (PKINIT)L. Zhu, B. Tung | Proposed Standard | June 2006 |
| 4432 | RSA Key Exchange for the Secure Shell (SSH) Transport Layer ProtocolB. Harris | Proposed Standard | March 2006 |
| 4251 | The Secure Shell (SSH) Protocol ArchitectureT. Ylonen, C. Lonvick, Ed. | Proposed Standard | January 2006 |
| 4107 | Guidelines for Cryptographic Key ManagementS. Bellovin, R. Housley | Best Current Practice | June 2005 |
| 4086 | Randomness Requirements for SecurityD. Eastlake 3rd, J. Schiller, S. Crocker | Best Current Practice | June 2005 |
| 3871 | Operational Security Requirements for Large Internet Service Provider (ISP) IP Network InfrastructureG. Jones, Ed. | Informational | September 2004 |