| 7147 | Definitions of Managed Objects for the Internet Small Computer System Interface (iSCSI)M. Bakke, P. Venkatesen | Proposed Standard | April 2014 |
| 7146 | Securing Block Storage Protocols over IP: RFC 3723 Requirements Update for IPsec v3D. Black, P. Koning | Proposed Standard | April 2014 |
| 7145 | Internet Small Computer System Interface (iSCSI) Extensions for the Remote Direct Memory Access (RDMA) SpecificationM. Ko, A. Nezhinsky | Proposed Standard | April 2014 |
| 7144 | Internet Small Computer System Interface (iSCSI) SCSI Features UpdateF. Knight, M. Chadalapaka | Proposed Standard | April 2014 |
| 7143 | Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)M. Chadalapaka, J. Satran, K. Meth, D. Black | Proposed Standard | April 2014 |
| 6885 | Stringprep Revision and Problem Statement for the Preparation and Comparison of Internationalized Strings (PRECIS)M. Blanchet, A. Sullivan | Informational | March 2013 |
| 6392 | A Survey of In-Network Storage SystemsR. Alimi, Ed., A. Rahman, Ed., Y. Yang, Ed. | Informational | October 2011 |
| 5664 | Object-Based Parallel NFS (pNFS) OperationsB. Halevy, B. Welch, J. Zelenka | Proposed Standard | January 2010 |
| 5661 | Network File System (NFS) Version 4 Minor Version 1 ProtocolS. Shepler, Ed., M. Eisler, Ed., D. Noveck, Ed. · obsoleted by RFC 8881 | Proposed Standard | January 2010 |
| 5505 | Principles of Internet Host ConfigurationB. Aboba, D. Thaler, L. Andersson, S. Cheshire | Informational | May 2009 |
| 5387 | Problem and Applicability Statement for Better-Than-Nothing Security (BTNS)J. Touch, D. Black, Y. Wang | Informational | November 2008 |
| 5056 | On the Use of Channel Bindings to Secure ChannelsN. Williams | Proposed Standard | November 2007 |
| 5048 | Internet Small Computer System Interface (iSCSI) Corrections and ClarificationsM. Chadalapaka, Ed. · obsoleted by RFC 7143 | Proposed Standard | October 2007 |
| 5047 | DA: Datamover Architecture for the Internet Small Computer System Interface (iSCSI)M. Chadalapaka, J. Hufferd, J. Satran, H. Shah | Informational | October 2007 |
| 5046 | Internet Small Computer System Interface (iSCSI) Extensions for Remote Direct Memory Access (RDMA)M. Ko, M. Chadalapaka, J. Hufferd, U. Elzur, H. Shah, P. Thaler · obsoleted by RFC 7145 | Proposed Standard | October 2007 |
| 5044 | Marker PDU Aligned Framing for TCP SpecificationP. Culley, U. Elzur, R. Recio, S. Bailey, J. Carrier | Proposed Standard | October 2007 |
| 5042 | Direct Data Placement Protocol (DDP) / Remote Direct Memory Access Protocol (RDMAP) SecurityJ. Pinkerton, E. Deleganes | Proposed Standard | October 2007 |
| 4949 | Internet Security Glossary, Version 2R. Shirey | Informational | August 2007 |
| 4939 | Definitions of Managed Objects for iSNS (Internet Storage Name Service)K. Gibbons, G. Ramkumar, S. Kipp | Proposed Standard | July 2007 |
| 4850 | Declarative Public Extension Key for Internet Small Computer Systems Interface (iSCSI) Node ArchitectureD. Wysochanski · obsoleted by RFC 7143 | Proposed Standard | April 2007 |
| 4545 | Definitions of Managed Objects for IP Storage User Identity AuthorizationM. Bakke, J. Muchow | Proposed Standard | May 2006 |
| 4544 | Definitions of Managed Objects for Internet Small Computer System Interface (iSCSI)M. Bakke, M. Krueger, T. McSweeney, J. Muchow · obsoleted by RFC 7147 | Proposed Standard | May 2006 |
| 4455 | Definition of Managed Objects for Small Computer System Interface (SCSI) EntitiesM. Hallak-Stamler, M. Bakke, Y. Lederman, M. Krueger, K. McCloghrie | Proposed Standard | April 2006 |
| 4174 | The IPv4 Dynamic Host Configuration Protocol (DHCP) Option for the Internet Storage Name ServiceC. Monia, J. Tseng, K. Gibbons | Proposed Standard | September 2005 |
| 4173 | Bootstrapping Clients using the Internet Small Computer System Interface (iSCSI) ProtocolP. Sarkar, D. Missimer, C. Sapuntzakis | Proposed Standard | September 2005 |
| 4171 | Internet Storage Name Service (iSNS)J. Tseng, K. Gibbons, F. Travostino, C. Du Laney, J. Souza | Proposed Standard | September 2005 |
| 4018 | Finding Internet Small Computer Systems Interface (iSCSI) Targets and Name Servers by Using Service Location Protocol version 2 (SLPv2)M. Bakke, J. Hufferd, K. Voruganti, M. Krueger, T. Sperry | Proposed Standard | May 2005 |
| 3980 | T11 Network Address Authority (NAA) Naming Format for iSCSI Node NamesM. Krueger, M. Chadalapaka, R. Elliott · obsoleted by RFC 7143 | Proposed Standard | February 2005 |
| 3783 | Small Computer Systems Interface (SCSI) Command Ordering Considerations with iSCSIM. Chadalapaka, R. Elliott | Informational | May 2004 |
| 3723 | Securing Block Storage Protocols over IPB. Aboba, J. Tseng, J. Walker, V. Rangan, F. Travostino | Proposed Standard | April 2004 |
| 3722 | String Profile for Internet Small Computer Systems Interface (iSCSI) NamesM. Bakke | Proposed Standard | April 2004 |
| 3721 | Internet Small Computer Systems Interface (iSCSI) Naming and DiscoveryM. Bakke, J. Hafner, J. Hufferd, K. Voruganti, M. Krueger | Informational | April 2004 |