| 9838 | Group Key Management Using the Internet Key Exchange Protocol Version 2 (IKEv2)V. Smyslov, B. Weis | Proposed Standard | November 2025 |
| 9498 | The GNU Name SystemM. Schanzenbach, C. Grothoff, B. Fix | Informational | November 2023 |
| 8750 | Implicit Initialization Vector (IV) for Counter-Based Ciphers in Encapsulating Security Payload (ESP)D. Migault, T. Guggemos, Y. Nir | Proposed Standard | March 2020 |
| 8221 | Cryptographic Algorithm Implementation Requirements and Usage Guidance for Encapsulating Security Payload (ESP) and Authentication Header (AH)P. Wouters, D. Migault, J. Mattsson, Y. Nir, T. Kivinen | Proposed Standard | October 2017 |
| 7321 | Cryptographic Algorithm Implementation Requirements and Usage Guidance for Encapsulating Security Payload (ESP) and Authentication Header (AH)D. McGrew, P. Hoffman · obsoleted by RFC 8221 | Proposed Standard | August 2014 |
| 7296 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen, T. Kivinen | Internet Standard | October 2014 |
| 7181 | The Optimized Link State Routing Protocol Version 2T. Clausen, C. Dearlove, P. Jacquet, U. Herberg | Proposed Standard | April 2014 |
| 7146 | Securing Block Storage Protocols over IP: RFC 3723 Requirements Update for IPsec v3D. Black, P. Koning | Proposed Standard | April 2014 |
| 7143 | Internet Small Computer System Interface (iSCSI) Protocol (Consolidated)M. Chadalapaka, J. Satran, K. Meth, D. Black | Proposed Standard | April 2014 |
| 6786 | Encrypting the Protocol for Carrying Authentication for Network Access (PANA) Attribute-Value PairsA. Yegin, R. Cragie | Proposed Standard | November 2012 |
| 6407 | The Group Domain of InterpretationB. Weis, S. Rowles, T. Hardjono · obsoleted by RFC 9838 | Proposed Standard | October 2011 |
| 6311 | Protocol Support for High Availability of IKEv2/IPsecR. Singh, Ed., G. Kalyani, Y. Nir, Y. Sheffer, D. Zhang | Proposed Standard | July 2011 |
| 6071 | IP Security (IPsec) and Internet Key Exchange (IKE) Document RoadmapS. Frankel, S. Krishnan | Informational | February 2011 |
| 6054 | Using Counter Modes with Encapsulating Security Payload (ESP) and Authentication Header (AH) to Protect Group TrafficD. McGrew, B. Weis | Proposed Standard | November 2010 |
| 6027 | IPsec Cluster Problem StatementY. Nir | Informational | October 2010 |
| 5996 | Internet Key Exchange Protocol Version 2 (IKEv2)C. Kaufman, P. Hoffman, Y. Nir, P. Eronen · obsoleted by RFC 7296 | Proposed Standard | September 2010 |
| 5930 | Using Advanced Encryption Standard Counter Mode (AES-CTR) with the Internet Key Exchange version 02 (IKEv2) ProtocolS. Shen, Y. Mao, NSS. Murthy | Informational | July 2010 |
| 5529 | Modes of Operation for Camellia for Use with IPsecA. Kato, M. Kanda, S. Kanno | Proposed Standard | April 2009 |
| 5528 | Camellia Counter Mode and Camellia Counter with CBC-MAC Mode AlgorithmsA. Kato, M. Kanda, S. Kanno | Informational | April 2009 |
| 4835 | Cryptographic Algorithm Implementation Requirements for Encapsulating Security Payload (ESP) and Authentication Header (AH)V. Manral · obsoleted by RFC 7321 | Proposed Standard | April 2007 |
| 4307 | Cryptographic Algorithms for Use in the Internet Key Exchange Version 2 (IKEv2)J. Schiller · obsoleted by RFC 8247 | Proposed Standard | December 2005 |
| 4305 | Cryptographic Algorithm Implementation Requirements for Encapsulating Security Payload (ESP) and Authentication Header (AH)D. Eastlake 3rd · obsoleted by RFC 4835 | Proposed Standard | December 2005 |
| 4172 | iFCP - A Protocol for Internet Fibre Channel Storage NetworkingC. Monia, R. Mullendore, F. Travostino, W. Jeong, M. Edwards | Proposed Standard | September 2005 |
| 4106 | The Use of Galois/Counter Mode (GCM) in IPsec Encapsulating Security Payload (ESP)J. Viega, D. McGrew | Proposed Standard | June 2005 |
| 3723 | Securing Block Storage Protocols over IPB. Aboba, J. Tseng, J. Walker, V. Rangan, F. Travostino | Proposed Standard | April 2004 |
| 3720 | Internet Small Computer Systems Interface (iSCSI)J. Satran, K. Meth, C. Sapuntzakis, M. Chadalapaka, E. Zeidner · obsoleted by RFC 7143 | Proposed Standard | April 2004 |